Página 4 de 15 PrimeiroPrimeiro 123456789 ... ÚltimoÚltimo
+ Responder ao Tópico

PCC



  1. #61

    Padrão

    brother, se nao me engano, o pppoe não funciona com o PCC, pra fazer o balanceamento vai na página 5 desse mesmo post, e tem as regras do tiagomatias, que foi as mesmas que eu usei!

  2. #62

    Padrão

    Citação Postado originalmente por kilder Ver Post
    opa, estou com um problema, usei as regras que o tiago passou, mais quando adiciona os gateways, o primeiro gateway fica Ativo e Estático, mais os outros 2 os gateways ficam marcados em azul, achei que podia ser algo que eu fiz errado, apaguei tudo, e fiz novamente, agora pela explicação da wiki da mikrotik, e tá o mesmo problema, alguem testou o PCC na v3.27?
    Caro Kilder,

    da para notar pelo que escreveu que esta engatinhando ainda sobre os assunto a respeito de balanceamento de link e roteamento. Tome muito cuidado com copia e cola, q muito das vezes da resultados inesperados e na grande maioria nada bons. Te aconcelho a ler mais o manual da mikrotik para poder entender o funcionamento de cada ferramenta em especifico de acordo com a sua necessidade. Mas vamos a explicação do pq das rotas estarem da forma que relatou.

    Não sei se reparou, mas cada rota padrão adicionada tem uma DISTANCIA, essa distancia em outras palavras diz qual é a prioridade ou qual é a rota que vai ser usada primeiro caso ela esteja UP, o numero colocado nela tem um valor de peso, quanto menor o numero ela será a primeira a ser usada, exemplo:

    imagine 3 rotas com as seguintes distancias:

    distancia=1
    distancia=2
    distancia=3

    cada uma com um gateway diferente. O Mikrotik vai jogar o trafego na rota que que estiver com a distancia menor no caso a "1" e assim sucessivamente. Caso o link da distancia=1 fique DOWN a distancia=2 vai assumir etc.

    Não tem nada de errado nas regras que colocou, quando as distancias estão de backup ou não sendo usadas no momento aguardando o link cair para ela assumir, ela fica em AZUL como relatou.

    A grosso modo é isso ai, como ja disse acima, leia bastante, o manual da mikrotik explica tudo certinho, e é o melhor material que existe.

    Copiar e colar é bom sim e ajuda muito, mas entender como que ela funciona é fundamental para poder adaptar com sua necessidades.

    abraços



  3. #63

    Padrão

    Citação Postado originalmente por ElonPJr Ver Post
    Amigo vc pode me ajudar? eu estou com dois links adsl do net virtua que me dão ip validos dhcp e precisava de um tuto ou regaras para fazer um load no 3,27 rb1000u com hot e pppoe vc tem ou sabe onde tem pra me ajudar? Tenho 99 clientes e estou tendo problemas por favor me ajude....
    obrigado
    Te aconselho a começar a ler por aqui:
    >>> http://www.mikrotik.com/testdocs/ros/3.0/ip/route.php
    >>> ECMP load balancing with masquerade - MikroTik Wiki
    >>> NTH load balancing with masquerade - MikroTik Wiki
    >>> NTH load balancing with masquerade (another approach) - MikroTik Wiki
    e por ultima este que vai resolver seu problema
    >>> PCC - MikroTik Wiki

    Depois de enternder o funcionamento, acredito que se ler esse topico do inicio vai conseguir fazer qualquer balanceamento que quiser.

    abraços
    Última edição por tiagomatias; 07-08-2009 às 14:13.

  4. #64

    Padrão PCC

    segue em anexo a parte do mangle um que prentedo testar esse fim de semana pra 6 link sendo dois links full de 2mb ether 1 e ether2 o resto link de 2mb normais.



  5. #65

    Padrão PCC

    segue anexo
    Arquivos Anexos Arquivos Anexos
    • Tipo de Arquivo: txt pcc.txt (7,3 KB, 528 visualizações)

  6. #66

    Padrão

    Citação Postado originalmente por aprinou Ver Post
    segue anexo
    Aprinou,
    mude seu script de both-address-and-both-ports para apenas both-address

    pq em both-address-and-both-ports ele fica dando algumas paginas expiradas, no caso n esta 100%, é a única forma de somar os links com gerenciador de download, mas traz esses problemas q n é o ideal.



  7. #67

    Padrão PCC

    certo me confundi mesmo nesse quesito ja havia lido isso e me esqueci de mudar mais valeu vou testalo esse fim de semana e ver como ele vai se sair e posto resultados...

  8. #68

    Talking

    aproveitando os colegas aprinou e tiagomatias estarem por ai resolvi por em pratica esse load balance por aqui tambem e pra mim funcionou 100 % não tive problemas com nada nem con videos do youtube nem com bancos hehehe versão do MK 3.27 mais alem do otimo funcionamento o que eu mais gostei é que quando cai um link o outro assume heheeh
    valeu pessoal e obrigado
    Última edição por Arlin; 08-08-2009 às 06:45.



  9. #69

    Padrão pcc

    o sistema e muito bom como tiago falou na versao 3.27 forao corrigidos alguns erros...

  10. #70

    Padrão

    André vc conhece o balancedor TP-LINK TL-R488T que vem com 04 wans e 01 lan? vc ja viu ou ouviu falar se presta?



  11. #71
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por ElonPJr Ver Post
    André vc conhece o balancedor TP-LINK TL-R488T que vem com 04 wans e 01 lan? vc ja viu ou ouviu falar se presta?
    Meu caro, crie um tópico ou pesquise, agora desvirtuar o tópico com um assunto nada a ver... está desmerecendo quem vem aqui dar dicas sem nada em troca.

  12. #72

    Padrão

    Como eu faço pra jogar as portas HTTPS, MSN para um link, pois marquei a porta no mangle com mark routing e em routes indiquei por qual link iria sair mais não deu certo, sempre a alteração de ip, lembrando que coloquei a a regra acima do load no mangle.



  13. #73

    Padrão pcc

    poste a regra que criou inteira amigo pra vermos onde esta errando ou a parte do mangle e ip router

  14. #74

    Padrão

    Citação Postado originalmente por aprinou Ver Post
    poste a regra que criou inteira amigo pra vermos onde esta errando ou a parte do mangle e ip router
    Segue meu mangle e route...

    /ip firewall mangle
    add action=mark-connection chain=output comment=WINBOX_FULL disabled=no \
    new-connection-mark=WINBOX_FULL passthrough=yes protocol=tcp src-port=\
    8291
    add action=mark-packet chain=output comment="" connection-mark=WINBOX_FULL \
    disabled=no new-packet-mark=Winbox_Full passthrough=no protocol=tcp
    add action=mark-connection chain=output comment=FTP_FULL disabled=no \
    new-connection-mark=FTP_FULL passthrough=yes protocol=tcp src-port=8021
    add action=mark-packet chain=output comment="" connection-mark=FTP_FULL \
    disabled=no new-packet-mark=FTP passthrough=no protocol=tcp
    add action=accept chain=prerouting comment="Mikrotik Brasil" disabled=no \
    dst-address=200.210.70.16 dst-port=80 protocol=tcp
    add action=mark-routing chain=prerouting comment="Paginas Dinamicas" \
    disabled=no dst-port=443 new-routing-mark=https passthrough=no protocol=\
    tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=1863 \
    new-routing-mark=https passthrough=no protocol=tcp
    add action=mark-routing chain=prerouting comment="" disabled=no dst-port=25 \
    new-routing-mark=https passthrough=no protocol=tcp
    add action=mark-connection chain=input comment=LOAD-PCC connection-state=new \
    disabled=no in-interface=NET-1 new-connection-mark=ether1_conn \
    passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new \
    disabled=no in-interface=NET-2 new-connection-mark=ether2_conn \
    passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=ether1_conn \
    connection-state=new disabled=no new-routing-mark=to_ether1 passthrough=\
    no
    add action=mark-routing chain=output comment="" connection-mark=ether2_conn \
    connection-state=new disabled=no new-routing-mark=to_ether2 passthrough=\
    no
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=OUT new-connection-mark=ether1_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:3/0
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=OUT new-connection-mark=ether2_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:3/1
    add action=mark-connection chain=prerouting comment="" disabled=no \
    dst-address-type=!local in-interface=OUT new-connection-mark=ether2_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:3/2
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    ether1_conn disabled=no in-interface=OUT new-routing-mark=to_ether1 \
    passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=\
    ether2_conn disabled=no in-interface=OUT new-routing-mark=to_ether2 \
    passthrough=no
    add action=mark-connection chain=prerouting comment=ORKUT_TURBO content=\
    orkut.com disabled=no new-connection-mark=ORKUT passthrough=yes
    add action=mark-connection chain=postrouting comment="" content=orkut.com \
    disabled=no new-connection-mark=ORKUT passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=ORKUT \
    disabled=no new-packet-mark=ORKUT-PCKT passthrough=no
    add action=mark-packet chain=postrouting comment="" connection-mark=ORKUT \
    disabled=no new-packet-mark=ORKUT-PCKT passthrough=no
    add action=mark-connection chain=prerouting comment=YOUTUBE disabled=no \
    new-connection-mark=YTB passthrough=yes src-address-list=Youtube
    add action=mark-connection chain=postrouting comment="" disabled=no \
    new-connection-mark=YTB passthrough=yes src-address-list=Youtube
    add action=mark-packet chain=prerouting comment="" connection-mark=YTB \
    disabled=no new-packet-mark=youtube passthrough=no
    add action=mark-packet chain=postrouting comment="" connection-mark=YTB \
    disabled=no new-packet-mark=youtube passthrough=no

    /ip route
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=NET-2
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=NET-2 routing-mark=to_ether2
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=NET-1 routing-mark=to_ether1
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=\
    0.0.0.0/0 gateway=NET-1 routing-mark=https
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=\
    0.0.0.0/0 gateway=NET-1



  15. #75

    Padrão PCC

    ip firewall mangle

    chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=https passthrough=no

    ip route

    add dst-address=0.0.0.0/0 gateway=ip gateway routing-mark=https


    Coloque acima de todo seu balanceamento no mangle voce poder cuidar dessa saida usando o netwatch...

    Existem varias formas acredito essa uma bem simples pra voce testar...

  16. #76

    Padrão

    Citação Postado originalmente por aprinou Ver Post
    ip firewall mangle

    chain=prerouting protocol=tcp dst-port=443 action=mark-routing new-routing-mark=https passthrough=no

    ip route

    add dst-address=0.0.0.0/0 gateway=ip gateway routing-mark=https


    Coloque acima de todo seu balanceamento no mangle voce poder cuidar dessa saida usando o netwatch...

    Existem varias formas acredito essa uma bem simples pra voce testar...
    O meu ja esta dessa forma como vc mencionou, so qe ao invez de colocar o ip eu coloquei a interface do gateway em Route...



  17. #77

    Padrão PCC

    teste dessa forma e poste se resolveu pra voce amnha de tarde vou colcaor um no ar com 6 links e varios direcionamentos de portas etc e posto os resultados...

  18. #78

    Padrão

    Bom dia pessoal,bem uma duvida creio eu que seja simples.Estou utilizando o PCC em uma RB especifica somente para balancear e depois mandar o link pronto pro mikrotik principal (pppoe-server,firewall,queue,etc)....Bem,tenho 2 links roteados (10.100.0.1/24 e 10.100.1.1/24) que chegam no balanceador,ai eh feito o NAT (Masquerade) la etc...eu preciso refazer o masquerada ou NAT no mikrotik principal ? Ou pelo fato do Masquerade ja estar sendo feito no balanceador eu posso descarta-lo no servidor princiapal?


    Muito obrigado



  19. #79

    Padrão

    precisa sim, pq se não quisesse refazer, teria que usar em bridge, mais dae não teria necessidade de ter o servidor principal, a tua estrutura tá assim?

    links ---> Balanceador ---> Server Principal ---> Clientes?

    se for isso, é preciso sim!

  20. #80

    Padrão

    Citação Postado originalmente por kilder Ver Post
    precisa sim, pq se não quisesse refazer, teria que usar em bridge, mais dae não teria necessidade de ter o servidor principal, a tua estrutura tá assim?

    links ---> Balanceador ---> Server Principal ---> Clientes?

    se for isso, é preciso sim!
    Isso mesmo!

    LINK1 (10.100.0.1) -----> Balanceador PCC (RB433) -----> Mikrotik (X86) ---> Clientes
    LINK2 (10.100.1.1) ----->


    Entao tenho mesmo dando masquerade nas interfaces do LINK1 e LINK2 no balanceador,eu tenho que utilizar masquerade tambem na interface Clientes?

    Poxa pois estou fazendo isso e as x conecta e depois ja para de funcionar....uma outra duvida para o PCC funcionar ok precisa estar os 2 Links ativos ou caso um nao esteja funcionando tudo para?


    Muito Obrigado