Página 7 de 15 PrimeiroPrimeiro ... 23456789101112 ... ÚltimoÚltimo
+ Responder ao Tópico

PCC



  1. #121

    Padrão

    fiz aqui o balanceamento PCC com 3 link adsl de 2 mb cada bom tudo funcionando uma maravilha por aki mais ja aconteceu 3 vezes e eu nunca vi isso os ips das placas de rede mudarm de lugar exemplo lan-1 ip 192.168.1.1 lan-2 192.168.2.1 lan-3 192.168.3.1 lan-4 192.168.5.1
    ai trocarm os ips tipo a lan-1 ficou 192.168.5.1 a lan -2 mudou pra 192.168.1.1 e a lan-3 pra 192.168.4.1 e a lan-4192.168.3.1

    alguem ja passou por isso ou sabe oque esta acontecendo ?

  2. #122

    Padrão

    Citação Postado originalmente por fasseabra Ver Post
    Referente a questão nº 2 já esta resolvida. consegui acessar o MK, não era nada, rs.

    Ref. a questão nº 1 vou verificar e mudar os modens p/ bridge, se pintar algum problema posto aki, Obrigado Tiago.
    Opa,cara vc usa ip x mac , pppoe ,hotspot?

    Fiz uns testes aqui com modens em modo bridge,porem ele jogou as conexoes para um msm link,(usando pppoe) ai fiz controle por ip x mac dae ele jogou um para um link e outro para o outro link... O correto seria usar LB em mk separado?

    t+



  3. #123

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    Opa,cara vc usa ip x mac , pppoe ,hotspot?

    Fiz uns testes aqui com modens em modo bridge,porem ele jogou as conexoes para um msm link,(usando pppoe) ai fiz controle por ip x mac dae ele jogou um para um link e outro para o outro link... O correto seria usar LB em mk separado?

    t+
    Olá BillGates,
    Eu uso ipxmac, mas desde o começo uso o Balance em MK separado por indicação dos colegas. Funciona perfeitamente e não tive nenhum problema.
    Se precisar posto as regras p/ vc. ok!

  4. #124

    Padrão pcc

    modem em bridge ja tem dica do proprio Luciano como corrgir isso o balanceamento roda perfeito mais pra poder te ajudar fica mais facil caso nao tenha seguindo os scripts postado no forum do prorio tiago postar suas regras pra vermos onde esta o erro...



  5. #125

    Padrão

    Citação Postado originalmente por fasseabra Ver Post
    Olá amigo,
    Ref. a questão 1
    Ocorreto é vc somar as duas adsl 4 + 2 = 6Mb e dividir em 3 de 2Mb.
    Faça assim com os links as regras de INPUT, OUTPUT e PREROUTING com marcação de MARK ROUTING não mudam, não se acrecenta nada, o q vai acrecentar são as regras de PREROUTING com marcação de MARK CONNECTION, nelas que vc vai dividir o trafego por igual, no caso a divisão seria:
    2 marcação para 1 link de 4MB
    1 marcação para 1 link de 2MB
    (essa explicação foi copiada do Tiago nesse mesmo post).

    Ref. a questão 2.
    dst-address-type=!local
    Esta correto, a que ela se refere não sei explicar direito, mas acredito que seja a respeito dos destinos dos pacotes.

    então em meu caso que tenho um ADSL de 4 mb e um ADSL de 2 mb em mangle séria asi?

    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface= Ether1-MKT TOWER new-connection-mark=conn_ma0 passthrough=yes per-connection-classifier=both-addresses-and-ports:3/0

    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface= Ether1-MKT TOWER new-connection-mark=conn_mb1 passthrough=yes per-connection-classifier=both-addresses-and-ports:3/1

    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface= Ether1-MKT TOWER new-connection-mark=conn_mc2 passthrough=yes per-connection-classifier=both-addresses-and-ports:3/2

    agradecere qualquer correccion


    saludos

  6. #126

    Padrão

    Tenho estado tentando realizar a configuracion vendo os exemplos, mas fazem-no com ADSL da mesma capacidade, em m i caso tenho meus ADSL como segue:

    Interface do links:
    ADSL 4 MB = Ether3-ADSL1(2WIRE-1)-main
    ADSL 2 MB = Ether4-ADSL2(2WIRE-2)-second
    Interface Clientes= Ether1-MKT TOWER

    Modem ADSL em modo ruteador

    100.10.1.254 = Ip do modem A (ADSL 4MB)
    100.10.2.254 = Ip do modem B (ADSL 2 MB)

    Endereços das interfaces no Mikrotik ROS
    100.10.1.8 = Ip da interface Ether3-ADSL1(2WIRE-1)-main
    100.10.2.10 = Ip da interface ADSL2(2WIRE-2)-second


    Mangle:

    add action=accept chain=prerouting comment="SEM BALANCE" disabled=no dst-address-list=sem_balance in-interface=Ether1-MKT TOWER

    add action=mark-connection chain=input comment="ADSL1_conn" connection-state=new disabled=no in-interface=Ether3-ADSL1(2WIRE-1)-main new-connection-mark=ADSL1_conn passthrough=yes

    add action=mark-connection chain=input comment="ADSL2_conn" connection-state=new disabled=no in-interface= Ether4-ADSL2(2WIRE-2)-second new-connection-mark=ADSL2_conn passthrough=yes


    add action=mark-routing chain=output comment="to_ADSL1" connection-mark= ADSL1_conn disabled=no new-routing-mark=to_ADSL1 passthrough=no

    add action=mark-routing chain=output comment="to_ADSL2" connection-mark= ADSL2_conn disabled=no new-routing-mark=to_ADSL2 passthrough=no

    (Nesta seccion que segue é onde tenho dúvidas ao igual que em ROUTES, agradecere a ajuda para completar as instruções nesta seccion considerando a informacion proporcionada ao princípio)


    Nat:

    add action=masquerade chain=srcnat comment="MASCARAMENTO PCC ADSL1" disabled=no out-interface= Ether3-ADSL1(2WIRE-1)-main

    add action=masquerade chain=srcnat comment=" MASCARAMENTO PCC ADSL2" disabled=no out-interface= Ether4-ADSL2(2WIRE-2)-second


    Rotas:

    add comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=100.10.1.254 scope=30 target-scope=10
    add comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=100.10.2.254 scope=30 target-scope=10

    aqui em rotas esta correcto ou falta-me algo?


    agradecere a ajuda

    saludos



  7. #127

    Padrão pcc

    /ip firewall mangle

    add action=mark-connection chain=input comment=ether1_conn connection-state=new disabled=no in-interface=ether1 new-connection-mark=ether1_conn passthrough=yes
    add action=mark-connection chain=input comment=ether2_conn connection-state=new disabled=no in-interface=ether2 new-connection-mark=ether2_conn passthrough=yes

    add action=mark-routing chain=output comment=to_ether1 connection-mark=ether1_conn connection-state=new disabled=no new-routing-mark=to_ether1 passthrough=no
    add action=mark-routing chain=output comment=to_ether2 connection-mark=ether2_conn connection-state=new disabled=no new-routing-mark=to_ether2 passthrough=no

    add action=mark-connection chain=prerouting comment=ether1_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether1_conn passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=prerouting comment=ether1_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether1_conn passthrough=yes per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting comment=ether2_conn disabled=no dst-address-type=!local in-interface=ether9-Clientes new-connection-mark=ether2_conn passthrough=yes per-connection-classifier=both-addresses:3/2

    add action=mark-routing chain=prerouting comment=to_ether1 connection-mark=ether1_conn disabled=no in-interface=ether9-Clientes new-routing-mark=to_ether1 passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether2 connection-mark=ether2_conn disabled=no in-interface=ether9-Clientes new-routing-mark=to_ether2 passthrough=no

    /ip firewall nat

    add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether1
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=ether2

    /ip route

    add comment=link1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=100.10.1.254 scope=30 target-scope=10
    add comment=link2 disabled=no distance=2 dst-address=0.0.0.0/0 gateway=100.10.2.254 scope=30 target-scope=10
    add comment=link1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=100.10.1.254 routing-mark=to_ether1 scope=30 target-scope=10
    add comment=link2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=100.10.2.254 routing-mark=to_ether2 scope=30 target-scope=10

    segue as regras so foi mudado pra sua estrutura de dois links um de 4mb e outro de 2mb as regras sao as mesmas postadas aki mesmo pelo tiago matias so adptadas pra sua realidade contando 2 pro link maior e 1 pro link menor...

  8. #128

    Padrão

    hola aprinou, muito obrigado por responder

    segui as regras que me indicaste e se consigo navegar, somente que em IP ROUTE me ficaram umas regras em azul, o que fiz foi criar um bridge com os ether1, ether2 e ether3 ao que chame CLIENTES, e no ether8 e ether9 pus meus ADSL

    /ip firewall mangle
    add action=accept chain=prerouting comment="SIN BALANCE" disabled=no \
    dst-address-list=sem_balance in-interface=CLIENTES

    add action=mark-connection chain=input comment="marca conexion ADSL1_conn" \
    connection-state=new disabled=no in-interface=Ether8-ADSL1 \
    new-connection-mark=ADSL1_conn passthrough=yes
    add action=mark-connection chain=input comment="marca conexion ADSL2_conn" \
    connection-state=new disabled=no in-interface=Ether9-ADSL2 \
    new-connection-mark=ADSL2_conn passthrough=yes

    add action=mark-routing chain=output comment="pone marca de ruteo to_ADSL1" \
    connection-mark=ADSL1_conn disabled=no new-routing-mark=to_ADSL1 \
    passthrough=no
    add action=mark-routing chain=output comment="pone marca de ruteo to_ADSL2" \
    connection-mark=ADSL2_conn disabled=no new-routing-mark=to_ADSL2 \
    passthrough=no

    add action=mark-connection chain=prerouting comment=ether1_conn disabled=no \
    dst-address-type=!local in-interface=CLIENTES new-connection-mark=\
    ADSL1_conn passthrough=yes per-connection-classifier=both-addresses:3/0
    add action=mark-connection chain=prerouting comment=ether1_conn disabled=no \
    dst-address-type=!local in-interface=CLIENTES new-connection-mark=\
    ADSL1_conn passthrough=yes per-connection-classifier=both-addresses:3/1
    add action=mark-connection chain=prerouting comment=ether2_conn disabled=no \
    dst-address-type=!local in-interface=CLIENTES new-connection-mark=\
    ADSL2_conn passthrough=yes per-connection-classifier=both-addresses:3/2

    add action=mark-routing chain=prerouting comment=to_ether1 connection-mark=\
    ADSL1_conn disabled=no in-interface=CLIENTES new-routing-mark=to_ADSL1 \
    passthrough=no
    add action=mark-routing chain=prerouting comment=to_ether2 connection-mark=\
    ADSL2_conn disabled=no in-interface=CLIENTES new-routing-mark=to_ADSL2 \
    passthrough=no

    /ip firewall nat
    add action=masquerade chain=srcnat comment="enmascara PCC ADSL1" disabled=no \
    out-interface=Ether8-ADSL1
    add action=masquerade chain=srcnat comment="enmascara PCC ADSL2" disabled=no \
    out-interface=Ether9-ADSL2
    add action=masquerade chain=srcnat comment="enmascara interface CLIENTES" \
    disabled=no out-interface=CLIENTES

    /ip route
    (estas regras ficam em cor azul)
    add comment=link2 disabled=no distance=2 dst-address=0.0.0.0/0 gateway=\
    100.10.2.254 scope=30 target-scope=10
    add comment=link1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    100.10.1.254 scope=30 target-scope=10


    (estas regras aparecem bem)
    add comment=link2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    100.10.2.254 routing-mark=to_ADSL2 scope=30 target-scope=10
    add comment=link1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=\
    100.10.1.254 routing-mark=to_ADSL1 scope=30 target-scope=10


    agradecere a ajuda para corrigir este balanço, como te comento no bridge chamado CLIENTES concte um computador e estou a navegar mas essas regras seguem em azul...

    saludos



  9. #129

    Padrão pcc

    sim ficao em azul pois elas ficam em standy by pois elas podem ser monitoradas via chek ping ou netwatch verificando a atividade dos links caso um saia fora vai pro outro link por isso tem as distancias neles, caso use modem em modo roteado use o netwatch pra monitorar seus links e rodar regras de desativar etc...esssa regras que postem e apenas um exemplo que vc deve claro adptar pro nos de suas interfaces...

  10. #130

    Padrão

    Aprinou, vc comentou que elas ficam em Stanby by para serem monitoradas, isso em modo chek ping é para os modems em router, e para quem ta usando em modo bridge, o MK discando, como seria esse monitoramento em ping, ja que so tem interfaces ativas? no caso os discadores pppoe´s.



  11. #131

    Padrão pcc

    isso so funciona pra modens em bridge mesmo com mk discando pois ele estaria verifcando a conectividade desses modens, para modens roteados use o netwatch usando scripts...

  12. #132

    Padrão pcc

    conforme havia prometido como nao fui autorizado a por de de cleintes posto de um servidor meu...a foto...
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         Balanceamento PCC 5 Links.jpg
Visualizações:	245
Tamanho: 	24,7 KB
ID:      	5348  



  13. #133

    Padrão

    Citação Postado originalmente por aprinou Ver Post
    conforme havia prometido como nao fui autorizado a por de de cleintes posto de um servidor meu...a foto...
    Parabéns, André

  14. #134
    vmh0909
    Visitante

    Padrão

    Alguem sabe me dizer se alguem ja conseguiu rodar na mesma interface PCC com hotspot? ou isso é imposivel?



  15. #135

    Padrão

    Citação Postado originalmente por vmh0909 Ver Post
    Alguem sabe me dizer se alguem ja conseguiu rodar na mesma interface PCC com hotspot? ou isso é imposivel?
    Sim, é possível, n estou com as regras aqui em mãos agora, mais depois posto o q vc tem q mudar, se alguém aqui tiver já em mãos posta ai q n estou na minha maquina, ou aguarde amigo

    Mas respondendo sua pergunta, pode sim

  16. #136
    vmh0909
    Visitante

    Padrão

    Obrigado Thiago, vou ficar no aguardo, pois o que eu ja quebrei a cabeça, e não obtive sucesso, ja fazem mais de duas semanas que estou empenhado nisso.



  17. #137

    Padrão

    Citação Postado originalmente por vmh0909 Ver Post
    Alguem sabe me dizer se alguem ja conseguiu rodar na mesma interface PCC com hotspot? ou isso é imposivel?
    Caro vmh0909, o nosso amigo m4d3 fez um howto sobre loadbalaced pcc e no load dele ele mudou para que o hotspot funcione na mesma maquina, o mesmo esta aqui:

    >>>>> https://under-linux.org/f131343-pcc-...links-por-m4d3

    teste, qualquer coisa poste ai a duvida

    abraços

  18. #138
    vmh0909
    Visitante

    Padrão

    Muito Obrigado Thiago, valeu a dica.

    Agora vou a luta, com este material fica mais facil.

    Um Grande abraço.



  19. #139

    Padrão Distribuição da carga entre os links

    Boa Noite,

    Estou usando o PCC em uma RB450 com 3 links:

    1) GVT 5MB
    2) GVT 5MB
    3) NET 6MB

    Não tive dificuldades na configuração, acompanhando as explicações do fórum.

    No entanto, tenho uma dúvida:

    A distribuição da carga entre os links não parece estar regular, ou seja, observando o Tx/Rx Bytes das interfaces de rede, verifiquei que a carga parece estar sendo enviada mais para o link 3.

    Dividi o total dos links (16MB) e iniciei repassando 5 pacotes para o link1 (5MB), 5 pacotes para o link2 (5MB) e 6 pacotes para o link3 (6MB).

    Quando reparei quantidade muito maior de tráfego no link3, alterei uma das regras do link3 para o link2 que era o que apresentava o menor tráfego.

    No entanto, os bytes no link3 continuam aumentando em taxas bem superiores aos 2 outros (mais que o dobro).

    Alguém tem uma pista ???????

    Vejam a imagem:

    http://www.awgnet.com.br/Images/pcc1.jpg

  20. #140

    Padrão

    Citação Postado originalmente por awgnet Ver Post
    Boa Noite,

    Estou usando o PCC em uma RB450 com 3 links:

    1) GVT 5MB
    2) GVT 5MB
    3) NET 6MB

    Não tive dificuldades na configuração, acompanhando as explicações do fórum.

    No entanto, tenho uma dúvida:

    A distribuição da carga entre os links não parece estar regular, ou seja, observando o Tx/Rx Bytes das interfaces de rede, verifiquei que a carga parece estar sendo enviada mais para o link 3.

    Dividi o total dos links (16MB) e iniciei repassando 5 pacotes para o link1 (5MB), 5 pacotes para o link2 (5MB) e 6 pacotes para o link3 (6MB).

    Quando reparei quantidade muito maior de tráfego no link3, alterei uma das regras do link3 para o link2 que era o que apresentava o menor tráfego.

    No entanto, os bytes no link3 continuam aumentando em taxas bem superiores aos 2 outros (mais que o dobro).

    Alguém tem uma pista ???????

    Vejam a imagem:

    http://www.awgnet.com.br/Images/pcc1.jpg
    Qual dos 3 links que é a rota padrão default principal "com a menor distancia", se for o link3 pode ser isso, ele vai tem um trafego um pouco maior, pq a rota padrão com menor distancia gera o trafego da router, como por exemplo consultas dns, e qualquer outro serviço q vc venha a realizar nela propria.