+ Responder ao Tópico



  1. Olá pessoal,
    Tenho percebido que o procura por instalar, configurar e rodar o thundercache 100% tem sido muito grande.
    Porém uma coisa que tenho observado são as reclamações no controle de velocidade. Vou postar aqui uma maneira de controlar o linux e algumas dicas para controlar apenas o thundercache(para quem usa o content).
    A regra é muito simples:
    Código :
    /ip firewall mangle
    add chain=postrouting action=mark-connection new-connection-mark=linux_connection passthrough=yes src-address=192.168.254.2 out-interface=wan 
     
    add chain=postrouting action=mark-packet new-packet-mark=linux_packets passthrough=no connection-mark=linux_connection

    wan - interface onde entrar o link(internet).

    Depois vão ao queue simple ou tree, como desejarem e façam o controle de velocidade.

    Vimos acima que:
    Todo tráfego de saída na interface wan vindo do ip do linux será marcado e controlado.

    Uma observação a ser feita é:
    Neste caso não será controlado apenas o thundercache e sim todo o tráfego do linux.
    Uma coisa a ser feita:
    Marcar o content cache miss do thunder na regra acima e controlá-lo. não tentei desta forma pois não uso o content THUNDER: THUNDER.

    Como o thunder está em constante transformações, acredito que este problema já tenha sido resolvido, pois ainda não atualizei a minha versão.

    Fica aí a minha dica. Caso não sirva, favor ignorar.

    Boa sorte!

  2. Toda dica é bem vinda Raniel, parabéns .....
    Vai servir pra alguém com certeza .
    Falow



  3. Sei...mas não precisa fazer esse "arrudeio" todo para marcar todo tráfego down do linux, tanto thunder quanto squid!
    Basta colocar o ip do seu thunder/linux no queue simple e seta upload = unlimited e download = "desejado" e pronto fez o mesmo efeito da regra acima do colega.

    Já para marcar somente o thunder utilizando o "content" em mangle, acho q não funcionaria pois o headers THUNDER: THUNDER só é aplicado ao q sai em cache do thunder !?

    Até agora o q me parece estar funcionando é setar a variável $download_speed no thunder.conf para apenas 5 e assim aqui nos testes cada instância do thunder baixou em média a 250Kbps em vez dos 600Kbps padrão.

  4. Você tem certeza que vai marcar apenas o tráfego de saída para à Internet com as regras postas acima?
    Em relação ao content, acho que ainda não leu/ouviu falar do Cache MISS.

    Peço perdão se estiver errado.



  5. Tranquilo amigo, só para esclarecer mesmo...não q suas regras estão erradas, mas tem modo mais simples com mesmo efeito.

    Respondendo:
    Não...o queue simple vai controla o tráfego down do linux para o mk, mas o linux em parelelo é basicamente um cliente do mk com tráfego na porta 80 requisitados pelos clientes redirecioanados, com isso o controle será efetivo, ou seja, mesma coisa q suas regras do início sendo q mais simples.

    Claro q ouvi sobre cache HIT, cache MISS, respectivamente, content X-Cache: HIT e X-Cache: MISS !
    Mas já foi comprovado q não é 100% certo qualquer controle sobre esses content.

    Abraço!






Tópicos Similares

  1. Controle do Thunder 3 no Mikrotik
    Por caracolnet no fórum Servidores de Rede
    Respostas: 3
    Último Post: 26-10-2009, 08:31
  2. Problemas no controle P2P do WIKI
    Por faieppi no fórum Redes
    Respostas: 11
    Último Post: 27-06-2008, 01:08
  3. Respostas: 4
    Último Post: 17-07-2007, 18:12
  4. Respostas: 11
    Último Post: 27-12-2006, 13:34
  5. Problemas no Boot do RH8
    Por no fórum Servidores de Rede
    Respostas: 6
    Último Post: 20-12-2002, 16:17

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L