+ Responder ao Tópico



  1. Boa Noite pessoal.

    Bem pessoal andei pesquisando e tentei sem sucesso deixar os arquivos que se encontram no cache do thundercache sendo carregados a ful. Como minha distro é MK_AUTH autenticando por Freeradius percebi que se removendo a queue que o hotspot cria automaticamente, os arquivos que estao em cache do thunder sao carregados totalmente a full e os arquivos que ainda não estao em cache sao carregados com a velocidade contratada pelo cliente la no cadastro do mk-auth.
    Partindo desse principio resolvi entao criar um script para remover a queue simples criada pelo hotspot no tempo programado em 05 segundo apos o
    cliente ser logada. Com essa gambiarra resolveu em parte meu problema, visto que não tenho nenhum controle de download sobre os arquivos em
    cache. Espero cometarios e dicas dos amigo Uderlinux de boa vontade para que eu possa resolver essa situação. Abaixo scritp que remove a queue criada pelo hotspot.

    / system script
    add name="Remove-queue" source=":foreach m in=\[/queue simple find \
    priority=8\] do {/queue simple remove \$m;};" \
    policy=ftp,reboot,read,write,policy,test,winbox,password,sniff

    / system scheduler
    add name="Remove-queue" on-event=":foreach m in=\[/queue simple find \
    priority=8\] do {/queue simple remove \$m;};" start-date=jul/01/2009 \
    start-time=00:00:05 interval=05s comment="" disabled=no

    Estou pensando em modicar esse scrip para que ele ao invés de remover a queue, mude o limit Rate para: 1M/2M, upload e download respectivamente como forma de controle do que sai do cache, até que eu consiga fazer isso pelo metodo tradicional de marcação de pacotes. Abraços virtuais a todos.
    Última edição por Mirandapb; 01-07-2009 às 23:11. Razão: consertar titulo

  2. RESOLVIDO:

    Bem pessoal, uma pesquisa minuciosa aqui mesmo no forum e ja consegui resolver o problema de cache full do thundercache. Segui fielmente as regras de nat e redireciomento do post Mikrotik + thunderCache= perfeito... do roberto21 e ja funfou legal, visto que eu ja havia feito algumas alteraçoes no apache2 e nas regras de mangle conforme o artigo tambem sugerido aqui pelo roberto21 sobe o titulo:FAZENDO CACHEFULL COM THUNDERCACHE + MIKROTIK.
    Aproveito o espaço para agradecer mais uma vez o roberto21, pois são de pessoas como voce e tantos outros companheiros de mesmos principios eticos, profissionais e morais, que ajudam e repassam o que sabem demonstrando serem dignos de elogios, e elevam grandemente o nivel do forum. Pena é que estou tentanndo encontrar a segunda parte desse topicos, que voce mesmo enunciou como sendo a continuação de dicas para melhoramento do thunder cache, inclusive já baixei os programas sugeridos... Continue assim, pois colhemos o que plantamos e dessa forma voce so tem a ganhar. Abraços virtual a todos...
    Última edição por Mirandapb; 02-07-2009 às 17:23.



  3. Citação Postado originalmente por Mirandapb Ver Post
    RESOLVIDO:

    Bem pessoal, uma pesquisa minuciosa aqui mesmo no forum e ja consegui resolver o problema de cache full do thundercache. Segui fielmente as regras de nat e redireciomento do post Mikrotik + thunderCache= perfeito... do roberto21 e ja funfou legal, visto que eu ja havia feito algumas alteraçoes no apache2 e nas regras de mangle conforme o artigo tambem sugerido aqui pelo roberto21 sobe o titulo:FAZENDO CACHEFULL COM THUNDERCACHE + MIKROTIK.
    Aproveito o espaço para agradecer mais uma vez o roberto21, pois são de pessoas como voce e tantos outros companheiros de mesmos principios eticos, profissionais e morais, que ajudam e repassam o que sabem demonstrando serem dignos de elogios, e elevam grandemente o nivel do forum. Pena é que estou tentanndo encontrar a segunda parte desse topicos, que voce mesmo enunciou como sendo a continuação de dicas para melhoramento do thunder cache, inclusive já baixei os programas sugeridos... Continue assim, pois colhemos o que plantamos e dessa forma voce so tem a ganhar. Abraços virtual a todos...
    Amigo estou com o mesmo problema que você passo tambem utilizo mk e MK-AUTH já tentei de tudo mas não marca os pacotes do thunder cache sera que você poderia me ajudar a configurar as regras de nat e mangle, como ficou seu thunder.conf e apache você modificou alguma coisa?

  4. sim, modifiquei de acordo com o poste do roberto21, abaixo segue minhas regras de nat, nangle e queue:

    / ip firewall nat
    add chain=srcnat action=masquerade comment="" disabled=no
    add chain=srcnat action=masquerade src-address=169.200.0.0/24 comment="NAT \
    DEBIAN-SERVER" disabled=no
    add chain=dstnat action=accept dst-address=200.221.0.0/16 dst-port=80 \
    protocol=tcp comment="Radio-UOL" disabled=no
    add chain=dstnat action=accept dst-address=200.241.192.0/24 dst-port=80 \
    protocol=tcp comment="Tribunal de Justi a da Paraiba" disabled=no
    add chain=srcnat action=accept comment="Conectivbidade Social" disabled=no
    add chain=dstnat action=dst-nat to-addresses=169.200.0.2 to-ports=3128 \
    src-address=192.168.100.0/24 dst-address=!169.200.0.2 dst-port=80 \
    protocol=tcp comment="proxy for HTTP requests" disabled=no

    / ip firewall mangle
    add chain=postrouting action=mark-connection new-connection-mark=n-cache \
    passthrough=yes src-port=3128 protocol=tcp tos=48 comment="Marca o com e o \
    sem TOS" disabled=no
    add chain=postrouting action=mark-connection new-connection-mark=s-cache \
    passthrough=yes src-port=3128 protocol=tcp tos=!48 comment="" disabled=no
    add chain=postrouting action=mark-packet new-packet-mark=Cache-Packet \
    passthrough=no connection-mark=n-cache comment="Libera cache full" \
    disabled=no
    add chain=forward action=mark-connection new-connection-mark=thunderC \
    passthrough=yes protocol=tcp content="THUNDER: THUNDER" comment="Thunder \
    cache FULL" disabled=no
    add chain=forward action=mark-packet new-packet-mark=thunderP passthrough=yes \
    connection-mark=thunderC comment="" disabled=no
    add chain=prerouting action=mark-routing new-routing-mark="POP3 Trafico" \
    passthrough=no dst-port=110 protocol=tcp comment="Marcando Servi o POP3" \
    disabled=no
    add chain=prerouting action=mark-routing new-routing-mark="SMTP Trafico" \
    passthrough=no dst-port=25 protocol=tcp comment="" disabled=no
    add chain=prerouting action=mark-routing new-routing-mark="P2P Trafico" \
    passthrough=no p2p=all-p2p comment="Marcando rota P2P" disabled=no


    / queue tree
    add name="CACHE-FULL" parent=global-out packet-mark=Cache-Packet limit-at=0 \
    queue=cache priority=8 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="THUNDER CACHE FULL" parent=global-out packet-mark=thunderP \
    limit-at=8000000 queue=pcq-upload priority=5 max-limit=8000000 \
    burst-limit=0 burst-threshold=0 burst-time=0s disabled=no


    / queue type
    set default name="default" kind=pfifo pfifo-limit=50
    set ethernet-default name="ethernet-default" kind=pfifo pfifo-limit=50
    set wireless-default name="wireless-default" kind=sfq sfq-perturb=5 \
    sfq-allot=1514
    set synchronous-default name="synchronous-default" kind=red red-limit=60 \
    red-min-threshold=10 red-max-threshold=50 red-burst=20 red-avg-packet=1000
    set hotspot-default name="hotspot-default" kind=sfq sfq-perturb=5 \
    sfq-allot=1514
    add name="cache" kind=pcq pcq-rate=4800000 pcq-limit=50 \
    pcq-classifier=dst-address,dst-port pcq-total-limit=2000
    add name="pcq-download" kind=pcq pcq-rate=4800000 pcq-limit=50 \
    pcq-classifier=dst-address,dst-port pcq-total-limit=4000
    add name="pcq-upload" kind=pcq pcq-rate=0 pcq-limit=50 \
    pcq-classifier=src-address,src-port pcq-total-limit=4000
    add name="default-small" kind=pfifo pfifo-limit=10

    Lá nas conf do bedian so coloquei as tags THUNDER: THUNDER
    Última edição por Mirandapb; 10-07-2009 às 19:59.



  5. Citação Postado originalmente por Mirandapb Ver Post
    sim, modifiquei de acordo com o poste do roberto21, abaixo segue minhas regras de nat, nangle e queue:

    / ip firewall nat
    add chain=srcnat action=masquerade comment="" disabled=no
    add chain=srcnat action=masquerade src-address=169.200.0.0/24 comment="NAT \
    DEBIAN-SERVER" disabled=no
    add chain=dstnat action=accept dst-address=200.221.0.0/16 dst-port=80 \
    protocol=tcp comment="Radio-UOL" disabled=no
    add chain=dstnat action=accept dst-address=200.241.192.0/24 dst-port=80 \
    protocol=tcp comment="Tribunal de Justi a da Paraiba" disabled=no
    add chain=srcnat action=accept comment="Conectivbidade Social" disabled=no
    add chain=dstnat action=dst-nat to-addresses=169.200.0.2 to-ports=3128 \
    src-address=192.168.100.0/24 dst-address=!169.200.0.2 dst-port=80 \
    protocol=tcp comment="proxy for HTTP requests" disabled=no

    / ip firewall mangle
    add chain=postrouting action=mark-connection new-connection-mark=n-cache \
    passthrough=yes src-port=3128 protocol=tcp tos=48 comment="Marca o com e o \
    sem TOS" disabled=no
    add chain=postrouting action=mark-connection new-connection-mark=s-cache \
    passthrough=yes src-port=3128 protocol=tcp tos=!48 comment="" disabled=no
    add chain=postrouting action=mark-packet new-packet-mark=Cache-Packet \
    passthrough=no connection-mark=n-cache comment="Libera cache full" \
    disabled=no
    add chain=forward action=mark-connection new-connection-mark=thunderC \
    passthrough=yes protocol=tcp content="THUNDER: THUNDER" comment="Thunder \
    cache FULL" disabled=no
    add chain=forward action=mark-packet new-packet-mark=thunderP passthrough=yes \
    connection-mark=thunderC comment="" disabled=no
    add chain=prerouting action=mark-routing new-routing-mark="POP3 Trafico" \
    passthrough=no dst-port=110 protocol=tcp comment="Marcando Servi o POP3" \
    disabled=no
    add chain=prerouting action=mark-routing new-routing-mark="SMTP Trafico" \
    passthrough=no dst-port=25 protocol=tcp comment="" disabled=no
    add chain=prerouting action=mark-routing new-routing-mark="P2P Trafico" \
    passthrough=no p2p=all-p2p comment="Marcando rota P2P" disabled=no


    / queue tree
    add name="CACHE-FULL" parent=global-out packet-mark=Cache-Packet limit-at=0 \
    queue=cache priority=8 max-limit=0 burst-limit=0 burst-threshold=0 \
    burst-time=0s disabled=no
    add name="THUNDER CACHE FULL" parent=global-out packet-mark=thunderP \
    limit-at=8000000 queue=pcq-upload priority=5 max-limit=8000000 \
    burst-limit=0 burst-threshold=0 burst-time=0s disabled=no


    / queue type
    set default name="default" kind=pfifo pfifo-limit=50
    set ethernet-default name="ethernet-default" kind=pfifo pfifo-limit=50
    set wireless-default name="wireless-default" kind=sfq sfq-perturb=5 \
    sfq-allot=1514
    set synchronous-default name="synchronous-default" kind=red red-limit=60 \
    red-min-threshold=10 red-max-threshold=50 red-burst=20 red-avg-packet=1000
    set hotspot-default name="hotspot-default" kind=sfq sfq-perturb=5 \
    sfq-allot=1514
    add name="cache" kind=pcq pcq-rate=4800000 pcq-limit=50 \
    pcq-classifier=dst-address,dst-port pcq-total-limit=2000
    add name="pcq-download" kind=pcq pcq-rate=4800000 pcq-limit=50 \
    pcq-classifier=dst-address,dst-port pcq-total-limit=4000
    add name="pcq-upload" kind=pcq pcq-rate=0 pcq-limit=50 \
    pcq-classifier=src-address,src-port pcq-total-limit=4000
    add name="default-small" kind=pfifo pfifo-limit=10

    Lá nas conf do bedian so coloquei as tags THUNDER: THUNDER
    Obrigado por responder, mas qual versão do MK-AUTH você usa a minha é 3.7 eu atualizei para 3.8 nas confs o pedro modificou não estou entenden dosegue abaixo,

    em /etc/apache2/sites-enabled/000-default


    <VirtualHost *:80>
    ServerAdmin powernet.wireless@gmail.com

    DocumentRoot /var/www/
    <Directory />
    Options FollowSymLinks
    AllowOverride None
    </Directory>
    <Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>
    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>
    ErrorLog /var/log/apache2/error.log
    # Possible values include: debug, info, notice, warn, error, crit,
    # alert, emerg.
    LogLevel warn
    CustomLog /var/log/apache2/access.log combined
    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
    Options Indexes MultiViews FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>
    </VirtualHost>
    <VirtualHost *:85>
    ServerAdmin powernet.wireless@gmail.com
    ServerName localhost
    DocumentRoot /usr/local/thunder/
    </VirtualHost>


    se eu digitar esse endereço http://169.254.0.2:85/youtube/yL2Vpxk016o.flv e fazer o download sai a full ai o mangle do cache full marca os pacotes mas quando tento ver esse video pelo site do youtube ele sai com o controle de banda.
    Última edição por antoniocarlosd; 10-07-2009 às 23:41.






Tópicos Similares

  1. Respostas: 3
    Último Post: 03-06-2011, 19:06
  2. Interface no Queue do HotSpot
    Por admskill no fórum Redes
    Respostas: 1
    Último Post: 19-08-2008, 08:15
  3. Script no profile do Hotspot
    Por netover no fórum Redes
    Respostas: 3
    Último Post: 06-08-2008, 13:31
  4. Controlar Banda Queues ou Profile do HotSpot
    Por fafadinhu no fórum Redes
    Respostas: 7
    Último Post: 28-07-2008, 20:12
  5. Remover o Pop-UP "Status" do HotSpot
    Por deivyn no fórum Redes
    Respostas: 2
    Último Post: 15-05-2007, 20:57

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L