Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Resolvendo o problema de travamento de modens ADSL junto do Mikrotik - CATVBRASIL

    Bom, postei esse tópico, explicando o porque os modens travam. Já sabemos que em bridge a possibilidade de travar é praticamente nula, certo?

    Analizem o tópico abaixo:

    Uma abordagem sobre travamentos nos ADSL x Controle de Conexão do Mikrotik

    Bom a solução seria usar todos os modens em bridge, então o problema tá resolvido certo? Certo, porém os adsl sendo da mesmo operadora há um problema: os gateways são iguais... Então os pacotes não sabem por onde sair e o problema não é resolvido.

    Bom, mas isso é coisa do passado agora. A Mikrotik em sua últimas versões corrigiu vários bugs, dentre eles, um importante que resolveria esse problema, mas não estava funcionando.

    Vamos a solução:

    Como é feito o loadbalance ou mesmo um roteamento da forma tradicional? De forma básica define-se a rede e qual é o gateway por qual essa rede irá sair, certo?

    Ficaria algo assim:

    /ip route
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=200.217.255.104 routing-mark=A scope=30 target-scope=10

    add check-gateway=ping comment=LINK2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.254.254 routing-mark=B scope=255 target-scope=10



    Como ficará a solução? Primeiro coloque TODOS os modens em BRIDGE....

    Segundo crie um discaddor pppoe para cada modem... No primeiro, você deixa marcado as opções do dicador (menos "discar por demanda"). No outros discadores as 3 opções devem estar desmarcadas...

    Fazendo isso todos os dicadores estarão conectados e com a flag "R" ativa (conectado e rodando)...

    O segredo está nas rotas. Antigamente você faria como exemplifiquei acima certo? Definindo a rede ou mesmo os pacotes marcados e qual o gateway que sairia. Para resolver o problema, não será definido nenhum gateway, mas somente a INTERFACE a qual os pacotes sairão... Veja abaixo:

    /ip route
    add check-gateway=ping comment=LINK2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK2 routing-mark=B

    add check-gateway=ping comment=LINK1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=A


    Confira na figura abaixo como fica...

    Pronto!!! Viu como é fácil??? Bom, vou colocar isso no creative commons e quem iria comprar modens novos, agora pode doar para mim.... kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk

    PS: Essa função já existe a muito tempo, mas parece que só está funcionando satisfatoriamente na 3.23 para cima. Abaixo desta versão, o loadbalance trava e fica horrível a conexão (usando desta forma).

    Gostaram??

    Aqui nóis mata a cobra e mostra o pau, moço......... kkkkkkkkkkkkkkkkkkk
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         bridge123.jpg
Visualizações:	1229
Tamanho: 	25,6 KB
ID:      	4842  
    Última edição por catvbrasil; 08-07-2009 às 21:32.

  2. #2
    Sempre na luta Avatar de jacksonezidio
    Ingresso
    Jun 2008
    Localização
    São Paulo - SP
    Posts
    208
    Posts de Blog
    1

    Post

    Parabens!



  3. #3

    Padrão

    Meus parabens grande CATV, mais so me tira uma duvida, na sua explicação, vc fala pra colocar a interface do link em uma regra e na outra coloca a interfaçe pppoe, mais na sua imagem esta os dois pppoe, como seria a forma correta, me perdoe se to falando besteira!
    Última edição por sergio; 09-07-2009 às 17:06. Razão: Por favor, faça o comentário apenas, não precisa poluir o tópico com uma citação deste tamanho.

  4. #4

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Meus parabens grande CATV, mais so me tira uma duvida, na sua explicação, vc fala pra colocar a interface do link em uma regra e na outra coloca a interfaçe pppoe, mais na sua imagem esta os dois pppoe, como seria a forma correta, me perdoe se to falando besteira!
    Então... é isso mesmo...

    Você coloca a interface no lugar do gateway. Quando é criado uma interface virtual vinculada a uma interface real , quem valerá é a VIRTUAL... é o mesmo que acontece nas bridges, quando você cria uma bridge (interface virtual) e vincula uma ether ou uma wlan (interface real), quem valerá é a BRIDGE...



  5. #5

    Padrão

    Citação Postado originalmente por catvbrasil Ver Post
    Bom, postei esse tópico, explicando o porque os modens travam. Já sabemos que em bridge a possibilidade de travar é praticamente nula, certo?

    Analizem o tópico abaixo:

    Uma abordagem sobre travamentos nos ADSL x Controle de Conexão do Mikrotik

    Bom a solução seria usar todos os modens em bridge, então o problema tá resolvido certo? Certo, porém os adsl sendo da mesmo operadora há um problema: os gateways são iguais... Então os pacotes não sabem por onde sair e o problema não é resolvido.

    Bom, mas isso é coisa do passado agora. A Mikrotik em sua últimas versões corrigiu vários bugs, dentre eles, um importante que resolveria esse problema, mas não estava funcionando.

    Vamos a solução:

    Como é feito o loadbalance ou mesmo um roteamento da forma tradicional? De forma básica define-se a rede e qual é o gateway por qual essa rede irá sair, certo?

    Ficaria algo assim:

    /ip route
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=200.217.255.104 routing-mark=A scope=30 target-scope=10

    add check-gateway=ping comment=LINK2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.254.254 routing-mark=B scope=255 target-scope=10



    Como ficará a solução? Primeiro coloque TODOS os modens em BRIDGE....

    Segundo crie um discaddor pppoe para cada modem... No primeiro, você deixa marcado as opções do dicador (menos "discar por demanda"). No outros discadores as 3 opções devem estar desmarcadas...

    Fazendo isso todos os dicadores estarão conectados e com a flag "R" ativa (conectado e rodando)...

    O segredo está nas rotas. Antigamente você faria como exemplifiquei acima certo? Definindo a rede ou mesmo os pacotes marcados e qual o gateway que sairia. Para resolver o problema, não será definido nenhum gateway, mas somente a INTERFACE a qual os pacotes sairão... Veja abaixo:

    /ip route
    add check-gateway=ping comment=LINK2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK2 routing-mark=B

    add check-gateway=ping comment=LINK1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=A


    Confira na figura abaixo como fica...

    Pronto!!! Viu como é fácil??? Bom, vou colocar isso no creative commons e quem iria comprar modens novos, agora pode doar para mim.... kkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk

    PS: Essa função já existe a muito tempo, mas parece que só está funcionando satisfatoriamente na 3.23 para cima. Abaixo desta versão, o loadbalance trava e fica horrível a conexão (usando desta forma).

    Gostaram??

    Aqui nóis mata a cobra e mostra o pau, moço......... kkkkkkkkkkkkkkkkkkk

    muito legal o topico, é isso ai, tem q mostrar q mikrotik tem muito recurso desconhecido mesmo.
    parabéns

  6. #6



  7. #7
    Mikrotiando..
    Ingresso
    Sep 2007
    Localização
    São Paulo
    Posts
    329
    Posts de Blog
    2

    Padrão

    Cara! você é o Cara mesmo!
    Valeu!

  8. #8

    Padrão Conferindo...

    Duvida nesta parte!
    Postado originalmente:
    /ip route
    add check-gateway=ping comment=LINK2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=LINK2 routing-mark=B

    add check-gateway=ping comment=LINK1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=A


    ou deveria ser assim:

    Modificado:
    /ip route
    add check-gateway=ping comment=LINK2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out2 routing-mark=B

    add check-gateway=ping comment=LINK1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=pppoe-out1 routing-mark=A

    Uma vez que na Figura abaixo mostra como no Modificado
    https://under-linux.org/forums/attac...-bridge123.jpg
    Agradeço se alguém puder confirmar!!!

    Uso aqui apenas 1 modem em modo bridge,e os outros em router.
    O que esta em bridge esta marcado como default,então recebe todo o trafego que nao esteje marcado para os outros links,porém um dos modens que esta em router é usado apenas para a navegação então seria interessante deixa-lo em bridge também.

    Muito obrigado catv pelo post
    Última edição por BillGates; 12-07-2009 às 01:09.



  9. #9
    Avatar de renatocostas
    Ingresso
    Dec 2007
    Localização
    Av. Santos Dumont 119, centro -Montes Claros MG
    Posts
    288

    Padrão

    O nome do gateway vai depender do nome que vc definiu para o seu discador pppoe.

  10. #10

    Padrão

    Citação Postado originalmente por renatocostas Ver Post
    O nome do gateway vai depender do nome que vc definiu para o seu discador pppoe.
    Correto,mas na figura esta como pppoe-out1 e pppoe-out2,então suponho que os nomes do pppoe client dele seriam pppoe-out1 e pppoe-out2,devendo colocar na regra de ip route como pppoe-out2 e não Link2...

    ...me corrijam ai se eu estiver errado!!!

    OBS.:
    Olhando mais detalhamente a figura originalmente postada,notei um detalhe...
    Vou testar akee...
    Última edição por BillGates; 13-07-2009 às 15:56.



  11. #11
    Avatar de renatocostas
    Ingresso
    Dec 2007
    Localização
    Av. Santos Dumont 119, centro -Montes Claros MG
    Posts
    288

    Padrão

    Não se esqueça que esse nome pode ser alterado, nesse caso é isso, mas poderia ser muito bem Link2, se tivesse definido nome assim ao criar o discador. Eu mesmo uso os nome Link1 e Link2 para melhor organização do meu sistema, isso é uma questão de organização de cada um, na figura mostra o padrão mas poderia ser diferente se quizesse.

    Espero ter lhe esclarecido.

    Renato Costa.

  12. #12

    Padrão

    Muito boa CATV, vai quebrar um galho desgraçado aqui. Vou testar assim que minha rede estiver um pouquinho mais arrumada. Valeu.



  13. #13

    Padrão

    me passou uma coisa aqui na cabeça; como eu nunca configurei um pppoe_client nos meus servidores, tive uma dúvida. Tem como conectar vários modems em apenas uma ether no load balance, com um switch? Creio que não né? Atualmente meu load balance está assim, pois não achei placa nova que desse pra fazer 5 ether.

  14. #14

    Padrão

    Citação Postado originalmente por Gosulator Ver Post
    me passou uma coisa aqui na cabeça; como eu nunca configurei um pppoe_client nos meus servidores, tive uma dúvida. Tem como conectar vários modems em apenas uma ether no load balance, com um switch? Creio que não né? Atualmente meu load balance está assim, pois não achei placa nova que desse pra fazer 5 ether.
    Comprei uma 44GV. Resolve o problema até 4 links
    Que coisa cara esta bendita!!!



  15. #15

    Padrão

    CAT e em casos que os modens possuem ips fixos em bridge mas com os mesmo gateway pois é da mesmo operadora... qual a solução pra um balanceamento sem ter que por um router em um dos modens pra não sufocolo com o roteamento proprio.... abração e parabens pelo topico

  16. #16

    Padrão

    Citação Postado originalmente por megalink Ver Post
    CAT e em casos que os modens possuem ips fixos em bridge mas com os mesmo gateway pois é da mesmo operadora... qual a solução pra um balanceamento sem ter que por um router em um dos modens pra não sufocolo com o roteamento proprio.... abração e parabens pelo topico
    Não sei em qual estado você está, mas no RJ existe a NET VIRTUA que trabalha parecido com isso que você está falando. Na verdade ela trabalha com um cliente em DHCP, mas nesse caso o ip é dinâmico. Faça o seguinte, direcione cada 1 dos links para sua respectiva interface, ok?



  17. #17

    Padrão

    CAT... eu estou no estado de São Paulo... e uso Speedy comercial que é com ip fixo dinamico... então cada interface link1 e link2 recebe seu proprio ip tipo 172.29.100.10 link 1... e 172.29.100.20 link 2..... o problema é que pra fazer a rota os gateways são os mesmos 172.29.100.1..... setado dessa forma o balanceamento por marcação não funciona... sendo assim coloco um router junto com o moden do link2 pra fazer uma outra classe de ip e o balanceamento funcionar...

    Alguma sugestão... ?????... abraços

  18. #18
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    essas regra serveria para quais versões? a 2.9.27 serveria? caso não poderia me informar um script para ser um link cair ele seria disable e o que estava disable ficaria enable. Isso usando um modem router e o outro em brigde.

    Desde ja agradeço a atenção



  19. #19

    Padrão

    Citação Postado originalmente por angelangra Ver Post
    essas regra serveria para quais versões? a 2.9.27 serveria? caso não poderia me informar um script para ser um link cair ele seria disable e o que estava disable ficaria enable. Isso usando um modem router e o outro em brigde.

    Desde ja agradeço a atenção
    Da um relida de novo no post inicial do tópico!

    Quanto ao detalhe de um script para se um link cair outro assumir,não lembro o nome do tópico que tem o script (apesar que tem muitos sobre esse assunto),de uma pesquisada em loadbalance...

  20. #20

    Smile Link Remoto

    Boa tarde pessoal

    Alguem saberia me dizer se poderia colocar os meus modens que estão remotos em bridge, aqui tenho 6 links 3 locais e 3 remotos os locais beleza tudo certo mas me veio a duvida será que funciona eu passar eles(modens remotos) pra bridge faço o link deles chegar na sede por ponto a ponto em wds se alguem tiver a resposta e puder ajudar agradecemos

    abraços