Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Rede entre dois micro com IPs diferentes

    Pessoal é o seguinte.

    Tenho meu mikrotik aqui funcionando belezinha, nele tenho duas placa de rede, uma esta com ips nas faixa 192.168.1.1 e a outra placa esta na faixa 192.168.2.1, nessas duas placas eu tenho em cada uma um micro ligado.

    O que eu preciso é que os dois micros se encherguem em uma rede, ou seja, gostaria de trasferir aquivos de um micro para outro com essa config , isso é possivel ??

    Gostaria de lembrar que estou usando o vista nas duas maquinas.

  2. #2
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Vejamos:

    ponha o mesmo nome de rede e a mesma máscara 255.255.0.0 nos dois micros.

    Quais as máscaras que estão no momento? /24?

    Caso possa modificar a máscara e o nome da rede basta fazer o procedimento que citei.



  3. #3
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Colega,

    dê mais detalhes de sua rede: tem autenticação, DHCP, IP fixo? Quais as máscaras que estão nas interfaces do Mikrotik? Tem switch?

    A solução pode ser outra...rsrs.

  4. #4

    Padrão

    Coloque os 2 pcs no mesmo grupo de trabalho e a mesma mascara para os 2: 255.255.0.0. Para que se enxerguem, eles nao precisam estar com a mesma faixa de ips, mas sim na mesma sub rede. ip: 192.168.1.1 mascara 255.255.0.0 e ip 192.168.2.1 mascara 255.255.0.0, e o mesmo grupo de trabalho.



  5. #5

    Padrão

    Citação Postado originalmente por MarceloGOIAS Ver Post
    Colega,

    dê mais detalhes de sua rede: tem autenticação, DHCP, IP fixo? Quais as máscaras que estão nas interfaces do Mikrotik? Tem switch?

    A solução pode ser outra...rsrs.
    Boa tarde Marcelo, primeiro quero agradecer pela força dos colegas.


    Como disse acima, tenho duas placas de redes no mikrotik, cada uma dessas placas estão ligadas a um micro, e gostaria de formar uma ligação entre esses dois micro atráves dessas duas placas de redes.

    Estão da seguinte forma:

    Placa 1:

    Nome: Local
    Faixa de ip. 192.168.2.1/24

    Placa 2:

    Nome: Local_1
    Faixa de ip. 192.168.1.1/24

    Ambas estão com DHCP ativo e sem autenticação.
    Porém eu defino ips nas interfaces locais da seguinte forma:

    Placa 1:
    192.168.2.2
    255.255.255.0
    192.168.2.1

    Placa 2:

    192.168.1.2
    255.255.255.0
    192.168.1.1


    E não tenho nenhuma switch e tenho ip dinamico, porém com é uma rede local não creio que ip sendo fixo ou dinamico vai influenciar em alguma coisa, ou vai ???

    Fico no aguardo.
    Última edição por rafaelmju; 13-07-2009 às 16:01.

  6. #6

    Padrão

    Pelo que eu entendi, o seu MK vai servir de switch... entao o grupo de trabalho da maquinas devera ser o mesmo. ah, e eu tava esquecendo, a mascara nao é /24 e sim /16.

    mascara /24 é 255.255.255.0 e a mascara que vc tem que usar aí é a /16 = 255.255.0.0
    Última edição por liecht; 13-07-2009 às 16:19.



  7. #7

    Padrão

    Me perdõe pela ignorancia mas não entendo quando fala "mesmo grupo de trabalho" , poderia explicar melhor o que seria o grupo de trabalho ??

    E no caso dessa duas placas sim é quase uma suite como falou, mas é só nessas duas placas que pretendo fazer isso, meu mikrotik esta com interfaces wireless distribuindo sinal para meu clientes, e surgiu a nescessidade de montar uma rede entre esses dois micro, e pra não ter que deixar uma suite ou um hub ligado o tempo todo , preferi colocar duas placas de rede no mikrotik para ligar esses dois micros.

    valeu.

  8. #8

    Padrão

    mesmo grupo de trabalho: icone meu computador na area de trabalho, botão de direito, propriedades, aba: nome do computador, depois opção alterar, abrira uma nova janela. Nesta janela, na parte inferior tera a opção: Grupo de trabalho, esta opção devera estar marcada nos 2 pcs e no espaço em branco devera estar o memo nome.



  9. #9
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Bem,

    eu perguntei sobre autenticação por motivos obvios. Ao usar PPPoE, por exemplo, cria um túnel entre servidor e usuário o que tiraria os micros da rede.

    Colega, como está apontando IP fixo nas máquinas ponha máscara 255.255.0.0 (/16) como eu disse na minha primeira mensagem. Cria uma rede nos dois micros com Windows (escolha um nome para ela) e um nome para cada máquina.

    Configure assim e teste. Em alguns casos é preciso reiniciar o velho Windows quando "mexemos" na rede dele. Sem testar não vamos saber do resultado confiável, né? rs

    Citação Postado originalmente por rafaelmju Ver Post
    Boa tarde Marcelo, primeiro quero agradecer pela força dos colegas.


    Como disse acima, tenho duas placas de redes no mikrotik, cada uma dessas placas estão ligadas a um micro, e gostaria de formar uma ligação entre esses dois micro atráves dessas duas placas de redes.

    Estão da seguinte forma:

    Placa 1:

    Nome: Local
    Faixa de ip. 192.168.2.1/24

    Placa 2:

    Nome: Local_1
    Faixa de ip. 192.168.1.1/24

    Ambas estão com DHCP ativo e sem autenticação.
    Porém eu defino ips nas interfaces locais da seguinte forma:

    Placa 1:
    192.168.2.2
    255.255.255.0
    192.168.2.1

    Placa 2:

    192.168.1.2
    255.255.255.0
    192.168.1.1


    E não tenho nenhuma switch e tenho ip dinamico, porém com é uma rede local não creio que ip sendo fixo ou dinamico vai influenciar em alguma coisa, ou vai ???

    Fico no aguardo.

  10. #10

    Padrão

    Boa tarde Galera,

    Eu estou usando hotspot, uso PPPoE na autenticação do adsl com o provedor, mas para os clientes uso hotspot.

    E a configuração que vcs me passaram ai, não deu em nada, simplesmente os micros não se enchergam.

    Eu deixe assim:

    Micro com interface 1:

    IP: 192.168.2.2
    Máscara de sub-rede: 255.255.0.0
    Gateway Padráo: 192.168.2.1


    Micro com interface 2

    IP: 192.168.1.2
    Máscara de sub-rede: 255.255.0.0
    Gateway Padráo: 192.168.1.1

    Essa config ai em cima esta nas placas locais que estão nos micros 1 e 2, que estão ligados cada um, a uma placa de rede no mikrotik

    No mikrotik as placas estão assim:

    Em ip Address / address list esta:

    Placa 1

    Nome: Local_1
    Address: 192.168.2.2/24
    Network: 192.168.2.0
    Broadcast: 192.168.2.255

    Placa 2

    Nome: Local_2
    Address: 192.168.1.1/24
    Network: 192.168.1.0
    Broadcast: 192.168.1.255

    Será que ta faltando alguma coisa ???

    Talves uma ponte entre as duas placas, talves alguma mudança no firewall.

    No firewall esta assim:

    Placa 1

    action: masquerade
    Chain: srcnat
    Src Address: 192.168.2.1/24

    Placa 2

    action: masquerade
    Chain: srcnat
    Src Address: 192.168.1.1/24

    Alguém pode me dar uma luz, por favor ??
    Última edição por rafaelmju; 17-07-2009 às 14:52.



  11. #11
    Eng. Eletricista/Eletrôni Avatar de MarceloGOIAS
    Ingresso
    Feb 2007
    Localização
    Goiânia
    Posts
    2.120
    Posts de Blog
    2

    Padrão

    Se não deu em nada culpa sua.

    Eu perguntei se estava usando PPPoE. Com autenticação muda tudo.

  12. #12

    Padrão

    bom, pelo que eu percebi, a configuracao nas placas em si esta ok... pelo que vejo deve ser algum bloqueio do MK que vc esta usando... dessa forma nao poderei ajudar, pois nao sou mto entendido de MK. Mas pelo que vi, a configuração das placas dos 2 pcs e do MK estao certas... vc fez a outra configuracao que eu passei:


    mesmo grupo de trabalho: icone meu computador na area de trabalho, botão de direito, propriedades, aba: nome do computador, depois opção alterar, abrira uma nova janela. Nesta janela, na parte inferior tera a opção: Grupo de trabalho, esta opção devera estar marcada nos 2 pcs e no espaço em branco devera estar o memo nome.



  13. #13

    Padrão

    No mikrotik as placas estão assim:

    Em ip Address / address list esta:

    Placa 1

    Nome: Local_1
    Address: 192.168.2.2/24
    Network: 192.168.2.0
    Broadcast: 192.168.2.255

    Placa 2

    Nome: Local_2
    Address: 192.168.1.1/24
    Network: 192.168.1.0
    Broadcast: 192.168.1.255

    Será que ta faltando alguma coisa ???

    Talves uma ponte entre as duas placas, talves alguma mudança no firewall.

    No firewall esta assim:

    Placa 1

    action: masquerade
    Chain: srcnat
    Src Address: 192.168.2.1/24

    Placa 2

    action: masquerade
    Chain: srcnat
    Src Address: 192.168.1.1/24
    você tem que usar /16 e não /24 aqui também!

  14. #14

    Padrão

    é... nao tinha observado isso nao... pode ser isso mesmo...



  15. #15

    Padrão

    Citação Postado originalmente por liecht Ver Post
    bom, pelo que eu percebi, a configuracao nas placas em si esta ok... pelo que vejo deve ser algum bloqueio do MK que vc esta usando... dessa forma nao poderei ajudar, pois nao sou mto entendido de MK. Mas pelo que vi, a configuração das placas dos 2 pcs e do MK estao certas... vc fez a outra configuracao que eu passei:


    mesmo grupo de trabalho: icone meu computador na area de trabalho, botão de direito, propriedades, aba: nome do computador, depois opção alterar, abrira uma nova janela. Nesta janela, na parte inferior tera a opção: Grupo de trabalho, esta opção devera estar marcada nos 2 pcs e no espaço em branco devera estar o memo nome.
    Obrigado pela ajuda, eu fiz o que vc disse, estou usando nas maquinha o windows 7, é nele é muito facil criar um grupo de trabalho. Os dois mikros estão no mesmo grupo de trabalho como vc disse.

    O no meu firewall não tem bloqueio nenhum, apanas alguns bloqueios para webproxy nada mais.

  16. #16

    Padrão

    Citação Postado originalmente por MarceloGOIAS Ver Post
    Se não deu em nada culpa sua.

    Eu perguntei se estava usando PPPoE. Com autenticação muda tudo.
    A questão é que tem dois tipos de pppoe, um que é usando para conexão nos clientes e outro que é a autenticação do adsl, e eu te falei sim que usando pppoe, se vc ler na primeira pagina vai ver isso. Mesmo assim obrigado



  17. #17

    Padrão

    as 4 placas tbm tem de estar na mesma mascara de sub-rede... pelo que eu vi, vc colocou as placas da mauquina com mascara 255.255.0.0, entao as placas do MK que se conectam aos pcs, tbm tem de estar na mesma mascara 255.255.0.0

  18. #18

    Padrão

    Citação Postado originalmente por liecht Ver Post
    as 4 placas tbm tem de estar na mesma mascara de sub-rede... pelo que eu vi, vc colocou as placas da mauquina com mascara 255.255.0.0, entao as placas do MK que se conectam aos pcs, tbm tem de estar na mesma mascara 255.255.0.0
    Vou tentar fazer isso que vc falou.

    Vamos ver se vai dar certo. por hora muito obrigado pela ajuda.



  19. #19

    Padrão

    Rafaelmj...

    é o seguinte...

    placa 01 - ip 192.168.10.1
    placa 02 - ip 192.168.20.1

    vá em ip>firewall>nat e crie as seguintes regras:

    add chain=srcnat out-interface=01 dst-address=192.168.10.0/24 action=masquerade comment="" \ disabled=no

    add chain=srcnat out-interface=02 dst-address=192.168.20.0/24 action=masquerade comment="" \ disabled=no

    ou seja... você deve criar regras de nat para os ranges com as devidas interfaces.. desse modo você vai conseguir pingar as máquinas..

    com relação a enxergar pelo windows.. se não funcionar deste modo como coloquei acima.. então você deve alterar as máscaras para /16 ao invés de /24, sem esquecer de alterar em ip address também... outra coisa.. será mais fácil se você mapear o micro.. tipo digite na barra do navegador ou explorer o ip da outra máquina, ao invés de deixar o windows procurar, pois o range será maior e o windows demorará para receber as respostas das requisições..

    acho que é por aí..

    abraços.

  20. #20
    Não Registrado
    Visitante

    Padrão valeu

    Pois meu caro, até hj não consegui resolver esse problema, continuo sem enchergar os micro na rede com a config dessa forma que expliqui ai, vamos ver com essa sua dica se vai dar certo, vou testar e depois posto o resultado.

    por hora muito obrigado pela dica.