Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Balanceamento link dedicado e adsl

    Bom, andei pesquizando aqui pelo forum, mas não encontrei um modelo de balanceamento, ficam duvidas, aguem saberia indicar a melhor opção de balancear 1 dedicado de 512kbps e um adsl de 8mb? eu tinha em mente deixar navegação para o dedicado, já que não possue limite de conexões e o adsl para o restante, alguem sabe dizer onde acho um tutorial?

  2. #2

    Padrão

    ola, eu fiz da seguinte forma, marquei os pacotes para http (add chain=prerouting protocol=tcp dst-port=80 action=mark-routing new-routing-mark=load passthrough=yes comment="\"\"" disabled=no)

    E deixei as rotas configuradas assim (add dst-address=0.0.0.0/0 gateway=189.10.255.145,201.14.223.254 scope=255 target-scope=10 routing-mark=load comment="load balance" disabled=no
    add dst-address=0.0.0.0/0 gateway=201.14.223.254 distance=1 scope=255 target-scope=10 comment="Outros" disabled=no)

    ao meu ver as paginas de internet usariam a porta 80, e passariam pelo gateway 189.10.255.145, e o restante passaria pelo segundo gateway 201.14.223.254, porem fika muito pouco trafego pelo primeiro gateway, quase nada, errei alguma coisa? gostaria de deixar tambem o msn pelo primeiro link, gostaria que quando o cliente visitasse o www.meuip.com.br aparecesse o ip do link com o gateway 189.10.255.145, alguem ai sabe fazer este tipo de configuração??
    Última edição por MaxAdriano; 14-07-2009 às 22:50.



  3. #3

    Padrão

    O perguntinha que não quer calar neh!!!

    Qual a melhor forma de fazer um Loadbalance??????????????

    Primeiramente faça por portas,pronto!Fazendo assim,vc separa o Tragefo limpo do trafego sujo...

    Quem hoje em dia que não da uma mesclada de Dedicado + Adsl???????

    Então,dedicado sem controle de conexoes certo???? Perfeitamente, Dedicado com um UP muitoooo bom,Certo??????? Pefeitamannte...

    Entao,um dedicado de 512k faz um regasso na rede se implantado corretamente, e como seria corretamente??????????

    Deixe o Dedicado apenas para a navegação,pegue + uns 2 links Adsl(8MB) e jogue um para os downs e outro para os p2p...

    Tudo bem filtrado fik show...

    PQ qual é a pergunta mais temida por parte de um cliente ???

    Cliente...
    - Pq a "net" ta lenta???

    Chato isso neh!!!

    O cliente percebe/sente que a internet dele esta lenta pela navegação,pois num mês é provavel que ele nao faça nenhum download apenas navegue...

    Então de prioridade a navegação, e soque os downs,p2p etc para links de adsl que servirão muito bem para estes tipos de serviços.


  4. #4

    Padrão

    Citação Postado originalmente por BillGates Ver Post
    O perguntinha que não quer calar neh!!!

    Qual a melhor forma de fazer um Loadbalance??????????????

    Primeiramente faça por portas,pronto!Fazendo assim,vc separa o Tragefo limpo do trafego sujo...

    Quem hoje em dia que não da uma mesclada de Dedicado + Adsl???????

    Então,dedicado sem controle de conexoes certo???? Perfeitamente, Dedicado com um UP muitoooo bom,Certo??????? Pefeitamannte...

    Entao,um dedicado de 512k faz um regasso na rede se implantado corretamente, e como seria corretamente??????????

    Deixe o Dedicado apenas para a navegação,pegue + uns 2 links Adsl(8MB) e jogue um para os downs e outro para os p2p...

    Tudo bem filtrado fik show...

    PQ qual é a pergunta mais temida por parte de um cliente ???

    Cliente...
    - Pq a "net" ta lenta???

    Chato isso neh!!!

    O cliente percebe/sente que a internet dele esta lenta pela navegação,pois num mês é provavel que ele nao faça nenhum download apenas navegue...

    Então de prioridade a navegação, e soque os downs,p2p etc para links de adsl que servirão muito bem para estes tipos de serviços.

    exatamento isso que quero fazer, porem naum to conseguindo marcar os pacotes das conexões, to levando um baile aki...



  5. #5

    Padrão

    eu sugeria um balanceamento por rotas estaticas amigo, separando paginas no link e download na adsl..fica muito bom...
    mas para isso teria que saber quantidade de clientes e estrutura do server,,,,
    abraço..

  6. #6

    Padrão

    Citação Postado originalmente por Everloko Ver Post
    eu sugeria um balanceamento por rotas estaticas amigo, separando paginas no link e download na adsl..fica muito bom...
    mas para isso teria que saber quantidade de clientes e estrutura do server,,,,
    abraço..
    ta certo, mas como se faz isso?eu consegui, mas separando alguns sites, fiz tbem da porta 80, 443, tudo com menos de 500k....



  7. #7

    Padrão

    AMIGO EU ATÉ PODERIA POSTAR AS REGRAS A VC ...DIFERENTE DE ALGUNS AQUI NO FORUM QUE COBRAM POR ELAS....
    MAS PARA ISSO COO EU DISSE PRECISO SABER DE SUA ESTRUTURA NO SEU SERVER OQUE VC USA COMO USA ...ETC...PQ AS REGRAS NÃO É SÓ COPIAR E COLAR...

  8. #8

    Padrão

    Citação Postado originalmente por Everloko Ver Post
    AMIGO EU ATÉ PODERIA POSTAR AS REGRAS A VC ...DIFERENTE DE ALGUNS AQUI NO FORUM QUE COBRAM POR ELAS....
    MAS PARA ISSO COO EU DISSE PRECISO SABER DE SUA ESTRUTURA NO SEU SERVER OQUE VC USA COMO USA ...ETC...PQ AS REGRAS NÃO É SÓ COPIAR E COLAR...
    sim eu entendo, mas como funcionaria? só me explique o funcionamento que eu coloco pra funcionar...



  9. #9

    Padrão

    Olá MaxAdriano
    É muito fácil fazer isso que você quer amigo.

    Vamos ao cenário
    1 dedicado de 512kb e um ADSL de 8MB


    Com essas configurações você pode joga a porta 80=http, para o link dedicado de 512KB e restante para a rota default que é o ADSL de 8MB.

    Bom se raciocinar bem: o link dedicado com uns 20 users on-line vai fica no gargalo, e olha que 20 é muito em rsss; já que a porta 80 é danada pra consumir download. Que no caso do Link dedicado só tem 512kb, más em compensação tem um ótimo upload.


    Eu pessoalmente faria da seguinte forma.

    ADSL de 8MB para passar as portas abaixo, ja que não consome tanto UPLOAD.

    53 - dns
    80 - web
    110 - smtp
    25 - pop3
    22 - ssh
    1863 - msn
    443 - apache
    69 - tftp
    995 - pop3 seguro
    465 - smtp seguro
    23 - telnet
    8082 - tse
    1080 - instant messenger
    8291 – winbox

    Como sobro só as pedreiras no campo de 65535 portas.
    Eu jogaria isso tudo para o link dedicado, que tem mais estabilidade e mais conexões simultâneas... Agora se o Link dedicado fosse de no mínimo 2mb full, lógico que ele seria pra marcar as portas que o ADSl vai marcar.

    Bom mão na massa:


    IP do meu Modem é: 10.1.1.1 que será o meu Gateway de marcação.
    IP do meu Link dedicado é: 201.2.2.1 que será minha rota default, onde vai passar o resto das portas que não serão marcadas no ADSL.

    /ip firewall mangle
    mangle.txt

    /ip route
    route.txt

    bom espero ter te ajudado MaxAdriano, qualquer coisa estamos aí...

  10. #10

    Padrão

    Citação Postado originalmente por thiagogenesis Ver Post
    Olá MaxAdriano
    É muito fácil fazer isso que você quer amigo.

    Vamos ao cenário
    1 dedicado de 512kb e um ADSL de 8MB


    Com essas configurações você pode joga a porta 80=http, para o link dedicado de 512KB e restante para a rota default que é o ADSL de 8MB.

    Bom se raciocinar bem: o link dedicado com uns 20 users on-line vai fica no gargalo, e olha que 20 é muito em rsss; já que a porta 80 é danada pra consumir download. Que no caso do Link dedicado só tem 512kb, más em compensação tem um ótimo upload.


    Eu pessoalmente faria da seguinte forma.

    ADSL de 8MB para passar as portas abaixo, ja que não consome tanto UPLOAD.

    53 - dns
    80 - web
    110 - smtp
    25 - pop3
    22 - ssh
    1863 - msn
    443 - apache
    69 - tftp
    995 - pop3 seguro
    465 - smtp seguro
    23 - telnet
    8082 - tse
    1080 - instant messenger
    8291 – winbox

    Como sobro só as pedreiras no campo de 65535 portas.
    Eu jogaria isso tudo para o link dedicado, que tem mais estabilidade e mais conexões simultâneas... Agora se o Link dedicado fosse de no mínimo 2mb full, lógico que ele seria pra marcar as portas que o ADSl vai marcar.

    Bom mão na massa:


    IP do meu Modem é: 10.1.1.1 que será o meu Gateway de marcação.
    IP do meu Link dedicado é: 201.2.2.1 que será minha rota default, onde vai passar o resto das portas que não serão marcadas no ADSL.

    /ip firewall mangle
    mangle.txt

    /ip route
    route.txt

    bom espero ter te ajudado MaxAdriano, qualquer coisa estamos aí...
    sim, euu já usei este método, só naum sabia o nome, mqs nomomneto que direciono a porta 80 pra o dedicado ele "explode" vai ao maximo rapidinho, então eu coloquei porta 80 com limite de 500k, acima de 500k sairia pelo adsl, mas os 512k dedicado foram pouco pra isso tbem.

    eu fiz o seguinte, pesquizei com meus clientes paginas mais acessadas e redirecionei apenas algumas paginas, meu ip (para aparecer o ip dedicado), google, orkut. mas, dns....



  11. #11

    Padrão

    Citação Postado originalmente por thiagogenesis Ver Post
    Olá MaxAdriano
    É muito fácil fazer isso que você quer amigo.

    Vamos ao cenário
    1 dedicado de 512kb e um ADSL de 8MB


    Com essas configurações você pode joga a porta 80=http, para o link dedicado de 512KB e restante para a rota default que é o ADSL de 8MB.

    Bom se raciocinar bem: o link dedicado com uns 20 users on-line vai fica no gargalo, e olha que 20 é muito em rsss; já que a porta 80 é danada pra consumir download. Que no caso do Link dedicado só tem 512kb, más em compensação tem um ótimo upload.


    Eu pessoalmente faria da seguinte forma.

    ADSL de 8MB para passar as portas abaixo, ja que não consome tanto UPLOAD.

    53 - dns
    80 - web
    110 - smtp
    25 - pop3
    22 - ssh
    1863 - msn
    443 - apache
    69 - tftp
    995 - pop3 seguro
    465 - smtp seguro
    23 - telnet
    8082 - tse
    1080 - instant messenger
    8291 – winbox

    Como sobro só as pedreiras no campo de 65535 portas.
    Eu jogaria isso tudo para o link dedicado, que tem mais estabilidade e mais conexões simultâneas... Agora se o Link dedicado fosse de no mínimo 2mb full, lógico que ele seria pra marcar as portas que o ADSl vai marcar.

    Bom mão na massa:


    IP do meu Modem é: 10.1.1.1 que será o meu Gateway de marcação.
    IP do meu Link dedicado é: 201.2.2.1 que será minha rota default, onde vai passar o resto das portas que não serão marcadas no ADSL.

    /ip firewall mangle
    mangle.txt

    /ip route
    route.txt

    bom espero ter te ajudado MaxAdriano, qualquer coisa estamos aí...
    Olá Thiago... e no meu caso que tenho
    1 link 4mb full
    1 adsl 1mb
    1 adsl 1mb

    qual seria o conselho?
    vlw..

  12. #12

    Padrão

    Tente colocar mais peso no ADSL usando o ECMP, e o site omeuip.com.br tu redireciona ele para a rota Link Dedicado.

    / ip address
    add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Cliente
    add address=10.1.1.1/24 network=10.1.1.0 broadcast=10.1.1.255 interface=wlan1
    add address=10.1.1.2/24 network=10.1.1.0 broadcast=10.1.1.255 interface=wlan2

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1,10.1.1.2,10.1.1.2,10.1.1.2 check-gateway=ping

    / ip firewall nat
    add chain=srcnat out-interface=wlan1 action=masquerade
    add chain=srcnat out-interface=wlan2 action=masquerade

    / ip firewall mangle
    add chain=input in-interface=wlan1 action=mark-connection new-connection-mark=wlan1_conn
    add chain=input in-interface=wlan2 action=mark-connection new-connection-mark=wlan2_conn
    add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wla1
    add chain=output connection-mark=wlan1_conn action=mark-routing new-routing-mark=to_wla2

    / ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 routing-mark=to_wla1
    add dst-address=0.0.0.0/0 gateway=10.1.1.2 routing-mark=to_wla2

    Acrescenta + essa regra acima de todas no ip/firewall/mangle, destinando o site www.omeuip.com.br sair pelo link dedicado.

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="" disabled=no dst-address=67.205.42.197 dst-port=80 new-routing-mark=to_wla1 passthrough=yes protocol=tcp

    testa aí Adriano, e poste os resultados...



  13. #13

    Padrão

    Citação Postado originalmente por froyer Ver Post
    Olá Thiago... e no meu caso que tenho
    1 link 4mb full
    1 adsl 1mb
    1 adsl 1mb

    qual seria o conselho?
    vlw..

    Então Froyer no teu caso eu faria da seguinte forma.

    ADSL1 ficaria como rota default, saindo por ele todas as portas não marcadas no Link Dedicado e ADSL2.
    ADSL2 ficaria pra marca todo o trafego P2P, tanto temido rss, e colocaria o Link Dedicado para marcas as portas que eu sitei aí, como você mesmo ja sabe.

    Você também pode está dando uma olhadinha na lista de portas que tem o link abaixo; para marca mais o que quiser, "jogue sem dó as portas do VOIP mais usado em tua rede, vai ficar bem legal saindo elas pelo link dedicado neh rss".

    www.pt.wikipedia.org/wiki/Lista_de_portas_de_protocolos

    até mais espero ter lhe ajudado.
    Última edição por thiagogenesis; 31-07-2009 às 12:06.

  14. #14

    Padrão

    Citação Postado originalmente por MaxAdriano Ver Post
    sim eu entendo, mas como funcionaria? só me explique o funcionamento que eu coloco pra funcionar...
    ok amigo vamos la ...
    primeiramente serea colocado um modem em bridge e autenticado pelo MK ...
    os outros serão feioto um load separando rotas para cada adsl ...
    assim ficara dividido as rotas entre os adsl...

    adsl principal em bridge para paginas e o restante para download



  15. #15

    Padrão

    Citação Postado originalmente por thiagogenesis Ver Post
    Então Froyer no teu caso eu faria da seguinte forma.

    ADSL1 ficaria como rota default, saindo por ele todas as portas não marcadas no Link Dedicado e ADSL2.
    ADSL2 ficaria pra marca todo o trafego P2P, tanto temido rss, e colocaria o Link Dedicado para marcas as portas que eu sitei aí, como você mesmo ja sabe.

    Você também pode está dando uma olhadinha na lista de portas que tem o link abaixo; para marca mais o que quiser, "jogue sem dó as portas do VOIP mais usado em tua rede, vai ficar bem legal saindo elas pelo link dedicado neh rss".

    www.pt.wikipedia.org/wiki/Lista_de_portas_de_protocolos

    até mais espero ter lhe ajudado.

    no seu caso seria o melhor ...como rodava aqui no meu server ...
    o link para download ....e 2 adsl dividindo rotas só pra abrirem pagina...
    fica muito bom...só que um pouco complicado pra se implantar..

  16. #16

    Padrão

    então Everloko, poste as regras das configurações pra ajudar todos aki. So falando não vai ajudar o cara.
    Eu ja fiz esse tipo de LB aki também, tive muitos problemas com webmail...
    Aí optei em fazer um com o Mikrotik e Debian como eu postei aki no forum.
    segue o Link: LoadBalance com cache-full Mikrotik e Debian



  17. #17

    Padrão

    Citação Postado originalmente por thiagogenesis Ver Post
    então Everloko, poste as regras das configurações pra ajudar todos aki. So falando não vai ajudar o cara.
    Eu ja fiz esse tipo de LB aki também, tive muitos problemas com webmail...
    Aí optei em fazer um com o Mikrotik e Debian como eu postei aki no forum.
    segue o Link: LoadBalance com cache-full Mikrotik e Debian

    certo amigo hj tbm uso MK paraleo debian cache full...muito bom mas para quem não consegue chegar a isso temos varios requisitos....

    vou postar ai 4 tipos de load balance

    espero que ajude ...
    Arquivos Anexos Arquivos Anexos

  18. #18

    Padrão

    Citação Postado originalmente por Everloko Ver Post
    certo amigo hj tbm uso MK paraleo debian cache full...muito bom mas para quem não consegue chegar a isso temos varios requisitos....

    vou postar ai 4 tipos de load balance

    espero que ajude ...
    o load 1 eu já testei, e não achei bom,já que os downloads usam a mesma porta que http (80).
    o load 2 tambem já usei, ele é bem funcional, mas cada grupo usará um link apenas e tendo um link dedicado e uma adsl não estaria aproveitando ao maximo oq o dedicado pode oferecer...
    o load 3 eu não testei, teria como explicar como funciona, olhando por cima não consegui entender....

    Mas Obrigado pelas informações...



  19. #19

    Padrão

    Citação Postado originalmente por MaxAdriano Ver Post
    o load 1 eu já testei, e não achei bom,já que os downloads usam a mesma porta que http (80).
    o load 2 tambem já usei, ele é bem funcional, mas cada grupo usará um link apenas e tendo um link dedicado e uma adsl não estaria aproveitando ao maximo oq o dedicado pode oferecer...
    o load 3 eu não testei, teria como explicar como funciona, olhando por cima não consegui entender....

    Mas Obrigado pelas informações...
    O load 3 é um load automatico que o mkt faz.. chamado nth... eu usei ele até agora, com 1 link full 2mb + 2 adsl 1mb cada...
    Agora quero mudar... implantar um server linux para cache, usar o link full q agora foi ampliado pra 4mb para navegação e usar os adsl para sujeira...
    Só não tenho ideia se devo usar thundercache ou somente squid, se devo usar uma maquina a parte com mkt soh para fazer o loadbalance, se o load deve ser feito na mesma maquina q hoje é o meu server de controle hotspot/mkt ou se o link deve entrar diretamente na minha maquina de controle e os adsl numa maquina a parte fazendo o load...
    Bom, essas sao as minhas duvidas... primeiro definir como vai ficar ligados os servers e os links, para depois aplicar as devidas regras....
    Abraços

  20. #20

    Padrão

    Então froyer tente fazer esse loadbalance aqui que não é tão dificil assim e tem uma grande performance, ta bem explicado o post é so tu ignorar o lance do pppoe para o modem!!!
    segue no Link: LoadBalance com cache-full Mikrotik e Debian