Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Lançada a versão Mikrotik 3.26 !!!

    Quentinha do forno!

    MikroTik Routers and Wireless

  2. #2

    Padrão

    Porque desde a versão 3.24, aquele script pra derrubar os clientes com ACK Timeout não funciona, será que mudou alguma coisa no mk pra funcionar o script?



  3. #3

  4. #4

    Padrão

    Citação Postado originalmente por agpnet Ver Post
    alguém ja atualizou ?
    Atualizei e fiz um downgrade logo em seguida, pois alguns scripts não funcionam!



  5. #5

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Atualizei e fiz um downgrade logo em seguida, pois alguns scripts não funcionam!
    rogeriodj, qual versão você esta utilizando atualmente ?
    Utilizo a 3.24 no server e nas rb´s ta tudo misturado 3.xx (quero ver se passo tudo para 3.26 para deixar tudo padronizado e facilitar a manutenção).

    Valew!

  6. #6

    Padrão

    Citação Postado originalmente por agpnet Ver Post
    rogeriodj, qual versão você esta utilizando atualmente ?
    Utilizo a 3.24 no server e nas rb´s ta tudo misturado 3.xx (quero ver se passo tudo para 3.26 para deixar tudo padronizado e facilitar a manutenção).

    Valew!
    Aqui a versõ quue uso é 3.23 e é a unica que funciona tudo direito pra mim.



  7. #7

    Padrão

    Citação Postado originalmente por rogeriodj Ver Post
    Porque desde a versão 3.24, aquele script pra derrubar os clientes com ACK Timeout não funciona, será que mudou alguma coisa no mk pra funcionar o script?
    Posta esse script aqui para eu darmos uma analisada, pois quando atualizei da 2.9.51 para a 3.25 teve um dos meus scripts q não funcionou mais era o de verificar o BUSY no DHCP, mas analizando consegui decifrar o pq dele não funcionar.
    Na primeira linha dele estava:

    :foreach i in=[/ip dhcp-server lease find status=busy]\

    então foi eu colocar as aspas dupla em busy q funcionou certinho:

    :foreach i in=[/ip dhcp-server lease find status="busy"]\

  8. #8

    Padrão

    Atualizei tudo para 3.26 - vamos ver no que vai dar....



  9. #9

    Padrão

    Citação Postado originalmente por kryseck Ver Post
    Posta esse script aqui para eu darmos uma analisada, pois quando atualizei da 2.9.51 para a 3.25 teve um dos meus scripts q não funcionou mais era o de verificar o BUSY no DHCP, mas analizando consegui decifrar o pq dele não funcionar.
    Na primeira linha dele estava:

    :foreach i in=[/ip dhcp-server lease find status=busy]\

    então foi eu colocar as aspas dupla em busy q funcionou certinho:

    :foreach i in=[/ip dhcp-server lease find status="busy"]\
    Segue o script que so funciona na versao 3.23 e anteriores.

    # Defina abaixo o valor mínimo de ACK
    :global ack 46;
    # Defina abaixo 1 para bloquear e 0 para não bloquear o cliente que estiver acima do valor mínimo
    :global block 0;
    # Defina abaixo 1 para dropar e 0 para não dropar o cliente que estiver acima do valor mínimo
    :global drop 1;
    # Defina abaixo a Interface
    :global interf "MEGANET2";
    # =============================================================================
    # ATENÇÃO ! SO FAÇA ALTERAÇÕES ABAIXO, SE TIVER CERTEZA DO QUE ESTA FAZENDO
    # =============================================================================
    :global total 0;
    :global mac "";
    :global cliente "";
    :log info "Listando Clientes com ACK acima de $ack ms:";
    :foreach i in=[/interface wireless registration-table find interface=$interf] do={
    :if ([/interface wireless registration-table get $i ack-timeout] > $ack) do={
    :log info ("COMENTARIO: " . [/interface wireless registration-table get $i comment] . " - MAC: " . [/interface wireless registration-table get $i mac-address] . " - ACK: " . [/interface wireless registration-table get $i ack-timeout]);
    :set mac [/interface wireless registration-table get $i mac-address];
    :set cliente [/interface wireless access-list find mac-address=$mac];
    :if ($block = 1) do={
    /interface wireless access-list disable $cliente;
    };
    :if ($drop = 1) do={
    /interface wireless registration-table remove $i;
    };
    :set total total+1;
    };
    };
    :if ($total = 0) do={
    :log info "Parabéns ! Nenhum Cliente com ACK acima de $ack ms encontrado.";
    };

  10. #10



  11. #11

    Padrão

    Quando há um post duplicado não verificamos qual foi postado antes ou depois, apaga-se um dos dois.

  12. #12

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    Quando há um post duplicado não verificamos qual foi postado antes ou depois, apaga-se um dos dois.
    Luciano, neste caso eu deletei verificando quem era o mais antigo.

    Tenhamos como encerrado esse assunto.
    Última edição por catvbrasil; 15-07-2009 às 12:36.



  13. #13

    Padrão

    David,

    Obrigado por esclarecer.

  14. #14

    Padrão

    Para os mais entendidos ai q q me dizem de atualizar o servidor hotspot que esta rodando em um pc para a versão 3.26?



  15. #15

    Padrão

    Um dia rodando sem problemas!!!, x86 e rb´s 4xx... muito bom usar tudo na mesma versão, a rede ficou mais rápida, maior facilidade para fazer regras, e menor número delas mas com a mesma eficiência, show de bola, só me decepcionei em uma coisa com a série 3.xx porque quando usava a 2.xx... ela salvava os gráficos de conexão dos clientes PPPoE, pois sempre que o cliente conectava ela dava continuidade no mesmo gráfico, como um histórico de uso de banda, isto é normal da série 3 do mk ou tem como configurar ?

    Obrigado Galera !!!

  16. #16

    Padrão

    Aqui não tenho problemas com gráficos no 3.25 que estou usando.



  17. #17

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    Aqui não tenho problemas com gráficos no 3.25 que estou usando.
    lucianogf, o problema é que por ex. um cliente pppoe conecta agora, fica 1h navegando, no webserver do mk eu vejo o gráfico da conexão dele <pppoe-usuario>, até ai tudo bem, mas se ele desconectar e entrar mais tarde, o gráfico inicia novamente a partir da nova conexão, na ver. 2 do mk, eu podia ver quanto ele usava por dia/semana/mes/ano, pelo gráfico dava para ter uma idéia de quanto ele usava de banda no dia etc...
    Muito antes...... quando usava RB para controle de banda ela tinha a ver.3.14 e também se comportava desta maneira, mas como era uma rb achei que era normal.

  18. #18

    Padrão

    E pelo winbox os gráficos também são zerados? Não uso o webserver então não sei dizer a respeito dele.



  19. #19

    Padrão

    Citação Postado originalmente por lucianogf Ver Post
    E pelo winbox os gráficos também são zerados? Não uso o webserver então não sei dizer a respeito dele.
    no winbox funciona normal, enquanto o cliente ta ativo ele mostra todos os dados, mas eu gosto do graphs via web porque é parecido com o mrtg e também por onde vejo o consumo do link, interface com o proxy, interface dos clientes.

  20. #20

    Padrão

    se você usar linux dá pra você instalar o cacti e gerar o gráfico disso tudo.