Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Smile Web proxy e cache full como fazer?

    estou com dificuldade para fazer rodad web proxy e cache full alguem pode me ajudar?
    Última edição por sergio; 30-07-2009 às 21:11. Razão: Texto estava em maiúsculas

  2. #2

    Padrão

    Sim! no que você está com problemas, poste aí tuas regras e explique melhor o que está acontecendo.
    Qual Versão de Mikrotik tu usa?
    T+++++++++



  3. #3

    Thumbs up MINHAS REGRAS






    #
    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark=squid-connection-HIT \
    passthrough=yes comment="\"Cache-squid\" disabled=no" disabled=no
    add chain=input connection-mark=squid-connection-HIT action=mark-packet \
    new-packet-mark=squid-packet-HIT passthrough=yes comment="\"\" \
    disabled=no" disabled=no
    add chain=prerouting in-interface=1.Lan src-address=192.168.1.0/24 \
    action=mark-packet new-packet-mark=test-up passthrough=no comment="\"UP \
    \n" disabled=no
    add chain=forward src-address=192.168.1.0/24 action=mark-connection \
    new-connection-mark=test-conn passthrough=yes comment="\"CONN-MARK\" \
    disabled=no" disabled=no
    add chain=forward in-interface=1.Lan connection-mark=test-conn \
    action=mark-packet new-packet-mark=test-down passthrough=yes \
    \n" disabled=no isabled=no \\
    add chain=output out-interface=1.Lan dst-address=192.168.1.0/24 \
    action=mark-packet new-packet-mark=test-down passthrough=no \
    comment="\"DOWN-VIA PROXY\" \\ disabled=no" \
    disabled=no
    / ip firewall nat
    add chain=srcnat action=masquerade comment="" disabled=no
    add chain=dstnat in-interface=1.Lan protocol=tcp dst-port=80 action=redirect \
    to-ports=3128 comment="" disabled=yes
    add chain=dstnat protocol=tcp dst-port=80 action=redirect to-ports=3128 \
    comment="" disabled=yes
    / ip firewall connection tracking
    set enabled=yes tcp-syn-sent-timeout=5s tcp-syn-received-timeout=5s \
    tcp-established-timeout=1d tcp-fin-wait-timeout=10s \
    tcp-close-wait-timeout=10s tcp-last-ack-timeout=10s \
    tcp-time-wait-timeout=10s tcp-close-timeout=10s udp-timeout=10s \
    udp-stream-timeout=3m icmp-timeout=10s generic-timeout=10m \
    tcp-syncookie=no
    / ip firewall filter
    add chain=forward action=accept comment="" disabled=no
    add chain=input in-interface=1.Lan protocol=tcp dst-port=3128 action=drop \
    comment="" disabled=no
    add chain=input in-interface=1.Lan protocol=tcp dst-port=3128 action=drop \
    comment="\"bloqueio do proxy externo\"" disabled=no
    add chain=input in-interface=1.Lan protocol=tcp dst-port=3128 action=drop \
    \n" disabled=no OQUEIO DO PROXY EXTERNO
    add chain=input in-interface=1.Lan protocol=tcp dst-port=3126 action=drop \
    \n" disabled=no rote ao Externa Proxy\" disabled=no
    add chain=input in-interface=1.Lan protocol=tcp dst-port=53 action=drop \
    comment="\"Prote ao Externa Dns\" disabled=no " disabled=no
    add chain=input in-interface=1.Lan protocol=udp dst-port=53 action=drop \
    \n" disabled=no " disabled=no

    amigo meu msn:[email protected]
    me adicione pra mim falar com vc,grato luciano

  4. #4

    Padrão

    Vamos lá:

    Tente não usar in-interface, faça da seguinte forma.

    /ip firewall nat
    add action=redirect chain=dstnat comment="Redirecionamento para o proxy" disabled=yes dst-port=80 protocol=tcp src-address=10.1.1.0/24 to-ports=3128

    /ip firewall mangle
    add action=mark-connection chain=output comment="cache full" content="X-Cache: HIT" disabled=yes new-connection-mark=squid_connection-HIT passthrough=yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="" connection-mark=squid_connection-HIT disabled=yes new-packet-mark=squid-packet-HIT passthrough=yes

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=50000000 name="down cache-full" packet-mark=squid-packet-HIT parent=global-out priority=8 queue=default

    Lembrando!!!
    Não se esqueça de aumenta o “Max cachê size” em /ip web-proxy settings
    Se usar hotspot não habilitar o Transparent Proxy no profiles dos usuários.
    t++++



  5. #5

    Thumbs up A REGRA DO NAT ESTA BLOQUEANDO

    OI AMIGO ESTA REGRA DO NAT ESTA BLOQUEANDO A INTERNET QUANDO EU FIZ ELA A INTERNET NAO ABRE.

  6. #6

    Padrão

    ela vai pegar tudo da porta 80 e joga para a 3128 do proxy certo:
    agora verifique se o web-proxy ta habilitado.



  7. #7

    Padrão

    qual versão do mk??
    posta ai!
    Última edição por smith; 31-07-2009 às 17:18.

  8. #8

    Talking

    Bom vamos primeiramente vou resaltar que se sua verão de mk for 2.9.27 aquela crackeada!
    consultei 2 amigos meu analistas e os 2 tiveram o mesmo problema !
    esqueça.. o proxy dela da pau ... mesmo! acabei com minha rede aqui tentando configura-lo!
    a solução que eu achei foi um segundo servidor em série , com slack 12.0 só pra fazer cache ful e web-proxy !
    que voçê pode encontrar neste link >>>> Linux: MikroTik + Squid 2.6 com cache full [Artigo]
    fazendo resaltar que esta receita de bolo serve pra quaquer versão de mk!
    + façil que issu só se eu for ai fazer pra voçê
    espero que consiga!
    Smit
    __________________________________________
    Analista Junior (por enquanto) up grade em breve !
    se ajudei agradeça !
    falouuuuuuuuuuuuuuuuu!
    irmão!
    Última edição por smith; 31-07-2009 às 17:18.



  9. #9

    Thumbs up cache como fazer

    O MEU CACHE ESTA DANDO INVALIDO HOST NAME ALGUEM PODE ME AJUDAR?

  10. #10

    Padrão

    Segue o tutorial daqui mesmo que funciona 100% e nessa versão ai.



  11. #11
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por luk21 Ver Post
    O MEU CACHE ESTA DANDO INVALIDO HOST NAME ALGUEM PODE ME AJUDAR?
    Prezado,

    além de usar essa porcaria de versão pirata do Mikrotik (sim a 2.9.27) você não leu nem os Termos de Uso nem o FAQ e nada que diz respeito a netiqueta? Por favor colabore, digite em minúsculas, use acentuação. Vamos manter o mínimo de nível, assim você se ajuda, colabora com o portal e demais usuários.

  12. #12

    Padrão COMO FAZER PARA ABRIR PAGINAS DINAMICAS

    OLA AMIGO OBRIGADO PELAS AULAS DE PORTUGUES MAS NAO É DESSAS QUE ESTOU PRECISANDO AGORA E SIM AJUDA NO MICROTIK SE VC NAO PODE ME AJUDAR NAO ATRAPALHA QUEM TEM BOA VONTADE DE AJUDAR,GRATO LUCIANO



  13. #13
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por luk21 Ver Post
    OLA AMIGO OBRIGADO PELAS AULAS DE PORTUGUES MAS NAO É DESSAS QUE ESTOU PRECISANDO AGORA E SIM AJUDA NO MICROTIK SE VC NAO PODE ME AJUDAR NAO ATRAPALHA QUEM TEM BOA VONTADE DE AJUDAR,GRATO LUCIANO
    Não é português é o padrão do forum. Poderia ler os Termos de Uso e FAQ e vários tópicos sobre o funcionamento dos fóruns? Garanto que não doerá nada e sairá com mais conhecimento e quem sabe até conseguirá ajuda para seus problemas terríveis de configurações do Mikrotik RoS.

  14. #14

    Padrão

    Amigo

    Acho que se copiou e colou as regras acima, faltou a do "Nat", e eu concordo com o Sergio
    quanto ao modo adequado e padronizado, fica mais facil para podermos ajudar, pelo menos
    ja entenderemos o problema

    Abçs ae Sergio
    Sds



  15. #15

    Padrão

    Citação Postado originalmente por powernetscm Ver Post
    Amigo

    Acho que se copiou e colou as regras acima, faltou a do "Nat", e eu concordo com o Sergio
    quanto ao modo adequado e padronizado, fica mais facil para podermos ajudar, pelo menos
    ja entenderemos o problema

    Abçs ae Sergio
    Sds
    então amigo a do nat eu passei pra ele antes ate mesmo de postar as regras.
    aí resolvi posta so o que precisa mesmo para que todos podem ver.
    e passei Nat Full.

  16. #16

    Padrão

    Para com isu mano segue meu conselho!
    faz o proxy no linux , ja te falei ...
    ta quebrando a cabeça a toa , te falei não funciona ..!
    abraços t+!!
    [ame]http://www.youtube.com/watch?v=8zFYt1_0FUE[/ame]
    Última edição por smith; 14-08-2009 às 11:36.



  17. #17

    Padrão

    eu tentei aqui colocar o proxy paralelo com debian mais o engraçado é que ele ta parando do nada, o meu squid conf esta ae www.powernetscm.com.br/squid.conf se alguem achar algo errado por favor me avise pois voltei pro proxy do mk que ta rodando bem, mas nao tem os logs de acesso dos clientes que hj é necessário caso alguem precise

  18. #18

    Padrão

    Boa noite a todos,

    Galera to precisando tirar uma duvida e de uma mão, bom possuo servidor mk 2.9.51 licenciado e faço controle dos meus clientes atravéz do queue e estava querendo colocar um cache para começar a colocar a ``casa em ordem`` mas não sei muito por onde começar se algum dos amigos puderem me ajudar fico grato... abraço a todos!!!



  19. #19

    Padrão

    Citação Postado originalmente por powernetscm Ver Post
    eu tentei aqui colocar o proxy paralelo com debian mais o engraçado é que ele ta parando do nada, o meu squid conf esta ae www.powernetscm.com.br/squid.conf se alguem achar algo errado por favor me avise pois voltei pro proxy do mk que ta rodando bem, mas nao tem os logs de acesso dos clientes que hj é necessário caso alguem precise
    Andei olhando o teu squid.conf powernet, o teu "maximum_object_size 300 MB" muito graaaaaaaaaaaaaande cara pra pouca memoria aí.
    Tenta colocar mais memoria e diminuir aí o maximum_object_size 300 MB pra uns 6 MB.
    precisando tamos aí....

  20. #20