+ Responder ao Tópico



  1. #1

    Padrão PAgina de aviso/bloqueio ok! Agora quero uma index

    Com a configuração abaixo consegui com sucesso de 100% colocar uma pagina de bloqueio(aviso) para meus clientes. Assim que o cliente abre o browser, a pagina que aparece para ele eh a que eu "determinei" na configuração abaixo, e ele nao consegue mais sair da pagina que "determinei" aqui testei e funcionou.
    Usei esta configuração no servidor(mkt) que ta configurado apenas com ip + mac + queue.

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="REDIRECIONA CLIENTES DEBITO-AVISO" disabled=no \
    protocol=tcp src-address=192.168.10.222 to-addresses=\
    192.168.10.232 to-ports=8888

    Onde em azul, é o IP do devedor lazarento
    Em vermelho, é o ip do meu servidor

    "creditos para nosso amigo Alan Dias"


    Agora queria fazer com que apenas a primeira pagina que o cliente abrir apareça a pagina que eu "determinei" e as demais paginas que ele abrir no browser abrirao normalmente.
    Tem como fazer isso, sem ter que usar hotspot poo pppoe ?

  2. #2

    Padrão

    Citação Postado originalmente por mdcsp Ver Post
    Com a configuração abaixo consegui com sucesso de 100% colocar uma pagina de bloqueio(aviso) para meus clientes. Assim que o cliente abre o browser, a pagina que aparece para ele eh a que eu "determinei" na configuração abaixo, e ele nao consegue mais sair da pagina que "determinei" aqui testei e funcionou.
    Usei esta configuração no servidor(mkt) que ta configurado apenas com ip + mac + queue.

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="REDIRECIONA CLIENTES DEBITO-AVISO" disabled=no \
    protocol=tcp src-address=192.168.10.222 to-addresses=\
    192.168.10.232 to-ports=8888

    Onde em azul, é o IP do devedor lazarento
    Em vermelho, é o ip do meu servidor

    "creditos para nosso amigo Alan Dias"


    Agora queria fazer com que apenas a primeira pagina que o cliente abrir apareça a pagina que eu "determinei" e as demais paginas que ele abrir no browser abrirao normalmente.
    Tem como fazer isso, sem ter que usar hotspot poo pppoe ?
    amigo muito bom seu redirect, o 192.168.10.232 to-ports=8888, é o ip do proprio servodor, mikrotik? ou um outro que armazena a pagina de bloqueio? como fez a pagina? teria como dar alguma dica?

    obrigado!!!



  3. #3
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Se quiser melhorar...

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="AVISO PARA BLOQUEADOS" disabled=no dst-port=0-65535 protocol=tcp src-address-list=Devedores to-addresses=\
    189.x.x.x to-ports=80

    /ip firewall address-list
    add address=10.8.11.0/30 comment=ZéDasCandongas disabled=no list=Devedores
    add address=10.3.8.0/30 comment=MariaDasCouves disabled=yes list=Devedores


    Onde poderá habilitar ou desabilitar o cliente na address-list.

  4. #4
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Para abrir somente a primeira vez, o que pode fazer é colocar o IP numa address list e dar um time-out de 24 horas por exemplo. Depois das 24 horas ele cai na regra do DNAT de novo.



  5. #5

    Padrão

    Dei uma improvisada( ja que a hospedagem seria somente pra uma pagina(index)):

    Instalei um servidorzinho chamado "sambar server"(baixei do baixaki) num Pentium III, e joguei este PIII na minha rede.
    Quanto a pagina, fiz no frot-page bem simples mesmo, basica e leve, coloquei apenas a logomarca e abaixo solicitando que o cliente entre em contato o mais breve possivel no numero tal.... nao coloquei nada a mais do que isso, para evitar qualquer tipo de constrangimenmto ao cliente.

    Agora to em busca:
    - Como colocar esta index direto no MKT sem ter que usar o PIII.
    - E se posso adaptar pra usar como pagina inicial(pro cliente soh ver a pagina uma unica vez a cada "conexao" depois pode navega a vontade).

    "creditos para nosso amigo Alan Dias"

  6. #6

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Para abrir somente a primeira vez, o que pode fazer é colocar o IP numa address list e dar um time-out de 24 horas por exemplo. Depois das 24 horas ele cai na regra do DNAT de novo.

    Bom, dica valida ate mesmo para uma outra situação que eu tenho aqui.

    Mas teria outra forma de fazer uma pagina inicial mesmo, o cliente ligou o micro-> a primeira e apenas a primeira pagina eu que determino, independente do horario. E para todos os clientes.
    e isso tudo , sem usar pppeo ou hotspot ?



  7. #7

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Se quiser melhorar...

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="AVISO PARA BLOQUEADOS" disabled=no dst-port=0-65535 protocol=tcp src-address-list=Devedores to-addresses=\
    189.x.x.x to-ports=80

    /ip firewall address-list
    add address=10.8.11.0/30 comment=ZéDasCandongas disabled=no list=Devedores
    add address=10.3.8.0/30 comment=MariaDasCouves disabled=yes list=Devedores


    Onde poderá habilitar ou desabilitar o cliente na address-list.
    valeu mesmo ai sergio...

  8. #8

    Padrão

    Citação Postado originalmente por mdcsp Ver Post
    Dei uma improvisada( ja que a hospedagem seria somente pra uma pagina(index)):

    Instalei um servidorzinho chamado "sambar server"
    vc sabe de algum tutorial dele?



  9. #9

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Se quiser melhorar...

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="AVISO PARA BLOQUEADOS" disabled=no dst-port=0-65535 protocol=tcp src-address-list=Devedores to-addresses=\
    189.x.x.x to-ports=80

    /ip firewall address-list
    add address=10.8.11.0/30 comment=ZéDasCandongas disabled=no list=Devedores
    add address=10.3.8.0/30 comment=MariaDasCouves disabled=yes list=Devedores


    Onde poderá habilitar ou desabilitar o cliente na address-list.
    Galera essa dica do Ségio é bem simples e funcionou perfeitamente, ja tive ate umas ideias aki de usar esse tipo de regra pra avisos em geral para toda rede como uma manutenção preventiva ou um maketing, divulgar promoçoes da loja etc rsrsr... Criei uma página bem basica usando o publisher e hospedei em um servidor 2003 com IIS que tenho aki, ficou dahora rsrsr Valeu Sérgio.

    texto da página:


    Navegação Não Permitida! —( ERRO 51 )


    Prezado cliente!

    Identificamos pendências no seu cadastro, favor entrar em contato conosco o mais breve possível para que continuem utilizando os nossos serviços.

    Ligue: 11 XXXX-XXXX

    obs.. esse erro 51 é só pra gente saber qual é o aviso que está aparecendo. DA VONTADE DE COLOCAR ERRO 171 rsrsr


    até mais