+ Responder ao Tópico



  1. #1

    Padrão Qos_Youtube

    Olá, pessoal........
    Numa dessas pesquisadas nos forums da vida, achei legal esse Qos pro youtube .
    Testem e postem os resultados.
    Abraços

    /ip firewall filter
    add chain=forward src-address=192.168.10.0/24 protocol=tcp content=.flv \
    action=add-dst-to-address-list address-list=downloads \
    address-list-timeout=01:00:00
    ------------------
    /ip firewall mangle add chain=forward \
    protocol=tcp src-address-list=downloads \
    action=mark-packet new-packet-mark=download-paket
    --------------------
    /queue simple add name=download-files \
    max-limit=64000/64000 packet-marks=download-paket


  2. #2

    Padrão content

    Citação Postado originalmente por rps67 Ver Post
    Olá, pessoal........
    Numa dessas pesquisadas nos forums da vida, achei legal esse Qos pro youtube .
    Testem e postem os resultados.
    Abraços

    /ip firewall filter
    add chain=forward src-address=192.168.10.0/24 protocol=tcp content=.flv \
    action=add-dst-to-address-list address-list=downloads \
    address-list-timeout=01:00:00
    ------------------
    /ip firewall mangle add chain=forward \
    protocol=tcp src-address-list=downloads \
    action=mark-packet new-packet-mark=download-paket
    --------------------
    /queue simple add name=download-files \
    max-limit=64000/64000 packet-marks=download-paket

    acho que não funciona, pq o content pega strings no arquivo e os flv não tem a menos que vc defina, seria boa se pega-se a extensão do arquivo .flv, acho que tem como mais não lembro como marcar pela extensão, vi em algum topico que era para dropar arquivos .src ......



  3. #3

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    Olá, pessoal........
    Numa dessas pesquisadas nos forums da vida, achei legal esse Qos pro youtube .
    Testem e postem os resultados.
    Abraços

    /ip firewall filter
    add chain=forward src-address=192.168.10.0/24 protocol=tcp content=.flv \
    action=add-dst-to-address-list address-list=downloads \
    address-list-timeout=01:00:00
    ------------------
    /ip firewall mangle add chain=forward \
    protocol=tcp src-address-list=downloads \
    action=mark-packet new-packet-mark=download-paket
    --------------------
    /queue simple add name=download-files \
    max-limit=64000/64000 packet-marks=download-paket

    Bela iniciativa, tentei aki mas não tive exito hem nem uma marcarão dessas regras.
    Mas valeu.

  4. #4

    Padrão

    eu coloco no content youtube redtube tube e consigo controlar versao 3.27 abraços



  5. #5

    Padrão

    Legal a participação e das opiniões.... a questão é o processamento usando-se o content, estou testando layer7, se alguém conseguiu poste aqui, conseguindo aqui vou postar.

  6. #6

    Padrão

    Será que dá para redirecionar também para um link? Na versão 3.27 está funcionando o content? Nas anteriores não tive muito suucesso.



  7. #7
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Olha só, eu uso essa regex com o thunder, ela dá match na url do youtube certinho, só a url do vídeo mesmo:
    Código :
    (youtube|google(video)?)\.(([a-zA-z]){2,3}(\.)?){1,2}/(videoplay(back)?)\?

    Não sei se ajuda, mas usar content youtube é muito vago para minha cabeça.

  8. #8
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Citação Postado originalmente por osmano807 Ver Post
    Olha só, eu uso essa regex com o thunder, ela dá match na url do youtube certinho, só a url do vídeo mesmo:
    Código :
    (youtube|google(video)?)\.(([a-zA-z]){2,3}(\.)?){1,2}/(videoplay(back)?)\?

    Não sei se ajuda, mas usar content youtube é muito vago para minha cabeça.
    Se é um regex, no Mikrotik poderá usar o layer7, que trabalha por regex, que irá funcionar. Qualquer coisa só consultar o Layer 7 Kernel HOWTO para verificar como se desenvolve os protocolos de definições.



  9. #9

    Padrão

    Citação Postado originalmente por osmano807 Ver Post
    Olha só, eu uso essa regex com o thunder, ela dá match na url do youtube certinho, só a url do vídeo mesmo:
    Código :
    (youtube|google(video)?)\.(([a-zA-z]){2,3}(\.)?){1,2}/(videoplay(back)?)\?

    Não sei se ajuda, mas usar content youtube é muito vago para minha cabeça.
    Na realidade eu uso um balanceamento com tcp_outgoing_addrees, funcionando legal, contudo o YouTube em particular me da a impressão que passa fora da regra. Você poderia me explicar como ficaria esse regex em uma acl do tipo dst_domain por exemplo? Aqui uso assim:

    #Sites para o Link2
    acl link2 dstdom_regex youtube
    tcp_outgoing_address 165.190.0.2 link2
    http_access allow link2

  10. #10
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Citação Postado originalmente por Josue Guedes Ver Post
    Na realidade eu uso um balanceamento com tcp_outgoing_addrees, funcionando legal, contudo o YouTube em particular me da a impressão que passa fora da regra. Você poderia me explicar como ficaria esse regex em uma acl do tipo dst_domain por exemplo? Aqui uso assim:

    #Sites para o Link2
    acl link2 dstdom_regex youtube
    tcp_outgoing_address 165.190.0.2 link2
    http_access allow link2
    É regex, então:

    acl link2 url_regex -i "/etc/squid/lista_regex.lst"

    Dentro do arquivo coloca as regex