Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    vmh0909
    Ola

    novamente estou precisando da ajuda dos universitarios, rsrs

    tenho que fazer redundancia e balanceamento de carga com dois link's de 12Mb e 8mb, um net virtua e outro gvt, e distribuir para um hotel com 350 aptos e salão de eventos para mais ou menos 2000 pessoas.

    tenho um PC com 4 placas de rede e Mikrotik 3.28 Nivel5

    ja instalei o hotspot e utilizei o software ISGI para gerenciar os usuarios ja que ele é integrado com o sistema do hotel e faz tudo automaticamente não necessito fazer nada, quando é feito o checkin na recepção ele ja cria o usuario e imprime o cupom com usuario e senha e no checkout ele encera automaticamente tambem e lança os valores na conta do hospede, e guarda os log's de sites e endereços acessados para analize forense.

    com apenas um link funciona perfeitamente bem, o meu problema começa quando tenho que colocar dois link's.

    depois de muito pesquizar em foruns da vida e muitos testes,(ja que não sou muito bom em MK) eu utilizei o exemplo do link PCC - MikroTik Wiki e adaptei ele para a minha estrutura, e ficou assim:

    / ip address
    add address=10.5.50.1/16 network=10.5.50.0 broadcast=10.5.50.255 interface=ether1
    add address=192.168.10.2/24 network=192.168.10.0 broadcast=192.168.10.255 interface=ether2
    add address=192.168.0.2/24 network=192.168.0.0 broadcast=192.168.0.255 interface=ether3

    / ip firewall mangle
    add chain=input in-interface=ether2 action=mark-connection new-connection-mark=ether2_conn
    add chain=input in-interface=ether3 action=mark-connection new-connection-mark=ether3_conn
    add chain=output connection-mark=ether2_conn action=mark-routing new-routing-mark=to_ether2
    add chain=output connection-mark=ether3_conn action=mark-routing new-routing-mark=to_ether3
    add chain=prerouting dst-address=192.168.10.0/24 action=accept in-interface=ether1
    add chain=prerouting dst-address=192.168.0.0/24 action=accept in-interface=ether1
    add chain=prerouting dst-address-type=!local in-interface=ether1 per-connection-classifier=both-addresses:2/0 \
    action=mark-connection new-connection-mark=ether2_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=ether1 per-connection-classifier=both-addresses:2/1 \
    action=mark-connection new-connection-mark=ether3_conn passthrough=yes
    add chain=prerouting connection-mark=ether2_conn in-interface=Local action=mark-routing new-routing-mark=to_ether2
    add chain=prerouting connection-mark=ether3_conn in-interface=Local action=mark-routing new-routing-mark=to_ether3

    / ip route
    add dst-address=0.0.0.0/0 gateway=192.168.10.1 routing-mark=to_ether2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.0.1 routing-mark=to_ether2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.10.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.0.1 distance=2 check-gateway=ping

    / ip firewall nat
    add chain=srcnat out-interface=ether2 action=masquerade
    add chain=srcnat out-interface=ether3 action=masquerade

    a redundancia eu sei que funciona pois ja testei e funcionou perfeitamente, minha duvida é se com estas regras ele faz o balanceamento tambem ou não?

    outra duvida é como fazer ele funcionar sem ter que colocar ip fixo na ether2 e 3 pois o net virtua muda o ip quando cai o link ja o gvt mantem porque eu estou usando o modem roteado.

    se alguem puder me ajudar desde ja agradeço.


  2. Nesse seu caso, com "Peso" diferente, faz por NTH com bastante divisões que fica perfeito.



  3. O raciocinio no Pcc é similar ao do Nth. Ou seja, quando temos links de maior largura de banda, criamos repeticoes para o link. Exemplo:

    Link 1 = 2 M + link 2 = 4 M, vc visualiza como se fossem 3 links, assim:

    Link1 = 2
    Link2 = 2 total 6 M
    Link2 = 2

  4. #4
    vmh0909
    Ola Pessoal.

    testei com NTH seguindo o que estava no wiki do site da mikrotik, com as seguintes regras

    /ip firewall mangle
    add action=mark-packet chain=prerouting new-packet-mark=AAA nth=2,1;

    /ip firewall mangle
    add action=mark-packet chain=prerouting new-packet-mark=AAA nth=3,1 passthrough=yes;
    add action=mark-packet chain=prerouting new-packet-mark=BBB nth=3,2 passthrough=yes;
    add action=mark-packet chain=prerouting new-packet-mark=CCC nth=3,3 passthrough=yes;

    porem não funcionou, como comentei anteriormente nunca fiz isso, porem com PCC e as regras
    que coloquei anteriormente funcionou, ele faz o balanceamento e a redundancia.

    meu problema é com o login nos clientes hotspot, pois só aparece a tela de login se um digitar no browse o ip do hotspot ou o endereço tipo Under-Linux.Org O Portal do Administador de Sistemas ele não direciona automaticamente como deveria.

    alguem sabe se tem que adicionar alguma regra no firewall, ou o que eu fiz de errado.

    desde ja agradeço o auxilio de todos.



  5. #5
    vmh0909
    Ola.

    depois de muito quebrar a cabeça muita pesquiza, acabei descobrindo que o hotspot não funciona com o PCC na mesma maquina, a solução foi utilizar uma RB450G para o balanceamento com PCC e uma outra maquina com o hotspot.

    se por acaso alguem sabe como fazer os dois funcionarem na mesma maquina e puder me ajudar eu agradeço.

    estou disposto a pagar pela consultoria.







Tópicos Similares

  1. Não Autentiucar com hotspot...
    Por klemensonleal no fórum Redes
    Respostas: 2
    Último Post: 04-05-2006, 23:13
  2. Balanceamento com ADSL+Link
    Por liandrocarniel no fórum Redes
    Respostas: 3
    Último Post: 31-03-2006, 10:28
  3. Problemas com HotSpot
    Por Samuelso no fórum Redes
    Respostas: 3
    Último Post: 17-02-2006, 23:13
  4. Balanceamento com 2 links ADSL
    Por maverick_cba no fórum Servidores de Rede
    Respostas: 37
    Último Post: 20-06-2005, 16:00
  5. Redundancia e balanceamento de Tsunamis
    Por Mac-Dowell no fórum Redes
    Respostas: 2
    Último Post: 30-05-2005, 11:25

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L