+ Responder ao Tópico



  1. #1

    Padrão Squid porreta - não vai

    pessoal to com um squid em paralelo com mikrotik mas o trem não funciona. alias explicando melhor não abre yahoo, MSN e demora para abrir alguns sites de banco e e de exemplo o baixaki.com.br. segue as config

    Squid.conf

    Código :
    http_port 9999
    visible_hostname webproxy
     
    hierarchy_stoplist cgi-bin ?
    acl QUERY urlpath_regex cgi-bin \?
    cache deny QUERY
     
    acl manager proto cache_object
    acl localhost src 127.0.0.1/255.255.255.255
    acl SSL_ports port 443 563
    acl Safe_ports port 80
    acl Safe_ports port 21
    acl Safe_ports port 443 563
    acl Safe_ports port 70 #protocolo gopher antigo
    acl Safe_ports port 210 #whais
    acl Safe_ports port 1024-65535 #todas as outras portas
    acl Safe_ports port 280 #http-mgmt
    acl Safe_ports port 488 #gss-http
    acl Safe_ports port 591 #filemaker
    acl Safe_ports port 777 #multi http
    acl Safe_ports port 901 #acesso Swat
    acl purge method PURGE
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access allow purge localhost
    http_access deny purge
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_PORTS
     
    #permissao de acesso ao proxy, rede do Mikrotik
    #classe de rede ou classes separadas por espa�os.
    acl redelocal src 0.0.0.0/0
    http_access allow localhost
    http_access allow redelocal
     
    #bloquear todos outros acessos.
    http_access deny all
     
    #access log
    cache_access_log /var/log/squid3/access.log
     
    #cache.log
    cache_log /var/log/squid3/cache.log
     
    #memoria reservada para o cache, coloque um valor de preferencia 40%
    # do total da sua maquina, e nao mais.
    cache_mem 2000 MB
     
    #maximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 80 KB
     
    #maximo tamanho dos arquivo cache no hd
    maximum_object_size 50 MB
    minimum_object_size 0 KB
     
    #regra que comeca a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 80
    cache_swap_high 90
     
    #indicacao de localizacao da pasta de arquivos cache e em sequencia valor
    #total em MB de espaco no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid3               716800 32 256
     
    #intervalos de tempos que o proxy verificara os arquivos dos site acessado
    #conferem com o do cache, o valor 4560 significa 04 dias
    refresh_pattern ^ftp: 15 20% 4560
    refresh_pattern ^gopher: 15 0% 4560
    refresh_pattern . 15 20% 4560
     
    #Mantendo objetos recentes e pequenos na memoria
    memory_replacement_policy heap GDSF
     
    #Ativando pools de memoria, evitando o Squid ficar realocando memoria toda
    #hora que precisar, manter pools de 32MB
    #memory_pools off
    #memory_pools_limit 0
     
    #Admnistrador
    cache_mgr [email protected]
     
    #Pagina de Erros em Portugues
    error_directory /usr/share/squid3/errors/Portuguese
    ip firewall nat
    Código :
    add action=redirect chain=dstnat comment="" disabled=yes dst-address=!ipvalido dst-port=80 in-interface=LAN protocol=tcp src-address=192.168.32.64/26 to-ports=312
    ip web-proxy
    Código :
    set always-from-cache=no [email protected] cache-hit-dscp=4 cache-on-disk=no enabled=yes max-cache-size=none max-client-connections=1000 max-fresh-time=3d max-server-connections=1000 \
        parent-proxy=10.10.10.2 parent-proxy-port=5128 port=3128 serialize-connections=no src-address=0.0.0.0
    ip web-proxy cache
    Código :
    set always-from-cache=no [email protected] cache-hit-dscp=4 cache-on-disk=no enabled=yes max-cache-size=none max-client-connections=1000 max-fresh-time=3d max-server-connections=1000 \
        parent-proxy=10.10.10.2 parent-proxy-port=5128 port=3128 serialize-connections=no src-address=0.0.0.0
    o que pode estar de errado?
    A versão do mk é 3.22

    Lembrando que esta tendo problemas com yahooo, hotmail e paginas de banco.
    O hits do ip web-proxy cache não estão sendo contados.

    Obrigado.
    Última edição por byosni; 11-08-2009 às 10:24.

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    quanto tem de RAM esse squid e o que os logs dizem?



  3. #3

    Padrão

    a maquina tem de ram 4 GB.
    Código :
    2009/08/11 07:17:36| Starting Squid Cache version 3.0.STABLE8 for i486-pc-linux-gnu...
    2009/08/11 07:17:36| Process ID 9128
    2009/08/11 07:17:36| With 65535 file descriptors available
    2009/08/11 07:17:36| DNS Socket created at 0.0.0.0, port 58181, FD 7
    2009/08/11 07:17:36| Adding nameserver 189.38.95.95 from /etc/resolv.conf
    2009/08/11 07:17:36| Adding nameserver 189.38.95.96 from /etc/resolv.conf
    2009/08/11 07:17:37| Unlinkd pipe opened on FD 12
    2009/08/11 07:17:37| Local cache digest enabled; rebuild/rewrite every 3600/3600 sec
    2009/08/11 07:17:37| Swap maxSize 734003200 KB, estimated 56461784 objects
    2009/08/11 07:17:37| Target number of buckets: 2823089
    2009/08/11 07:17:37| Using 4194304 Store buckets
    2009/08/11 07:17:37| Max Mem  size: 2048000 KB
    2009/08/11 07:17:37| Max Swap size: 734003200 KB
    2009/08/11 07:17:37| Rebuilding storage in /var/spool/squid3 (DIRTY)
    2009/08/11 07:17:37| Using Least Load store dir selection
    2009/08/11 07:17:37| Current Directory is /
    2009/08/11 07:17:37| Loaded Icons.
    2009/08/11 07:17:37| Accepting  HTTP connections at 0.0.0.0, port 9999, FD 13.
    2009/08/11 07:17:37| HTCP Disabled.
    2009/08/11 07:17:37| Ready to serve requests.
    2009/08/11 07:17:38| Done scanning /var/spool/squid3 swaplog (0 entries)
    2009/08/11 07:17:38| Finished rebuilding storage from disk.
    2009/08/11 07:17:38|        10 Entries scanned
    2009/08/11 07:17:38|         0 Invalid entries.
    2009/08/11 07:17:38|         0 With invalid flags.
    2009/08/11 07:17:38|        10 Objects loaded.
    2009/08/11 07:17:38|         0 Objects expired.
    2009/08/11 07:17:38|         0 Objects cancelled.
    2009/08/11 07:17:38|         0 Duplicate URLs purged.
    2009/08/11 07:17:38|         0 Swapfile clashes avoided.
    2009/08/11 07:17:38|   Took 1.06 seconds (  9.42 objects/sec).
    2009/08/11 07:17:38| Beginning Validation Procedure
    2009/08/11 07:17:38|   Completed Validation Procedure
    2009/08/11 07:17:38|   Validated 45 Entries
    2009/08/11 07:17:38|   store_swap_size = 52
    2009/08/11 07:17:38| storeLateRelease: released 0 objects
    este é o arquivo do cache.log

    Agora olha que interessante o arquivo store.log. quando eu acesso o yahoo.

    Código :
    1249985907.202 RELEASE -1 FFFFFFFF 1322489AC92B8D6B332D74088C454239  301 1249996747        -1        -1 text/html -1/141 GET [URL]http://www.yahoo.com.br/[/URL]
    1249985907.371 RELEASE -1 FFFFFFFF 3AA2BD5EDE96D0182AAEB585B07CCDEE  200 1249996748        -1 1249996748 text/html 24038/24038 GET [URL]http://br.yahoo.com/[/URL]
    1249985918.655 RELEASE -1 FFFFFFFF 12B7E3E8DB929399590CD57576F96632  404 1249996759        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/lib/latam/sp/css/styles_br_rb_1.30.css[/URL]
    1249985918.668 RELEASE -1 FFFFFFFF 11B7EDAC6EAE9DEED80C5191F8C81181  404 1249996759        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/combo[/URL]?
    1249985929.203 RELEASE -1 FFFFFFFF 391D682A75DF5C4BF29D7D3F029A16EF  404 1249996769        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/esportes/2009-2/schumacherandbadoer_300_gettyimages.j$[/URL]
    1249985929.212 RELEASE -1 FFFFFFFF F8200858E40B084A25F3B215DACCB7FC  404 1249996769        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/x/i/img2/200801/yahooadins_v01d.js[/URL]
    1249985929.217 RELEASE -1 FFFFFFFF F1DC5CC782B71D0D9682838EE2C02180  404 1249996769        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/entret/0709/michael_jackson_filme300.jpg[/URL]
    1249985929.238 RELEASE -1 FFFFFFFF 0D33EDE3C3C44D2B4EC2C8FE06E271A0  404 1249996769        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/latam/logos/brazilfplogo.gif[/URL]
    1249985929.242 RELEASE -1 FFFFFFFF 03961F57C6F602F8BCA16314D3334869  404 1249996769        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/esportes/0809/internacional_100809_300x196_ae.jpg[/URL]
    1249985929.243 RELEASE -1 FFFFFFFF CC2A8AA02B60C6AB816A9953DA5E34ED  404 1249996769        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/0809/grampos_post_1008.jpg[/URL]
    1249985929.602 RELEASE -1 FFFFFFFF 5C04DD12CC4148DF65C68816BFB5D1FA  200 1249996770        -1 1249985929 image/gif -1/43 GET [URL]http://mfa.bradesco.predicta.net/mrm-ad/ad/pc/[/URL]?
    1249985939.573 RELEASE -1 FFFFFFFF 26FBB60107EDE7943A9D6AB72AF0A704  404 1249996780        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/entret/0709/fiodental300.jpg[/URL]
    1249985939.754 RELEASE -1 FFFFFFFF B025B8343FDBFA845C57A4266DABB8C2  404 1249996780        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/0809/praca_1008.jpg[/URL]
    1249985939.761 RELEASE -1 FFFFFFFF 3B8951138EC15D28F25F8F27DC6DA4CF  404 1249996780        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/news/0709/serra_lula104.jpg[/URL]
    1249985939.781 RELEASE -1 FFFFFFFF DAFE409D723BF2F1A078260A1FE4BAC4  404 1249996780        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/0809/mstp_1008.jpg[/URL]
    1249985939.801 RELEASE -1 FFFFFFFF 1182624423F546DEC111F67628449A4F  404 1249996780        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/0809/claudiap_1008.jpg[/URL]
    1249985939.811 RELEASE -1 FFFFFFFF 11E264549ECFCB9A3D2B45127481B6C5  404 1249996780        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/0809/festa_boliviana_1008.jpg[/URL]
    1249985950.160 RELEASE -1 FFFFFFFF 0271B3C3D47067E93FE0327057C2364A  404 1249996790        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/0809/rap_1008.jpg[/URL]
    1249985950.417 RELEASE -1 FFFFFFFF 1AB63A5142E1CFB4347744678C64B431  404 1249996791        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/0809/loucura_1008.jpg[/URL]
    1249985950.426 RELEASE -1 FFFFFFFF E3D064A2A08599B8A5FBF342D3D94734  404 1249996791        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/search/cade/vanessahudgensexplore.jpg[/URL]
    1249985950.427 RELEASE -1 FFFFFFFF 090F826B9C53488D6AA704347E906F21  404 1249996791        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/search/cade/ashleyexplore.jpg[/URL]
    1249985950.428 RELEASE -1 FFFFFFFF 53F092C4902FC601E156CA3D92AD7B03  404 1249996791        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/0809/cubo_magico_1008.jpg[/URL]
    1249985950.451 RELEASE -1 FFFFFFFF 7746DEAE85568558BD81099F735A23FA  404 1249996791        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/search/cade/emmaexplore.jpg[/URL]
    1249985960.765 RELEASE -1 FFFFFFFF D35D8D6DBB7B2041B101AD8A35F1C477  404 1249996801        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/0809/emprego_1008.jpg[/URL]
    1249985960.946 RELEASE -1 FFFFFFFF 38FCC78C12D2C403522613B593BB159A  404 1249996801        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/x/i/img2/200907/casal_1_50x50.gif[/URL]
    1249985960.971 RELEASE -1 FFFFFFFF 7DAD78F4C17BE7991BCD9BBA290A0E41  404 1249996801        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/x/i/img2/200908/only-the-brave-diesel.gif[/URL]
    1249985960.976 RELEASE -1 FFFFFFFF AF6DB6A34AFF309DB4FB5002C197409C  404 1249996801        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/br.yimg.com/i/img2/200904/nextel_box_blackberry_0428.gif[/URL]
    1249985961.000 RELEASE -1 FFFFFFFF D0E84FB238C4D0B75F874DD41CB47F0D  404 1249996801        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/x/i/img2/200906/0601box_fogoes.gif[/URL]
    1249985961.032 RELEASE -1 FFFFFFFF 0679A20E17311A235169BFDCBBB0AF10  404 1249996801        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/x/i/img2/200908/sky_yahoo_home_boxshopping_090624.jpg[/URL]
    1249985971.332 RELEASE -1 FFFFFFFF D56D1EC1A0CAEAF5B8FAE0FC4E05977E  404 1249996812        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/x/i/img2/200908/box4j.gif[/URL]
    1249985971.499 RELEASE -1 FFFFFFFF EA62B6B2FC03CC229689710F86785CA7  404 1249996812        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/tech/0109/foto_pulso_metallica.jpg[/URL]
    1249985971.537 RELEASE -1 FFFFFFFF 66DC7E8631B7B6EF4C761AD9AE15F63B  404 1249996812        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/tech/0109/foto_pulso_psp.jpg[/URL]
    1249985971.562 RELEASE -1 FFFFFFFF 14E9F25CCFD8A3A6CF26E29DEDB4D956  404 1249996812        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/a/i/br/tech/0109/foto_pulso_sims.jpg[/URL]
    1249985971.577 RELEASE -1 FFFFFFFF CB2DC05AB515536396466DFBC5887845  404 1249996812        -1        -1 text/html 176/176 GET [URL]http://98.137.80.33/d/lib/bc/bcr_2.0.4.js[/URL]
    1249986046.949 RELEASE 00 00000105 4A4E96FA1445C9D7B2798849173ED918   ?         ?         ?         ? ?/? ?/? ? ?

    OBS. mudei a porta do squid.conf para 9999.
    Última edição por byosni; 11-08-2009 às 10:28.

  4. #4

    Padrão

    Código :
    cache_dir ufs /var/spool/squid3  716800 32 256


    ???? esse cache num ta muito grande naum brother ????

    https://under-linux.org/f87231-squid...nstrucao-ideal
    Última edição por Lincoln; 11-08-2009 às 11:29.



  5. #5

    Padrão

    Então o HD é de 750GB vc acha que eu deveria fazer assim

    cache_dir ufs /var/spool/squid3/cache1 307200 32 256
    cache_dir ufs /var/spool/squid3/cache2 307200 32 256

    Vou fazer pra ver

    obrigado...

    Citação Postado originalmente por Lincoln Ver Post
    Código :
    cache_dir ufs /var/spool/squid3  716800 32 256


    ???? esse cache num ta muito grande naum brother ????

    squid - cache_dir construção ideal

  6. #6

    Padrão

    1> abaixe sua memoria, nao precisa tanto, deixe como abaixo
    cache_mem 256 MB
    2> aqui vc pode aumentar um pouco mais o tamanho de cache em memoria, tendo em vista q vc tem 4gb de memoria
    #maximo tamanho dos arquivo cache na memoria
    maximum_object_size_in_memory 2048 KB
    3> qual o tamanho do seu hd? qual o tamanho q vc quer do cache squid?
    eu com hd de 80gb, deixo como tamanho maximo 256 MB
    #maximo tamanho dos arquivo cache no hd
    maximum_object_size 256 MB
    minimum_object_size 0 KB
    4> abaixe um pouco a porcentagem para esvaziar
    #regra que comeca a esvaziar / substituir arquivos no cache em 90%
    cache_swap_low 70
    cache_swap_high 75

    5> abaixe um pouco o tamanho do cache squid, tendo em vista que:
    o squid consome 15mb de memoria para cada 1gb de arquivo (mas eu acho q eh mais)
    coloque algo em torno de uns 20gb... eh mais q o suficiente
    #indicacao de localizacao da pasta de arquivos cache e em sequencia valor
    #total em MB de espaco no hd a ser usado pelo cache, numero de pastas, e
    #numero de subpastas do cache.
    cache_dir ufs /var/spool/squid3 20000 32 256

    da uma olhadinha no squid q postei a algum tempo atras no vivaolinux...
    hoje em dia ta um pouco diferente, algumas regras a mais...

    Linux: Configurar Squid - squid.conf



  7. #7

    Padrão

    amigos não adiataram as soluções olhem como esta abrindo o yahoo.
    Obrigado
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         Sem título123.jpg
Visualizações:	68
Tamanho: 	112,2 KB
ID:      	5107  

  8. #8

    Padrão

    pessoal, outra coisa, o que de mais interessanten acontece é que se eu redirecionar pelo MK ele dá pau no site do yahoo, mas seu eu colocar o iport do proxy no meu navegador e sem ser redirecionado pelo mikrotik tudo funciona normal. Estou achando que o squid esta certo, redondo o problema é no mikrotik. Veja as config do web-proxy

    Obrigado.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         01.jpg
Visualizações:	54
Tamanho: 	55,3 KB
ID:      	5109   Clique na imagem para uma versão maior

Nome:	         02.jpg
Visualizações:	56
Tamanho: 	34,4 KB
ID:      	5110  

    Clique na imagem para uma versão maior

Nome:	         03.jpg
Visualizações:	52
Tamanho: 	26,1 KB
ID:      	5111   Clique na imagem para uma versão maior

Nome:	         04.jpg
Visualizações:	52
Tamanho: 	41,0 KB
ID:      	5112  

    Clique na imagem para uma versão maior

Nome:	         05.jpg
Visualizações:	47
Tamanho: 	24,0 KB
ID:      	5113  



  9. #9

    Padrão

    pessoal, e ai niguem? Existe outra forma de redirecionar o trafego para o meu proxy serm precisar ligar o webproxy usando o parent proxy do mikrotik?

    Obrigado.

  10. #10

    Padrão

    resolução do problemas. Não tinha DNS no servidor MK!

    Código :
    /ip dns
    set allow-remote-requests=no cache-max-ttl=1w cache-size=10240KiB \
        max-udp-packet-size=512 primary-dns=189.38.95.95 secondary-dns=\
        189.38.95.96

    OBRIGADO A TODOS!