+ Responder ao Tópico



  1. #1

    Padrão Script para enviar ip do servidor por e-mail

    Alguem sabe se é possivel enviar do servidor mikrotik um e-mail constando o ip do servidor
    para acesso.

  2. #2

    Padrão

    É só criar um script da seguinte forma:

    ip address print file=tabela_ip

    Este irá gerar um arquivo txt no file com todos os ips que estiver no servidor mikrotik, depois só criar o script de envio para seu e-mail, capturando o arquivo gerado.

    Espero ter ajudado.
    Última edição por supmk; 19-08-2009 às 12:39. Razão: erro



  3. #3

    Padrão

    Citação Postado originalmente por supmk Ver Post
    É só criar um script da seguinte forma:

    ip address print file=tabela_ip

    Este irá gerar um arquivo txt no file com todos os ips que estiver no servidor mikrotik, depois só criar o script de envio para seu e-mail, capturando o arquivo gerado.

    Espero ter ajudado.
    Mas o script para enviar por e-mail vc teria como me informar como fazer
    desde ja agradeço

  4. #4

    Padrão

    O script é o mesmo usado para backup por -email, so fazer algumas alterações, para capturar o arquivo que vc precisa.

    https://under-linux.org/f83156-backu...il-no-mikrotik



  5. #5

    Padrão

    Mas fácil utilizar um script para o changeip e ao invés de acessar o servidor por IP acesse por nome, sem se preocupar se o IP mudou ou não.

  6. #6

    Padrão

    sim seria otimo mas uso modem roteado entao nao achei um script que funcione
    e meu modem nao tem a função de atualizar o ip
    vc teria alguma ideia e ja conseguiu atualizar com modem roteado ?



  7. #7

    Padrão

    Citação Postado originalmente por deson00 Ver Post
    sim seria otimo mas uso modem roteado entao nao achei um script que funcione
    e meu modem nao tem a função de atualizar o ip
    vc teria alguma ideia e ja conseguiu atualizar com modem roteado ?
    Realmente com Modem Roteado acho que não tem como, a não ser que seu Modem tenha a função DDNS, assim você consegueria atualizar seu endereço através de outros serviços parecidos com o ChangeIP, como DynDNS e outros.

    A solução para são duas :

    1- Você põe seu modem no Modo Bridge, põe o MKT para fazer a discagem e com o IP válido no MKT você conseguirá rodar o Script sem problemas.

    ou

    2- Você deixa uma máquina dentro da rede com o DynDNS rodando 24hs e faz um DMZ do modem direcionando para o servidor.

    Para as duas soluções você encontra todo o material no Fórum.

    Espero ter ajudado.

    Abçs.

  8. #8

    Padrão SCRIP DDNS MK COM MODEM EM BRIDGE

    voce deve tem uma conta no changeip.com para utilizar este script
    va em system, scritp
    clique no botao +
    name: ddns
    em source: coloque isto:

    :log info "DDNS: Begin"
    :global ddns-user "seu login"
    :global ddns-pass "sua senha"
    :global ddns-host "seu_host_name"
    :global ddns-interface "nome da interface que esta ligado o modem"
    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]
    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }
    :if ([ :typeof $ddns-ip ] = nil ) do={
    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")
    } else={
    :if ($ddns-ip != $ddns-lastip) do={
    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip
    } else={
    :log info "DDNS: No change"
    }
    }
    :log info "DDNS: End"


    agora em system, scheduler:

    name: ddns
    start date: jan/08/2009
    start time: 00:00:00
    interval: 01:00:00
    on event: / system script run ddns



    espero ter ajudado
    caso isto nao de certo procure sobre DMZ e DDNS em seu modem



  9. #9

    Padrão Usa o DDNS

    Amigo procura ai um script chamado DDNS que tem pronto..
    "Eu mesmo ja peguei,,.."
    Ai vc cadastra o seu servidor e acessa via winbox pelo endereço que será fornecido pra vc..."GRATIS".. o server autentica toda vez que faz a discagem do pppoeclient;
    Abraços...