Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Como faço load balance com o modem em bridge?

    Pessoal, to quebrando a kbeça aki a uma semana...

    tenho dois links adsl de 2 megas, e os dois modems estão em bridge, meu mikrotik fazendo a conexão através do pppoe-out.

    Tudo que achei pesquisando na net sobre balanceamento de links é com modem roteado ou link dedicado, por isso até agora não consegui configurar meu mikrotik pra fazer o load balance.

    Alguém sabe me dizer como faço?

    Configurações:

    modem1 IP: 10.0.0.1
    modem2 IP: 10.2.2.1

    Obrigado!

  2. #2

    Padrão

    nossa eu tbm preciso mt disso alguem pode ajudar??



  3. #3

    Thumbs up

    Citação Postado originalmente por williamterencio Ver Post
    Pessoal, to quebrando a kbeça aki a uma semana...

    tenho dois links adsl de 2 megas, e os dois modems estão em bridge, meu mikrotik fazendo a conexão através do pppoe-out.

    Tudo que achei pesquisando na net sobre balanceamento de links é com modem roteado ou link dedicado, por isso até agora não consegui configurar meu mikrotik pra fazer o load balance.

    Alguém sabe me dizer como faço?

    Configurações:

    modem1 IP: 10.0.0.1
    modem2 IP: 10.2.2.1

    Obrigado!
    Olá !

    Se for link de mesma operadora, vai precisar de um MK para cada modem e mais um para fazer o loadbalance !

  4. #4

    Padrão

    Citação Postado originalmente por Giovani.couto Ver Post
    Olá !

    Se for link de mesma operadora, vai precisar de um MK para cada modem e mais um para fazer o loadbalance !
    nao tem como o cara fazer o load em cima das interfaces pppoe??? mesmo sendo ip fixo???



  5. #5

    Padrão

    Bom Dia!

    Tem possibilidades tranquilamente sim.Contanto que voce utilize um mikrotik somente para efetuar o load balance,seja de 2 ou 10 links e outro para fazer o servico de hotspot,firewall,marcacao para proxy,pppoe-server etc e tudo oque sua rede interna ira precisar...

    De uma pesquisada a respeito do PCC o novo metodo ai implementado pela Mikrotik que funciona bem melhor ao NTH e tranquilamente voce conseguira efetuar um load nesses links...

    Aqui utilizo 4 ADSLs de 4Mega + 1 Link Dedicado para HTTP de 4Megas

    Abracao,

  6. #6

    Thumbs up

    Citação Postado originalmente por tskstar Ver Post
    Bom Dia!

    Tem possibilidades tranquilamente sim.Contanto que voce utilize um mikrotik somente para efetuar o load balance,seja de 2 ou 10 links e outro para fazer o servico de hotspot,firewall,marcacao para proxy,pppoe-server etc e tudo oque sua rede interna ira precisar...

    De uma pesquisada a respeito do PCC o novo metodo ai implementado pela Mikrotik que funciona bem melhor ao NTH e tranquilamente voce conseguira efetuar um load nesses links...

    Aqui utilizo 4 ADSLs de 4Mega + 1 Link Dedicado para HTTP de 4Megas

    Abracao,
    Tão explica como se faz com dois link da mesma operadora com o mesmo gateway com os modem em bridge !



  7. #7

    Padrão

    Citação Postado originalmente por Giovani.couto Ver Post
    Tão explica como se faz com dois link da mesma operadora com o mesmo gateway com os modem em bridge !

    Muito simples colega,simplesmente invez de utilizar o ip como saida utilize a interface como saida...(pppoe-out1,pppoe-out2...etc)

    Caso queiram posto as regras para ajudar o nosso amigo que esta precisando.

    Segue uma SS para verificar o load funcionando e repare bem que o GATEWAY DE SAIDA é o mesmo...Simplesmente marque por interface

    Estas regras estão sendo utilizadas em uma cidade lateral a minha,pois as minhas regras possuem 4adsls e 1dedicado.Mas o esquema de fazer é o mesmo.

    http://img529.imageshack.us/img529/7277/load.jpg
    Última edição por tskstar; 21-08-2009 às 18:46. Razão: Adicionar ss

  8. #8

    Padrão

    fiz alguns testes aki e só consegui fazer o load balance com um modem em bridge e o outro roteado.

    O problema é que modem roteado da muita queda de conexão.



  9. #9

    Padrão

    se o amigo puder postar as regras será muito útil pra gente.

    obrigado!

  10. #10

    Padrão

    Citação Postado originalmente por williamterencio Ver Post
    se o amigo puder postar as regras será muito útil pra gente.

    obrigado!
    Ola brother...

    Ok hoje a tarde posto as regras para ajudar no que precisar voce.Estarei na empresa por volta das 17:00

    Abracao



  11. #11

    Padrão

    Consegue vir antes e postar para vocês....

    Segue código base para balanceamento utilizando PCC com 2 ADSLs da mesma operadora em bridge

    Lembrem de desmarcar a opcao "add default route" nas propriedades do pppoe-out

    Sistema utilizado: Mikrotik 3.28 X86

    Interfaces:Local (clientes pppoe-server)
    pppoe-out1 (ADSL1)
    pppoe-out2 (ADSL2)

    Mangle
    Código :
    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=Local
    add action=mark-connection chain=input comment="Make the packet leaves via same interface" connection-state=new disabled=no in-interface=wan1-pppoe \
        new-connection-mark=wan1_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=wan2-pppoe new-connection-mark=wan2_conn passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wan1_conn connection-state=new disabled=no new-routing-mark=to_wan1 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wan2_conn connection-state=new disabled=no new-routing-mark=to_wan2 passthrough=no
    add action=accept chain=prerouting comment="Assigning the propper routing-mark" disabled=yes dst-address=10.111.0.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=yes dst-address=10.112.0.0/24 in-interface=Local
    add action=mark-connection chain=prerouting comment="PCC Balance" disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan1_conn \
        passthrough=no per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan2_conn passthrough=yes \
        per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Marking all the packets" connection-mark=wan1_conn disabled=no in-interface=Local new-routing-mark=to_wan1 \
        passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn disabled=no in-interface=Local new-routing-mark=to_wan2 passthrough=no

    NAT
    Código :
    /ip firewall nat
    add action=masquerade chain=srcnat comment="Masquerade Interfaces" disabled=no out-interface=wan1-pppoe
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan2-pppoe

    ROUTES
    Código :
    /ip route
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=Local
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=to_wan1
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=to_wan2
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe

    Espero que isso ajude...

    Abração a todos! Precisando tamo ai!

  12. #12

    Thumbs up

    Citação Postado originalmente por tskstar Ver Post
    Consegue vir antes e postar para vocês....

    Segue código base para balanceamento utilizando PCC com 2 ADSLs da mesma operadora em bridge

    Lembrem de desmarcar a opcao "add default route" nas propriedades do pppoe-out

    Sistema utilizado: Mikrotik 3.28 X86

    Interfaces:Local (clientes pppoe-server)
    pppoe-out1 (ADSL1)
    pppoe-out2 (ADSL2)

    Mangle
    Código :
    /ip firewall mangle
    add action=accept chain=prerouting comment="FORA DO LOADBALACED" disabled=no dst-address-list=loopback in-interface=Local
    add action=mark-connection chain=input comment="Make the packet leaves via same interface" connection-state=new disabled=no in-interface=wan1-pppoe \
        new-connection-mark=wan1_conn passthrough=yes
    add action=mark-connection chain=input comment="" connection-state=new disabled=no in-interface=wan2-pppoe new-connection-mark=wan2_conn passthrough=yes
    add action=mark-routing chain=output comment="" connection-mark=wan1_conn connection-state=new disabled=no new-routing-mark=to_wan1 passthrough=no
    add action=mark-routing chain=output comment="" connection-mark=wan2_conn connection-state=new disabled=no new-routing-mark=to_wan2 passthrough=no
    add action=accept chain=prerouting comment="Assigning the propper routing-mark" disabled=yes dst-address=10.111.0.0/24 in-interface=Local
    add action=accept chain=prerouting comment="" disabled=yes dst-address=10.112.0.0/24 in-interface=Local
    add action=mark-connection chain=prerouting comment="PCC Balance" disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan1_conn \
        passthrough=no per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=prerouting comment="" disabled=no dst-address-type=!local in-interface=Local new-connection-mark=wan2_conn passthrough=yes \
        per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Marking all the packets" connection-mark=wan1_conn disabled=no in-interface=Local new-routing-mark=to_wan1 \
        passthrough=no
    add action=mark-routing chain=prerouting comment="" connection-mark=wan2_conn disabled=no in-interface=Local new-routing-mark=to_wan2 passthrough=no
    NAT
    Código :
    /ip firewall nat
    add action=masquerade chain=srcnat comment="Masquerade Interfaces" disabled=no out-interface=wan1-pppoe
    add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan2-pppoe
    ROUTES
    Código :
    /ip route
    add comment="" disabled=yes distance=1 dst-address=0.0.0.0/0 gateway=Local
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe routing-mark=to_wan1
    add check-gateway=ping comment="" disabled=no distance=2 dst-address=0.0.0.0/0 gateway=wan2-pppoe
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan2-pppoe routing-mark=to_wan2
    add check-gateway=ping comment="" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=wan1-pppoe
    Espero que isso ajude...

    Abração a todos! Precisando tamo ai!
    Pô! Legal sua iniciativa!
    Ta de parabéns!



  13. #13

    Padrão

    Citação Postado originalmente por Giovani.couto Ver Post
    Pô! Legal sua iniciativa!
    Ta de parabéns!
    Magina,isso não custa nada eu fazer...afinal quando eu precisei me ajudaram nada mais justo do que repassar meus conhecimentos no que eu sei para ajudar alguem que precisa né?

    Abracao e obrigado pelo elogio!

  14. #14

    Padrão Pegando Carona

    Pegando carona neste post embora ja fora bem explicado ae pelo colega:
    Pra fazer o load pela interface so se faz nas versões 3.x
    OBS: Muita gente me procura querendo fazer PCC com versão cracker 2.9.27
    Valeu........... parabéns ao post.



  15. #15

    Padrão

    Citação Postado originalmente por rps67 Ver Post
    Pegando carona neste post embora ja fora bem explicado ae pelo colega:
    Pra fazer o load pela interface so se faz nas versões 3.x
    OBS: Muita gente me procura querendo fazer PCC com versão cracker 2.9.27
    Valeu........... parabéns ao post.
    Obrigado rps,e muito bem lembrado este detalhe que muita gente se esquece.2.9.27 o mais usado é o nth,fora rota estatica,ecmp mais ai nao tem um desempenho muito favoravel pelo oque andei testando.E vamos ser sincero,que deixar de gastar miseros R$200,00 como investimento e algo que lhe trara seguranca e estabilidade e gerar mais receita para o seu negocio é o minimo que alguem poderia fazer.Mas cada cabeca tem sua sentenca né..
    Última edição por tskstar; 22-08-2009 às 23:27.

  16. #16

    Padrão

    TESTADO E APROVADO!


    Parabéns pelo post, testei aqui no meu PCC, e funcionou tranquilamente!

    Só de raiva, coloquei NTH na RB e seguindo o msm raciocínio tb funcionou que foi uma beleza!

    Parabéns pelo post!


    PS: Testado e aprovado no MK3, creio q não funcione no MK2.

    Abs.



  17. #17

    Padrão

    Citação Postado originalmente por xnetinho Ver Post
    TESTADO E APROVADO!


    Parabéns pelo post, testei aqui no meu PCC, e funcionou tranquilamente!

    Só de raiva, coloquei NTH na RB e seguindo o msm raciocínio tb funcionou que foi uma beleza!

    Parabéns pelo post!


    PS: Testado e aprovado no MK3, creio q não funcione no MK2.

    Abs.
    ola xnetinho,

    Realmente nao ira funcionar nas versoes 2.x somente nas 3.x o PCC esta disponivel.O NTH ja funcionan as versoes anteriores.

    Abracao,

  18. #18

    Padrão

    Olá tskstar,

    Vejamos que o bojo deste tópico é o load balance usando modems em bridge, e nesse caso só é possível tanto com PCC ou NTH nas versões 3.x, uma vez que nas versões 2.x não existe o Gateway Interface no sub-item IP > Routes.


    Para que não hajam dúvidas, e evitemos posts desnecessários: Não há como fazer LoadBalance(por PCC ou NTH) usando TODOS(usando apenas um há) os modems em bridge nos MK 2.x.


    Abs a todos!
    Última edição por xnetinho; 25-08-2009 às 02:18.



  19. #19

    Padrão

    Ótima dica colega. Estava precisando fazer isso, vou testar e posto o resultado.

  20. #20

    Padrão

    É isso ai man, funcionou perfeitamente, só adaptei os nomes das interfaces pois ja tinha pcc seguindo a dica do amigo Tiago Matias. Valeu tskstar, continue assim.