Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Balanceamento funcioanando mas a redundancia não quer funcionar.
    Quando tiro o cabo de rede de uma das placas que recebe o LINK1 o LINK2 não está assumindo.

    Fui fazer o teste manualmente,
    deixei tudo zerado, formatei e instalei o Debian4 novamente.
    Deixei o seguinte cenário:

    ETH1: Link1 (ligado)
    ETH2: Link2 (desligado)
    ETH3: local (ligado)

    Quando digo ligado é que está com o cabo de rede plugado na ETH.

    Então habilito o compartilhamento:
    echo "1" > /proc/sys/net/ipv4/ip_forward
    E faço o masquerade para a eth do link:
    iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE

    Beleza, feito isso o pc ligado a rede local navega tranquilo.
    Então agora quero habilitar apenas o outro link e desativar esse.
    Tiro o cabo de rede do ETH1 e coloco o respectivo cabo do LINK2 na ETH2.
    Limpo as regras de iptables:
    iptables -F
    iptables -t nat -F
    Ativo o compartilhamento novamente, faço o MASQUERADE para o LINK2 na ETH2
    Até um restart na interface eu faço, mesmo sabendo que não precisa.
    Só que mesmo fazendo tudo isso não consigo dar ping em site direto do servidor e nem o pc local funciona.

    Placa de rede não é pois já deixei apenas duas placas de rede sendo uma o link e o outro local e funcionou.

    O que pode ser? Não era pra funcionar assim?
    Valeuuu!

  2. usa o comando route e verifica as rotas se estao corretas...



  3. amigo, veja suas configurações de dns parao link2!

    Adicione os 4 nameservers dos dois links!

    veja suas rotas!


    abraços

  4. Como vejo as rotas?
    Como uso o comando route?



  5. amigo utilize este comando:

    /sbin/route -n
    ou
    netstat -r

    as rotas ficam assim
    default a.b.c.d 0.0.0.0 UG 0 0 0 eth0

    a.b.c.d=gateway eth0 <- interface utilizada pelo gateway

    adicionar rota
    /sbin/route add default gw a.b.c.d netmask x.y.z.w dev eth0

    deletar rota
    route del default
    deletes the current default route, which is labeled "default" or
    0.0.0.0 in the destination field of the current routing table.

    route del default

    ou

    route del a.b.c.d

    qualquer dúvida, posta ae, mas dá uma olhada em man route

    abraços






Tópicos Similares

  1. Respostas: 0
    Último Post: 01-03-2017, 11:36
  2. Respostas: 9
    Último Post: 26-08-2016, 11:20
  3. Respostas: 5
    Último Post: 27-01-2011, 22:44
  4. regra de proxy transp. não funciona
    Por netuno no fórum Servidores de Rede
    Respostas: 4
    Último Post: 18-07-2005, 18:44
  5. Conectiva 10 - Com placa de rede, navegador não funciona.
    Por dbvilar no fórum Servidores de Rede
    Respostas: 0
    Último Post: 14-12-2004, 18:46

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L