Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. tenho um server com debian P4 2.66ghz/160GB/1GB de memória e ele passa do dia consumindo 400mb de memória e no final do dia ele só tem 8mb free o que pode ser? mesmo com 1GB só setei cache mem 64mb mas mesmo assim continua consumindo toda a memória ai eu reinicio a máquina ele passa quase o dia todo consumindo 279mb depois vai aumentando até estourar novamente e isso esta deixando a internet lenta...só tenho 38 usuários para essa máquina e sempre funcionou perfeitamente.

    Só tenho iptables + htb + squid 2.7 + apache rodando.

    alguém pode me ajudar?

  2. Tenho um server slackware que tinha o mesmo comportamento, consumia quantias gigantes de memória e o pior, nele tenho algo como 20 acessos. É um proxy Squid + Dansguardian + ClamAV, Postfix + Courier + Spamassassin + Clamav + Maildrop, o Bind, o Dansguardian e o Postfix estão carregando uma lista para evitar malwares meio grandinha também. Esse servidor tinha 2 GB de RAM e 1 GB de swap e utilizava toda a memória. Passava 2 dias ligado e já esgotava. Hoje está estacionado no consumo em algo um pouco maior que 1 GB em picos de consumo. O que fiz foi diminuir um pouco o máximo e mínimo de children do Dansguardian e limitar a memória do Squid. Já ouvi falar que pode ser problema de hardware, se não me engano aqui no fórum mesmo.

    Sei lá, a minha sugestão é vc acompanhar qual processo está consumindo mais pelo top, foi assim que eu consegui chegar à solução.


    EDIT: Cara, também vi um problema semelhante que era o apache, a orientação do pessoal foi limitar acessos e por aí vai.

    Boa sorte!
    Última edição por glaucioklipel; 09-09-2009 às 07:47.



  3. eu tirei alguns serviços...agora noto que ultimamente meu link está ficando ou saturado ou em muito uso visto que só tenho dois usuários liberados total o restante só acessa e-mails e sites como receita e caixa o resto como orkut, youtube é tudo bloqueado como faço para ver onde está o pico de acessos? no sarg mostra mais sites visitados...

  4. Tem boas ferramentas de monitoramento de tráfego no sourceforge.net. Procura aqui mesmo no fórum sobre monitoramento de táfego que já vc acha alguma ferramenta pra isso.

    Sobre o link saturado, pode ser que alguém esteja acessado redes P2P ou algo parecido, ou ainda vc pode realmente estar com problemas de hardware mesmo. Era o que acontecia com esse slackware que eu lhe falei, a rede parecia lenta demais. Resolvi trocando o HD que estava indo pro céu hehehe.

    Verifique seu hardware, algo pode ter dado problema, depois veja os logs do squid se não estão muito grandes, depois vale monitorar o tráfego pra ver se não tem nenhum espertinho usando P2P. Se estiver, recomendo o layer7.



  5. bom..para evitar de ser hardware troquei hoje para um servidor itautec opteron 2.1ghz com 4GB ddr2-800mhz e 250GB sata...vamos ver o que estou achando é que a internet está lenta...e quando a tivo o htb(QoS para o voip) e latencia para esse servidor aumentar significamente..o que pode ser?agora tenho hardware de sobra.

    tenho bloqueio para algumas portas p2p porque eles tentam mudando mas acho estranho isso acontecer só depois de 1 ano de uso...tme alguma dica para bloquear todo tipo de p2p no iptables?






Tópicos Similares

  1. Respostas: 3
    Último Post: 04-09-2013, 11:31
  2. Mk consumindo toda memória!!!
    Por FernandodeDeus no fórum Redes
    Respostas: 6
    Último Post: 10-07-2009, 10:07
  3. servidor consumindo muita memoria
    Por Alberto-de no fórum Servidores de Rede
    Respostas: 0
    Último Post: 29-08-2005, 21:56
  4. consumindo muito memoria
    Por alesandro no fórum Servidores de Rede
    Respostas: 6
    Último Post: 01-10-2004, 07:41
  5. Consumindo muito memória - me ajudem
    Por c4f0f0 no fórum Servidores de Rede
    Respostas: 7
    Último Post: 20-04-2004, 10:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L