+ Responder ao Tópico



  1. Óla tem muita gente com dificudades para confg o balance no mikrotik,algém aqui por favor podeira postar um video para ajudar a todos nós da under-linux

    Obrigado jean

    se houver alguem nos ajude e que Deus Sabe do coração de cada um de nós

    Deus te de em dobro]

    o q sei e so isso (Everloko ) usuário da under

    existe e ja usei esse equipamento mas não recomendo...
    porem no seu caso um load por rotas ou simplesmente por grupos ja ficaria legal...

    mas se vc quer ...ta ai...3 tipos de load ja postado no forum...


    LOAD BALANCE 1
    e o mais simples de todos, onde vc coloca dois gatewey e redireciona a porta do msn e https!!
    exemplo:
    Interfaces
    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    regras:
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
    1863 new-routing-mark=msn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=msn passthrough=yes routing-mark=extra
    add action=mark-routing chain=prerouting comment=https disabled=no dst-port=\
    443 new-routing-mark=https passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=https passthrough=yes routing-mark=extra
    /ip route
    add comment=balanceamento disabled=no dst-address=0.0.0.0/0 \
    gateway=10.10.10.1,20.20.20.1 scope=255 target-scope=\
    10
    add comment=extras disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=20.20.20.1 routing-mark="extra" scope=255 target-scope=\
    10

    LOAD BALANCE 2
    Esse vc separa por grupos de usuarios da sua rede.
    Exemplo:
    Interface
    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    regras:

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.129-192.168.0.254
    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10
    galera agora vou colocar uns sripts para se for o caso de algum link cair:
    Regras:
    /system script
    add name=link1-on policy=\
    ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"
    add name=link1-off policy=\
    ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"
    add name=link2-on policy=\
    ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"
    add name=link2-off policy=\
    ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"
    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=\
    10.10.10.1 interval=5m timeout=1s up-script=link1-on
    add comment="Rota - Grupo B" disabled=no down-script=link2-off \
    host=20.20.20.1 interval=5m timeout=1s up-script=link2-on

    exemplo 2
    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Link3 ip - 30.30.30.1/24
    Link4 ip - 40.40.40.1/24
    Regras
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.64
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.65-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupC" \
    disabled=no new-routing-mark=GrupC passthrough=no src-address=\
    192.168.0.129-192.168.0.192
    add action=mark-routing chain=prerouting comment="GrupD" \
    disabled=no new-routing-mark=GrupD passthrough=no src-address=\
    192.168.0.193-192.168.0.254
    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    30.30.30.1 routing-mark=GrupC scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    40.40.40.1 routing-mark=GrupoD scope=255 target-scope=10
    LOAD BALANCE 3
    esse um load que o mikrotik distribui por pacotes de conexão ja e mais um pouca complicada de se explicar mas vamos lá.
    Mikrotik Versão 2.9
    exemplo:
    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Regras
    / ip firewall mangle
    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface= Rede connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= Rede connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.10.10.1 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=20.20.20.1 to-ports=0-65535 comment="" disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.10.10.1 scope=255 target-scope=10 routing-mark=odd comment="Gateway link1" disabled=no
    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 routing-mark=even comment="Gateway link2" disabled=no
    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 comment="principal" disabled=yes
    Espero que ajude muita gente, qualquer duvida e so postar obrigado

  2. Citação Postado originalmente por djjeantechno Ver Post
    Óla tem muita gente com dificudades para confg o balance no mikrotik,algém aqui por favor podeira postar um video para ajudar a todos nós da under-linux

    Obrigado jean

    se houver alguem nos ajude e que Deus Sabe do coração de cada um de nós

    Deus te de em dobro]

    o q sei e so isso (Everloko ) usuário da under

    existe e ja usei esse equipamento mas não recomendo...
    porem no seu caso um load por rotas ou simplesmente por grupos ja ficaria legal...

    mas se vc quer ...ta ai...3 tipos de load ja postado no forum...


    LOAD BALANCE 1
    e o mais simples de todos, onde vc coloca dois gatewey e redireciona a porta do msn e https!!
    exemplo:
    Interfaces
    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    regras:
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment=msn disabled=no dst-port=\
    1863 new-routing-mark=msn passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=msn passthrough=yes routing-mark=extra
    add action=mark-routing chain=prerouting comment=https disabled=no dst-port=\
    443 new-routing-mark=https passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" disabled=no \
    new-packet-mark=https passthrough=yes routing-mark=extra
    /ip route
    add comment=balanceamento disabled=no dst-address=0.0.0.0/0 \
    gateway=10.10.10.1,20.20.20.1 scope=255 target-scope=\
    10
    add comment=extras disabled=no distance=1 dst-address=0.0.0.0/0 \
    gateway=20.20.20.1 routing-mark="extra" scope=255 target-scope=\
    10

    LOAD BALANCE 2
    Esse vc separa por grupos de usuarios da sua rede.
    Exemplo:
    Interface
    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    regras:

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.129-192.168.0.254
    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10
    galera agora vou colocar uns sripts para se for o caso de algum link cair:
    Regras:
    /system script
    add name=link1-on policy=\
    ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=10.10.10.1 }"
    add name=link1-off policy=\
    ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
    "/ip route {set [find comment=GrupA] gateway=20.20.20.1 }"
    add name=link2-on policy=\
    ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=20.20.20.1 }"
    add name=link2-off policy=\
    ftp,reboot,read,write,policy,test,w inbox,password,sniff source=\
    "/ip route {set [find comment=GrupB] gateway=10.10.10.1 }"
    /tool netwatch
    add comment="Rota - Grupo A" disabled=no down-script=link1-off host=\
    10.10.10.1 interval=5m timeout=1s up-script=link1-on
    add comment="Rota - Grupo B" disabled=no down-script=link2-off \
    host=20.20.20.1 interval=5m timeout=1s up-script=link2-on

    exemplo 2
    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Link3 ip - 30.30.30.1/24
    Link4 ip - 40.40.40.1/24
    Regras
    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="GrupA" \
    disabled=no new-routing-mark=GrupA passthrough=no src-address=\
    192.168.0.2-192.168.0.64
    add action=mark-routing chain=prerouting comment="GrupB" \
    disabled=no new-routing-mark=GrupB passthrough=no src-address=\
    192.168.0.65-192.168.0.128
    add action=mark-routing chain=prerouting comment="GrupC" \
    disabled=no new-routing-mark=GrupC passthrough=no src-address=\
    192.168.0.129-192.168.0.192
    add action=mark-routing chain=prerouting comment="GrupD" \
    disabled=no new-routing-mark=GrupD passthrough=no src-address=\
    192.168.0.193-192.168.0.254
    /ip route
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    10.10.10.1 routing-mark=GrupA scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    20.20.20.1 routing-mark=GrupoB scope=255 target-scope=10
    add comment=GrupA disabled=no dst-address=0.0.0.0/0 gateway=\
    30.30.30.1 routing-mark=GrupC scope=255 target-scope=10
    add comment=GrupB disabled=no dst-address=0.0.0.0/0 gateway=\
    40.40.40.1 routing-mark=GrupoD scope=255 target-scope=10
    LOAD BALANCE 3
    esse um load que o mikrotik distribui por pacotes de conexão ja e mais um pouca complicada de se explicar mas vamos lá.
    Mikrotik Versão 2.9
    exemplo:
    Rede ip - 192.168.0.1/24
    Link1 ip - 10.10.10.1/24
    Link2 ip - 20.20.20.1/24
    Regras
    / ip firewall mangle
    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,0 action=mark-connection new-connection-mark=odd passthrough=yes comment="Balanceamento de carga" disabled=no
    add chain=prerouting in-interface= Rede connection-mark=odd action=mark-routing new-routing-mark=odd passthrough=no comment="" disabled=no
    add chain=prerouting in-interface= Rede connection-state=new nth=1,1,1 action=mark-connection new-connection-mark=even passthrough=yes comment="" disabled=no
    add chain=prerouting in-interface= Rede connection-mark=even action=mark-routing new-routing-mark=even passthrough=no comment="" disabled=no

    / ip firewall nat
    add chain=srcnat connection-mark=odd action=src-nat to-addresses=10.10.10.1 to-ports=0-65535 comment="Balanceamento de carga" disabled=no
    add chain=srcnat connection-mark=even action=src-nat to-addresses=20.20.20.1 to-ports=0-65535 comment="" disabled=no
    / ip route
    add dst-address=0.0.0.0/0 gateway=10.10.10.1 scope=255 target-scope=10 routing-mark=odd comment="Gateway link1" disabled=no
    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 routing-mark=even comment="Gateway link2" disabled=no
    add dst-address=0.0.0.0/0 gateway=20.20.20.1 scope=255 target-scope=10 comment="principal" disabled=yes
    Espero que ajude muita gente, qualquer duvida e so postar obrigado
    detalhe modem em modo bridge



  3. Ola amigos postem ai um vídeo como fazer um load pois como o amigo tenho dificuldades em fazer um load ou seja ai informações são poucas nos tutorias que segui não falava que tinha que ser um PC só para load não fala se o modem pode esta em bridge e um router não tem muitas coisas como depois de fazer um load tem que ligar com o cabo crossover ou um switcher não explica só tem as regras e pronto vc se vira para fazer funcionar ou seja vc que não tem muita experiência não vai entender nada por favor quando vcs tiverem um tempinho posta um vídeo que iria facilitar muito nossas vidas amigo estou na guerra tentando fazer um load a mais de uma semana já tentei de tudo vario tutoriais mas nada ate agora. Mais o amigo Giovanni esta me ajudando e se eu conseguir prometo a vc e a todos do fórum que vou fazer uma vídeo aula para tirar todas as duvidas ok abraços ate mais .


    Obs. se quiser mando tudo o que tenho sobre load balance .






Tópicos Similares

  1. Respostas: 7
    Último Post: 20-09-2017, 08:43
  2. Load Balance PCC "Voltado para HTTPs" !
    Por RadNet no fórum Redes
    Respostas: 6
    Último Post: 01-01-2015, 12:40
  3. Respostas: 1
    Último Post: 10-07-2013, 08:43
  4. Respostas: 16
    Último Post: 01-08-2012, 21:02
  5. Respostas: 2
    Último Post: 12-04-2008, 09:21

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L