Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão FailOver - NetWatch

    Amigos tudo bem?

    Tenho configurado e rodando o NetWatch, sempre que um link cai o outro volta a funcionar... porem........

    Tenho 2 links, sendo feito Load Balance, e quero que quando o Link1 cair o 2 assuma, e quando o Link1 voltar os 2 voltei a funcionar juntos com Load Balance...

    No momento tenho o PCC rodando perfeitamente, junto com o NetWatch... mas nao estou achando uma maneira CERTA de fazer com que um link assuma o outro, e quando voltarem ambos voltem a rodar...
    ==========================================================================

    SOLUÇÃO

    /ip route
    add comment="ROTA PARA ROOT-SERVER \"F\" - FAILOVER LINK1" disabled=no distance=1 dst-address=192.5.5.241/32 gateway=yyy.yyy.yyy.yyy scope=30 target-scope=10
    add comment="ROTA PARA ROOT-SERVER \"J\" - FAILOVER LINK2" disabled=no distance=1 dst-address=192.58.128.30/32 gateway=xxx.xxx.xxx.xxx scope=30 target-scope=10
    /system script
    add name=LINK2-OFF policy=ftp,reboot,read,write,test,winbox source="/ip route set [/ip \
    route find gateway=xxx.xxx.xxx.xxx] disable=yes\r\
    \n\r\
    \n/ip route set [/ip route find dst-address=192.58.128.30/32] disable=no"
    add name=LINK2-ON policy=ftp,reboot,read,write,policy,test,winbox source="/ip route set\
    \_[/ip route find gateway=xxx.xxx.xxx.xxx] disable=no\r\
    \n\r\
    \n/ip route set [/ip route find dst-address=192.5.5.241/32] disable=no"
    add name=LINK1-OFF policy=ftp,reboot,read,write,policy,test,winbox source="/ip route se\
    t [/ip route find gateway=yyy.yyy.yyy.yyy] disable=yes\r\
    \n\r\
    \n/ip route set [/ip route find dst-address=192.5.5.241/32] disable=no"
    add name=LINK1-ON policy=ftp,reboot,read,write,policy,test,winbox source="/ip route set\
    \_[/ip route find gateway=yyy.yyy.yyy.yyy] disable=no\r\
    \n\r\
    \n/ip route set [/ip route find dst-address=192.58.128.30/32] disable=no"
    add name=LINKS-UPS policy=ftp,reboot,read,write,policy,test,winbox source="/tool netwat\
    ch set [/tool netwatch find host=192.5.5.241] disable=no\r\
    \n\r\
    \n/tool netwatch set [/tool netwatch find host=192.58.128.30] disable=no"
    /tool netwatch
    add comment=LINK1 disabled=no down-script=LINK1-OFF host=192.5.5.241 interval=5s timeout=3s up-script=LINK1-ON
    add comment=LINK2 disabled=no down-script=LINK2-OFF host=192.58.128.30 interval=5s timeout=3s up-script=LINK2-ON
    /system scheduler
    [quote]add comment="Forcar Verificacao dos Links" disabled=no interval=10s name=\[/quote]
    LINKS-UPS on-event=LINKS-UPS policy=ftp,read,policy,test,winbox,sniff start-date=\
    sep/10/2009 start-time=00:00:00

    Espero ter ajudado os companheiros!!

    Postem o resultado e se possivel agradeçam =)

    Obs: Aonde tiver yyy.yyy.yyy.yyy trocar pelo GATEWAY seu do LINK1
    Obs²: Aonde tiver xxx.xxx.xxx.xxx trocar pelo GATEWAY seu do LINK2

    PS: Lembrando que voce tem que ter seu Load Balance funcionando, isso serve apenas para fazer Fail Over, de quando um link cair, o outro assume, e quando ele voltar, os 2 voltam a funcionar corretamente.

    Qualquer duvida postem ai!

    E Obrigado a todos que me ajudaram!

    Em especial nosso amigo "Raniel"
    Última edição por thiagotgc; 30-09-2009 às 08:00. Razão: Achei a solução - Atualizado

  2. #2

    Padrão

    também to embaralhado com isto, quebrei a cabeça para fazer o script mas ainda não tive sucesso, se eu conseguir posto aqui como eu fiz...
    até mais...



  3. #3

    Padrão

    Entao amigo, se quiser pode usar meus scripts ai, apenas altere os IPs...

    Lembrando que o IP=64.233.163.99 é o IP usado para pingar e quando nao obtver respostas
    ele alterar a rota e ativar o script de mudança.

    Ainda estou me matando para fazer ficar funcional com load balance...

  4. #4

    Padrão

    Olá amigos,
    Você deve usar um script para pingar um certo host por um interface, caso ele não retorne o desejado ele vai desabilitar suas configurações de loadbalance e ativar uma outra configuração que estava desativada. Se o modem estiver roteado, com o netwatch ele não vai funcionar pois ele sempre vai pingar para o modem. Só com scripts será possível setar uma interface.
    Espero ter ajudado...



  5. #5

    Padrão

    opa... amigo poderia deixar um script de exemplo para nós? ajudaria muito.

    até mais...

    Citação Postado originalmente por Raniel Ver Post
    Olá amigos,
    Você deve usar um script para pingar um certo host por um interface, caso ele não retorne o desejado ele vai desabilitar suas configurações de loadbalance e ativar uma outra configuração que estava desativada. Se o modem estiver roteado, com o netwatch ele não vai funcionar pois ele sempre vai pingar para o modem. Só com scripts será possível setar uma interface.
    Espero ter ajudado...

  6. #6



  7. #7

    Padrão

    Olha pessoal,
    Para quem usa mais de um link, no caso do loadbalance, o que deve ser feito para usar o netwatch é o seguinte:
    Supomos que temos aqui 2 links (gw: 200.201.19.177; gw: 201.20.198.177). Dois route mark: link1 e link2.
    Digamos que todo o tráfego icmp, na maioria que vejo, tenha uma rota default.
    Ex:
    Código :
    /ping uol.com.br
    "200.98.249.120" - este já deve ter uma rota default 201.20.198.177
    O que testei aqui foi o seguinte:
    Não deixei uma rota default, deixei que cada mark routing seja responsável por cada.
    Criei duas rotas para dois sites/ips diferentes, uma para um link e outro para outro.
    Código :
    /ip route add dst-address=200.98.249.120 gateway=201.20.198.177 comment="rota para o uol"
    Código :
    /ip route add dst-address=64.233.169.104 gateway=202.201.19.177 comment="rota para o google"
    Código :
    /tool netwatch add host=200.98.249.120 interval=10s up-script=":log info \"Acao quando um dos links voltar\";" down-script=":log info \"Acao quando um dos links parar\";"
    Código :
    /tool netwatch add host=64.233.169.104 interval=10s up-script=":log info \"Acao quando um dos links voltar\";" down-script=":log info \"Acao quando um dos links  parar\";"
    Faça um teste desativando o route para cada destino e verá o resultado em
    Código :
    /log print
    Espero ter dado uma ajuda.
    Última edição por Raniel; 23-09-2009 às 15:22.

  8. #8

    Padrão

    Ahh legal amigo... agora qual dessas ai vai fazer os LINKS voltarem ao normal quando os 2 tiverem UP?

    Pq pelo que vi, parece que quando um CAI, o outro eh desativado, e fica desativado! nao eh?



  9. #9

    Padrão

    Você pode usar as suas regras de netwatch normalmente. Esta é uma maneira para você usar o netwatch. Mas você não pode desativar os routes para os hosts do netwatch.

  10. #10

    Padrão

    Citação Postado originalmente por Raniel Ver Post
    Espero ter dado uma ajuda.
    Excelente contribuição. Resolveu o problema por aqui.



  11. #11

  12. #12

    Padrão

    Amigos consegui faze-lo rodar corretamente.

    Vou atualizar o primeiro post, e por as configs corretas...!

    Valw os amigos que ajudaram!



  13. #13

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    E QUAL ERA SEU PROBLEMA?
    Checar se ambos os links estão conectados usando o netwatch, para então executar a inversão do gateway padrão.

  14. #14

    Padrão

    Bom eu postei aqui e em um post só disso a solução para esse fim.

    Ele ficou ótimo, faz as verificações em 2 servers dns ótimos, e força uma verificação do serviço a cada 10segundos... Isso deve para CASO aconteça algo e desativar sem querer as rotas, ele FORÇA a fazer a verificação novamente e ativa-las ou desativalas conforme necessario.

    Abraços!



  15. #15

    Padrão

    Não esqueça de quem postou a solução, o nosso amigo e meste
    Raniel

    Tem que referenciá-lo em seus post. Espero que tenha senso.
    Abraços

  16. #16

    Padrão

    Agradeço meu caro,
    Pena que são poucos...



  17. #17

    Padrão

    Citação Postado originalmente por O-Ren Ver Post
    Não esqueça de quem postou a solução, o nosso amigo e meste
    Raniel

    Tem que referenciá-lo em seus post. Espero que tenha senso.
    Abraços
    Valw!!!!

  18. #18

    Padrão Script atualizado.

    Citação Postado originalmente por thiagotgc Ver Post
    Amigos consegui faze-lo rodar corretamente.

    Vou atualizar o primeiro post, e por as configs corretas...!

    Valw os amigos que ajudaram!
    Companheiro posta aí o script atualizado, pois será de grande auxílio para os iniciantes no Mikrotik e de grande contribuição para o fórum.



  19. #19
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão

    Para 2 links fica bem legal.

    Uma ideia, digamos que esteja usando 4 links. Quando 1 link cair, o trafego do link que caiu sairá pela rota default o que acaba sobrecarregando o link default. Então é legal na verdade fazer o balanceamento considerando que o link pode cair e usar o netwatch para que nesse caso desative o balanceamento feito para 4 links e ative um outro balancemento para 3 links. Principalmente para provedores que possuem link "pequenos" somando com links "grandes". Vai dá trabalho, porem é uma só vez que vai sofrer.

  20. #20