Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão FailOver - Funcional 2LINKS

    Bom amigos, vou postar minhas configurações que realmente funcionam.

    Lembrando que aonde tiver yyy.yyy.yyy.yyy deve ser seu o GATEWAY do seu LINK1 e aonde estiver xxx.xxx.xxx.xxx deve ser o GATEWAY do seu LINK2

    Lembrando tambem que se voce tiver um terceiro link, apenas adicione mais conforme suas necessidades.

    /ip route
    add comment="ROTA PARA ROOT-SERVER \"F\" - FAILOVER LINK1" disabled=no distance=1 dst-address=192.5.5.241/32 gateway=yyy.yyy.yyy.yyy scope=30 target-scope=10
    add comment="ROTA PARA ROOT-SERVER \"J\" - FAILOVER LINK2" disabled=no distance=1 dst-address=192.58.128.30/32 gateway=xxx.xxx.xxx.xxx scope=30 target-scope=10
    /system script
    add name=LINK2-OFF policy=ftp,reboot,read,write,test,winbox source="/ip route set [/ip \
    route find gateway=xxx.xxx.xxx.xxx] disable=yes\r\
    \n\r\
    \n/ip route set [/ip route find dst-address=192.58.128.30/32] disable=no"
    add name=LINK2-ON policy=ftp,reboot,read,write,policy,test,winbox source="/ip route set\
    \_[/ip route find gateway=xxx.xxx.xxx.xxx] disable=no\r\
    \n\r\
    \n/ip route set [/ip route find dst-address=192.5.5.241/32] disable=no"
    add name=LINK1-OFF policy=ftp,reboot,read,write,policy,test,winbox source="/ip route se\
    t [/ip route find gateway=yyy.yyy.yyy.yyy] disable=yes\r\
    \n\r\
    \n/ip route set [/ip route find dst-address=192.5.5.241/32] disable=no"
    add name=LINK1-ON policy=ftp,reboot,read,write,policy,test,winbox source="/ip route set\
    \_[/ip route find gateway=yyy.yyy.yyy.yyy] disable=no\r\
    \n\r\
    \n/ip route set [/ip route find dst-address=192.58.128.30/32] disable=no"
    add name=LINKS-UPS policy=ftp,reboot,read,write,policy,test,winbox source="/tool netwat\
    ch set [/tool netwatch find host=192.5.5.241] disable=no\r\
    \n\r\
    \n/tool netwatch set [/tool netwatch find host=192.58.128.30] disable=no"
    /tool netwatch
    add comment=LINK1 disabled=no down-script=LINK1-OFF host=192.5.5.241 interval=5s timeout=3s up-script=LINK1-ON
    add comment=LINK2 disabled=no down-script=LINK2-OFF host=192.58.128.30 interval=5s timeout=3s up-script=LINK2-ON
    /system scheduler
    add comment="Forcar Verificacao dos Links" disabled=no interval=10s name=\
    LINKS-UPS on-event=LINKS-UPS policy=ftp,read,policy,test,winbox,sniff start-date=\
    sep/10/2009 start-time=00:00:00
    Espero ter ajudado os companheiros!!

    Postem o resultado e se possivel agradeçam =)
    Última edição por thiagotgc; 29-09-2009 às 10:55. Razão: Atualziado

  2. #2

    Padrão

    O mano, desculpa a minha ignorância, mas onde eu coloco essa parada toda aí? no roteador? no server?



  3. #3

    Padrão

    Amigo tudo bem pode perguntar, mas aqui é uma area relacionada ao SO Mikrotik, entao de fato voce deve por isso aonde tiver o sistema MIKROTIK. Fui claro?

  4. #4
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    thiago uma duvida, ficaria assim mesmo no caso do 1º link ser router no MK e o 2º router no modem mesmo?



  5. #5

    Padrão

    Citação Postado originalmente por angelangra Ver Post
    thiago uma duvida, ficaria assim mesmo no caso do 1º link ser router no MK e o 2º router no modem mesmo?
    Vamos la, seu MK deve ter 2 rotas para internet certo? Mesmo que seja com IPs validos ou Invalidos(roteado pelo modem)

    Voce de fato coloca 2 GTW no MK certo? entao voce ve qual é sua rota padrao e pensa em ser o LINK1 yyy.yyy.yyy.yyy e a outra rota pense em ser LINK2 xxx.xxx.xxx.xxx ok?

    Ou seja, indiferente se esta roteando no MK ou no MODEM, o principal é a saida do link para testar se esta ATIVO ou NAO . . .

    Espero ter sido claro....

    Qualquer duvida só perguntar

  6. #6

    Padrão Pergunta

    Thiago
    Eu tenho dois links validos da Oi aqui no RJ e uma mesma rede por detras será que funciona no meu caso?



  7. #7

    Padrão

    Citação Postado originalmente por diaslaco Ver Post
    Thiago
    Eu tenho dois links validos da Oi aqui no RJ e uma mesma rede por detras será que funciona no meu caso?
    Amigo funciona sim, voce só tem que se atentar para colocar as rotas corretamente.

    Teste e poste aqui como ficou

    Abraços

  8. #8

    Padrão pergunta2

    Entao no script aonde vc coloca os dois ips diferentes eu coloco os da minha rede interna e so mudo os gw nos xxx e yyy correto?



  9. #9
    Avatar de angelangra
    Ingresso
    Jul 2007
    Localização
    Angra dos Reis, Rio de Janeiro, Brazil, Brazil
    Posts
    368

    Padrão

    esse ip 192.5.5.241/32 e o outro são o que?

  10. #10

    Padrão FailOver - Funcional 2LINKS

    Bom dia...

    Caso os links estajam em modo Bridge ppoe velox e estou utilizando balanceamento PCC.. a versão do mikrotik 2.38 nivel 4. Como poderia fazer ?

    []´s

    Antecipadamente agradeço,

    Carlos Gonzaga.




    Citação Postado originalmente por thiagotgc Ver Post
    Bom amigos, vou postar minhas configurações que realmente funcionam.

    Lembrando que aonde tiver yyy.yyy.yyy.yyy deve ser seu o GATEWAY do seu LINK1 e aonde estiver xxx.xxx.xxx.xxx deve ser o GATEWAY do seu LINK2

    Lembrando tambem que se voce tiver um terceiro link, apenas adicione mais conforme suas necessidades.

    /ip route


    /system script


    /tool netwatch


    /system scheduler


    Espero ter ajudado os companheiros!!

    Postem o resultado e se possivel agradeçam =)



  11. #11

    Padrão

    Citação Postado originalmente por diaslaco Ver Post
    Entao no script aonde vc coloca os dois ips diferentes eu coloco os da minha rede interna e so mudo os gw nos xxx e yyy correto?
    A UNICA coisa que voce tem que mudar é os GW ai pra vc

  12. #12

    Padrão

    Citação Postado originalmente por angelangra Ver Post
    esse ip 192.5.5.241/32 e o outro são o que?

    São os 2 DNS Root Servers brasileiros.

    Eles tem Ping mtooo baixo.. isso ajuda muito =)



  13. #13

    Padrão

    Citação Postado originalmente por cgonzaga Ver Post
    Bom dia...

    Caso os links estajam em modo Bridge ppoe velox e estou utilizando balanceamento PCC.. a versão do mikrotik 2.38 nivel 4. Como poderia fazer ?

    []´s

    Antecipadamente agradeço,

    Carlos Gonzaga.
    Bom dia amigo, mas as configs irão ser as mesmas...

    Unica coisa que voce tem que se atentar é na hora de colocar os GTW dos seus links. Como eles estao em pppoe voce nao poem GTW poem a interface do PPPOe

    Espero ter ajudado

  14. #14

    Padrão

    Citação Postado originalmente por thiagotgc Ver Post
    Bom amigos, vou postar minhas configurações que realmente funcionam.

    Lembrando que aonde tiver yyy.yyy.yyy.yyy deve ser seu o GATEWAY do seu LINK1 e aonde estiver xxx.xxx.xxx.xxx deve ser o GATEWAY do seu LINK2

    Lembrando tambem que se voce tiver um terceiro link, apenas adicione mais conforme suas necessidades.

    /ip route


    /system script


    /tool netwatch


    /system scheduler


    Espero ter ajudado os companheiros!!

    Postem o resultado e se possivel agradeçam =)
    Caro amigo, desculpe a minha ignorania. Mas ignorancia maior é ficar com a dúvida! Esse conceito "FailOver" é o procedimento para quando um link "cair" o outro "segurar"e vice-versa ??
    Última edição por rasonline; 07-10-2009 às 15:04.



  15. #15

    Padrão

    Citação Postado originalmente por rasonline Ver Post
    Caro amigo, desculpe a minha ignorania. Mas ignorancia maior é ficar com a dúvida! Esse conceito "FailOver" é o procedimento para quando um link "cair" o outro "segurar"e vice-versa ??
    Correto.
    é um script q vc vai ter q fazer para q o mesmo fique testando cada links, e se um cair o outro assume, vice-versa.

  16. #16

    Padrão

    Galera esse FailOVer, é para deixar ambos funcionando, quando um cair o outro fica sozinho, até o outro voltar, dai volta os 2 a funcionarem...


    Valw



  17. #17

    Padrão

    Este script funciona junto com balanceamento PCC?

  18. #18

    Padrão FailOver com Load Balance por rotas estáticas

    Citação Postado originalmente por tiagomatias Ver Post
    Correto.
    é um script q vc vai ter q fazer para q o mesmo fique testando cada links, e se um cair o outro assume, vice-versa.

    Te agradeço por tirar minha dúvida!!

    Aproveitando, gostaria de tirar outra dúvida se possível, Esse código FailOver, posso implantá-lo em um load balance por rotas estática? Mas precisamente o Load Balance da Wiki do CATVBrasil?



  19. #19

    Padrão

    Citação Postado originalmente por rasonline Ver Post
    Te agradeço por tirar minha dúvida!!

    Aproveitando, gostaria de tirar outra dúvida se possível, Esse código FailOver, posso implantá-lo em um load balance por rotas estática? Mas precisamente o Load Balance da Wiki do CATVBrasil?
    sim, ele pode ser implementado em qualquer loadbalaced.
    se é o mesmo que o CATV fez, agora n sei te dizer, n me lembro qual foi o q ele fez, mas deve ser o mesmo.

    Citação Postado originalmente por ijr Ver Post
    Este script funciona junto com balanceamento PCC?
    Sim, funciona, é um script q se integra junto ao netwath, vc já deve ter visto aqui no forum.

    abraços

  20. #20

    Padrão

    Galera, esse script que fiz, pode ser implantando em qualquer sistema MK, é só voces verem como é feito e aplicarem em seu ambiente, nao tem erro.....