Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal,

    Sou novo aqui no UnderLinux mas já vi visitei muito o site.

    Estou pela segunda vez configurando um proxy no ubuntu server 9.04, e a segunda vez que nao consigo configura-lo como transparente...

    No meu squid.conf estava colocando no inicio:

    http_port 192.168.7.1:3128 transparent
    Alem disso tambem criei as regras de iptables para que todas as requisições de entrada na porta 80 já direcionam automaticamente para a 3128.. e mesmo assim nao funciona..

    Problemas:

    - nas maquinas clientes sem configurar o browser, o acesso fica muito lento.
    - nas maquinas clientes sem configurar o browser nao funciona https (mesmo sendo permitida entrada na porta 443.. webmails e qualquer site https fica carregando um tempao e acaba dando erro e nao é exibido.
    - Sem configurar o browser as acls nao funcionam, ou seja, os bloqueios a sites nao funcionam..

    Por favor, se alguem souber como resolver, ou se esqueci algo, por favor me passe, pois nao encontrei nada sobre isso em foruns e outros..

    Desde já agradeço a cooperação de todos.

    Altair

  2. - nas maquinas clientes sem configurar o browser, o acesso fica muito lento.
    Código :
    iptables -L -n -t nat 
    iptables -L -n

    e cole aqui os resultados para que eu possa analisar certamente suas regras de firewall estao de certaforma erradas.

    - nas maquinas clientes sem configurar o browser nao funciona https (mesmo sendo permitida entrada na porta 443.. webmails e qualquer site https fica carregando um tempao e acaba dando erro e nao é exibido.
    Isso é impossivel de se fazer no caso do HTTPS realmente o cliente tem que configurar na maquina o proxy. Caso contrario seria como se fosse um ataque muito conhecido como Man in the middle. voce pode ler um pouco em ingles Man-in-the-middle attack - Wikipedia, the free encyclopedia
    Mas como já disse anteriormente para fazer o https funcionar tem que setar no navegador..

    - Sem configurar o browser as acls nao funcionam, ou seja, os bloqueios a sites nao funcionam..
    Se isso esta acontecendo eu tenho certeza que seu trafego nao esta passando pelo proxy e seu redirecionamento nao esta funcionando.



  3. #3
    Não Registrado
    MarcusMaciel Muito obrigado pela resposta! impressionante a velocidade do forum!

    Entao, o pessoal aqui usa muito https para e-mail.. vou ter que continuar usando configurado mesmo.

    na verdade queria que fosse transparente pois trata-se de uma faculdade, e os alunos possuem acesso a rede wireless, e por ter que configurar isso gera muito atendimento para tirar duvidas...

    So mais 1 duvida:

    Trabalhei em uma empresa que construia firewalls e proxys, e nos proxys que produsiam funcionava https normalmente, sem ter que configurar no browser... estranho... existe algum recurso que permita isso?

    desde ja agradeço muito a atenção

  4. Amigo eu acredito que voce esteja enganado pra HTTPS não existe essa opcao provavelmente as maquinas ja estavam configuradas para usar o proxy interno.



  5. #5
    Não Registrado
    Olá novamente!

    Entao Marcus, tenho certeza! nao configurava nada, dei manutenção em diversas redes que essa empresa mantinha, em nenhuma era preciso configurar...

    Apesar que:

    1- eles usavam Fedora (o que acho que nao tem influencia).
    2- algumas dessas redes (creio eu) usavam versoes mais antigas do squid.

    pode ser por isso.. Vi algumas pessoas em alguns foruns tentando "burlar" isso.. mas nao vi nenhum sucesso (a nao ser alguns magos... que DIzem ter conseguido...).

    Grande abraço!

    novamente obrigado pela ajuda.






Tópicos Similares

  1. Proxy transparente com 2 links - URGENTE
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 25-06-2003, 05:08
  2. Proxy transparente com 2 links - URGENTE
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 23-06-2003, 10:06
  3. Proxy Transparente com dois links
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 20-06-2003, 14:42
  4. proxy transparente no squid com erro
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 20-06-2003, 11:37
  5. QUERO MONTAR PROXY/NAT COM SQUID
    Por NoiseMaster no fórum Servidores de Rede
    Respostas: 2
    Último Post: 06-09-2002, 18:15

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L