Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão script instalar thunder cache 3

    Criei um script de instalação do Thunder Cache 3 em sistemas Debian com base no tutorial de meu amigo Rodrigo Minelli postado em www.biazus.com/forum/viewtopic.php?f=6&t=636&p=5303
    abaixo como usar o script.

    execute os comandos abaixo como root:

    wget http://www.pedrofilho.com.br/thunder.sh
    chmod +x thunder.sh
    ./thunder.sh


    O endereço do relatório do thunder é: http://ip_do_seu_servidor/thunder.php

    O script é gratuito e seu fonte encontra-se anexado, o mesmo não possuir nenhuma garantia e peço que modificações no mesmo seja postado aqui para ajuda de outros .....

    Obs: testado no Debian 5.02, Ubuntu 9.X e no MK-AUTH 4 ....

  2. #2

    Padrão

    Citação Postado originalmente por pedrovigia Ver Post
    Criei um script de instalação do Thunder Cache 3 em sistemas Debian com base no tutorial de meu amigo Rodrigo Minelli postado em www.biazus.com/forum/viewtopic.php?f=6&t=636&p=5303
    abaixo como usar o script.

    execute os comandos abaixo como root:

    wget http://www.pedrofilho.com.br/thunder.sh
    chmod +x thunder.sh
    ./thunder.sh

    O endereço do relatório do thunder é: http://ip_do_seu_servidor/thunder.php

    O script é gratuito e seu fonte encontra-se anexado, o mesmo não possuir nenhuma garantia e peço que modificações no mesmo seja postado aqui para ajuda de outros .....

    Obs: testado no Debian 5.02 e no MK-AUTH 4 ....
    Obrigado pela colaboração, vai ajudar muita gente.



  3. #3

    Padrão

    me tira uma pequena duvida...
    /etc/php5/apache2/php.ini

    seria o conf do http?

    pois no meu caso, fedora
    ele fica em /etc/httpd/conf/httpd.conf

  4. #4

    Padrão apache conf

    Citação Postado originalmente por mascaraapj Ver Post
    me tira uma pequena duvida...
    /etc/php5/apache2/php.ini

    seria o conf do http?

    pois no meu caso, fedora
    ele fica em /etc/httpd/conf/httpd.conf
    não isso é do php, do apache fica em /etc/apache2/



  5. #5

    Padrão

    Amigo, estava dando uma olhada no script e fiquei em duvida em alguns pontos....

    No caso voce instala o squid3 versão essa que não parece estar mto estavel e q os proprios desenvolvedores do tc não aconselham...

    Não acha viavel continuar com o 2.7?
    E percebi que voce cancela o cache_log e access_log...não acha perigoso ficar sem o log de acesso dos usuarios e sem os relatos de possiveis erros com o squid?

    não sei quanto a voce mas por aqui ainda estamos trabalhando com ip´s locais.....

    mas de qualquer forma, obrigado!

  6. #6

    Padrão squid 3

    Citação Postado originalmente por iceblue Ver Post
    Amigo, estava dando uma olhada no script e fiquei em duvida em alguns pontos....

    No caso voce instala o squid3 versão essa que não parece estar mto estavel e q os proprios desenvolvedores do tc não aconselham...

    Não acha viavel continuar com o 2.7?
    E percebi que voce cancela o cache_log e access_log...não acha perigoso ficar sem o log de acesso dos usuarios e sem os relatos de possiveis erros com o squid?

    não sei quanto a voce mas por aqui ainda estamos trabalhando com ip´s locais.....

    mas de qualquer forma, obrigado!
    gosto mais do squid3 e comigo vem funcionando 100%, mais como o script é aberto vc pode altera como desejar, obrigado ....

    testei e esta aprovado tb no ubuntu .....



  7. #7

  8. #8

    Padrão

    to com ubuntu, sera que roda e esse seu script é a versao completa ou a basica para quem nao fez a doação?



  9. #9

    Padrão ubuntu

    Citação Postado originalmente por powernetscm Ver Post
    to com ubuntu, sera que roda e esse seu script é a versao completa ou a basica para quem nao fez a doação?
    testei no ubuntu desktop e server e foi 100%, sobre a versão não sei pq parece tudo igual criptografado

  10. #10

    Padrão

    instalei mas esta fazendo de tudo menos do youtube



  11. #11

    Padrão Thunder 3

    Aqui tive esse problema...

    só voltei pra um update do Thunder3 e tudo voltou ao normal...

  12. #12



  13. #13
    Avatar de kyanbatera
    Ingresso
    Jun 2008
    Localização
    Vila Velha, Brazil, Brazil
    Posts
    132
    Posts de Blog
    1

    Padrão

    ae pessoal atualizei o thunder cache para o 3 e depois que fiz a atualização o ping para meu roteador fica alto e a net fica lenta de mais desabilito as regras e fica normal só que o thunder é claro que não funciona segue a baixo as regras que estou utilizando:

    /ip firewall filter
    add action=accept chain=forward comment="Aceitar todos os tipos de conexoes ou pacotes que venham do proxy" disabled=no src-address=192.168.100.0/24

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="Redirecionamento para o Proxy" disabled=no dst-address=!192.168.100.2 dst-port=80 protocol=tcp \
    src-address=192.168.2.0/24 to-addresses=192.168.100.2 to-ports=3128

    /ip firewall mangle
    add action=mark-connection chain=prerouting comment="Squid - Cache Full" disabled=no dscp=12 new-connection-mark=proxy-hits passthrough=yes
    add action=mark-packet chain=prerouting comment="" connection-mark=proxy-hits disabled=no new-packet-mark=proxy-squid passthrough=no
    add action=mark-connection chain=prerouting comment="Thunder - Cache Full" disabled=no dst-address=192.168.100.2 dst-port=80 new-connection-mark=\
    thunder-connection passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="" connection-mark=thunder-connection disabled=no new-packet-mark=thunder-packs passthrough=no protocol=tcp

    Agora vamos às marcações dos Pacotes e taxas de transferência:

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2000000 max-limit=3000000 name=SquidCache-Down packet-mark=proxy-squid parent=\
    global-out priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=2000000 max-limit=3000000 name=SquidCache-Up packet-mark=proxy-squid parent=global-in \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=2000000 max-limit=3000000 name=ThunderCache-Down packet-mark=thunder-packs parent=global-out \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=yes limit-at=2000000 max-limit=3000000 name=ThunderCache-Up packet-mark=thunder-packs parent=global-in \
    priority=8 queue=default

  14. #14

    Padrão

    nao tenho certeza mas acho que a segunda regra que era usada no thunder 2 nao roda pois agora ele roda como serviço aqui marquei ele como x:cache : HIT



  15. #15
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Header:
    Código :
    X-Cache: HIT from Thunder

  16. #16

    Padrão marcação

    Citação Postado originalmente por osmano807 Ver Post
    Header:
    Código :
    X-Cache: HIT from Thunder
    testei isso aqui e não funcionou, funcionou com apenas:

    X-Cache: HIT



  17. #17
    Avatar de kyanbatera
    Ingresso
    Jun 2008
    Localização
    Vila Velha, Brazil, Brazil
    Posts
    132
    Posts de Blog
    1

    Padrão

    alguém ai pode me dar uma dica para acerta esse erro??

  18. #18

    Padrão

    Amigo me esclarece uma duvida, qto a relaçao do desempenho a versao 3 melhorou, desculpe mas qual é a diferença entre a 2.1 e a 3.0 pois estou a 2.1 estou querendo desativar devido a lentidão que ocorre depois de um certo tempo de uso!

    Desde já agradeço!



  19. #19

    Padrão funciona

    Citação Postado originalmente por adepad Ver Post
    Amigo me esclarece uma duvida, qto a relaçao do desempenho a versao 3 melhorou, desculpe mas qual é a diferença entre a 2.1 e a 3.0 pois estou a 2.1 estou querendo desativar devido a lentidão que ocorre depois de um certo tempo de uso!

    Desde já agradeço!
    bem até o presente momento parece que o negocio agora funciona direito, estou achando muito boa essa versão, pra mim esta 100% ...

  20. #20
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Citação Postado originalmente por pedrovigia Ver Post
    testei isso aqui e não funcionou, funcionou com apenas:

    X-Cache: HIT
    Sabe, todos os sites hospedados nos servidores da Amazon mandam esse header. Imaginou? Tem muitos outros sites que mandam esse header também.

    Tem que tomar cuidado.