Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá pessoal,


    Eu acho que após uma queda de luz aqui na empresa, a minha partição swap deu problema. Quando a máquina dá boot, a mesma não monta a área de swap.
    Pelo /etc/fstab ve que a linha que monta a swap está assim:

    #LABEL=<83>x^L^EP^O<92>ÃA<89>N è^WY swap swap defaults 0 0

    Será que dá para recuperar a swap ?

    Segue as linhas fdisk e fstab:


    fdisk -l

    Disk /dev/sda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 13 104391 83 Linux
    /dev/sda2 276 1550 10241437+ 83 Linux
    /dev/sda3 14 275 2104515 82 Linux swap / Solaris
    /dev/sda4 1551 14593 104767897+ 5 Extended
    /dev/sda5 1551 14593 104767866 83 Linux

    Partition table entries are not in disk order

    Disk /dev/sdb: 250.0 GB, 250059350016 bytes
    255 heads, 63 sectors/track, 30401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sdb1 * 1 15201 122102001 83 Linux
    /dev/sdb2 15202 30401 122094000 83 Linux


    fstab

    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    LABEL=/ / ext3 defaults 1 1
    LABEL=/boot /boot ext2 defaults 1 2
    /dev/devpts /dev/pts devpts gid=5,mode=620 0 0
    /dev/shm /dev/shm tmpfs defaults 0 0
    /dev/proc /proc proc defaults 0 0
    /dev/sys /sys sysfs defaults 0 0
    LABEL=/u01 /u01 ext3 defaults 1 2
    LABEL=/u02 /u02 ext3 defaults 1 2
    LABEL=/u03 /u03 ext3 defaults 1 2
    #LABEL=<83>x^L^EP^O<92>ÃA<89>N è^WY swap swap defaults 0 0
    /dev/hda /media/cdrom auto pamconsole,exec,noauto,managed 0 0


    Sds.

  2. Olá,

    Simplesmente "uncoment" a linha assim:

    Abra o terminal

    Edite o /etc/fstab pelo terminal:
    Código :
     gksudo gedit /etc/fstab
    e remova esta "#"
    Código :
     #LABEL=<83>x^L^EP^O<92>ÃA<89>N è^WY   swap                    swap    defaults        0 0

    por esta

    Código :
    LABEL=<83>x^L^EP^O<92>ÃA<89>N è^WY   swap                    swap    defaults        0 0
    Salve

    Agora rode, no terminal:
    Código :
    sudo mount -a
    free
    Se não funcionar

    Volte na edição do /etc/fstab
    Código :
     gksudo gedit /etc/fstab
    remova toda a linha:
    Código :
      #LABEL=<83>x^L^EP^O<92>ÃA<89>N è^WY   swap                    swap    defaults        0 0
    e inclua esta:
    Código :
      /dev/sda3   none   swap   sw   0   0
    Salve

    rode novamente, no terminal:
    Código :
    sudo mount -a
    free
    Última edição por Calabresi; 21-10-2009 às 23:01.



  3. Bom,

    Segui a dica de um outro colega e fiz assim na linha swap, achei que era mas com o padrão do arquivo.

    /dev/sda3 swap swap defaults 0 0

    Dei um mount -a e não apresentou nenhum erro.

    Obrigado pela ajuda !

    Mas, tem idéia porque isso aconteceu ?

  4. Nenhuma ideia clara ou certa sobre seu caso, mas voce perdeu a luz sem o sistema ter desmontado o volume é a mais provavel, outra é ele por não ter sido desmontado, se corrompeu, perdeu o LABEL=nome de formatação sendo bem simplorio.

    Hoje as distribuições, baseadas em Debian até onde sei, estão configurando acesso as unidades pelo FSTAB via UUID ou LABEL por segurança, em casos como queda repentina de força em um swap com conteúdo acontece isto, Ubuntu é um bom exemplo disso sendo que desde a versão 8 se usa UUID. E configura-se UUID de uma unidade pelo Grub, e ele pode perder esta conf. assim, o o FSTAB enganado, não passa a informação correta da unidade.

    Mas tudo que eu disse são as mais prováveis suposições



  5. Bom, podem me ajudar de novo !
    Deu o comando free, mas a swap está com 0k, olha só:

    #free
    total used free shared buffers cached
    Mem: 1033700 1020204 13496 0 68512 868268
    -/+ buffers/cache: 83424 950276
    Swap: 0 0 0

    Já dei o comando mount -a e não deu erro, mas não montou a swap

    Alguém pode me dar uma ajuda ?

    Sds,
    Robson.






Tópicos Similares

  1. Como montar uma particao Windows com o Samba?
    Por Bit no fórum Servidores de Rede
    Respostas: 3
    Último Post: 16-09-2005, 10:43
  2. Urgente!! Galera como montar uma partição Reiserfs?
    Por alexandresamorim no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 16-08-2005, 13:24
  3. como montar uma partição...
    Por mcyberx no fórum Servidores de Rede
    Respostas: 6
    Último Post: 20-08-2004, 22:40
  4. COMO MONTAR A PARTIÇÃO DO WINDOWS????
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 15-09-2002, 19:41
  5. COMO MONTAR A PARTIÇÃO DO WINDOWS????
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 07-09-2002, 19:35

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L