Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Galera não tô conseguindo fazer o cache full funcionar na versão 2.9.27 ja procurei varios tutoriais mais não tive resultado preciso da ajuda de voces aqui do forum. estou rodando o MK com Hotspot na Wireless e pppoe na ethernet qualquer ajuda será bem vinda!
    sei que aqui só tem fera
    agradeço desde ja valew

  2. Brother segue ai as regras desde web-proxy, mangle, nat e queue

    / ip web-proxy

    set enabled=yes src-address=0.0.0.0 port=3128 hostname="proxy" \
    transparent-proxy=yes parent-proxy=0.0.0.0:0 \
    cache-administrator="webmaster" max-object-size="tamano max. de cada arquivo"KiB \
    cache-drive=system max-cache-size="Tamanho total do cache" KiB max-ram-cache-size="tamanho max memória"KiB
    / ip web-proxy access
    add dst-port=23-25 action=deny comment="block telnet & spam e-mail relaying" \
    disabled=no
    / ip web-proxy cache
    add url=":cgi-bin \\?" action=deny comment="don't cache dynamic http pages" \
    disabled=no
    add url="https://" action=deny comment="no faz cache de paginas dinamicas" \
    disabled=no

    --------------------------------------------------------------------------

    /ip firewall nat

    - Configuração NAT pra PPPoE

    add chain=dstnat in-interface=!"interface pppoe" protocol=tcp dst-port=80 \
    action=redirect to-ports=3128 comment="DSTNAT - Webproxy PPPoE" \
    disabled=no


    - Nat Proxy Para Hotspot

    add chain=pre-hotspot in-interface="interface hotspot" src-address=192.168.200.0/24 \
    protocol=tcp dst-port=80 hotspot=auth action=redirect to-ports=3128 \
    comment="Web-Proxy Hotspot" disabled=no

    OBS.: Perceba a sutil diferença no na do pppoe e no hotspot. Leia não de CTRL+C / CTRL + V.
    ----------------------------------------------------------------------------------
    / ip firewall mangle
    add chain=output protocol=tcp src-port=3128 content="X-Cache: HIT" \
    action=mark-connection new-connection-mark=Cache-Connection \
    passthrough=yes comment="Cache-Full" disabled=no
    add chain=output connection-mark=Cache-Connection action=mark-packet \
    new-packet-mark=cache-packet passthrough=yes comment="" disabled=no
    add chain=output connection-mark=Cache-Connection action=return comment="" \
    disabled=no

    ------------------------------------------------------------------------------------
    / queue tree

    add name="Cache-FULL" parent=global-out packet-mark=cache-packet limit-at=0 \
    queue=ethernet-default priority=8 max-limit=" burst-limit=0 \
    burst-threshold=0 burst-time=0s disabled=no

    Última edição por caicarabruno; 28-10-2009 às 14:19.



  3. Neste caso:
    Código :
    add chain=dstnat in-interface=!"interface pppoe" protocol=tcp dst-port=80 \
        action=redirect to-ports=3128 comment="DSTNAT - Webproxy PPPoE" \
        disabled=no
    Vai está desviando todo o tráfego vindo de outras interfaces, inclusive a wan para o proxy, deixando a interface que atende aos usuários fora desta marcação.
    Lembre-se que as interfaces virtuais do pppoe utiliza a interface física, nele configurada, para comunicação. O cache pode até funcionar, mas não irá funcionar perfectly.

  4. Bom aqui até hoje não tive problemas, esta em perfeito funcionamento.

    TUDO, tudo mesmo antes de eu colocar em funcionamento, sempre fica em teste no mínimo 30 dias, então fiz testes a exaustão!

    meu proxy é squid com thunder em 2 SAS, depois de vários testes que fiz enquanto não coloquei daquela forma não ia PPPoE não ia. Depois que coloquei o "!".

    Vo estudar mais um pouco e fazer mais testes.

    Abraços Vlw pela dica

    Bruno Queiroz



  5. O thundercache está respondendo na interface pppoe também?






Tópicos Similares

  1. Respostas: 7
    Último Post: 30-06-2007, 12:20
  2. HTB + SQUID CACHE FULL não estou conseguindo
    Por binhorp no fórum Servidores de Rede
    Respostas: 10
    Último Post: 21-06-2007, 06:51
  3. Cache Full
    Por gerusso no fórum Servidores de Rede
    Respostas: 0
    Último Post: 03-03-2007, 16:34
  4. Cache Full
    Por gerusso no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-02-2007, 07:58
  5. Regras de Iptables para Cache Full
    Por tianguapontocom no fórum Servidores de Rede
    Respostas: 0
    Último Post: 27-10-2006, 11:56

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L