Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Depois de muito tempo de aprender com este maravilhoso fòrum vou tentar colaborar um pouco.

    Antes de começar, eu quero que você saiba que eu sou de Formosa (Argentina) e meu Português é horrível.
    Desculpe minha horrores de ortografia.

    Vamos aprender a controlar downloads com 2 opções de mangle: "connection-byte" y "connection-rate"
    Connection Rate esta desde a versão 3.30 e permite marcar o tráfego com base em sua velocidade atual.


    Você pode criar regras no mangle fazendo que, se uma conexão após de "X" Kbytes contínua a "Y" Kbps de velocidade é marcado e pode atribuir uma prioridade mais baixa.


    Um exemplo para melhor compreensão:

    Link: 3 M
    Plano Cliente: 256 kbps Download / 128 kbps Upload
    -------------------------------------------------------------------------------------
    As regras para Mangle

    /ip firewall mangle
    add chain=forward action=mark-connection connection-mark=!trafego_pesado_conn \
    new-connection-mark=all_conn
    add chain=forward action=mark-connection connection-bytes=1000000-0 \
    connection-mark=all_conn connection-rate=200k-100M \
    new-connection-mark=trafego_pesado_conn protocol=tcp
    add chain=forward action=mark-connection connection-bytes=1000000-0 \
    connection-mark=all_conn connection-rate=200k-100M \
    new-connection-mark=trafego_pesado_conn protocol=udp
    add chain=forward action=mark-packet connection-mark=trafego_pesado_conn \
    new-packet-mark=trafego_pesado passthrough=no
    add chain=forward action=mark-packet connection-mark=all_conn \
    new-packet-mark=other_traffic passthrough=no



    Explicação:

    add chain=forward action=mark-connection connection-bytes=1000000-0 \
    connection-mark=all_conn connection-rate=200k-100M \
    new-connection-mark=trafego_pesado_conn protocol=tcp
    add chain=forward action=mark-connection connection-bytes=1000000-0 \
    connection-mark=all_conn connection-rate=200k-100M \
    new-connection-mark=trafego_pesado_conn protocol=udp

    Estas 2 regras fazen que cada conexão que, após o primeiro 1 Mbyte continuar a uma velocidade de 200kbps ou superior, são marcadas como "tráfego pesado"

    -----------------------------------------------------------------------------------------------------------------------
    As regras para Queue Tree

    /queue tree
    add name=upload parent=Internet max-limit=3M
    add name=other_upload parent=upload limit-at=2M max-limit=3M \
    packet-mark=other_traffic priority=1
    add name=trafego_pesado parent=upload max-limit=1M \
    packet-mark=trafego_pesado priority=8
    add name=download parent=Clientes max-limit=3M
    add name=other_download parent=download limit-at=2M max-limit=3M \
    packet-mark=other_traffic priority=1
    add name=heavy_download parent=download max-limit=1M \
    packet-mark=trafego_pesado priority=8




    Todo o "tráfego pesado" da rede (Conexões que mantêm ritmo acelerado por longos períodos de tempo como P2P, HTTP - FTP donwloads) sempre terá no máximo 1M, para ser compartilhado entre todos os clientes da rede.
    Deste modo pode ser dada prioridade a outro tràfego por exemplo VOIP, navegação HTTP e jogos online

    Saudações

  2. Boa tarde, chefia...meus conhecimentos são meios limitados....rsrsrs, tentei fazer isso com a versão 2.9.27 generica mas não concegui....poderia me ajudar a migrar este Controle para a minha versão do mk?


    Anderson Junior



  3. Connection Rate esta desde a versão 3.3, não pode ser usado no versão 2.9.27.

    Eu agora estou usando para limitar a velocidade de download a 64k para cada usuário que fez download mais de 5M a toda a velocidade.
    Apenas limite de downloads... a navegação continua a toda velocidade

  4. sim...sei...mas será que não tem alguma forma de fazer nesta versão que eu to usando? usar algum outro recurso do mk 2.9.27 tipo o conection bytes?



  5. Na versão 2.9.x não pode ser feito controle com base no velocidade de conexão, na forma como faz connection rate

    Você pode usar o QOS FREEZER, que de acordo com a quantidade de tráfego baixa a velocidade de conexão.


    Eu estou preparando um outro post, que mostra como fazer limite de velocidade com base na extensão (*.exe, *.rar, *.iso.....) usando proxy paralelo. Funciona para qualquer versão.


    Espere, talvez é útil para você






Tópicos Similares

  1. Respostas: 7
    Último Post: 18-02-2013, 10:15
  2. Qual limite de conexões por ip Velox/telemar
    Por faieppi no fórum Redes
    Respostas: 13
    Último Post: 26-06-2007, 13:27
  3. Controle de Downloads por tamanho e Horário
    Por Inforway_pb no fórum Servidores de Rede
    Respostas: 4
    Último Post: 04-05-2006, 07:11
  4. limite de download por grupo no squid!
    Por flipeexpl no fórum Servidores de Rede
    Respostas: 0
    Último Post: 23-09-2005, 04:16
  5. Problema estranho: limite de files por pasta
    Por jesaelduarte no fórum Servidores de Rede
    Respostas: 0
    Último Post: 22-09-2005, 00:00

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L