+ Responder ao Tópico



  1. #1

    Padrão snmpd nao funciona

    Nao sei se estou a por o topico no sitio certo. Se nao tiver avisem me sff.
    Estou a usar uma imagem do ubuntu 9.10 no VMware e tenho o seguinte problema.
    Preciso de usar o snmpd, ja fiz as configuracoes todas no snmpd.conf, mas quando faco start ao snmpd, quando vou ver o status acontece o seguite:

    [email protected]:~$ sudo service snmpd start
    * Starting network management services: [ OK ]
    [email protected]:~$ sudo service snmpd status
    * could not access PID file for snmpd

    e quando faco "ps -aux| grep snmpd" tambem nao me aparece o processo do snmpd.

    o snmpd estara a correr?
    sera que algem me pode ajudar?

    Cumprimentos a todos.
    Última edição por redhatlesi; 13-11-2009 às 17:15. Razão: titulo nao explicativo

  2. #2

    Thumbs up

    seguinte crie o arquivo snmpd.pid dentro de "/var/run"

    de permissão de "leitura e escrita" apenas para root
    mude o dono do usuario e grupo para root :


    Código :
    sudo su [ENTER]
    touch /var/run/snmpd.pid
    chmod -Rv 600 /var/run/snmpd.pid
    chown -Rc root:root /var/run/snmpd.pid

    depois inicie o serviço!

    Código :
    /etc/init.d/snmpd start



  3. #3

    Padrão

    Citação Postado originalmente por Lincoln Ver Post
    seguinte crie o arquivo snmpd.pid dentro de "/var/run"

    de permissão de "leitura e escrita" apenas para root
    mude o dono do usuario e grupo para root :


    Código :
    sudo su [ENTER]
    touch /var/run/snmpd.pid
    chmod -Rv 600 /var/run/snmpd.pid
    chown -Rc root:root /var/run/snmpd.pid
    depois inicie o serviço!

    Código :
    /etc/init.d/snmpd start

    Obrigado, mas ja tentei isso e mesmo assim nao da, ou seja, da o mesmo erro quando vou ver o status e quando procuro o porcesso ele nao esta a correr.
    Tenho um trabalho pra entregar esta semana onde preciso de usar o protocolo snmp e nao esta a funcionar.
    Sera que e por estar a usar o ubuntu como imagen no VMware?


    Ja esta a funcionar... vejam como. para rir.

    lol copiei o dhclient.pid para o snmp.pid e depois executei:
    Código :
    chmod -Rv 644 /var/run/snmpd.pid

    para ficar com as mesmas permissoes do
    dhclient.pid, e ja esta a funcionar.
    tenho e de fazer isso sempre que faco start do snmpd.
    ha cada coisa. se alguem souber como resolver isso era bom.

    de qualquer forma muito obrigado pela ajuda.
    e peco desculpa pelo facto de nao ter acentuacao mas estou com problemas do teclado no ubuntu no vmware.

    cumprimentos a todos

    Última edição por redhatlesi; 18-11-2009 às 14:48. Razão: problema resolvido ou nao