+ Responder ao Tópico



  1. Boa tarde.

    Configurei o netlogon.bat conforme este post: https://under-linux.org/f130283-script-netlogon-bat

    Todavia, ocorre que quando o usuário se loga, o Windows não obedece às instruções fornecidas no netlogon.bat. Posso excluir o netlogon que ele continua mapeando e mapeia de acordo com o que estava no script antes de ser apagado.

    O problema é que em vez de ele mapear uma unidade 'publica z:' e outra 'pessoal x:' ele mapeia as duas como pessoal z: e x:

    Alguém sabe o que pode estar errado?

    Muito grato.

    Forte abraço.

  2. Olha dificilmente ele iria mapear uma unidade sozinho!
    Acredito que ele esteja lembrando conexões efetuadas manualmente com aquela opção "Reconectar ao fazer logon"

    1) Primeiro desconecte TODAS as unidades.
    2) depois disso va no prompt de comando e de um "net use" verifique se resta alguma conexão se houver desconecte.
    Código :
    net use X: /delete
    3) copie o bat pro micro e execute-o pelo prompt se ainda assim não funcionar ira lhe mostrar o erro no prompt dai vc posta ai se não der certo!



  3. complementando a resposta

    vc criou o script pelo linux ou pelo windows. Lembre-se que o arquivo tem q esta no padrao windows então se crio pelo linux vc precisa converter ele com o comando "unix2dos nome do arquivo" para saber se ele ta dando erro no script ou algo do genero da uns pauses no meio assim fica mais facil para gerenciar vou colar um script q uso nos meus servidores.

    @echo off
    rem Logon script Default
    rem
    REM Coloque na linha abaixo o nome dado ao servidor
    REM definido no smb.conf pelo parametro "netbios name"
    rem
    set LOGONSERVER=\\lx-prefpb-01
    echo ========================================================
    echo Executando o script de login do Servidor %LOGONSERVER%
    echo ========================================================
    echo ...
    rem
    echo Efetuando os Mapeamentos G: I: H: e O:
    rem
    if %OS%.==Windows_NT. goto WinNT
    rem
    :Win95
    :Win98
    NET USE J: %LOGONSERVER%\DPTO
    NET USE I: %LOGONSERVER%\HOME
    NET USE H: %LOGONSERVER%\SHARE
    NET USE G: %LOGONSERVER%\SISTEMA\HOTAL
    goto Fim_Mapeamento
    rem
    :WinNT
    REM Se for um Windows_NT fazendo login devo desmapear o drive mapeado ao fazer logoff
    rem NET USE J: %LOGONSERVER%\DPTO /PERSISTENT:NO
    NET USE I: %LOGONSERVER%\home /PERSISTENT:NO
    NET USE H: %LOGONSERVER%\share /PERSISTENT:NO
    NET USE G: %LOGONSERVER%\dpto /PERSISTENT:NO
    NET USE O: %LOGONSERVER%\sistema /PERSISTENT:NO
    rem
    rem if member of "sistema" goto sistema
    rem
    REM :sistema
    REM NET USE O: %LOGONSERVER%\SISTEMA /PERSISTENT:NO
    rem
    :Fim_Mapeamento
    echo Atualizando a hora local com o Relogio do Servidor
    NET TIME %LOGONSERVER% /SET /YES
    rem
    :Fim_Geral
    REM == FIM DO CODIGO ==






Tópicos Similares

  1. Script netlogon.bat
    Por maurenginaldo no fórum Servidores de Rede
    Respostas: 7
    Último Post: 30-07-2009, 09:39
  2. windows não enxerga o servidor linux
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-03-2003, 19:46
  3. windows não vê olinux
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 19-01-2003, 06:59
  4. Erro de parâmetro no Script logon.bat
    Por ATNunes no fórum Servidores de Rede
    Respostas: 4
    Último Post: 06-12-2002, 10:35
  5. As estacoes windows nao conseguem se logar!!!!
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 03-12-2002, 09:47

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L