+ Responder ao Tópico



  1. #1

    Padrão LIBERANDO PING DO CONTROLE DE BANDA (DICA)

    Olá pessoal, já vi muita gente perguntando como fazer pra liberar os pacotes icmp do controle de banda individual dos clientes, uma vez que este tem prioridade menor que outros serviços, certamente uma banda já totalmente utilizada, irá acontecer o que deixa o pessoal do suporte malucos, a perda de pacote. Para facilitar a vida de meus colegas aqui da empresa, criei as seguinte regras para liberar de qualquer controle o ping entre meu servidor e os clientes:

    0 chain=prerouting action=mark-packet new-packet-mark=icmp_in passthrough=no protocol=icmp in-interface=CLIENTES

    1 chain=postrouting action=mark-packet new-packet-mark=icmp_out passthrough=no protocol=icmp out-interface=CLIENTES

    Na mangle, observe que minha interface de entrada e saida desses pacotes está setada para a "CLIENTES", mude conforme sua configuração.

    Agora só precisamos adicionar uma queue tree para esses pacotes marcados.

    0 name="icmp_down" parent=global-in packet-mark=icmp_in limit-at=0 queue=ethernet-default priority=1 max-limit=0
    burst-limit=0 burst-threshold=0 burst-time=0s

    1 name="icmp_out" parent=global-out packet-mark=icmp_out limit-at=0 queue=ethernet-default priority=1 max-limit=0
    burst-limit=0 burst-threshold=0 burst-time=0s

    Bom, aqui está funcionando corretamente, se alguém quiser fazer algum comentário ou crítica fique a vontade, se lhe servir, não esqueça de agradecer.


    Abraços, fui.

  2. #2

    Padrão

    Muito bom amigo, se eu entendi você fez da seguinte forma:
    1. Através do firewall > mangle você marcou todos os pacotes ICMP que entram e saem da interface dos clientes.
    2. Em seguida você criou uma queue priorizando e deixando sem limite de banda o tráfego ICMP.

    Dúvida: Essa regra deve ficar antes das regras que fazem o controle de banda para os clientes, correto ?

    É mais ou menos isso ?

    Abraços,



  3. #3

    Padrão

    Não amigo, a regra fica no queue tree e vc faz o controle de seus clientes no simple queue.

    abracos

    Citação Postado originalmente por caiojosino Ver Post
    Muito bom amigo, se eu entendi você fez da seguinte forma:
    1. Através do firewall > mangle você marcou todos os pacotes ICMP que entram e saem da interface dos clientes.
    2. Em seguida você criou uma queue priorizando e deixando sem limite de banda o tráfego ICMP.

    Dúvida: Essa regra deve ficar antes das regras que fazem o controle de banda para os clientes, correto ?

    É mais ou menos isso ?

    Abraços,

  4. #4

    Thumbs up Re: LIBERANDO PING DO CONTROLE DE BANDA (DICA)

    Boa Noite!
    Sr. standart


    Gostei muito de sua dica. foi muito Eficaz.

    mais achei um erro na digitação e vou postar para você, e corrigir .

    errado.
    "1 chain=postrouting action=mark-packet new-packet-mark=icmp_out passthrough=no protocol=icmp out-interface=CLIENTES "

    certo.
    "1 chain=output action=mark-packet new-packet-mark=icmp_out passthrough=no protocol=icmp out-interface=CLIENTES "

    valeuuuuuuuuuuuuuuuuuuu , muito obrigado pela informação. Você salvou muitas madrugadas em claro. kkkkkkkk

    Qualquer coisa da um toque. fui

    Clique na imagem para uma versão maior

Nome:	         Vtek-Barnner.jpg
Visualizações:	149
Tamanho: 	269,1 KB
ID:      	24394
    Última edição por vanilson; 11-07-2011 às 01:53.



  5. #5

    Padrão Re: LIBERANDO PING DO CONTROLE DE BANDA (DICA)

    pessoal, tentei fazer estas regras mas não funcionou!!
    tenho um servidor aserisk em minha rede, mas os pacotes icmp continuam passando pelo controle de banda,
    pipocando a voz quando o cliente usa o tel e a net simultaneamente.
    sera que vcs podem me ajudar??

  6. #6

    Padrão Re: LIBERANDO PING DO CONTROLE DE BANDA (DICA)

    Citação Postado originalmente por ferluizber Ver Post
    pessoal, tentei fazer estas regras mas não funcionou!!
    tenho um servidor aserisk em minha rede, mas os pacotes icmp continuam passando pelo controle de banda,
    pipocando a voz quando o cliente usa o tel e a net simultaneamente.
    sera que vcs podem me ajudar??

    Boa noite!

    Tenta assim:

    Código :
    /ip firewall mangleadd action=mark-connection chain=postrouting comment="QoS DE PING" disabled=no new-connection-mark=ping-ipvalido passthrough=yes protocol=icmp
    add action=mark-packet chain=postrouting comment="" connection-mark=ping-ipvalido disabled=no new-packet-mark=pacote_ipvalido passthrough=yes

    Código :
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=100000000 name="' QoS IP VALIDO SAIDA" packet-mark=pacote_ipvalido parent=global-out priority=8 queue=default



  7. #7

    Padrão Re: LIBERANDO PING DO CONTROLE DE BANDA (DICA)

    VOU POSTAR COMO EU USO AKI, E MAIS UMA REGRA QUE LIBERA A BANDA DE COMPATILHAMENTO DE ARQUIVOS EM REDE PRA NAO PASSAR NO CONTROLE DE BANDA, PRA QUEM TEM MAIS DE UMA REDE INTERNA.

    LIBERANDO ICMP (ALTERE A INTERFACE LOCAL)

    /ip firewall mangle
    add action=mark-packet chain=prerouting comment="ICMP FORA DA QUEUE" \
    disabled=no in-interface=INTERFACE-REDE-LOCAL new-packet-mark=icmp-in passthrough=no \
    protocol=icmp
    add action=mark-packet chain=postrouting disabled=no new-packet-mark=icmp-out \
    out-interface=INTERFACE-REDE-LOCAL passthrough=no protocol=icmp

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=icmp-in packet-mark=icmp-in parent=global-in priority=8 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=0 name=icmp-out packet-mark=icmp-out parent=global-out \
    priority=8 queue=default






    LIBERANDO COMPARTILHAMENTO

    /ip firewall mangleadd action=mark-connection chain=prerouting comment=\
    "COMPARTILHAMENTO FORA DA QUEUE" disabled=no dst-port=445 \
    new-connection-mark=REDE passthrough=yes protocol=tcp
    add action=mark-connection chain=postrouting disabled=no dst-port=445 \
    new-connection-mark=REDE passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting connection-mark=REDE disabled=no \
    new-packet-mark=REDE passthrough=yes
    add action=mark-packet chain=postrouting connection-mark=REDE disabled=no \
    new-packet-mark=REDE passthrough=yes



    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=50M name=REDE-ENTRADA packet-mark=REDE parent=global-in \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 \
    max-limit=50M name=REDE-SAIDA packet-mark=REDE parent=global-out \
    priority=8 queue=default

  8. #8

    Padrão Re: LIBERANDO PING DO CONTROLE DE BANDA (DICA)

    atualizei pra versão 6.7 e deixou de funcionar a regra, alguém sabe como resolver?