+ Responder ao Tópico



  1. #1

    Exclamation Redirecionar inadimplente - nao redireciona !!!!

    Ola pessoal, faz um tempo q tenho essa regra redirecionando o povo inadimplente, mas de uma hora pra outra parou de redirecionar. Alguem pode me ajudar ??
    Desde ja agradeço, eis as regras

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="Redireciona Clientes bloqueados para Aviso" disabled=no dst-address=!200.183.146.204 dst-port=0-65535 protocol=tcp src-address=172.16.0.0/16 to-addresses=172.17.254.2 to-ports=80
    add action=accept chain=dstnat comment=central_assinante disabled=no dst-address=xxx.xxx.xxx.xxx
    add action=masquerade chain=srcnat comment=NAT_NEW disabled=no out-interface=BALANCE src-address=172.17.0.0/16
    add action=masquerade chain=srcnat comment=THUNDER_NEW disabled=no src-address=10.21.0.2
    add action=accept chain=dstnat comment=REGRAS_CACHE_NEW disabled=no dst-address=10.21.0.2 dst-port=80 protocol=tcp \
    src-address=10.21.0.2
    add action=dst-nat chain=dstnat comment=REDIRECIONA_CACHE disabled=no dst-port=80 protocol=tcp src-address=172.17.0.0/16 \
    to-addresses=10.21.0.2 to-ports=3190

    Explicando: Seguinte o sistema financeiro verefica quem esta inadimplente, se "OK" ele utiliza o pool "liberado" q usa o escopo 172.17.0.0/16, mas se o individuo estiver inadimplente ele utiliza o pool "bloqueado" q usa o escopo 172.16.0.0/16, onde a regra de NAT alem de bloquear a navegação do cliente, direciona ele para uma pagina no ip 172.17.254.2, e deixa ele acessar apenas a central do assinante q é o ip xxx.xxx.xxx.
    Commo ja falei, um bom tempo funcionou tudo mil maravilha, mas apos colocar essas regras para acesso ao thunder (tem q passar o ip do cliente) parou de direcionar para a pagina de bloqueio.


    Espero ter explicado certo e espero a ajuda dos amigos.

    Abraços

  2. #2

    Exclamation Resolvido

    Pronto pessoal, ja q ninguem respondeu, mas se alguem tiver o problema, eis a solução

    /ip firewall nat
    add action=dst-nat chain=dstnat comment="Redireciona Clientes bloqueados para Aviso" disabled=no dst-address=\
    !200.183.146.204 dst-port=0-65535 protocol=tcp src-address=172.16.0.0/16 to-addresses=172.17.254.2 to-ports=80
    add action=masquerade chain=srcnat comment="" disabled=no src-address=172.16.0.0/16

    Pq ?? Bom teoricamente, fazer um NAT no escopo diferente ao dos clientes, se olharem o escopo pra onde é redirecionado é 172.17.... e o escopo de quem esta bloqueado é 172.16.... por isso q nao redirecionava para a pagina.

    Depois q coloquei a regra testei, e voltou tudo ao normal, qualque cliente q estiver no escopo 172.16.0.0/16 será bloqueado, ou seja nao navega, msn nao conecta, nem skype, e toda pagina q tentar abrir sera direcionado para uma pagina de aviso q esta no ip 172.17.254.2.


    Pronto

    Obrigado pela ajuda de todos.


    Paulo Jr




  3. #3
    tobiloucoinfo
    Visitante

    Padrão

    Cara ja tentei a sua e varias outras + ainda nÃo consegui colocar em pppoe do mk pagina de aviso ja estou olhando foruns a respeito disso a uns 6 meses e ate agora nada

  4. #4

    Padrão

    bom dia amigo, aqui pra mim funciona de boa... mas seria mais interessante vc nos passar detalhes de sua rede.
    Sua autenticação pppoe é via radius ? os clientes bloqueados estao em outro pool ? os bloqueados iram receber outra faixa de ip ?? Qualquer coisa me add no skipe ou no msn q te dou uma força.

    Boa sorte



  5. #5

    Padrão

    Citação Postado originalmente por tobiloucoinfo Ver Post
    Cara ja tentei a sua e varias outras + ainda nÃo consegui colocar em pppoe do mk pagina de aviso ja estou olhando foruns a respeito disso a uns 6 meses e ate agora nada
    Posta da maneira que vc tentou fazer, e a topologia de sua rede, pra gente poder te ajuda .

  6. #6

    Padrão Re: Redirecionar inadimplente - nao redireciona !!!!

    Pessoal sou novo por aqui e estou me dedicando para aprender com voces. Não estou consequindo entender neste ponto em negrito.
    ip firewall nat
    add action=dst-nat chain=dstnat comment="Redireciona Clientes bloqueados para Aviso" disabled=no dst-address=\
    !200.183.146.204 dst-port=0-65535 protocol=tcp src-address=172.16.0.0/16 to-addresses=172.17.254.2 to-ports=80
    add action=masquerade chain=srcnat comment="" disabled=no src-address=172.16.0.0/16.

    Abraço a todos.



  7. #7

    Padrão Re: Redirecionar inadimplente - nao redireciona !!!!

    esta falando pra nao desabilitar a regra !!! disable=no se vc colcoar yes ela ficara desativa