Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão TUTORIAL: Montando web-proxy + cahce full versão 3.13 (valido para 3.10 a 3.30).

    Amigo, a algumas horas atraz, procurrei como fazer e nao achei nada, agora que descobrir vou compartilhr com voces.. salvo enganos e erros...
    peço para que o moderado exclua o topico se achar algo de errado.. abraço!!!
    Para termos um cache-full temos q primeiro criar um web-proxy.

    1º) no winbox: MENU> IP > WEB-PROXY
    Clique no botão: [WEB PROXY SETIINGS]
    marque a caixa: enable
    src address: deixe em como esta (em branco)
    port: 3128 (porta padrão)
    parent proxy: deixe em como esta (em branco)
    parent proxy port: deixe em como esta (em branco)
    cache driver: system
    cache administrador: ponha uma mensagem que sera exibida ao clientes em caso de erro 404 ou sem link
    [site nao disponivel no momento]
    maxi chache size: unlimited
    marque a opção: cache on disk (para gravar no disco e nao na ram)
    o resto deixe como esta....
    clique no botao APPLY
    ------
    agora vamos criar algumas regras pelo console do webox:
    clique em NEW TERMINAL E LAH DENTRO COLE OS SEGUINTES COMANDOS..
    DEPOIS DE ENTER... (copie aqui e para colar la clique com o botão direito do mouse em PASTE no meio do campo de digitação terminal)...>>>>

    /ip proxy access
    add action=deny comment=\
    "MPSnet WEB PROXY block telnet & spam e-mail relaying" disabled=no \
    dst-port=23-25
    add action=allow comment="MPSnet WEB PROXY " disabled=no src-address=\
    192.168.2.0/24
    add action=deny comment="MPSnet WEB PROXY " disabled=no

    /ip firewall filter
    add action=drop chain=input comment=\
    "MPSnet WEB PROXY - BLOQUEIO DO PROXY EXTERNO" disabled=no dst-port=3128 \
    in-interface=wan1 protocol=tcp

    /ip firewall nat
    add action=redirect chain=dstnat comment=\
    "MPSnet WEB PROXY redirecionamento porta 80 para webproxy 3128" disabled=\
    no dst-port=80 protocol=tcp src-address=192.168.2.0/24 to-ports=3128

    ok.. proxy tah pronto.. agora...
    agora vamos criar o CACHE FULL (sem cache full o servidor armazena apenas os html e jpg gif e asp e .php ) com o cache ful ele armazena os downloads tambem, assim quando outro usuario for baixar algum aquivo q ja foi baixado antes, ele baixa do teu servidor e nao do teu link.. ou seja.. vai entregar a ele a 20 mbps..

    mais algumas regrinhas no new terminal....

    /ip firewall mangle
    add action=mark-connection chain=output comment="CACHE FULL" content=\
    "X-Cache: HIT" disabled=no new-connection-mark=conn_squid-up passthrough=\
    yes protocol=tcp src-port=3128
    add action=mark-packet chain=output comment="CACHE FULL" connection-mark=\
    conn_squid-up disabled=no new-packet-mark=pacotes_squid-up passthrough=\
    yes
    add action=mark-connection chain=prerouting comment="CACHE FULL" disabled=no \
    dst-port=3128 new-connection-mark=conn_squid-down passthrough=yes \
    protocol=tcp
    add action=mark-packet chain=prerouting comment="CACHE FULL" connection-mark=\
    conn_squid-down disabled=no new-packet-mark=pacotes_squid-down \
    passthrough=yes

    /ip firewall filter
    add action=accept chain=input comment="CHACHE FULL - ACEITAR CONEXOES PROXY" \
    disabled=no dst-port=3128 protocol=tcp

    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=10000000 name=CACHE-FULL-Download packet-mark=pacotes_squid-down parent=global-in priority=1 \
    queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=10000000 name=CACHE-FULL-Upload packet-mark=pacotes_squid-up parent=global-out priority=1 queue=\
    default

    acho que é isto galera... façam um teste agora
    pelo internet explorer, sem gerenciador de downloads, tente baixar o msn plus por 3 veses.. a primeira baixada sera lenta.. mas as outras serao veloz, note a interface do link na segunda baixada ela mal se mexe no grafico do wimbox, enquanto a de saida vai a 15 mbps...
    abraços . é meiu primeiro post se ficou ruim comenten abaixo.
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         DD.JPG
Visualizações:	1449
Tamanho: 	166,3 KB
ID:      	6252  
    Última edição por mpsnet; 06-12-2009 às 13:04.

  2. #2

    Padrão

    Começou bem, mas tem que lembrar de alterar a classe de ip para a usada pela pessoa



  3. #3

    Padrão

    Citação Postado originalmente por jardelalmeida Ver Post
    Começou bem, mas tem que lembrar de alterar a classe de ip para a usada pela pessoa
    como assim amigo ?

  4. #4



  5. #5

    Padrão

    Quando falei da classe de ip me referia que nas suas regras tem "src-address=192.168.2.0/24 ", no caso tem que altera para a classe que a pessoa usa, no meu caso, 10.1.1.0/24

  6. #6

    Padrão web-proxy travando

    amigos não importa da onde veio este tutorial e sim que possa ajudar alguem,,
    veja meu caso e de outros que estão com mesma duvida,.
    a um bom tempo eu tenho web-proxi funcionando perfeitamente na versão 2.9 no entanto troquei o servidor e versão com versão 4.3 e outro com 4.2,.,
    ja reiz as regras divesas x e não funciona nem com as que tinha e nem com esta q vc passo,.,.

    sem regras cache ele não faz proxy e com regras cache fuul clientes fica sem net..
    ao repetir as regras na nat as opção dst port fica sem opção de escolha em cinza

    alguem ja passo por este ?



  7. #7

    Thumbs up

    Citação Postado originalmente por cls7007 Ver Post
    KKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKKK..........

    cara porque vc não faz uma coisa mais pratica mostrando que saca tudo do assunto do cache-full da uma repensada no seu topico, e tenta postar ele direitinho tentando evitar tais situações......

    inclusive estou com uma duvida aqui, quem sabe vc possa me esclarecer, alias uma não 4?

    1ª qual a diferença entre o web-proxy e o cache-full, o que as regras do cache-full agregam de funcionalidades ao proxy?

    2ª qual seria a diferença entre o cache-full e o thuder-cache? posso usar os dois juntos sendo o ultimo em paralelo? qual serio o beneficio de um E do outro? vc aconselha esse tipo de sistema a ser usado?

    3ª implementei no meu thunder-cache um sistema de cobrança onde digito o ip+porta do servidor cache paralelo no browser e aparece uma pagina avisando do ocorrido para meus clientes, teria como automatizar isso pra aparecer nas datas de vencimentos dos clientes?

    4ª com relação a outro assunto load-balance, então tenho 2 links adsl e um link dedicado, fiz um load balance com esses 3 links, e tenho um cliente que usa cameras de segurança com porta 1999, como vou fazer pra colocar esse cliente pra sair por apenas 1 link e poder redirecionar as portas deles?


    Obrigado grande criador de tutoriais pelas suas explicações, serão de grande valia não so pra mim mais como para todos desse maravilhoso forum PUBLICO de discussão, opinião, fatos, relatos, agradecimentos e CRITICAS!

    NÃO QUER MOLHAR NÃO SAIA NA CHUVA!!! NÃO QUER QUEIMAR NAO SAIA NO SOL!!! QUER AJUDAR NÃO ESPERE NADA EM TROCA....... SE FOR REALMENTE UTIL SUA RECOMPENSA CHEGARA RAPIDAMENTE!

    respostas:

    1) diferença entre wenproxy- e cache full... webproxy só armazena o conteudo dos sites, e o cachefull armazena e te entraga em velocidade superior não só o conteudo (htm gif jpg) como tambem os arquivos q trafegam na reed (downloads)... e quanto as regras... as regras só marcam e identificam os pacotes, para direcionar pro queue tree... podendo assim te entregar do cache por fora do teu controle de banda simple, toda vez q vc pega algo do cache e faz assim valer apenas a queue tree como controle...

    2) trunder cache seria mais abrangivo q o cache fulll, afinal ele alem de pegar o conteudo dos sites (html gifs), e os aquivos (download.exe , .zip) ele pega tambem:... estreaming , pedaços de arquivos como atualizações de windows, videos youtube, orkut e etc... eu ainda não estudei bem o trunder cache nem usei ainda, mas mesmo assim aconselho o uso dele pelo fato de pegar o orkut no cache.. mas acredito que tenha que usar tudo em um servidor só.


    3) pra eu te responder eu teria q conhecer teu sistema... mas acredito q exista uma maneira de redirecionar isto sim pelo firewall da mikrotik...


    4) bom... tera que criar uma regra no firewall, mas não como fazer, não sei criar todas as regra do zero...

    em breve, vou criar um trunder cache, e quando eu criar vou fazer um tutorial.. não pra receber agradecimentos.. mas sim pq acho não tem aqui ainda... assim como o caso deste tutorial..

    abraço amigo.. espero ter ajudado..


    NÃO FAÇA PARA O TOPICO DOS OUTROS O Q NAO QUER Q FAÇAM EM TEUS TOPICOS..

  8. #8

    Padrão

    oi amigo
    o tuto que vc passo é o que tem mais informação na versão 4.0 ,.,.parabens,.,.,.
    e preciso de sua ajuda ,.pois seu proxy funciono (outros nem funciono e o antigo da versão 2.9 trava a net e ninguem navega )com erro não saindo para cliente e mostrando um numero grande que não existe de clientes conectado no web ,,não sei oq pode ser,sei que esto errando em algo ou não usando alguma opção desta nova versão..
    não consigo fazer funcionar este web-proxy com pagina de bloqueio de atraso de pagamento no hotspot nesta versão.;.;; estou quase voltando para 2.9 que é perfeito,.,pena que comprei 3 licensa 4.2.,.
    obs.os clientes esta com arp e queue o hots pot e pagina de bloqueio.;
    aguardo obrigado



  9. #9

    Padrão

    Citação Postado originalmente por vie190 Ver Post
    oi amigo
    o tuto que vc passo é o que tem mais informação na versão 4.0 ,.,.parabens,.,.,.
    e preciso de sua ajuda ,.pois seu proxy funciono (outros nem funciono e o antigo da versão 2.9 trava a net e ninguem navega )com erro não saindo para cliente e mostrando um numero grande que não existe de clientes conectado no web ,,não sei oq pode ser,sei que esto errando em algo ou não usando alguma opção desta nova versão..
    não consigo fazer funcionar este web-proxy com pagina de bloqueio de atraso de pagamento no hotspot nesta versão.;.;; estou quase voltando para 2.9 que é perfeito,.,pena que comprei 3 licensa 4.2.,.
    obs.os clientes esta com arp e queue o hots pot e pagina de bloqueio.;
    aguardo obrigado
    PASSA TEU MSN Q TE AJUDO

  10. #10

    Padrão

    Citação Postado originalmente por mpsnet Ver Post
    PASSA TEU MSN Q TE AJUDO
    amigo os "clientes" conectado significam paginas abertas.. e não clientes assinantes... é normal..



  11. #11
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão MK - PIRATA

    Conforme regras do forum peço exclusão do tópico por incentivar pirataria.

  12. #12

    Padrão

    Citação Postado originalmente por minelli Ver Post
    Conforme regras do forum peço exclusão do tópico por incentivar pirataria.


    100% sabe tudo!



  13. #13

    Padrão

    Citação Postado originalmente por minelli Ver Post
    Conforme regras do forum peço exclusão do tópico por incentivar pirataria.
    o idiota tu ja viu versão 3.13 pirata ? provavelmente deve conhecer a 2.9.5 pirata certo?

    se só existir tutotial para versão 2.9.5 é lógico que vão sempre ficar com medo de sair de uma versão pirata para uma quente 3.x....

    na moral eu estou incentivando com meu topico o cara comprar a licença!

    obrigado por dedicar seu tempo importunando meu tópico... inves de fiscalizar meu topico acho que o sr. poderia ficanlizar a tua mulher seu corno manso!

  14. #14

    Padrão

    MPSnet, apesar de não ter nada a ver com o desenvolvimento inicial do tópico, fico preocupado com o desenrolar dos acontecimentos.
    Mesmo tu sendo acusado por alguns companheiros de plágio, onde eu não vou entrar no mérito pois me falta conhecimento para isso, obsevei que eles não levaram a conversa para um terreno tão delicado.

    Além de que a impressão que tive com o comentário do Minelli não é relacionado com a versão do MK. E ísto mostra que tu está realmente transtornado.
    Em outros tópicos tenho observado que tu tem sangue quente, e isso é prejudicial para a convivência num forum. Pela região onde tu moras, deves ter sangue de alemão. E aqui nós sabemos quanto este sangue é esquentado e teimoso. Falo isso, pelas minhas origens que também são germânicas.

    Mas temos que aprender a suportar quando temos razão, a corrigir quando errados.
    E o teu erro neste tópico, independente de plágio ou não, é a forma áspera como tu responde.
    Tem que ter mais cuidado, pois pode até ser banido do forum.
    E tenho certeza que não é isso que queremos.



  15. #15
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Resp...

    Citação Postado originalmente por mpsnet Ver Post
    o idiota tu ja viu versão 3.13 pirata ? provavelmente deve conhecer a 2.9.5 pirata certo?

    se só existir tutotial para versão 2.9.5 é lógico que vão sempre ficar com medo de sair de uma versão pirata para uma quente 3.x....

    na moral eu estou incentivando com meu topico o cara comprar a licença!

    obrigado por dedicar seu tempo importunando meu tópico... inves de fiscalizar meu topico acho que o sr. poderia ficanlizar a tua mulher seu corno manso!
    Idiota?? Desde quando te ofendi amigo?
    Para seu governo existe sim a 3.13 até 3.22 pirata.
    E ainda me ofender... cuidado isso da banimento.
    Fique atenta as regras do forum, por favor.

  16. #16
    Moderador Avatar de minelli
    Ingresso
    Aug 2006
    Localização
    Pres. Venceslau - SP | Pres. Prudente - SP
    Posts
    1.408
    Posts de Blog
    10

    Padrão Resp...

    Citação Postado originalmente por 1929 Ver Post
    MPSnet, apesar de não ter nada a ver com o desenvolvimento inicial do tópico, fico preocupado com o desenrolar dos acontecimentos.
    Mesmo tu sendo acusado por alguns companheiros de plágio, onde eu não vou entrar no mérito pois me falta conhecimento para isso, obsevei que eles não levaram a conversa para um terreno tão delicado.

    Além de que a impressão que tive com o comentário do Minelli não é relacionado com a versão do MK. E ísto mostra que tu está realmente transtornado.
    Em outros tópicos tenho observado que tu tem sangue quente, e isso é prejudicial para a convivência num forum. Pela região onde tu moras, deves ter sangue de alemão. E aqui nós sabemos quanto este sangue é esquentado e teimoso. Falo isso, pelas minhas origens que também são germânicas.

    Mas temos que aprender a suportar quando temos razão, a corrigir quando errados.
    E o teu erro neste tópico, independente de plágio ou não, é a forma áspera como tu responde.
    Tem que ter mais cuidado, pois pode até ser banido do forum.
    E tenho certeza que não é isso que queremos.
    Minha referencia foi sobre o MK somente.



  17. #17

    Padrão

    Citação Postado originalmente por minelli Ver Post
    Minha referencia foi sobre o MK somente.
    Grande Minelli, eu pensei que tu estava se referindo a copia das regras.
    Li e reli e não achei onde ele faz citação sobre piratear versão do MK.

    E na boa, ja vi também tutoriais sobre craquear versões 3.20 até 3.30 mas tem uma coisa que foi alertada no tutorial. Só permite level 4.
    E não vejo vantagem nenhuma em craquear uma versão para este nível. Paga logo os 100,00 e fica numa legal.
    O MK é tão barato que não compensa o risco. Vai que tem um problema escondido no programa só para casos de crack? Não dá para colocar o futuro do provedor em cima de craqueados.
    Mas parece que o povo gosta mesmo é de crackeados. A famosa lei de Gerson: "Leve vantagem voce também".

  18. #18

    Exclamation

    Citação Postado originalmente por 1929 Ver Post
    MPSnet, apesar de não ter nada a ver com o desenvolvimento inicial do tópico, fico preocupado com o desenrolar dos acontecimentos.
    Mesmo tu sendo acusado por alguns companheiros de plágio, onde eu não vou entrar no mérito pois me falta conhecimento para isso, obsevei que eles não levaram a conversa para um terreno tão delicado.

    Além de que a impressão que tive com o comentário do Minelli não é relacionado com a versão do MK. E ísto mostra que tu está realmente transtornado.
    Em outros tópicos tenho observado que tu tem sangue quente, e isso é prejudicial para a convivência num forum. Pela região onde tu moras, deves ter sangue de alemão. E aqui nós sabemos quanto este sangue é esquentado e teimoso. Falo isso, pelas minhas origens que também são germânicas.

    Mas temos que aprender a suportar quando temos razão, a corrigir quando errados.
    E o teu erro neste tópico, independente de plágio ou não, é a forma áspera como tu responde.
    Tem que ter mais cuidado, pois pode até ser banido do forum.
    E tenho certeza que não é isso que queremos.
    Sim... a cidade onde moro chama-se BROCHIER-RS 80% é alemão e 20% é francês... eu dou brasileiro mesmo... mas me criei no meio dos alemães.. e me sobe o sangue quando cometem injustiça... eu criei o topico pq nao tinha nada igual no forum... nem como criar proxy na 3.x , ja vieram gente com pedra na mao dizendo, que eu copiei, outro dizendo q tah errado e q nao sei nada.... (o que até contradiz a acusação de cópia) e outro vem dizer eu incentivei a pirataria.. e até ai eu estava calmo.. mas me deixaram com 80 reputções negativa sem nem explicar o por que.. acho q se eu for banido daqui.. nao vou fazer falta pro forum nem o forum pra min pois aqui tem muinta gente mesquinha! não acha?



  19. #19

    Exclamation

    Citação Postado originalmente por minelli Ver Post
    Idiota?? Desde quando te ofendi amigo?
    Para seu governo existe sim a 3.13 até 3.22 pirata.
    E ainda me ofender... cuidado isso da banimento.
    Fique atenta as regras do forum, por favor.
    ok! mas quem aqui falow em piratear o mikrotik... voce não esta postanto num topico relacionado a como crakear a mikrotik, e sim o meu topico... relacionado a como criar web proxy na versão 3.x em diante !

    a versão 3.13 quando me refiro a ela é por que é a que tem menos bug...

    e se existe tal crack... não é tão facil de crackear não.. ao contrario da 2.9.5 q tu istala e ja nasce full automaticamente sem fazer nada!

    Abraço e desculpa... mas me transtorno com estas coisas.. EXCLUIR TÓPICO!!!

  20. #20

    Padrão

    Citação Postado originalmente por 1929 Ver Post
    E na boa, ja vi também tutoriais sobre craquear versões 3.20 até 3.30 mas tem uma coisa que foi alertada no tutorial. Só permite level 4.
    Galera não me levem a mal, mas só para informação, eu mesmo ja instalei em um de meus servidores a versão 3.20 crackeada no Level6, claro que só para testes, pois creio que um sistema tão completo como o Mikrotik não custa nem 1/3 do valor que deveria custar...
    Até ++