+ Responder ao Tópico



  1. Bem amigo, vem através deste solicitar de vcs ajuda a respeito do cache do MK auth.

    O Cenário:
    Adquirir o Mk-auth recentemente, a uns 3 dias e instalei e configurei-o com o MK, depois disso percebir q o Msn, orkut e nem o gmail conseguim abrir e, tb não aparece nda de bloqueio do squid.
    isto acontece quando eu deixo o redirecionamento para o proxy.
    Quando eu coloco o mascarede sem o proxy funciona todo mormal. Acredito q seja na configuração do squid do Mk-auth que ainda não descobrir o que pode estar acontecendo, por isso q estou aqui pedindo uma ajuda de vcs.

    a miinha configuração do squid é essa: o squid é o 3.

    # MK-AUTH SISTEMA PARA ADMINISTRACAO DE PROVEDORES MIKROTIK
    # VISITE WWW.MK-AUTH.NING.COM
    http_port 3128 transparent
    visible_hostname Riachonet
    icp_port 0
    # retira o cache dos dinamicos
    hierarchy_stoplist cgi-bin
    acl QUERY urlpath_regex cgi-bin
    cache deny QUERY
    # cache de ip acessados
    ipcache_size 1024
    ipcache_low 90
    ipcache_high 95
    fqdncache_size 1024
    mime_table /etc/squid3/mime.conf
    pid_filename /var/run/squid3.pid
    # arquivos de Log retirados para melhor desempenho
    access_log /var/log/squid3/access.log
    cache_access_log /dev/null
    cache_log /dev/null
    cache_store_log /dev/null
    # tamanho maximo do cache em memoria ram
    cache_mem 400 MB
    cache_swap_low 90
    cache_swap_high 95
    # tamanho maximo de arquivo que o cache irar guardar
    maximum_object_size 30 MB
    minimum_object_size 0 KB
    maximum_object_size_in_memory 40 KB
    # diretorio onde serao ficarao armazenado o cache das paginas.
    # O 50000 MBs do HD que sera reservado para o meu cache.
    cache_dir aufs /var/spool/squid3 50000 16 256
    acl semcache url_regex "/etc/squid3/direto.lst"
    cache deny semcache
    always_direct allow semcache
    # Lista de sites proibidos para a rede toda
    acl proibidos dstdom_regex "/etc/squid3/proibidos.lst"
    # toda a internet
    acl todos src 0.0.0.0/0.0.0.0
    acl bannermsn url_regex ADSAdClien
    http_access deny bannermsn
    deny_info mk-auth bannermsn
    # redes invalidas, nao sao da internet
    acl rede src 127.0.0.1/32 5.0.0.0/8 169.254.0.0/16 192.168.0.0/16 10.0.0.0/8 172.16.0.0/16 172.17.0.0/16 172.18.0.0/16 172.19.0.0/16 172.20.0.0/16 172.21.0.0/16 172.22.0.0/16 172.23.0.0/16 172.24.0.0/16 172.25.0.0/16 172.26.0.0/16 172.27.0.0/16 172.28.0.0/16 172.29.0.0/16 172.30.0.0/16 172.31.0.0/16
    acl manager proto cache_object
    acl localhost src 127.0.0.1/32
    acl to_localhost dst 127.0.0.0/32
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # SWAT
    acl CONNECT method CONNECT
    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access deny proibidos
    http_access allow rede
    http_access deny todos
    # usuario que executa o servidor proxy
    cache_effective_user proxy
    cache_effective_group proxy
    error_directory /usr/share/squid3/errors/Portuguese
    coredump_dir /var/spool/squid3
    client_persistent_connections off
    server_persistent_connections off
    request_timeout 30 seconds
    pconn_timeout 120 seconds
    # Marcacao feita pelo Zero Penalty HIT
    zph_tos_local 0x30
    zph_tos_peer 0
    zph_tos_parent off

    Obs.: o programa é excepcional, só falto resolver esse problema para poder rodar 100%

    + detalhes:

    1261072735.835 4262 10.17.11.62 TCP_MISS/200 1999 GET orkut - - DIRECT/64.233.163.94 text/html esse é o log do access logs.

  2. Amigos, fiquei aqui batendo a cabeça para resolver esse problema e, não é q conseguir, irei postar aqui pois, pode existir alguém que está passando pela mesma dificuldade. A solução foi a seguinte:

    Adicionei um Nat separado para esses sites q estavam com problemas, obs.: As regras iram ficar acima do redirecionamento do nat para o mk-auth e, isses sites não irá para o cache.

    /ip firewall nat

    add action=masquerade chain=srcnat comment="Orkut - MSN - Gmail sem proxy" disabled=no dst-address=64.233.0.0/16
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=207.46.0.0/16
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=65.54.0.0/16
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=64.4.0.0/16
    add action=masquerade chain=srcnat comment="" disabled=no dst-address=65.54.0.0/16
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         solução MSN Orkut.JPG
Visualizações:	207
Tamanho: 	89,2 KB
ID:      	6343  



  3. Depois de várias tentativas com regras dos colegas, mas, infelizmente sem solução conseguir resolver, agora só falta conseguir fazer meu web proxy realizer cache fora da velocidade contratada por meus clientes. Quem puder me ajudar agradeço

  4. adiciona ai riachonet@hotmail.com



  5. Caro amigo coloquei todas as regras mais ainda assim meu MK não deixa abrir o orkut, gmail ele fica la com a barrinha apenas enchendo e não abre, pode me ajudar por favor estou desesperado e sou novato no mk.


    Agradeço toda e qualquer ajuda...






Tópicos Similares

  1. Problema com produtos Apple no MK
    Por matheusouza no fórum Redes
    Respostas: 10
    Último Post: 22-01-2017, 07:29
  2. Problemas com Threads Abertas no Thunder Cache 3.1
    Por geronimofsa no fórum Servidores de Rede
    Respostas: 9
    Último Post: 04-01-2011, 10:07
  3. Problema com Thunder Cache ! no Mk-Auth
    Por DeividMoika no fórum Redes
    Respostas: 4
    Último Post: 30-10-2010, 18:05
  4. Problema com MSN messeger no SQUID
    Por fjacunha no fórum Servidores de Rede
    Respostas: 2
    Último Post: 30-01-2004, 16:10
  5. Problemas com diretório virtual no apache
    Por no fórum Servidores de Rede
    Respostas: 5
    Último Post: 17-12-2002, 23:37

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L