+ Responder ao Tópico



  1. Gente
    sempre usei linux
    porem, ha aproximadamente 1 mes comecei a usar o mikrotik
    testei 3 versoes ate agora: 3.20 - 3.28 - 3.30

    em nenhuma delas, consegui achar o local para determinar o tamanho maximo de arquivo em cache...
    porem, em varios locais na web, vi q tinha essa opcao...

    isso ta certo?
    ou sera q o local para limitar o tamanho maximo de arquivo em cache, mudou de lugar?

  2. não consigo achar aonde colocar o tamanho máximo do arquivo pra armazenar ... não sei se é burrice , mas tb não achei . obrigado



  3. é...
    pelo q andei lendo
    parece que nao tem mesmo...
    depois q o squid saiu... mk criou um proxy proprio

    porem, estava pensando em uma forma de burlar isso...
    nao sou nenhum expert no mk... ao contrario, uso apenas a 1 mes...

    os expert me corrijam se eu estiver errado, por favor.

    em
    /ip firewall nat

    geralmente criamos uma regra para redirecionamento do trafego com destino a porta 80 para a porta 3128 (ou outra configurado em seu webproxy)

    exemplo:
    /ip firewall nat
    add action=redirect chain=dstnat comment="REDIRECIONAR PROXY" disabled=no dst-port=80 protocol=tcp src-address=172.167.2.0/24 to-ports=3128

    pensei em colocar um limite ai...
    ou seja.. todo arquivo com tamanho 1 a 65mb ser redirecionado:
    ficando assim:
    /ip firewall nat
    add action=redirect chain=dstnat comment="REDIRECIONAR PROXY" connection-bytes=0-6500000 disabled=no dst-port=80 protocol=tcp src-address=172.167.2.0/24 to-ports=3128


    ou...
    uma outra forma que pensei seria:
    - criar uma marcacao para os pacotes com tamanho 1 a 65mb
    - adicionar o redirecionamento no nat com essa marcacao.

    /ip firewall mangle
    add action=mark-packet chain=prerouting comment="" connection-bytes=0-6500000 disabled=no new-packet-mark=ate65 passthrough=yes protocol=tcp

    /ip firewall nat
    add action=redirect chain=dstnat comment="REDIRECIONAR PROXY" disabled=no dst-port=80 packet-mark=ate65 protocol=tcp src-address=172.167.2.0/24 to-ports=3128


    Devo dizer que nao testei
    nao sei se daria certo
    é apenas uma teoria minha... nao sou nenhum expert em mk






Tópicos Similares

  1. aumentar o tamanho do cache
    Por Lion_Black no fórum Servidores de Rede
    Respostas: 7
    Último Post: 17-02-2006, 23:36
  2. Tamanho de Cache ideal ??
    Por rfm no fórum Servidores de Rede
    Respostas: 3
    Último Post: 03-11-2005, 10:41
  3. Squid não controla tamanho do Cache...
    Por lacierdias no fórum Servidores de Rede
    Respostas: 2
    Último Post: 01-01-2005, 08:44
  4. Tamanho do Cache
    Por TheHawk no fórum Servidores de Rede
    Respostas: 18
    Último Post: 05-12-2004, 12:21
  5. squid tamanho do cache
    Por 1c3m4n no fórum Servidores de Rede
    Respostas: 2
    Último Post: 12-01-2003, 21:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L