+ Responder ao Tópico



  1. #1

    Padrão Erro no Proxy

    necessidades...
    • SRC-ADDRESS = Deixe em branco
    • PORT = Escolher a porta do seu web-proxy
    • TRANSPARENT PROXY = Deixe marcado para proxy transparente
    • PARENT PORT = Deixe em branco
    • PARENT PROXY PORT = Deixe em branco
    • CACHE ADMINISTRATOR = Deixe como está
    • MAXIMUM OBJECT SIZE = Deixe como está
    • CACHE DRIVE = Deixe como “system”
    • MAXIMUM CACHE SIZE = Define o tamanho do seu cache, varia de acordo com o tamanho do seu HD
    • MAXIMUM RAM CACHE SIZE = Define o tamanho máximo de sua memória RAM para o cache

    Após configurar estes parâmetros, aperte a tecla “ENABLE”
    NÃO se deve fazer CACHE de PÁGINAS DINÂMICAS (bancos, globo.com, etc etc...)
    Duas regras devem ser colocadas na aba "CACHE" do Web-Proxy para esse efeito:
    IP / WEB-PROXY / CACHE
    Crie uma nova regra (botão “+”)
    add url=":cgi-bin \\?" action=deny comment="no cache dynamic http pages" disabled=no
    add url="https://" action=deny comment="no cache dynamic https pages" disabled=no



    Companheiros, feliz ano novo para todos!!!!!




    Estou com dificuldade para entrar com estas duas ultimas regras do web-cache do mikrotik.
    Uso a versão 4.4, se alguem puder ajudar desde ja agradeço.

  2. #2

    Padrão

    /ip proxy
    set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 cache-on-disk=yes enabled=yes max-cache-size=unlimited max-client-connections=600 \
    max-fresh-time=7d max-server-connections=600 parent-proxy=0.0.0.0 parent-proxy-port=0 port=8080 serialize-connections=no src-address=0.0.0.0

    /ip firewall nat
    add action=redirect chain=dstnat comment="Redirecionar trafego para Proxy" disabled=no dst-port=80 in-interface=LAN protocol=tcp to-ports=8080

    /ip firewall filter
    add action=drop chain=input comment="bloqueio ao proxy externo" disabled=no dst-port=8080 in-interface=WAN protocol=tcp


    por padrao as versoes mais novas nao fazem cache de paginas dinamicas assim q nao eh necessario colocar as regras de paginas https e cgi-bin.



  3. #3

    Padrão

    Citação Postado originalmente por arauadbr Ver Post
    necessidades...
    • SRC-ADDRESS = Deixe em branco
    • PORT = Escolher a porta do seu web-proxy
    • TRANSPARENT PROXY = Deixe marcado para proxy transparente
    • PARENT PORT = Deixe em branco
    • PARENT PROXY PORT = Deixe em branco
    • CACHE ADMINISTRATOR = Deixe como está
    • MAXIMUM OBJECT SIZE = Deixe como está
    • CACHE DRIVE = Deixe como “system”
    • MAXIMUM CACHE SIZE = Define o tamanho do seu cache, varia de acordo com o tamanho do seu HD
    • MAXIMUM RAM CACHE SIZE = Define o tamanho máximo de sua memória RAM para o cache
    Após configurar estes parâmetros, aperte a tecla “ENABLE”
    NÃO se deve fazer CACHE de PÁGINAS DINÂMICAS (bancos, globo.com, etc etc...)
    Duas regras devem ser colocadas na aba "CACHE" do Web-Proxy para esse efeito:
    IP / WEB-PROXY / CACHE
    Crie uma nova regra (botão “+”)
    add url=":cgi-bin \\?" action=deny comment="no cache dynamic http pages" disabled=no
    add url="https://" action=deny comment="no cache dynamic https pages" disabled=no


    Companheiros, feliz ano novo para todos!!!!!




    Estou com dificuldade para entrar com estas duas ultimas regras do web-cache do mikrotik.
    Uso a versão 4.4, se alguem puder ajudar desde ja agradeço.



    esse link acho que vai te ajudar

    https://under-linux.org/f134106-web-...a-versao-4-3-a

  4. #4

    Padrão

    Citação Postado originalmente por arauadbr Ver Post
    necessidades...
    • SRC-ADDRESS = Deixe em branco
    • PORT = Escolher a porta do seu web-proxy
    • TRANSPARENT PROXY = Deixe marcado para proxy transparente
    • PARENT PORT = Deixe em branco
    • PARENT PROXY PORT = Deixe em branco
    • CACHE ADMINISTRATOR = Deixe como está
    • MAXIMUM OBJECT SIZE = Deixe como está
    • CACHE DRIVE = Deixe como “system”
    • MAXIMUM CACHE SIZE = Define o tamanho do seu cache, varia de acordo com o tamanho do seu HD
    • MAXIMUM RAM CACHE SIZE = Define o tamanho máximo de sua memória RAM para o cache
    Após configurar estes parâmetros, aperte a tecla “ENABLE”
    NÃO se deve fazer CACHE de PÁGINAS DINÂMICAS (bancos, globo.com, etc etc...)
    Duas regras devem ser colocadas na aba "CACHE" do Web-Proxy para esse efeito:
    IP / WEB-PROXY / CACHE
    Crie uma nova regra (botão “+”)
    add url=":cgi-bin \\?" action=deny comment="no cache dynamic http pages" disabled=no
    add url="https://" action=deny comment="no cache dynamic https pages" disabled=no


    Companheiros, feliz ano novo para todos!!!!!




    Estou com dificuldade para entrar com estas duas ultimas regras do web-cache do mikrotik.
    Uso a versão 4.4, se alguem puder ajudar desde ja agradeço.
    oi

    eu estava com mesmo problema e foi resolvido assim

    no meu caso o que deu certo foi,,,,,,,,,

    ip-webproxy-cache hit dscp (tos)4
    e por tambem ip-firewall-mangle-advanced-dscp(tos)4

    ai funciono perfeito;,.;
    --so uma duvida quanto o numero de requestes no web proxy ta muito alto e sempre subindo

    --não sei se é normal na versao 4.4


    ---quanto a por estas 2 regras faz assim(apesar de muinto dizer que a versao 4.4 não precisar destas regras pois ele é automatica.,.,.,mais em todo caso ta ai se vc for por.;.

    ip-webproxy-cache- no path poe exatamente assim *cgi-bim\\?*

    e a proxima regra ip-webproxy-cache- no path *https//*

    aqui ta rodando ,,so com o detali que descrevi acima e peço ajuda de quem quera ajudar