+ Responder ao Tópico



  1. #1

    Padrão Duvidas em Servidor PPPoE

    Olá amigos,,

    estou iniciando com servidor pppoe em mk, andei lendo alguns tutos aki no forum e no forum da propria mk,,minha duvida é a seguinte,,,
    deixei o mk on-line configurei o server pppoe controlando a banda,,, faço a autenticaçao pppoe com senha normal o meu server da um ip para a maquina e começa a navegar blz,,,mas se setar o ip na maquina nao precisa autenticar e o server libera banda sem ter q autenticar no pppoe, como resolver isso amigos?

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    A melhor maneira para entender e resolver os problemas é ler a documentação do sistema e outras mais para complementar o entendimento dos conceitos (MikroTik Wiki).

    PPPoE é um protocolo de camada 2 e portanto na interface que executa/escuta o mesmo não se configura endereço IP. Remova o endereço IP da interface e seus problemas se acabaram.



  3. #3

    Padrão

    Citação Postado originalmente por sergio Ver Post
    A melhor maneira para entender e resolver os problemas é ler a documentação do sistema e outras mais para complementar o entendimento dos conceitos (MikroTik Wiki).

    PPPoE é um protocolo de camada 2 e portanto na interface que executa/escuta o mesmo não se configura endereço IP. Remova o endereço IP da interface e seus problemas se acabaram.
    Intao Sergio, o problema é realmente isso se algum cliente meu descobrir o ip usado ele seta e usaria a internet sem restriçoes de banda e tudo mais, eu nos testes cliquei na rede no windows e me mostrou o ip que o server deu para o pc,,,,

  4. #4
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Não entendi... que server ?? que IP deu pro PC?? O servidor pppoe, reconhece um pppoe-discovery, provindo de um MAC Address, aceita, verifica a autenticação e atribui um IP a uma interface virtual, comumente chamada tunel. Pronto comunicação estabelecida, cliente já pode usar camada 3 (IP).

    Qualquer coisa fora disso é erro de configuração, como uns "expertos" por ai anunciam e até criam rautu, em como não exibir a mensagem de conectividade nula ou limitada da porcaria do windows, usando um dhcp server para atribuir IP. Isso é erro grosseiro de entendimento dos conceitos.

    Sugiro dar uma lida no link que informei, além da documentação do pppoe (não apenas Mikrotik, mas o protocolo).



  5. #5

    Padrão

    ola amigo

    Basta vc desativar o IP da interface e pronto!!
    eu ja conseguii resolver os meus problemas!!! precisando de ajuda e so add !!!
    [email protected]

  6. #6
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Conforme respondi, da primeira vez, este é o caminho correto. PPPoE não precisa IP configurado em nenhuma interface, nem servidor, nem cliente. Aproveitando que já resolveu seu problema, inclua uma proteção a mais, coloque a interface do PPPoE Server em uma bridge (mesmo que seja apenas uma interface) e crie filtros permitindo apenas os protocolos pppoe-discovery e pppoe-session, nega o resto.

    Citação Postado originalmente por kl3b3rr0x Ver Post
    ola amigo

    Basta vc desativar o IP da interface e pronto!!
    eu ja conseguii resolver os meus problemas!!! precisando de ajuda e so add !!!
    [email protected]



  7. #7

  8. #8
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Então não precisa de forum??? Legal, vem aqui aprende um monte e depois adiciona no MSN???

    Se é "o cara", posta aqui as configurações, garanto que todos vão aplaudir.

    Solicita todas as informações do usuário que postou as dúvidas e cola aqui todas as soluções.


    Citação Postado originalmente por cpmsilva Ver Post
    adiciona aí [email protected]



  9. #9

    Padrão

    caro amigo sergio em momento algum me auto-afirmei como se eu fosse o "cara", e em segundo lugar a minha intenção não é atrapalhar ninguém, muito pelo contrario, quero ajudar, se vc notar olhe bem o q ele falou no topico criado por ele, nisso td q vc escreveu aí uma coisa é verdade o fórum me ensinou muito com certeza... mas para eu postar as regras eu preciso entender o q está acontecendo com ele ok?
    após isso com certeza eu colocaria a solução, claro se estiver ao meu alcance, por isso pedi para q o amigo me adicionasse, para eu pode conversar com ele, ao inves de encher o topico com perguntas, mas de qualquer forma obrigado e me desculpe se cometi algum erro.

  10. #10
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    cpmsilva, a questão é que o forum é para isso, encher de perguntas e principalmente respostas. Quando um usuário posta com riqueza de detalhes e explicações sucintas sobre suas configurações, fica imensamente mais fácil responder.

    Não quis ofender, mas não foi apenas neste post que fez o comentário de adicionar ao MSN, e isto sempre dá a impressão daquele cara querendo "pegar" um servicinho e o propósito do forum não é este.

    Sem ressentimentos e continue postando, mas contatos via msn e afins use as mensagens privadas.

    thx!
    Citação Postado originalmente por cpmsilva Ver Post
    caro amigo sergio em momento algum me auto-afirmei como se eu fosse o "cara", e em segundo lugar a minha intenção não é atrapalhar ninguém, muito pelo contrario, quero ajudar, se vc notar olhe bem o q ele falou no topico criado por ele, nisso td q vc escreveu aí uma coisa é verdade o fórum me ensinou muito com certeza... mas para eu postar as regras eu preciso entender o q está acontecendo com ele ok?
    após isso com certeza eu colocaria a solução, claro se estiver ao meu alcance, por isso pedi para q o amigo me adicionasse, para eu pode conversar com ele, ao inves de encher o topico com perguntas, mas de qualquer forma obrigado e me desculpe se cometi algum erro.



  11. #11

    Padrão

    obrigado cara pelo esclarecimento, desculpa aê! a minha itenção foi boa mas existem regras eu entendo! foi malz!

  12. #12

    Padrão

    Citação Postado originalmente por sergio Ver Post
    Aproveitando que já resolveu seu problema, inclua uma proteção a mais, coloque a interface do PPPoE Server em uma bridge (mesmo que seja apenas uma interface) e crie filtros permitindo apenas os protocolos pppoe-discovery e pppoe-session, nega o resto.
    ola Sergio, conforme essa citação sua, queria uma ajudar, ja criei uma bridge e ja criei dentro do Filters os protocolos pppoe-discovery e pppoe session, so que nao estou conseguindo criar a regra que nega o resto, posta a regra pra ver como é. grato.



  13. #13
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Babton, segue abaixo.

    Código :
    /interface bridge filter
    add action=accept chain=input comment="" disabled=yes mac-protocol=\
        pppoe-discovery
    add action=accept chain=input comment="" disabled=yes mac-protocol=pppoe
    add action=drop chain=input comment="" disabled=yes

    Note que o canal é input, pois o servidor pppoe está escutando neste sistema. Se o filtro for configurado em um equipamento intermediário, que não é o concentrador pppoe, o canal é forward. A propósito no treinamento eu explico bem isso... hehehehe

    ps. deixei desabilitadas, para evitar que os curiosos de plantão copiem e colem em seus sistemas e fiquem se acesso.


    Citação Postado originalmente por babton Ver Post
    ola Sergio, conforme essa citação sua, queria uma ajudar, ja criei uma bridge e ja criei dentro do Filters os protocolos pppoe-discovery e pppoe session, so que nao estou conseguindo criar a regra que nega o resto, posta a regra pra ver como é. grato.

  14. #14

    Padrão

    opa amigos obrigado pela força, mas acho q ainda nao soube explicar pra vc's qual minha duvida, vamos por parte,,,sou iniciante pppoe e acabo explicando mal...vamos la:

    tenho 2 interface, a interface do link coloquei o nome de LINK o da rede interna coloquei REDE

    configurei os ip das interfaces-----------------ok
    defini a rota -------------------------------------ok
    defini o dns---------------------------------------ok
    no firewall em nat fiz srcnat masquerad -----ok

    mk on-line e navegando....

    meu proximo passo foi mudar o ARP da interface REDE para proxy-arp (mudei pq no wiki da mikrotik em ingles falava pra mudar)
    criei um pool de ip's
    em ppp criei um profile onde em local address coloquei o ip do server pppoe e em remote address coloquei o pool q havia criado
    criei um server pppoe
    criei um usuario em secrets

    ok,,,,,

    no windows xp configurei uma conexao pppoe ----------
    ok funcionou legal mesmo
    agora vem minha duvida.....
    se algum cliente ou até mesmo um invasor (no pior das ipoteses) descobrir os ips da REDE e do gateway o mk deixa navegar liberado sem senha nem nada
    pq ateh entao em nat deixei masquerad....
    minha duvida tem como bloquear isso?
    eu estava olhando quando se cria a conexao pppoe naquela rede virtual o o xp cria se vc clikar em propriedades vc ve os ip's de trabalho....
    essa eh minha duvida amigos sei q deve ser simples mas para mim eh um pé naquele lugar...hehe
    vou deixar minhas configuraçoes para vcs verem derepente esta tudo errado tb neh....vlw a todos....

    / ppp profile
    set default name="default" use-compression=default use-vj-compression=default use-encryption=default only-one=default \
    change-tcp-mss=yes comment=""
    add name="POOL 512K" local-address=208.67.222.1 remote-address="Pool IPS 1" use-compression=default \
    use-vj-compression=default use-encryption=default only-one=default change-tcp-mss=default rate-limit=512K/512K \
    comment=""
    set default-encryption name="default-encryption" use-compression=default use-vj-compression=default use-encryption=yes \
    only-one=default change-tcp-mss=yes comment=""
    / ppp secret
    add name="pool" service=pppoe caller-id="" password="102030" profile="POOL 512K" routes="" limit-bytes-in=0 \
    limit-bytes-out=0 comment="" disabled=no
    / ppp aaa
    set use-radius=no accounting=yes interim-update=0s



  15. #15
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Seu pppoe está livre, leve e solto... esqueça dele. Você tem que entender conceitualmente o que é o protocolo e os demais protocolos de redes. Sugiro (de novo) que dêe uma lida sobre redes estruturadas e o protocolo pppoe. Não adianta eu, ou outros, ficarem falando configuração aqui se vc não entende os conceitos básicos... grande parte do que for dito poderá ser asneira e vc não aproveitará muita coisa. Faça uma busca no wikipedia ou no google e leia um pouco. Garanto que ficará mais fácil criar suas questões aqui.