+ Responder ao Tópico



  1. olá amigos tenho dois mk conectados a vpn, mas estou com dificuldade em manter o acesso por causa do link velox, esse link é um link de backup e gostaria de implementar o ddns para que se o link velox de uma ponta cair ao mudar o ip ele consiga reconectar sozinho...

  2. Adicione a seguinte regra em system >> script:


    :log info "DDNS: Begin"

    :global ddns-user "LOGIN DE ACESSO AO SEU DDNS"
    :global ddns-pass "SENHA DE ACESSO AO SEU DDNS"
    :global ddns-host "ENDEREÇO DO SEU DDNS"
    :global ddns-interface "NOME DA SUA INTERFACE INTERNET NO MIKROTIK"

    :global ddns-ip [ /ip address get [/ip address find interface=$ddns-interface] address ]

    :if ([ :typeof $ddns-lastip ] = nil ) do={ :global ddns-lastip 0.0.0.0/0 }

    :if ([ :typeof $ddns-ip ] = nil ) do={

    :log info ("DDNS: No ip address present on " . $ddns-interface . ", please check.")

    } else={

    :if ($ddns-ip != $ddns-lastip) do={

    :log info "DDNS: Sending UPDATE!"
    :log info [ /tool dns-update name=$ddns-host address=[ick $ddns-ip 0 [:find $ddns-ip "/"] ] key-name=$ddns-user key=$ddns-pass ]
    :global ddns-lastip $ddns-ip

    } else={

    :log info "DDNS: No change"

    }

    }

    :log info "DDNS: End"



    Altere as configurações da sua conta do DDNS no script como o login, senha, endereço e o nome da sua interface.
    Adicione também a regra em system >> schenduler para executar o script de x em x tempo que você desejar.






Tópicos Similares

  1. Vpn entre dois MK
    Por Angelo_7 no fórum Redes
    Respostas: 0
    Último Post: 25-07-2013, 16:49
  2. Respostas: 3
    Último Post: 18-03-2010, 09:30
  3. Rede entre dois micro com IPs diferentes
    Por rafaelmju no fórum Redes
    Respostas: 26
    Último Post: 20-08-2009, 16:41
  4. Link entre dois pontos com Edimax 7203
    Por gstgomespb no fórum Redes
    Respostas: 2
    Último Post: 01-11-2005, 12:20
  5. Problema com rota entre dois servidores
    Por oyama no fórum Servidores de Rede
    Respostas: 20
    Último Post: 05-07-2005, 09:27

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L