Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Instalaçao do Lusca.

    Boa noite a todos.

    Estou muito interessado em testa o Lusca. Mas confesso nao sei nem por onde começa e nao encontrei nada na net que eu conseguisse entender sobre a instalaçao.
    Tenho algumas duvidas ou seja tenhos todas as duvidas do mundo em relaçao ao Lusca.

    1º Ele precisa do Squid para funciona.
    2º Qual o procedimento pra instalar o Lusca
    3º Alguem tem algum tutorial de como fazer isso.

    Eu agradeço de mais por isso.

    Hoje tenho o Mikrotik + Debian Lenny 5.0.3 + Squid 2.7 + ThunderCache4 rodando.
    A minha intensao e deixa apenas Mikrotik + Debian Lenny 5.0.3 e Lusca.

    Se puderem me dar um help eu agradeço. VLW

  2. #2

    Padrão

    Bom dia amigo, tenho o Lusca instalado, mas lhe garanto se vc procurar bem ira encontra aqui mesmo Under explicações, tem um poste do Alexandre Correa, mostrando a compilação do Lusca q é moleza.
    Primeiro- Lusca é um squid recompilado, um grupo pegou o codigo do Squid e reescreveu, tirando alguns bugs e melhorando ele, teorimente é o mesmo squid, só q melhorado.
    Segundo- Não vc nao precisa do squid instalado.
    Terceiro- Se vc já compilou algum pacote em linux vc nao terá dificuldade alguma.

    PS: Começe por aqui
    Google
    Patch: Lusca-Head - Nr. 60 - Flush DNS Entries - Blogs - Under-Linux.org

    Leia com calma q nao tem erro.
    Boa sorte



  3. #3

    Padrão

    Muito obrigado Paulo pela ajuda.
    Ainda nao achei nada concreto aki no forum. digo nada concreto para o meu conhecimento.
    fiz esses procedimento e por gentileza se puder me dizer onde estou errando.

    1° Crie uma pasta dentro do ETC com o nome lusca.
    2º Baixei e descompactei o Arquivo LUSCA_HEAD-r14371.tar.gz
    3º Entrei dentro da pasta descompactada e dei os seguintes comandos
    4º ./configure
    ai deu umas mensagens de erro ai instalei o cgg e o c++ ai voltei a dar o comando ./configure

    5º ai dei um comando make all " ai o sistema me retorna... make: Sem regra para processar o alvo.
    6º tentei dar o comando make install e retornou a mesma mensagem

    Se puder me dar um Help nisso agradeço. lembrando que estou começando com linux agora e nao compinei nenhum Kenel.

    vlw

  4. #4

    Padrão

    Bom dia Paulo eu lendo algumas coisa vi o Alexandre dizendo que tinha que compilar como os squid -v entao fiz isso.

    ./configure --prefix=/usr --sysconfdir=/etc/squid --libexecdir=/usr/libexec/squid --datadir=/usr/share/squid --enable-carp --with-pthreads
    --enable-removal-policies="heap lru" --enable-icmp --enable-delay-pools --enable-useragent-log --enable-referer-log --enable-kill-parent-hack
    --enable-snmp --enable-arp-acl --enable-htcp --enable-ssl --with-openssl=/usr --enable-forw-via-db --enable-default-err-language=Portuguese
    --enable-err-languages="Portuguese English Spanish" --enable-poll --enable-linux-netfilter --enable-leakfinder --enable-underscores
    --enable-auth="basic digest ntlm" --enable-basic-auth-helpers="PAM YP SMB SASL NCSA LDAP winbind" --enable-ntlm-auth-helpers="SMB winbind no_check fakeauth"
    --enable-digest-auth-helpers=password --enable-ntlm-fail-open --enable-external-acl-helpers="ip_user ldap_group unix_group wbinfo_group winbind_group"


    debian:/etc/lusca/LUSCA_HEAD-r14371# ./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-asynd-io --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl enable-epoll --enable-removal-policies=lru,heap --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --enable-underscores --enable-referer-log --enable-useragent-log --enable-auth=basic,digest,ntlm,negotiate --enable-negotiate-auth-helpers=squid_kerb_auth --enable-carp --enable-follow-x-forwarded-for --with-large-files --with-maxfd=65536 i386-debian-linux build_alias=i386-debian-linux host_alias=i386-debian-linux target_alias=i386-debian-linux
    configure: WARNING: you should use --build, --host, --target
    configure: WARNING: you should use --build, --host, --target
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for i386-debian-linux-gcc... no
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking whether gcc and cc understand -c and -o together... yes
    checking build system type... i386-debian-linux-gnu
    checking host system type... i386-debian-linux-gnu
    checking for pkg-config... false
    With pthreads
    Store modules built: aufs
    Removal policies built: lru heap
    Delay pools enabled
    User-Agent logging enabled
    Referer logging enabled
    SNMP monitoring enabled
    ARP ACL lists enabled (ether address)
    HTCP enabled
    USE_CACHE_DIGESTS enabled
    Linux-Netfilter Transparent Proxy enabled
    Using POSIX_V6_ILP32_OFFBIG build environment
    Auth scheme modules built: basic digest ntlm negotiate
    Negotiate auth helpers built: squid_kerb_auth
    unlinkd enabled
    follow X-Forwarded-For enabled
    checking for library containing inet_aton... none required
    checking for egrep... /bin/egrep
    checking how to run the C preprocessor... gcc -E
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for i386-debian-linux-ranlib... no
    checking for ranlib... ranlib
    checking whether ln -s works... yes
    checking for sh... /bin/sh
    checking for false... /bin/false
    checking for true... /bin/true
    checking for rm... /bin/rm
    checking for mv... /bin/mv
    checking for mkdir... /bin/mkdir
    checking for ln... /bin/ln
    checking for perl... /usr/bin/perl
    checking for ar... /usr/bin/ar
    checking for uudecode... no
    uudecode is required to compile Squid
    Please install uudecode and then re-run configure

    debian:/etc/lusca/LUSCA_HEAD-r14371# make all
    make: *** Sem regra para processar o alvo `all'. Pare.

    debian:/etc/lusca/LUSCA_HEAD-r14371#

    se puder me dar um Help.



  5. #5

    Padrão

    vamo lá... seguinte remove esse lusca de dentro do etc ok
    cria um diretorio tipo /pacote
    na raiz ouseja /
    cd /
    mkdir /pacote
    va dentro do diretorio pacote
    cd /pacote
    baixe o lusca
    wget http://lusca-cache.googlecode.com/fi...-r14371.tar.gz
    descompacte ele
    tar -xzvf LUSCA_HEAD-r14371.tar.gz
    instale esses pacotes pelo apt-get
    aptitude install build-essential
    apt-get install sharutils
    entre no diretorio
    cd /pacote/LUSCA_HEAD-r14371
    reveja oq o comando squid -v te informa, coloque entao no ./configure
    Exemplo:
    ./configure '--prefix=/usr' '--exec_prefix=/usr' '--bindir=/usr/sbin' '--sbindir=/usr/sbin' '--libexecdir=/usr/lib/squid' '--sysconfdir=/etc/squid' '--localstatedir=/var/spool/squid' '--datadir=/usr/share/squid' '--enable-async-io' '--with-pthreads' '--enable-storeio=aufs' '--enable-linux-netfilter' '--enable-arp-acl' '--enable-epoll' '--enable-removal-policies=lru,heap' '--enable-snmp' '--enable-delay-pools' '--enable-htcp' '--enable-cache-digests' '--enable-referer-log' '--enable-useragent-log' '--enable-follow-x-forwarded-for' '--with-large-files' '--with-maxfd=65536' 'build_alias=amd64-debian-linux' 'host_alias=amd64-debian-linux' 'target_alias=amd64-debian-linux' 'CFLAGS=-Wall -g -O2' 'LDFLAGS=' 'CPPFLAGS='
    ai sim
    make all
    depois
    make install
    se apresentar algum erro reporte

    Boa sorte

  6. #6

    Padrão

    detalhe na sua compilação...
    "checking for uudecode... no
    uudecode is required to compile Squid

    Please install uudecode and then re-run configure "
    ele diz q o pacote uudecode nao foi encontrado, pede pra instala-lo e recompilar novamente

    dá uma lida nesse post, como te disse no under tem tudo q vc precisa pra instalar o Lusca
    https://under-linux.org/f96/squid-em...77/index3.html



  7. #7

    Padrão

    Vou tenta aki ja digo oque ocorreu.
    mas desde ja muito obrigado.

  8. #8

    Padrão

    Estou tentando também, e sou mais leigo que o DuContra2, uma pegunta besta mas q não sei, é necessário o squid está instalado!???



  9. #9

    Padrão

    Nao precisa não amigo, se vc tiver alguma duvida nos parametros para a compilação do Lusca so vc executar o confihgure q ele te informa as confs
    ./configure --help

    Boa sorte

  10. #10

    Padrão

    Digitei esse comando aki e apareceu um erro....
    debian:/pacote/LUSCA_HEAD-r14371# ./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-async-io --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=lru,heap --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --enable-underscores --enable-referer-log --enable-useragent-log --enable-auth=basic,digst,ntlm,negotiate --enable-negoiate-auth-helpers=squid_kerb_auth --enable-carp --enable-follow-x-forwarded-for --with-large-files --with-maxfd=65536 i386-debian-linux build_alias=i386-debian-linux host_alias=i386-debian-linux target_alias=i386-debian-linux CFLAGS=-Wall -g -02 LDFLAGS= CPPFLAGS=
    configure: WARNING: you should use --build, --host, --target

    configure: error: unrecognized option: -g
    Try `./configure --help' for more information.

    Mas estou procurando aki no google algo sobre esse erro agora e questao de honra. rsrsr.

    ai resolvi tira o -g e o -02 e dei um enter.

    ai depois quando dei um make all deu esses erros

    make[3]: *** Sem regra para processar o alvo `libdigst.a', necessário por `all-am'. Pare.
    make[3]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src/auth'
    make[2]: ** [all-recursive] Erro 1
    make[2]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src'
    make[1]: ** [all] Erro 2
    make[1]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src'
    make: ** [all-recursive] Erro 1

    ai ja nao sei mais o que fazer. mas sou brasileiro nao desisto nunca
    Última edição por DuContra2; 06-02-2010 às 20:45.



  11. #11
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Tira essas CFLAGS CPPFLAGS

  12. #12

    Padrão

    Osmano eu tirei como vc recomendou e passou sem erros.
    Ai quando dou o Make all ainda da os seguintes erros

    make[3]: *** Sem regra para processar o alvo `libdigst.a', necessário por `all-am'. Pare.
    make[3]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src/auth'
    make[2]: ** [all-recursive] Erro 1
    make[2]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src'
    make[1]: ** [all] Erro 2
    make[1]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/src'
    make: ** [all-recursive] Erro 1



  13. #13
    MODERADOR-CHEFE Avatar de osmano807
    Ingresso
    Aug 2008
    Localização
    Araguari - Minas Gerais
    Posts
    1.985
    Posts de Blog
    5

    Padrão

    Vamos ver, execute isso:

    Código :
     ./configure '--prefix=/usr' '--exec_prefix=/usr' '--bindir=/usr/sbin' '--sbindir=/usr/sbin' '--libexecdir=/usr/lib/squid' '--sysconfdir=/etc/squid' '--localstatedir=/var/spool/squid' '--datadir=/usr/share/squid' '--enable-async-io' '--with-pthreads' '--enable-storeio=aufs,null' '--enable-linux-netfilter' '--enable-arp-acl' '--enable-epoll' '--enable-removal-policies=lru,heap' '--enable-snmp' '--enable-delay-pools' '--enable-htcp' '--enable-cache-digests' '--enable-underscores' '--enable-referer-log' '--enable-useragent-log' '--enable-auth=basic,digest,ntlm,negotiate' '--enable-negotiate-auth-helpers=squid_kerb_auth' '--enable-carp' '--enable-follow-x-forwarded-for' '--with-large-files' '--with-maxfd=65536' 'i386-debian-linux' 'build_alias=i386-debian-linux' 'host_alias=i386-debian-linux' 'target_alias=i386-debian-linux' 'CFLAGS=-Wall -O2' 'LDFLAGS=' 'CPPFLAGS='

    Certifique-se de estar usando a última revisão do svn.
    Última edição por osmano807; 06-02-2010 às 21:54.

  14. #14

    Padrão

    agora na hora do make all ta dando isso

    make[3]: ** [squid_kerb_auth.o] Erro 1
    make[3]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/helpers/negotiate_auth/squid_kerb_auth'
    make[2]: ** [all-recursive] Erro 1
    make[2]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/helpers/negotiate_auth'
    make[1]: ** [all-recursive] Erro 1
    make[1]: Saindo do diretório `/pacote/LUSCA_HEAD-r14371/helpers'
    make: ** [all-recursive] Erro 1



  15. #15

    Padrão

    Boa tarde ... a todos

    Galera como faço pra saber se o Lusca esta ok.
    Pois fui tentando aki e aparentemente consegui instala contaria de saber como faço pra saber se ele esta ok.
    Sera que da pra fazer cache do WindowsUpdate com o Squid Lusca.?
    Pois a minha maior necessidade é essa.
    Lembrando que nao quero usar o thunderCache pra fazer isso.
    Última edição por DuContra2; 07-02-2010 às 16:45.

  16. #16

    Padrão

    Galera agradeço a todos mas to fora desse Lusca....
    Voltei ao meu bom e velho amgio Squid 2.7 stable.
    E a todos que tetou me ajuda meu muito obrigado.
    Quando tiver mais informaçao sobre o Lusca talvez eu tente novamente.
    Novamente meu muito Obrigado a todos que tetaram me ajudar.



  17. #17

    Padrão

    aqui instalei ele usando a configuração abaixo:

    ./configure '--prefix=/usr' '--exec_prefix=/usr' '--bindir=/usr/sbin' '--sbindir=/usr/sbin' '--libexecdir=/usr/lib/squid' '--sysconfdir=/etc/squid' '--localstatedir=/var/spool/squid' '--datadir=/usr/share/squid' '--enable-async-io' '--with-pthreads' '--enable-storeio=aufs,null' '--enable-linux-netfilter' '--enable-arp-acl' '--enable-epoll' '--enable-removal-policies=lru,heap' '--enable-snmp' '--enable-delay-pools' '--enable-htcp' '--enable-cache-digests' '--enable-referer-log' '--enable-useragent-log' '--enable-auth=basic,digest,ntlm' '--enable-follow-x-forwarded-for' '--with-large-files' '--with-maxfd=65536' 'i386-debian-linux' 'build_alias=i386-debian-linux' 'host_alias=i386-debian-linux' 'target_alias=i386-debian-linux' 'CFLAGS=-Wall -O2' 'LDFLAGS=' 'CPPFLAGS='

    mais o problema que ele somente funciona se desativo o access.log, meu squid.conf esta como abaixo:

    # MK-AUTH SISTEMA PARA ADMINISTRACAO DE PROVEDORES MIKROTIK

    http_port 3128 transparent
    visible_hostname mk-auth
    icp_port 0

    # retira o cache dos dinamicos
    hierarchy_stoplist cgi-bin
    acl QUERY urlpath_regex cgi-bin
    cache deny QUERY

    # cache de ip acessados
    ipcache_size 1024
    ipcache_low 90
    ipcache_high 95

    fqdncache_size 1024

    mime_table /etc/squid/mime.conf

    pid_filename /var/run/squid.pid

    # arquivos de Log retirados para melhor desempenho
    access_log /dev/null
    cache_access_log /dev/null
    cache_log /dev/null
    cache_store_log /dev/null

    # tamanho maximo do cache em memoria ram
    cache_mem 400 MB
    cache_swap_low 90
    cache_swap_high 95

    # tamanho maximo de arquivo que o cache irar guardar
    maximum_object_size 30 MB
    minimum_object_size 0 KB
    maximum_object_size_in_memory 40 KB

    # diretorio onde serao ficarao armazenado o cache das paginas.
    # O 50000 MBs do HD que sera reservado para o meu cache.
    cache_dir aufs /var/spool/squid 50000 16 256

    acl semcache url_regex "/etc/squid/direto.lst"
    cache deny semcache
    always_direct allow semcache

    # Lista de sites proibidos para a rede toda
    acl proibidos dstdom_regex "/etc/squid/proibidos.lst"

    # toda a internet
    acl all src 0.0.0.0/0.0.0.0

    # redes invalidas, nao sao da internet
    acl rede src 127.0.0.1/32 5.0.0.0/8 169.254.0.0/16 192.168.0.0/16 10.0.0.0/8 172.16.0.0/16 172.17.0.0/16 172.18.0.0/16 172.19.0.0/16 172.20.0.0/16 172.21.0.0/16 172.22.0.0/16 172.23.0.0/16 172.24.0.0/16 172.25.0.0/16 172.26.0.0/16 172.27.0.0/16 172.28.0.0/16 172.29.0.0/16 172.30.0.0/16 172.31.0.0/16

    acl manager proto cache_object
    acl localhost src 127.0.0.1/32
    acl to_localhost dst 127.0.0.0/32
    acl SSL_ports port 443 563
    acl Safe_ports port 80 # http
    acl Safe_ports port 21 # ftp
    acl Safe_ports port 443 563 # https, snews
    acl Safe_ports port 70 # gopher
    acl Safe_ports port 210 # wais
    acl Safe_ports port 1025-65535 # unregistered ports
    acl Safe_ports port 280 # http-mgmt
    acl Safe_ports port 488 # gss-http
    acl Safe_ports port 591 # filemaker
    acl Safe_ports port 777 # multiling http
    acl Safe_ports port 901 # SWAT
    acl CONNECT method CONNECT

    http_access allow manager localhost
    http_access deny manager
    http_access deny !Safe_ports
    http_access deny CONNECT !SSL_ports
    http_access deny proibidos
    http_access allow rede
    http_access deny all

    # usuario que executa o servidor proxy
    cache_effective_user proxy
    cache_effective_group proxy

    error_directory /usr/share/squid/errors/Portuguese

    coredump_dir /var/spool/squid

    client_persistent_connections off
    server_persistent_connections off

    request_timeout 30 seconds
    pconn_timeout 120 seconds

    # Marcacao feita pelo Zero Penalty HIT
    zph_tos_local 0x30
    zph_tos_peer 0
    zph_tos_parent off
    Última edição por pedrovigia; 09-02-2010 às 11:35. Razão: erro de ortografia

  18. #18

    Padrão

    resolvido o problema do access.log, mudei a permissão do mesmo para 666, irei testa agora e ver se ele realmente legal como parece, o bom é que o mesmo já tem o zph incluso e alguns patches legais tb ....



  19. #19

    Padrão

    #compilando

    ./configure --libexecdir=/usr/lib/squid --localstatedir=/var --prefix=/usr --sysconfdir=/etc/squid --enable-async-io --with-pthreads --enable-heap-replacement --enable-coss-aio-ops --enable-ssl --enable-htcp --enable-arp-acl --enable-removal-policies=lru,heap --disable-hostname-checks --enable-default-err-language=Portuguese --enable-err-languages=Portuguese --enable-linux-netfilter --enable-snmp --disable-ident-lookups --with-maxfd=65536 --enable-storeio=aufs,diskd,ufs,null,coss --enable-epoll

    make &&
    make install

    eu consegui dessa forma.
    Agradeço a todos que me ajudaram , agora vou ver se realmente me atende.
    Heim Pedro vai postando ai suas experiencia com o Lusca.
    ai vou postanto a minha tambem

  20. #20

    Padrão

    criei uma ISO do debian com o lusca já instalado, a url para download é: http://bit.ly/PJN92 e o manual de instalação: http://mk-auth.ning.com/page/instalacao-1 adicionei tb um script em perl para que ele faça cache do youtube...
    Última edição por pedrovigia; 20-02-2010 às 22:24. Razão: ortografia