Página 1 de 6 12345 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa noite a todos.

    Estou muito interessado em testa o Lusca. Mas confesso nao sei nem por onde começa e nao encontrei nada na net que eu conseguisse entender sobre a instalaçao.
    Tenho algumas duvidas ou seja tenhos todas as duvidas do mundo em relaçao ao Lusca.

    1º Ele precisa do Squid para funciona.
    2º Qual o procedimento pra instalar o Lusca
    3º Alguem tem algum tutorial de como fazer isso.

    Eu agradeço de mais por isso.

    Hoje tenho o Mikrotik + Debian Lenny 5.0.3 + Squid 2.7 + ThunderCache4 rodando.
    A minha intensao e deixa apenas Mikrotik + Debian Lenny 5.0.3 e Lusca.

    Se puderem me dar um help eu agradeço. VLW

  2. Bom dia amigo, tenho o Lusca instalado, mas lhe garanto se vc procurar bem ira encontra aqui mesmo Under explicações, tem um poste do Alexandre Correa, mostrando a compilação do Lusca q é moleza.
    Primeiro- Lusca é um squid recompilado, um grupo pegou o codigo do Squid e reescreveu, tirando alguns bugs e melhorando ele, teorimente é o mesmo squid, só q melhorado.
    Segundo- Não vc nao precisa do squid instalado.
    Terceiro- Se vc já compilou algum pacote em linux vc nao terá dificuldade alguma.

    PS: Começe por aqui
    Google
    Patch: Lusca-Head - Nr. 60 - Flush DNS Entries - Blogs - Under-Linux.org

    Leia com calma q nao tem erro.
    Boa sorte



  3. Muito obrigado Paulo pela ajuda.
    Ainda nao achei nada concreto aki no forum. digo nada concreto para o meu conhecimento.
    fiz esses procedimento e por gentileza se puder me dizer onde estou errando.

    1° Crie uma pasta dentro do ETC com o nome lusca.
    2º Baixei e descompactei o Arquivo LUSCA_HEAD-r14371.tar.gz
    3º Entrei dentro da pasta descompactada e dei os seguintes comandos
    4º ./configure
    ai deu umas mensagens de erro ai instalei o cgg e o c++ ai voltei a dar o comando ./configure

    5º ai dei um comando make all " ai o sistema me retorna... make: Sem regra para processar o alvo.
    6º tentei dar o comando make install e retornou a mesma mensagem

    Se puder me dar um Help nisso agradeço. lembrando que estou começando com linux agora e nao compinei nenhum Kenel.

    vlw

  4. Bom dia Paulo eu lendo algumas coisa vi o Alexandre dizendo que tinha que compilar como os squid -v entao fiz isso.

    ./configure --prefix=/usr --sysconfdir=/etc/squid --libexecdir=/usr/libexec/squid --datadir=/usr/share/squid --enable-carp --with-pthreads
    --enable-removal-policies="heap lru" --enable-icmp --enable-delay-pools --enable-useragent-log --enable-referer-log --enable-kill-parent-hack
    --enable-snmp --enable-arp-acl --enable-htcp --enable-ssl --with-openssl=/usr --enable-forw-via-db --enable-default-err-language=Portuguese
    --enable-err-languages="Portuguese English Spanish" --enable-poll --enable-linux-netfilter --enable-leakfinder --enable-underscores
    --enable-auth="basic digest ntlm" --enable-basic-auth-helpers="PAM YP SMB SASL NCSA LDAP winbind" --enable-ntlm-auth-helpers="SMB winbind no_check fakeauth"
    --enable-digest-auth-helpers=password --enable-ntlm-fail-open --enable-external-acl-helpers="ip_user ldap_group unix_group wbinfo_group winbind_group"


    debian:/etc/lusca/LUSCA_HEAD-r14371# ./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-asynd-io --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl enable-epoll --enable-removal-policies=lru,heap --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --enable-underscores --enable-referer-log --enable-useragent-log --enable-auth=basic,digest,ntlm,negotiate --enable-negotiate-auth-helpers=squid_kerb_auth --enable-carp --enable-follow-x-forwarded-for --with-large-files --with-maxfd=65536 i386-debian-linux build_alias=i386-debian-linux host_alias=i386-debian-linux target_alias=i386-debian-linux
    configure: WARNING: you should use --build, --host, --target
    configure: WARNING: you should use --build, --host, --target
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... no
    checking for mawk... mawk
    checking whether make sets $(MAKE)... yes
    checking whether to enable maintainer-specific portions of Makefiles... no
    checking for i386-debian-linux-gcc... no
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... yes
    checking whether we are cross compiling... no
    checking for suffix of executables...
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether gcc accepts -g... yes
    checking for gcc option to accept ISO C89... none needed
    checking for style of include used by make... GNU
    checking dependency style of gcc... gcc3
    checking whether gcc and cc understand -c and -o together... yes
    checking build system type... i386-debian-linux-gnu
    checking host system type... i386-debian-linux-gnu
    checking for pkg-config... false
    With pthreads
    Store modules built: aufs
    Removal policies built: lru heap
    Delay pools enabled
    User-Agent logging enabled
    Referer logging enabled
    SNMP monitoring enabled
    ARP ACL lists enabled (ether address)
    HTCP enabled
    USE_CACHE_DIGESTS enabled
    Linux-Netfilter Transparent Proxy enabled
    Using POSIX_V6_ILP32_OFFBIG build environment
    Auth scheme modules built: basic digest ntlm negotiate
    Negotiate auth helpers built: squid_kerb_auth
    unlinkd enabled
    follow X-Forwarded-For enabled
    checking for library containing inet_aton... none required
    checking for egrep... /bin/egrep
    checking how to run the C preprocessor... gcc -E
    checking for a BSD-compatible install... /usr/bin/install -c
    checking for i386-debian-linux-ranlib... no
    checking for ranlib... ranlib
    checking whether ln -s works... yes
    checking for sh... /bin/sh
    checking for false... /bin/false
    checking for true... /bin/true
    checking for rm... /bin/rm
    checking for mv... /bin/mv
    checking for mkdir... /bin/mkdir
    checking for ln... /bin/ln
    checking for perl... /usr/bin/perl
    checking for ar... /usr/bin/ar
    checking for uudecode... no
    uudecode is required to compile Squid
    Please install uudecode and then re-run configure

    debian:/etc/lusca/LUSCA_HEAD-r14371# make all
    make: *** Sem regra para processar o alvo `all'. Pare.

    debian:/etc/lusca/LUSCA_HEAD-r14371#

    se puder me dar um Help.



  5. vamo lá... seguinte remove esse lusca de dentro do etc ok
    cria um diretorio tipo /pacote
    na raiz ouseja /
    cd /
    mkdir /pacote
    va dentro do diretorio pacote
    cd /pacote
    baixe o lusca
    wget http://lusca-cache.googlecode.com/fi...-r14371.tar.gz
    descompacte ele
    tar -xzvf LUSCA_HEAD-r14371.tar.gz
    instale esses pacotes pelo apt-get
    aptitude install build-essential
    apt-get install sharutils
    entre no diretorio
    cd /pacote/LUSCA_HEAD-r14371
    reveja oq o comando squid -v te informa, coloque entao no ./configure
    Exemplo:
    ./configure '--prefix=/usr' '--exec_prefix=/usr' '--bindir=/usr/sbin' '--sbindir=/usr/sbin' '--libexecdir=/usr/lib/squid' '--sysconfdir=/etc/squid' '--localstatedir=/var/spool/squid' '--datadir=/usr/share/squid' '--enable-async-io' '--with-pthreads' '--enable-storeio=aufs' '--enable-linux-netfilter' '--enable-arp-acl' '--enable-epoll' '--enable-removal-policies=lru,heap' '--enable-snmp' '--enable-delay-pools' '--enable-htcp' '--enable-cache-digests' '--enable-referer-log' '--enable-useragent-log' '--enable-follow-x-forwarded-for' '--with-large-files' '--with-maxfd=65536' 'build_alias=amd64-debian-linux' 'host_alias=amd64-debian-linux' 'target_alias=amd64-debian-linux' 'CFLAGS=-Wall -g -O2' 'LDFLAGS=' 'CPPFLAGS='
    ai sim
    make all
    depois
    make install
    se apresentar algum erro reporte

    Boa sorte






Tópicos Similares

  1. Problema instalação do LUSCA
    Por standart no fórum Servidores de Rede
    Respostas: 10
    Último Post: 20-02-2010, 21:23
  2. Instalação do samba
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 25-03-2005, 10:55
  3. Instalação do Wireless
    Por no fórum Redes
    Respostas: 2
    Último Post: 15-10-2002, 09:59
  4. Instalação do Red Hat 7.3
    Por arsnet no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-09-2002, 22:23
  5. instalacão do linux apartir do HD
    Por vanilia_sky no fórum Servidores de Rede
    Respostas: 1
    Último Post: 06-09-2002, 19:37

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L