+ Responder ao Tópico



  1. #1

    Padrão Windows 7 logando no samba.

    Boa tarde Galera,

    Seguinte depois de muito tutoriais revistas e pesquisas no google, consegui colocar o windows 7 no dominio samba o meu problema agora e que quando vou logar no dominio ele fala que o usuario ou a senha esta errada e nao deixa eu logar na maquina.

    quando dou o conhecido //172.16.1.1/publico ele pede user e senha quando digito passa normalmente.

    tenho outras maquinas com windows xp e 2k3 server na rede e funfa direitim.

    eu to usando centos 5.4
    samba 3.4.5
    openldap

    segue os passos feitos na configuração da maquina.
    Windows7 - SambaWiki

    ajuda ae povo pq tenho um cliente pra migrar e vai ser nesse sabado e todos querem windows 7 dai jah viu neh

  2. #2

    Padrão

    » Resolvendo problemas de Incompatibilidade de Windows 7 com Servidor PDC Samba no Centos 5.4… Powered Linux :-)

    ve se te ajuda !

    ah depois de mudar as configurações de autenticação vc deve refazer o password do user...

    Código :
    smbpasswd -a usuario
    smbpasswd -e usuario
    Última edição por Lincoln; 11-02-2010 às 10:05.



  3. #3

    Padrão

    Grande Lincoln,

    depois de muito quebrar cabeça eu descobri o q era eu estava tentando logar com o usuario administrador e reparei que ele faz uma confusão com o usuario local da maquina que e bloqueado entao deu merda.

    a solução foi apenas criar um novo usuario e entrar com um usuario que nao tinha no windows 7 que funciono 100%

  4. #4

    Padrão existe sim incompatibilidade

    Aproveitando o topico, existe sim uma incompatibilidade do samba com o windows 7, mais especificamente o problema é o protocolo de autenticação NTLMv2 do windows 7, segue solução para o problema.
    Fonte: Windows 7 Vs Samba NTLMv2

    Novidades no windows 7, por padrão ele so tem suporte ao NTLMv2, detalhe, o samba ainda nao utiliza o NTLMv2, mais um problema criado pela microsoft!

    A solução não é complicada, tem que editar uma diretiva de grupo, ou localmente ou via GPO, aqui mostrarei a solução para uma maquina, que pode ser utilizada via GPO em um Active Directory, com algumas adaptações.

    Vamo lá,

    1 - \"Iniciar, Executar\" e digite: \"secpol.msc\"

    http://www.builderau.com.au/i/s/vistasamba1.JPG

    2 - Clique em \"Diretivas Locais\" --> \"Opções de Segurança\" ou \"Local Policies\" --> \"Security Options\"

    http://www.builderau.com.au/i/s/vistasamba2.JPG

    3 - Navegue até a opção \"Segurança de Rede: Nível de autenticação LAN Manager\" ou \"Network Security: LAN Manager authentication leve\".

    4 - Por Default Windows seta a policy para \"NTVLM2 responses only\". Mude para \"Enviar LM and NTLM – usar segurança da sessão NTLMV2 se negociada\". ou em inglês \"LM and NTLM – use NTLMV2 session security if negotiated\".

    http://www.builderau.com.au/i/s/vistasamba3.JPG

    Done.
    []'s
    Lcm
    Blog lcmm.info



  5. #5

    Padrão

    lcmm84 e amigos do fórum.

    Eu segui estes passos indicados por vocês e consegui o ingresso no meu domínio samba (3.4.7) com o Windows 7 Professional.

    O usuário root do samba loga normalmente, carregando o Desktop sem problemas, mas notei que os mapeamentos não são montados. O Windows me dá erro 53, dizendo que o caminho da rede não foi encontrado.

    Até aí, não seria tão grave. Mas acontece que os outros usuários não conseguem o login. A mensagem "Bem-Vindo" aparece e no momento de carregar o Desktop, o Windows me retorna o seguinte erro:

    "Falha de logon do Serviço Cliente de Diretiva de Grupo"
    "Acesso negado"


    Após clicar no botão OK, aparece a mensagem "Fazendo Logoff".

    Pesquisei por aí mas não encontrei nada sobre esse erro. Me parece algo relacionado com permissão do usuário samba para logar no Windows, já que nem mesmo o root mapeia as unidades de rede automaticamente.

    Alguém tem uma idéia do que eu posso fazer para sanar esse erro?

    Agradeço a ajuda de todos!!!
    Abraços

  6. #6

    Padrão

    kra tu fez as alterações no registro do win 7 ????

    q esta no site do samba ???
    Windows7 - SambaWiki

    outra coisa pode ser uma boa vc atualizar para a versao 3.5 e habilitar o smb2 que pelo q li jah aceita o win 7 sem ter q fazer nada



  7. #7

    Padrão

    Caro amigo noir.

    Sim, já fiz as alterações no registro que constam no link que você me passou.

    Caso eu queira tentar a atualização do Samba 3.4.7 para o 3.5.2, versão mais recente, há algum repositório para eu instalar por apt-get sem problemas?

    Não estou querendo ter que compilar o samba.

    Obrigado pela ajuda!

  8. #8

    Padrão

    Citação Postado originalmente por felixleonardo Ver Post
    lcmm84 e amigos do fórum.

    Eu segui estes passos indicados por vocês e consegui o ingresso no meu domínio samba (3.4.7) com o Windows 7 Professional.

    O usuário root do samba loga normalmente, carregando o Desktop sem problemas, mas notei que os mapeamentos não são montados. O Windows me dá erro 53, dizendo que o caminho da rede não foi encontrado.

    Até aí, não seria tão grave. Mas acontece que os outros usuários não conseguem o login. A mensagem "Bem-Vindo" aparece e no momento de carregar o Desktop, o Windows me retorna o seguinte erro:

    "Falha de logon do Serviço Cliente de Diretiva de Grupo"
    "Acesso negado"


    Após clicar no botão OK, aparece a mensagem "Fazendo Logoff".

    Pesquisei por aí mas não encontrei nada sobre esse erro. Me parece algo relacionado com permissão do usuário samba para logar no Windows, já que nem mesmo o root mapeia as unidades de rede automaticamente.

    Alguém tem uma idéia do que eu posso fazer para sanar esse erro?

    Agradeço a ajuda de todos!!!
    Abraços
    vc colocou na GPO o procedimento para utilizar NTLM e nao somente o NTLMv2, para todas as maquinas do dominio ?



  9. #9

    Padrão

    lcmm84, eu coloquei a opção "Enviar LM and NTLM – usar segurança da sessão NTLMV2 se negociada"
    Porém, eu acrescentei algumas linhas ao meu smb.conf, que eu li serem necessárias para que isso funcione. As linhas foram:

    level2 oplocks = no
    ntlm auth = yes
    lanman auth = yes
    client ntlmv2 auth = yes

    Eu vi em alguns fóruns também uma variação com o nível 0 ao invés do 2:

    level0 oplocks = no
    ntlm auth = yes
    lanman auth = yes
    client ntlmv0 auth = yes

    Isto é mesmo necessário para o login do Windows 7?

    Para facilitar, seguem abaixo as configurações do meu smb.conf.

    level2 oplocks = no
    ntlm auth = yes
    lanman auth = yes
    client ntlmv2 auth = yes
    name resolve order = wins lmhosts bcast host
    wins support = yes
    workgroup = nome
    server string = Servidor Samba NEAD
    printing = cups
    printcap name = cups
    load printers = yes
    security = users
    hosts allow = 192.168.20. 127.0.0.1
    dns proxy = no
    read only = no
    logon script = %U.bat
    domain logons = Yes
    preferred master = Yes
    domain master = Yes
    create mask = 0777
    directory mask = 0777
    netbios name = NOME
    encrypt passwords = true
    unix charset = iso8859-1
    display charset = cp850
    ; preserve case = yes
    ; short preserve case = yes
    os level = 100
    logon script= %U.bat
    ; local master = yes
    username map = /etc/samba/smbusers
    passdb backend = smbpasswd

    Agradeço muito a ajuda.

  10. #10

    Padrão

    leonardo, nao entendi muito a sua estrutura e estou um pouco sem tempo aqui, vou postar o meu smb.conf çpara ja te dar uma ajuda, amanha entro denovo para analisar melhor o seu:
    minha estruture:
    -w2k3 + AD
    -samba auTH no AD

    segue meu smb.conf:
    PS: nao alterei nada pois este server esta como teste e nao irá para produção, com isso nao tem muitas informações "secretas", sendo assim faltam algumas conf's de segurança no smb para "fechá-lo"!!!

    espero que ajude!

    [global]
    security = ADS
    netbios name = bollywood
    realm = DETRAN.PA.GOV.BR
    server string = %h server (samba %v, ubuntu)
    password server = terra.detran.pa.gov.br
    workgroup = DETRANPA
    idmap uid = 10000-20000
    idmap gid = 10000-20000
    winbind enum users = yes
    winbind enum groups = yes
    winbind use default domain = no
    template homedir = /home/%D/%U
    template shell = /bin/bash
    client use spnego = yes
    domain master = no
    dns proxy = no
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    #security = ads
    #realm = DETRAN.PA.GOV.BR
    encrypt passwords = true
    passdb backend = tdbsam
    obey pam restrictions = yes
    unix password sync = yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    pam password change = yes
    map to guest = bad user
    domain master = no
    #idmap backend = lwopen
    #idmap uid = 50-9999999999
    #idmap gid = 50-9999999999
    #template shell = /bin/bash
    usershare allow guests = yes
    # comment = Printer Drivers
    # path = /var/lib/samba/printers
    [home]
    comment = %U directory
    writeable = yes
    path = %H
    Valid Users = %U
    inherit permissions = yes
    [Bollywood]
    Comment = Servidor do CJ
    read only = no
    path = /home/bollywood
    browseable = no
    Valid Users [email protected]\bollywood
    writeable = yes
    inherit permissions = yes
    [Publico]
    comment = Diretorio Publico
    read only = no
    path = /home/publico
    browseable = yes
    writeable = yes



  11. #11

    Padrão

    lcmm84, eu fiz a atualização do samba para 3.5.1.

    Verifiquei a versão com smdb -V e me informou 3.5.1 normalmente.

    Porém, o windows 7 ainda me retorna o mesmo erro. Só o root loga, mostrando o desktop, porém ao executar o arquivo .bat que monta os mapeamentos, dá erro dizendo não ter encontrado o caminho da rede.

    É possível que o windows esteja buscando esses profiles de usuários em outra pasta e, por isso, não loga ou não monta os mapeamentos?

    Só para esclarecer:

    Meus mapeamentos ficam em uma partição separada do linux:
    /dados/compartilhamentos

    Os profiles dos usuários, ficam dentro de:
    /dados/homes

    Essa informação está contida no arquivo smb.conf.

    Eu, porém, penso que ou o Windows não está achando o caminho do profile, ou está lendo um arquivo de configuração do samba que não informa nada que ajude a localizar esses profiles.

    Resumindo a confusão que eu falei:

    - Qual ou quais arquivos do samba o Windws 7 lê para saber onde estão usuários e mapeamentos?

    Obrigado!!!

  12. #12

    Padrão Re: Windows 7 logando no samba.

    Pessoal é o seguinte, não tenho tido problema em relação ao domínio do linux. Meu problema é como faço para adicionar um usuário do domínio em um grupo local do windows 7. No server 2003 isso funfa blz, mas não sei como fazer no Linux.
    Quando peço para pesquisar o usuário no domínio ele me pede a senha do domínio mas não lista nenhum usuário.
    Agradeço a atenção.


    Marcelo