Página 2 de 3 PrimeiroPrimeiro 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. kra tu fez as alterações no registro do win 7 ????

    q esta no site do samba ???
    Windows7 - SambaWiki

    outra coisa pode ser uma boa vc atualizar para a versao 3.5 e habilitar o smb2 que pelo q li jah aceita o win 7 sem ter q fazer nada

  2. Caro amigo noir.

    Sim, já fiz as alterações no registro que constam no link que você me passou.

    Caso eu queira tentar a atualização do Samba 3.4.7 para o 3.5.2, versão mais recente, há algum repositório para eu instalar por apt-get sem problemas?

    Não estou querendo ter que compilar o samba.

    Obrigado pela ajuda!



  3. Citação Postado originalmente por felixleonardo Ver Post
    lcmm84 e amigos do fórum.

    Eu segui estes passos indicados por vocês e consegui o ingresso no meu domínio samba (3.4.7) com o Windows 7 Professional.

    O usuário root do samba loga normalmente, carregando o Desktop sem problemas, mas notei que os mapeamentos não são montados. O Windows me dá erro 53, dizendo que o caminho da rede não foi encontrado.

    Até aí, não seria tão grave. Mas acontece que os outros usuários não conseguem o login. A mensagem "Bem-Vindo" aparece e no momento de carregar o Desktop, o Windows me retorna o seguinte erro:

    "Falha de logon do Serviço Cliente de Diretiva de Grupo"
    "Acesso negado"


    Após clicar no botão OK, aparece a mensagem "Fazendo Logoff".

    Pesquisei por aí mas não encontrei nada sobre esse erro. Me parece algo relacionado com permissão do usuário samba para logar no Windows, já que nem mesmo o root mapeia as unidades de rede automaticamente.

    Alguém tem uma idéia do que eu posso fazer para sanar esse erro?

    Agradeço a ajuda de todos!!!
    Abraços
    vc colocou na GPO o procedimento para utilizar NTLM e nao somente o NTLMv2, para todas as maquinas do dominio ?

  4. lcmm84, eu coloquei a opção "Enviar LM and NTLM – usar segurança da sessão NTLMV2 se negociada"
    Porém, eu acrescentei algumas linhas ao meu smb.conf, que eu li serem necessárias para que isso funcione. As linhas foram:

    level2 oplocks = no
    ntlm auth = yes
    lanman auth = yes
    client ntlmv2 auth = yes

    Eu vi em alguns fóruns também uma variação com o nível 0 ao invés do 2:

    level0 oplocks = no
    ntlm auth = yes
    lanman auth = yes
    client ntlmv0 auth = yes

    Isto é mesmo necessário para o login do Windows 7?

    Para facilitar, seguem abaixo as configurações do meu smb.conf.

    level2 oplocks = no
    ntlm auth = yes
    lanman auth = yes
    client ntlmv2 auth = yes
    name resolve order = wins lmhosts bcast host
    wins support = yes
    workgroup = nome
    server string = Servidor Samba NEAD
    printing = cups
    printcap name = cups
    load printers = yes
    security = users
    hosts allow = 192.168.20. 127.0.0.1
    dns proxy = no
    read only = no
    logon script = %U.bat
    domain logons = Yes
    preferred master = Yes
    domain master = Yes
    create mask = 0777
    directory mask = 0777
    netbios name = NOME
    encrypt passwords = true
    unix charset = iso8859-1
    display charset = cp850
    ; preserve case = yes
    ; short preserve case = yes
    os level = 100
    logon script= %U.bat
    ; local master = yes
    username map = /etc/samba/smbusers
    passdb backend = smbpasswd

    Agradeço muito a ajuda.



  5. leonardo, nao entendi muito a sua estrutura e estou um pouco sem tempo aqui, vou postar o meu smb.conf çpara ja te dar uma ajuda, amanha entro denovo para analisar melhor o seu:
    minha estruture:
    -w2k3 + AD
    -samba auTH no AD

    segue meu smb.conf:
    PS: nao alterei nada pois este server esta como teste e nao irá para produção, com isso nao tem muitas informações "secretas", sendo assim faltam algumas conf's de segurança no smb para "fechá-lo"!!!

    espero que ajude!

    [global]
    security = ADS
    netbios name = bollywood
    realm = DETRAN.PA.GOV.BR
    server string = %h server (samba %v, ubuntu)
    password server = terra.detran.pa.gov.br
    workgroup = DETRANPA
    idmap uid = 10000-20000
    idmap gid = 10000-20000
    winbind enum users = yes
    winbind enum groups = yes
    winbind use default domain = no
    template homedir = /home/%D/%U
    template shell = /bin/bash
    client use spnego = yes
    domain master = no
    dns proxy = no
    log file = /var/log/samba/log.%m
    max log size = 1000
    syslog = 0
    panic action = /usr/share/samba/panic-action %d
    #security = ads
    #realm = DETRAN.PA.GOV.BR
    encrypt passwords = true
    passdb backend = tdbsam
    obey pam restrictions = yes
    unix password sync = yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
    pam password change = yes
    map to guest = bad user
    domain master = no
    #idmap backend = lwopen
    #idmap uid = 50-9999999999
    #idmap gid = 50-9999999999
    #template shell = /bin/bash
    usershare allow guests = yes
    # comment = Printer Drivers
    # path = /var/lib/samba/printers
    [home]
    comment = %U directory
    writeable = yes
    path = %H
    Valid Users = %U
    inherit permissions = yes
    [Bollywood]
    Comment = Servidor do CJ
    read only = no
    path = /home/bollywood
    browseable = no
    Valid Users =@DETRANPA\bollywood
    writeable = yes
    inherit permissions = yes
    [Publico]
    comment = Diretorio Publico
    read only = no
    path = /home/publico
    browseable = yes
    writeable = yes






Tópicos Similares

  1. Windows Xp logando no samba do Red hat enterprise
    Por FabioBC no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-10-2005, 10:08
  2. como cadastrar uma maquina com windows 2003 no samba?
    Por quecosuix no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-09-2004, 02:09
  3. Win2003 DC logando no samba!!!???
    Por erikcap no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-06-2004, 09:53
  4. ERRO: Windows Logando no Samba
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 11-06-2004, 08:57
  5. Linux logando no Samba
    Por ghenri no fórum Servidores de Rede
    Respostas: 0
    Último Post: 09-10-2003, 10:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L