+ Responder ao Tópico



  1. Boa Tarde,

    Não tenho certeza se este seria o fórum certo para este tópico, então vamos lá. Tenho 2 links de internet em meu firewall, e ainda não implantei a alta disponibilade. A troca de links vinha sendo feita por mim na marra, para não gerar acúmulo de funções coloquei os comando que executo em dois scripts simples, que mando abaixo:

    firewall:/usr/sbin# cat via_link1.sh
    #!/bin/bash

    IPTABLES=/sbin/iptables

    $IPTABLES -t nat -D POSTROUTING -o ppp0 -j MASQUERADE
    $IPTABLES -t nat -I POSTROUTING -o eth2 -j MASQUERADE

    echo "INTERNET VIA LINK1 ATIVADA!"


    firewall:/usr/sbin# cat via_link2.sh
    #!/bin/bash

    IPTABLES=/sbin/iptables

    $IPTABLES -t nat -I POSTROUTING -o ppp0 -j MASQUERADE
    $IPTABLES -t nat -D POSTROUTING -o eth2 -j MASQUERADE

    echo "INTERNET VIA LINK2 ATIVADA!"


    Bom, o que ocorre é que quando rodo o script com o comando bash -xv script.sh, todos os comando são executados, porém os comandos não são aplicados. Quando coloco eles na força bruta, troca de link normalmente. Aí a pergunta, meus pequenos scripts etão com erro?

  2. Estou vendendo meu provedor em toledo paraná - aproximadamente 100 mil habitantes
    100 % mikrotik + squid + mkauth

    5 torres na cidade e 10 no interior
    internet + voip






Tópicos Similares

  1. Respostas: 4
    Último Post: 09-07-2009, 11:14
  2. Apache roda mas php não
    Por zzzhhh no fórum Servidores de Rede
    Respostas: 6
    Último Post: 30-03-2008, 11:57
  3. ProFTP roda 100% mas, não autentica ninguém
    Por seniDEac no fórum Servidores de Rede
    Respostas: 0
    Último Post: 21-11-2007, 21:44
  4. MRTG - Tá tudo certo mas não roda - Socorro
    Por Roldan117 no fórum Servidores de Rede
    Respostas: 2
    Último Post: 26-09-2005, 15:16
  5. script perl conecta no Oracle 8 mas nao no 9
    Por clever no fórum Servidores de Rede
    Respostas: 0
    Último Post: 07-01-2003, 13:56

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L