+ Responder ao Tópico



  1. Pessoal estou com um probleminha aqui e gostaria que se possivel me mostrassem meu erro nessa configuração. Eu ja tentei com outro tópico mas não consegui resolver.

    Ps: Eu já consigo acesso a internet normalmente nesse SRV01.

    Meu ambiente é o seguinte.

    Redes
    eth0 - 192.168.0.0/24 (deixei o mesmo padrão do router)
    eth1 - 172.28.32.0/24 (essa é só para rede interna)

    |modem velox| ---------- |eth0 -- SRV01 --eth1| ------------ |Clientes|

    Primeiro ação -> Configurei as ethernets
    eth0:
    DEVICE=eth0
    BOOTPROTO=static
    HWADDR=08:00:27:3D:A2:C7
    ONBOOT=yes
    IPADDR=192.168.0.116
    NETMASK=255.255.255.0
    GATEWAY=192.168.0.1
    DNS1=192.168.0.1

    eth1
    DEVICE=eth1
    BOOTPROTO=static
    HWADDR=08:00:27:1E:E8:E0
    ONBOOT=yes
    IPADDR=172.28.32.10
    NETMASK=255.255.255.0
    GATEWAY=192.168.0.116
    DNS1=192.168.0.1
    -----------------------------------------------------------------------------------------------
    Segunda Ação: Habilitei o roteamento no arquivo -> /etc/sysctl.conf
    # Controls IP packet forwarding
    net.ipv4.ip_forward = 1
    ------------------------------------------------------------------------------------------------
    Terceira Ação: Desativei o firewall no modo gráfico mesmo
    ------------------------------------------------------------------------------------------------
    Quarta Ação: Inseri os seguintes comando e regras

    modprobe iptables_nat
    iptables -A FORWARD -s 192.168.0.0/24 -d 172.28.32.0/24 -j ACCEPT
    iptables -A FORWARD -s 172.28.32.0/24 -d 192.168.0.0/24 -j ACCEPT
    iptables -A FORWARD -s 172.28.32.0/24 -m state --state ESTABLISHED,RELATED -j ACCEPT
    iptables -A FORWARD -s 172.28.32.0/24 -j ACCEPT
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    -----------------------------------------------------------------------------------------------
    Quinta Ação: Salvei o iptables em um arquivo.
    iptables-save > etc/firewall
    -----------------------------------------------------------------------------------------------
    Sexta Ação: Editei o arquivo de inicialização /etc/rc.d/rc.local
    modprobe iptables_nat
    iptables-restore < /etc/firewall
    -----------------------------------------------------------------------------------------------
    Sétima Ação: reiniciei o servidor
    -----------------------------------------------------------------------------------------------
    Oitava Ação: Verifiquei todas as configurações e configurei os clientes

    iptables -L (estava tudo la)
    iptables -t nat -L (estava tudo certinho)

    Client1
    eth0:
    DEVICE=eth0
    BOOTPROTO=static
    HWADDR=08:00:27:3D:A2:C7
    ONBOOT=yes
    IPADDR=172.28.32.20
    NETMASK=255.255.255.0
    GATEWAY=172.28.32.10
    DNS1=192.168.0.1 (testei usando os DNSs do opendns e nada tambem)
    -------------------------------------------------------------------------------------------------

    Resultado:

    Em algum momento que eu testando as alguns dns no cliente. eu consegui com o ping chegar até o ip do router da velox. Mas depois refiz toda a configuração novamente e mais nada. Não consigo mais nnem chegar no ip do router, quanto mais acessar a internet.

    Pessoal vejam essa minha configuração e me mostrem o erro por favor !!!! Agradeceria muuuuuito.

  2. Reveja sua sexta ação:
    Redes e Servidores Linux, 2ed.: Compartilhando
    e passa um feedback



  3. aparentemente está correta.
    Sexta Ação: Editei o arquivo de inicialização /etc/rc.d/rc.local (é o script de inicialização)
    modprobe iptables_nat (Habilita o módulo de roteamento usando NAT no iptabls)
    iptables-restore < /etc/firewall (recupera todas as regras do iptables salvas no arquivo chamado "firewall")

    Atualmente eu consigo pingar, do cliente para o modem de velox, e quando eu pingo por exmplo no google.com.br ele retonra o endereço ip do site mas da 100% de perca de pacote. se eu tentar abrir pelo browser não carrega o site. aparentemente o problema agora é só na resolução de nomes... porem... ja teste tudo o possivel tentei usar os proprios dns da velox... usei os do opendns.. tentei com o ip interno do proprio roteador...

  4. Cara, se possível, posta suas regras de firewall...






Tópicos Similares

  1. Eu vs IPTABLES vs internet
    Por GlauterVidal no fórum Servidores de Rede
    Respostas: 3
    Último Post: 29-03-2010, 19:19
  2. IPTABLES vs PPTP Win - uma conexão por vez.
    Por replicante no fórum Servidores de Rede
    Respostas: 1
    Último Post: 12-09-2006, 09:37
  3. ipfw vs. iptables
    Por lcr no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 21-06-2005, 09:36
  4. iptables vs. conexao simultaneas
    Por Good_speed no fórum Servidores de Rede
    Respostas: 6
    Último Post: 27-05-2005, 03:39
  5. Iptables Vs Netmeeting
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 10-03-2003, 10:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L