Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Salve galera, teho um servidor free radius controlado por my sql, lusca e thunder 3, no mk tenho hotspot e pppoe, acontece que o cache ta fungando 100%, problema é que quando o cliente pede um arquivo que esta no cache ele vem na velocidade definida pela queue dinamica criado pelo radius, andei lendo uns artigos em ingles e dizia que a simple queue pega o trafego primeiro que a queue tree, alguem sabe como contornar isso?

  2. #2
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Não use queue tree e queue simple no mesmo Mikrotik. Configure seu QoS em outro nó da rede, de preferência em algum roteador de borda.



  3. #3

  4. #4
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Normalmente configuro o cache em paralelo com o roteador de borda, desta forma o que vale é o queue tree (onde faço o qos).

    Agora que percebi, vc está apenas querendo liberar o que está em cache em banda maior que a contratada... se for isso, cria uma fila simples ao invés de arvore. Vai conseguir o que precisa.

    Citação Postado originalmente por fernandofiorentinn Ver Post
    de que forma vc repassa o cache sergio?



  5. #5

    Padrão

    tem que mudar o cadastro (forma que é criada a fila simples) no sql entao e remover o queue tree?

  6. #6
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    refaça sua questão, de forma completa, não economize em detalhes, pois não entendi nada.

    Citação Postado originalmente por fernandofiorentinn Ver Post
    tem que mudar o cadastro (forma que é criada a fila simples) no sql entao e remover o queue tree?



  7. #7

    Padrão

    Grande sérgio, obrigado pelo interesse... Vamos descascar o abacaxi então...
    Uso Ros 4.4 numa rb450g, nela tenho hotspot (perfeito), pcc ( ainda em testes mas funcionando), radius (paralelo), regras para o cache do thunder e redirecionamento para o proxy paralelo na porta 5128..
    regras que usei /ip firewall nat
    Código HTML:
    add action=dst-nat chain=dstnat comment="NAT - Proxy1" disabled=no dst-port=80 protocol=tcp src-address=192.168.0.0/24 \
    to-addresses=172.31.255.2 to-ports=5128
    add action=dst-nat chain=dstnat comment="NAT - Proxy" disabled=no dst-port=80 protocol=tcp src-address=10.0.0.0/24 \
    to-addresses=172.31.255.2 to-ports=5128
    Regras que usei mangle:
    Código HTML:
    add action=mark-connection chain=prerouting comment="Marca o com e sem TOS" disabled=no dscp=12 new-connection-mark=\
        n-cache passthrough=yes protocol=tcp src-port=5128
    add action=mark-connection chain=prerouting comment="" disabled=no dscp=!12 new-connection-mark=s-cache passthrough=yes \
        protocol=tcp src-port=5128
    add action=mark-connection chain=prerouting comment="THUNDER CACHE FULL - mark connect" content=\
        "X-Cache: HIT from Thunder" disabled=no new-connection-mark=thunder-connection passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="THUNDER CACHE FULL - mark Packet" connection-mark=thunder-connection \
        disabled=no new-packet-mark=thunder-packs passthrough=yes protocol=tcp
    add action=mark-packet chain=prerouting comment="Libera cache full" connection-mark=n-cache disabled=no new-packet-mark=\
        Cache-Packet passthrough=yes
    regras qu usei para queue tree:
    Código HTML:
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=CACHE-FULL packet-mark=\
    Cache-Packet parent=global-out priority=2 queue=cache
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=ThunderCache3 packet-mark=\
    thunder-packs parent=global-out priority=2 queue=cache
    Código HTML:
    add kind=pcq name=cache pcq-classifier=dst-address pcq-limit=50 pcq-rate=4000000 pcq-total-limit=2000
    autenticação por radius, que cria um simple queue dinamica igual a essa
    Clique na imagem para uma versão maior

Nome:	         fila simples din&#9.jpg
Visualizações:	239
Tamanho: 	68,9 KB
ID:      	9509
    o que acontece é que quando o cliente pede um arquivo que esta no cache ele vem na velocidade do simple queue e nada a mais, o que to querendo é passar os arquivos do cache a tipo 2 megas pro cliente e do link a velocidade contratada por causa dos heavy users e p2p da vida...

  8. #8
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Legal, agora ficou claro como água...

    Bem, o que eu mencionei antes seria o seguinte:

    Todas as filas dinâmicas são criadas após as filas simples definidas estaticamente. Então poderia criar uma (ou umas) fila simples usando as marcas dos pacotes (aba advanced da fila simples) e move-las para as primeiras posições da fila simples. Desta forma primeiro será processado as filas simples estáticas e depois sim, a fila dinâmica que realiza a limitação de banda. Desta forma terá a mesma funcionalidade da árvore de filas sem ter que usar o esquema que mencionei anteriormente (roteador borda). Não usará mais a árvore de filas e no seu código feito via radius fará apenas a criação da fila simples dinâmica.



  9. #9

    Thumbs down

    seria assim?
    Clique na imagem para uma versão maior

Nome:	         fila simples..jpg
Visualizações:	283
Tamanho: 	98,5 KB
ID:      	9512
    no caso eu teriq que criar duas pro hotspot e duas pro ppoe, uma pro thunder-packs e outra pro Cache-Packet

  10. #10
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão

    Sim, tem que criar para cada rede que desejar e uma para cada marca.

    Citação Postado originalmente por fernandofiorentinn Ver Post
    seria assim?
    Clique na imagem para uma versão maior

Nome:	         fila simples..jpg
Visualizações:	283
Tamanho: 	98,5 KB
ID:      	9512
    no caso eu teriq que criar duas pro hotspot e duas pro ppoe, uma pro thunder-packs e outra pro Cache-Packet



  11. #11

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Amigo, professor Sergio olha eu aqui aperriando novamente !
    As regras criadas estaticamente, ficam sempre abaixo das que vao sendo criadas dinamicamente, conforme vao sendo criadas as estaticas vao descendo. Como fasso para deixar a estatica sempre no topo ?

    Colocando por exemplo a regra que uso para controlar o cache com prioridade 7, daria no mesmo de coloca-la sempre no topo ?

  12. #12

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Citação Postado originalmente por sergio Ver Post
    Não use queue tree e queue simple no mesmo Mikrotik. Configure seu QoS em outro nó da rede, de preferência em algum roteador de borda.
    Sergio, fiquei com uma duvida que pode ser de todos aqui.

    Queria fazer com que o link principal ex:
    10MB -> Total Full - > tive-se controle de seu uso por serviços.

    queue tree + mangle.

    5MB (http, https).
    3MB (e-mail, msn, icmp).
    2MB ( resto).

    E os clientes em queue simple herda-se a proporção do link principal.

    cliente a 200k queue simple -> 100k (http, https) -> 70k (e-mail, msn, icmp) -> 30k (resto).

    Isso tem como ser feito ?



    No caso hoje uso este esquema parecido desta forma:

    Roteador mikrotik que esta no link de fibra optica 10MB

    queue tree + mangle devidindo os serviços com prioridades e velocidades diferentes.

    Servidor Hotspot mikrotik pegando o link total do Roteador mikrotik e distribuindo as velocidade dos clientes pelo hotspot + radius + mysql.

    A duvida é se esta velocidade final do cliente tem porcentagem no uso como o link total tem no Roteador mikrotik.


    Obrigado por qualque esclarecimento.



  13. #13
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Usando qual aplicação para crias as dinâmicas? HotSpot?

    Citação Postado originalmente por superxandaoce Ver Post
    Amigo, professor Sergio olha eu aqui aperriando novamente !
    As regras criadas estaticamente, ficam sempre abaixo das que vao sendo criadas dinamicamente, conforme vao sendo criadas as estaticas vao descendo. Como fasso para deixar a estatica sempre no topo ?

    Colocando por exemplo a regra que uso para controlar o cache com prioridade 7, daria no mesmo de coloca-la sempre no topo ?

  14. #14
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Citação Postado originalmente por ShadowRed Ver Post
    Sergio, fiquei com uma duvida que pode ser de todos aqui.

    Queria fazer com que o link principal ex:
    10MB -> Total Full - > tive-se controle de seu uso por serviços.

    queue tree + mangle.

    5MB (http, https).
    3MB (e-mail, msn, icmp).
    2MB ( resto).

    E os clientes em queue simple herda-se a proporção do link principal.

    cliente a 200k queue simple -> 100k (http, https) -> 70k (e-mail, msn, icmp) -> 30k (resto).

    Isso tem como ser feito ?
    Não. As simples sempre são executadas antes da árvores.

    Citação Postado originalmente por ShadowRed Ver Post



    No caso hoje uso este esquema parecido desta forma:

    Roteador mikrotik que esta no link de fibra optica 10MB

    queue tree + mangle devidindo os serviços com prioridades e velocidades diferentes.

    Servidor Hotspot mikrotik pegando o link total do Roteador mikrotik e distribuindo as velocidade dos clientes pelo hotspot + radius + mysql.

    A duvida é se esta velocidade final do cliente tem porcentagem no uso como o link total tem no Roteador mikrotik.


    Obrigado por qualque esclarecimento.
    Se o link estiver congestionado ele fará a distribuição conforme você definiu em Queue Tree, mas a banda individual de cada alvo (cliente) será o Max-Limit, obviamente respeitando o que estiver disponível no momento. Ao invés de tentar fazer o que pretende, que daria bastante trabalho, use como disciplinas de filas o SFQ ou PCQ para equalizar o fluxo da própria fila simples.



  15. #15

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Obrigado mais uma vez pela atenção.
    Vou trabalhar em cima destas filas simples criada pelo hotspot o uso do SFQ ou PCQ. A ideia era tentar fazer a queue simple do cliente criada pelo hotspot ter um controle melhor do trafego. Mas até agora eu so tinha a ideia e não uma maneira de executar.

    Que bom seria conseguir priorizar o trafego http de todo o resto no cliente final. Nunca mais ele iria ficar reclamando de lentidão em paginas causadas pelo uso e outros serviços no link dele.

  16. #16

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Sim, usando o hotspot para criar !



  17. #17
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Com PCQ ou SFQ vai equalizar o fluxo e o cliente não vai incomodar dizendo que o ping está lento quando está usando os seus P2P. Da mesma forma terá menos problemas com a navegação.

    Citação Postado originalmente por ShadowRed Ver Post
    Obrigado mais uma vez pela atenção.
    Vou trabalhar em cima destas filas simples criada pelo hotspot o uso do SFQ ou PCQ. A ideia era tentar fazer a queue simple do cliente criada pelo hotspot ter um controle melhor do trafego. Mas até agora eu so tinha a ideia e não uma maneira de executar.

    Que bom seria conseguir priorizar o trafego http de todo o resto no cliente final. Nunca mais ele iria ficar reclamando de lentidão em paginas causadas pelo uso e outros serviços no link dele.

  18. #18
    xargs -n 1 kill -9 Avatar de sergio
    Ingresso
    Jan 2004
    Localização
    Capital do Triângulo
    Posts
    5.202
    Posts de Blog
    9

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    HotSpot é um saco para trabalhar com as filas simples, pois ele coloca as mesmas antes das estáticas. O que poderá tentar fazer é trabalhar com as estáticas em hierarquia (Parent) e verificar se atende sua necessidade, ou usar Script para mover as estáticas sempre para as primeiras posições.

    Citação Postado originalmente por superxandaoce Ver Post
    Sim, usando o hotspot para criar !



  19. #19

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Citação Postado originalmente por fernandofiorentinn Ver Post
    seria assim?
    Clique na imagem para uma versão maior

Nome:	         fila simples..jpg
Visualizações:	283
Tamanho: 	98,5 KB
ID:      	9512
    no caso eu teriq que criar duas pro hotspot e duas pro ppoe, uma pro thunder-packs e outra pro Cache-Packet
    Não entendi como assim duas para o Hotspot? No meu aqui funciona porém o grafico individual para de funcionar e a velocidade fica liberada

  20. #20

    Padrão Re: Simple queue dinamico do radius sobrepoe o queue tree, há como contornar isso?

    Sou novato no MK e estou com o mesmo problema vi a explicação dele mais não entendi nada tentei aqui mais não funcionou