+ Responder ao Tópico



  1. #1

    Padrão Problema com o CUPS

    CUPS - BIXOU...

    BOA TARDE GALERA!

    ESTOU PRECISANDO MUITO DA AJUDA DE VOCES MEUS AMIGOS, TENHO UM SERVIDOR LINUX COM MEDIA DE 50 IMPRESSORAS INSTALADAS NO CUPS E QUE JA ESTA RODANDO A 2 ANOS SEM PROBLEMAS, MAS ONTEM COMEÇOU A SURPRESINHA, O PIOR QUE NAO TO CONSEGUINDO DECIFRAR O ERRO.

    * O CUPS FUNCIONA NORMALMENTE DURANTE UMA PARTE DO DIA AI DERREPENTE ELE PARA DE IMPRIMIR, O SERVICO ESTA NORMAL NAO APRESENTA NENHUM ERRO NO START OU RESTART.

    * AO REINICIAR O SERVIDOR (INIT 6) O SERVIÇO VOLTA A NORMALIDADE, DEVE ZERAR ALGUM TIPO DE CACHE OU CONEXAO ALGO ASSIM.

    * O PROBLEMA QUE NAO PRA REINICIAR UM SERVIDOR COM 200 USUARIOS CONECTADOS NO BANCO DE DADOS NO MEIO DO DIA, AGORA IMAGINA TE QUE FICAR FAZENDO ISSO TODO DIA, NAO DA.

    * PELO ERROR_LOG DO CUPS PELO O QUE INTERPLETEI, ELE TA PARANDO QUANDO CHEGA A 500 JOBS, MAS NO PRINTERS.CONF NAO TEM LIMITE DE JOBS E DETALHE TEM 2 ANOS Q ELE TA FUNCIONANDO SEM PROBLEMAS, POR QUE ISSO AGORA?

    * TO EM DUVIDA SE PODE TA RELACIONADO COM O XINETD, SERA?

    * OLHEM O LOG A BAIXO:
    E [03/Mar/2010:11:46:34 -0300] [Job 182443] Unable to connect to CIFS host, will retry in 60 seconds...
    D [03/Mar/2010:11:46:34 -0300] AcceptClient: 8 from localhost:631.
    D [03/Mar/2010:11:46:34 -0300] ReadClient: 8 POST / HTTP/1.1
    D [03/Mar/2010:11:46:34 -0300] ProcessIPPRequest: 8 status_code=1
    D [03/Mar/2010:11:46:34 -0300] ReadClient: 8 POST / HTTP/1.1
    D [03/Mar/2010:11:46:34 -0300] ProcessIPPRequest: 8 status_code=1
    D [03/Mar/2010:11:46:34 -0300] ReadClient: 8 POST / HTTP/1.1
    D [03/Mar/2010:11:46:34 -0300] ProcessIPPRequest: 8 status_code=0
    D [03/Mar/2010:11:46:34 -0300] AcceptClient: 10 from localhost:631.
    D [03/Mar/2010:11:46:34 -0300] CloseClient: 8
    D [03/Mar/2010:11:46:34 -0300] ReadClient: 10 POST /printers/nfe_mitcar HTTP/1.1
    D [03/Mar/2010:11:46:34 -0300] print_job: auto-typing file...
    D [03/Mar/2010:11:46:34 -0300] print_job: request file type is text/plain.
    I [03/Mar/2010:11:46:34 -0300] print_job: too many jobs - 500 jobs, max jobs is 500.
    D [03/Mar/2010:11:46:34 -0300] Sending error: client-error-not-possible
    D [03/Mar/2010:11:46:34 -0300] ProcessIPPRequest: 10 status_code=404
    D [03/Mar/2010:11:46:34 -0300] CloseClient: 10

  2. #2

    Thumbs up Problemas com o CUPS

    Amigo,

    Tive um problema desse num cliente e percebi que era falta de memoria e disco ao mesmo tempo...

    Verifica se o "testparm /etc/samba/smb.conf" esta dando as configurações corretas e se
    vc esta usando com AD o registro do servidor de impressão foi feito no servidor windows corretamente...

    Ps: Ah! Outra coisa... em um cliente tive que colocar o CUPS rodando sozinho devido as 30 impressoras que ele tem la... fica num computador so rodando o cups, sem outros serviços
    agregados a ele...ta + 1 ano, sem bronka, da mais bronka nas impressoras que no SRVIMP-CUPS dele, heheheheheh



  3. #3

    Padrão

    Altere a configuração dos jobs.

    O proprio log está reportando isso
    too many jobs - 500 jobs, max jobs is 500.

    man cupsd.conf