Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. bom pessoal ja andei lendo vairios tuturuas no forum e na web mais ainda não conseguia fazer na minha rede. to querendo acessar meu mk de uma rede externa. gostaria q vc mim passe o passo a passo.

    modem: DLINK 500b - Software Version: BCM-1.1.TM.20060205
    mk: rb750g versao: 3.31.

  2. So modem está como roteador, o IP público está nele, consequentemente vc tem que ver se ele tem suporte àlgum serviço de DNS dinâmico e criar a porta de redirecionamento para o seu mikrotik.

    Do contrário vc pode usar o modem como bridge e fazer o seu mikrotik conectar (pppoe ou pppoa) e receber o IP público e assim, usar o serviço de DDNS direto pelo mikrotik.



  3. amigo da uma olhadinha neste link. aqui n ficou bem explicado.

    https://under-linux.org/f143/configu...-no-mk-136072/

  4. Podes usar o codigo abaixo e colar em System - scripts com todos os "policy" ativados, e depois vá a System - Scheduler e adicione uma marcação para execução do script por exemplo de 5 em 5 minutos ou o tempo que vc achar necessário!!, é necessário antes que vc cadastre-se no CHANGEIP.ORG (que é a mesma coisa do dyndns) e utilize os dados, tipo Username , senha e host seuhost.changeip.org para ajustar o script!, este script só funcionou para o CHANGEIP.ORG, mas se alguem conseguir fazer funcionar no dyndns por favor me repasse!!!!

    segue código..

    #script testado para o CHANGEIP.ORG, não funcionou com dyndns....
    # Define User Variables
    :log info ("Inicio DDNS...")
    :global ddnsuser "seu login"
    :global ddnspass "sua senha"
    :global ddnshost "seuhost.changeip.org"

    # Define Global Variables
    #:log info ("Variaveis...")
    :global ddnsip
    :global ddnslastip
    :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip "0" }
    #:log info ("Obtendo versão...")
    :global ddnsinterface
    :global ddnssystem ("mt-4.2")
    #aparentemente a linha abaixo deixou de funcionar nas versões do MK acima de 4.0, por isso fixei a versão na linha acima...
    #[/system package get system version] )
    # Define Local Variables
    :local int

    #defina a interface por onde entra o link do seu modem roteado, neste caso aqui a ether1...
    :global ddnsinterface "ether1"

    # Grab the current IP address on that interface.
    #:log info ("Endereço IP atual...")
    :global ddnsip [ /ip address get [/ip address find interface=ether1 ] address ]
    :log info ("DDNS: IP Atual na interface " . $ddnsinterface . " é: " . $ddnsip)
    #coloque na linha abaixo o nome do seu HOST no changeip..
    :log info ("Endereço atual do IP dinamico: " . ut [:resolve seuhost.changeip.org])

    #:log info ("Compara endereços...")
    :global ddnslastip "0"
    # Did we get an IP address to compare?
    :if ([ :typeof $ddnsip ] = nil ) do={
    :log info ("DDNS: Não há endereço IP na interface: " . $ddnsinterface . ", verifique.")
    } else={
    :if ($ddnsip != $ddnslastip) do={
    :log info "DDNS: ATUALIZANDO..."
    :log info [ ut [/tool dns-update name=$ddnshost address=[ick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global ddnslastip $ddnsip
    } else={
    :log info "DDNS: Atualização não necessária."
    }
    }
    #:log info ("Fim script...")
    # End of script



  5. não sei o que houve com esses emoticons, não era pra estarem aí, onde há ut e ick os comandos são ": put" e ": pick" mas juntos os ":" e o comando, favor corrigir... a propósito como envio arquivos para o forum?

    Cordiais saudações
    Última edição por marcelodm; 05-03-2010 às 09:14. Razão: caracteres não desejados no post






Tópicos Similares

  1. Respostas: 1
    Último Post: 06-03-2010, 10:46
  2. Senao2511 EXt2Plus com 2 antenas no mk
    Por jhonnyp no fórum Redes
    Respostas: 6
    Último Post: 27-02-2007, 21:02
  3. Ajuda com portas estranhas no MK
    Por dumer99 no fórum Redes
    Respostas: 3
    Último Post: 10-01-2007, 19:49
  4. modem discado no MK
    Por Uairilessi no fórum Redes
    Respostas: 1
    Último Post: 05-01-2007, 19:57
  5. Como configurar ADSL com modem USB no linux?
    Por Liliana no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-02-2005, 17:46

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L