Página 2 de 4 PrimeiroPrimeiro 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Citação Postado originalmente por herlon2008 Ver Post
    Não pude ver o restante de sua configuração cisco, em virtude da outra interface não apaecer a configuração.

    Já aconteceu comigo este problema, experimente adicionar a rota no Linux para o gateway dos clientes.

    No meu caso passou a funcionar, ao que me parece ele não conseguia encontrar retorno.

    Bom dia Herlon,

    mudei algumas coisas aqui,

    ip wccp web-cache mudei para in, estava em out;

    como eu estava falando com Alexandre, o Tunel Gre (wccp2) estava só de enfeite, ou não sei se isso é assim mesmo.

    segue a configuração do Cisco:

    Código :
    Current configuration : 1484 bytes
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname MegaRouter
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$1wLv$dgIgekFXlOyGhnuFlxLBf1
    !
    no aaa new-model
    !
    resource policy
    !
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    ip subnet-zero
    ip wccp web-cache
    ip cef
    !
    !
    no ip dhcp use vrf connected
    !
    !
    !
    !
    !
    !
    interface FastEthernet0/0
     ip address 189.xxx.xxx.97 255.255.255.240
     ip wccp web-cache redirect in
     duplex auto
     speed auto
    !
    interface FastEthernet0/1
     ip address 172.16.1.5 255.255.255.252
     duplex auto
     speed auto
     !
    interface Serial0/1/0
     ip address 200.xxx.xxx.126 255.255.255.252
     encapsulation ppp
    !
    interface Serial0/1/1
     no ip address
     shutdown
     clockrate 2000000
    !
    interface Serial0/3/0
     no ip address
     shutdown
     clockrate 2000000
    !
    interface Serial0/3/1
     no ip address
     shutdown
     clockrate 2000000
    !
    router rip
     network 200.209.129.0
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 200.xxx.xxx.125
    ip route 189.xxx.xxx.0 255.255.255.192 198.xxx.xxx.98
    ip route 189.xxx.xxx.0 255.255.255.192 189.xxx.xxx.99
    ip route 189.xxx.xxx.64 255.255.255.192 198.xxx.xxx.98
    ip route 189.xxx.xxx.64 255.255.255.192 189.xxx.xxx.99
    ip route 200.xxx.xxx.0 255.255.255.0 200.xxx.xxx.125
    ip route 200.xxx.xxx.0 255.255.255.0 200.xxx.xxx.125
    !
    no ip http server
    !
    !
    !
    !
    control-plane
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     password 7 060B0A264D4F0A1C16041D1306573233767165
     login
    !
    end
     
    MegaRouter#

    Tentarei apontar então a rota default no Squid para 189.xxx.xxx.98 que é o Gateway das faixas válidas nos cliente, ou aponto para o Gateway dos clientes mesmo que 200.xxx.xxx.1?

    Grato.

  2. Citação Postado originalmente por alexandrecorrea Ver Post
    nao precisa de criar o tunel0 nao.. o wccp comunica com o proxy via gre sem esse tunel
    Hum, beleza, é porque fazendo o Tunnel0 no Cisco piorou, então a interface que levanta o tunel gre, tem o mesmo ip do tunel mesmo?



  3. na epoca que estava mexendo na codificação do tproxy no lusca, o adrian (mantedor e desenvolvedor) me disse que o ideal que o proy fique em uma interface SEPARADA, para evitar confusão do router em qual pacote atuar...

    mesmo que seja uma VLAN. e realmente, fiz isso aqui e fica muito melhor de trabalhar.. menos confuso e sem problemas de pacotes entrarem e sairem por locais errados..


    como tenho algumas FE´s sobrando.. coloquei os proxyes em interfaces separadas.. ficando assim:

    FastEthernet 0/0/0 - clientes
    FastEthernet 1/0/0 - lan proxyes
    FastEthernet 2/0/0 - wan1
    FastEthernet 2/0/1 - wan2

    na lan dos proxyes.. eu do um exclude no wccp.. na interface dos clientes eu coloco redirect IN

    no linux.. configuro a interface normal.. note que, o trafego na WCCP2, sera somente de ENTRADA (do router para o servidor) .. a saida sera pela ethernet normal

  4. Acho que existe uma forma mais facil de resolver seu problema, atribua um IP valido /30, que ao meu ver ira funcionar.

    Pois não encontrei um NAT ou algo que faça com que o proxy tenha saida para o mundo externo.



  5. Citação Postado originalmente por alexandrecorrea Ver Post
    na epoca que estava mexendo na codificação do tproxy no lusca, o adrian (mantedor e desenvolvedor) me disse que o ideal que o proy fique em uma interface SEPARADA, para evitar confusão do router em qual pacote atuar...

    mesmo que seja uma VLAN. e realmente, fiz isso aqui e fica muito melhor de trabalhar.. menos confuso e sem problemas de pacotes entrarem e sairem por locais errados..


    como tenho algumas FE´s sobrando.. coloquei os proxyes em interfaces separadas.. ficando assim:

    FastEthernet 0/0/0 - clientes
    FastEthernet 1/0/0 - lan proxyes
    FastEthernet 2/0/0 - wan1
    FastEthernet 2/0/1 - wan2

    na lan dos proxyes.. eu do um exclude no wccp.. na interface dos clientes eu coloco redirect IN

    no linux.. configuro a interface normal.. note que, o trafego na WCCP2, sera somente de ENTRADA (do router para o servidor) .. a saida sera pela ethernet normal
    Meu Cisco aqui é o 2801 ele tem 2 fastEthernet, a situação é um pouco parecida com a sua, pois estou com o proxy em uma interface separada. Já entendi sobre o tunuel, vou fazer mais testes agora a tarde, pelo que vi tenho colocar no tunnel o gre remote, o ip que vai interceptar as requisições, vou testar isso aqui. O trafego no wccp2 aconteceu somente na entrada, mais achei que isso estava errado, rsrsr. Posto novos resultados.






Tópicos Similares

  1. Configuracao Cisco 2801
    Por Good_speed no fórum Cisco
    Respostas: 15
    Último Post: 14-12-2012, 07:46
  2. Como Configurara um CISCO 2801
    Por pkmc no fórum Redes
    Respostas: 1
    Último Post: 17-04-2010, 22:38
  3. Snmp + crc + cisco 2801
    Por tianguapontocom no fórum Redes
    Respostas: 9
    Último Post: 29-10-2008, 09:28
  4. Balanceamento por destino cisco 2801 - 2 Link's
    Por tianguapontocom no fórum Redes
    Respostas: 2
    Último Post: 13-08-2008, 11:31
  5. squid + Cisco WCCP
    Por Patrick no fórum Servidores de Rede
    Respostas: 3
    Último Post: 29-12-2006, 09:39

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L