Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Bom pessoal aqui no meu provedor gosto de ver o sinal de cada cliente meu como esta!
    e para não ficar cadastrando manualmente fiz um script que pega o usuario e o mac dos que estão logados no hotspot, ai verifica se ele jah foi cadastrado no access-list, caso não ele cadastra automático. Então resolvi dar uma colher de chá as amigos do under e to compartilhando.

    segue o script:

    :global auth "yes";
    :global forw "no";
    :global interface "all";

    :foreach h in=[/ip hotspot active find] do={:global user [/ip hotspot active get $h user]; :global mac [/ip hotspot active get $h mac-address]; :global v "0"; :foreach hh in=[/interface wireless access-list find mac-address=$mac] do={:if ([/interface wireless access-list get $hh mac-address] = $mac ) do={:global v "1"}}; :if (v = "0") do={/interface wireless access-list add mac-address=$mac authentication=$auth forwarding=$forw comment=$user interface=$interface;}}


    Após isso criar um scheduler dizendo para rodar cada tanto tempo, no meu caso rodo a cada 5 minutos e rode

    /system scheduler add name="script_access-list" start-date=jan/01/1970 start-time=00:00:00 interval=5m on-event=script_access-list \
    policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive



  2. Blz, legal compartilhar.



  3. Gustavo,

    Muito obrigado por compartilhar esse script com a comunidade, antes tinha que fazer manual agora com esse script ficou uma blz!

    Obrigado novamento.

    Abraços.

    Christian Duarte

  4. Gustavo,

    Será que você pode me dar uma ajuda no seu script, ele cadastra no comment do access-list o nome do user tem a possibilidade de cadastra no comment do access-list o comment do user do hotspot?

    Desde já agradeço.

    Abraços.

    Christian Duarte



  5. vou ver o que consigo e posto depois

    Citação Postado originalmente por cduarte Ver Post
    Gustavo,

    Será que você pode me dar uma ajuda no seu script, ele cadastra no comment do access-list o nome do user tem a possibilidade de cadastra no comment do access-list o comment do user do hotspot?

    Desde já agradeço.

    Abraços.

    Christian Duarte






Tópicos Similares

  1. Respostas: 9
    Último Post: 07-02-2012, 07:54
  2. Access-list e WPA via RADIUS (no Rocket M5)
    Por felipezatta no fórum Redes
    Respostas: 4
    Último Post: 20-05-2011, 08:15
  3. Dúvida com access-list no PIX
    Por Magnun no fórum Redes
    Respostas: 0
    Último Post: 19-02-2009, 08:43
  4. Respostas: 4
    Último Post: 10-05-2008, 20:46
  5. Login automatico no telnet
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 20-12-2003, 22:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L