Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Log Hotstpot " already logged in"

    Amigos estou enfrentando um problema com um cliente. Ele tem dificuldade de navegar.
    No log aparece inicialmente que ele está logado.
    Aparece assim:

    IP xxxxxxxxxx logged in
    login failed . IP xxxxxxxxx is already logged in. Trying to login by http-pap
    login failed . IP xxxxxxxxx is already logged in. Trying to login by http-pap
    login failed . IP xxxxxxxxx is already logged in. Trying to login by http-pap
    .....
    ...
    Lá pelas tantas ele navega normalmente.
    Após ele logar na pagina de login, o navegador fica novamente tentando se logar.

  2. #2

    Padrão

    Amigo, vendo seu tópico ae tbm me identifiquei com esse problema, tem alguns clientes que dão esse problema, realmente é estranho, ja aumentei o keepalivetimeout para 1h e 30 m mesmo assim de vez em quando da problema, uso login por cokie, talvez seja isso, mas tem cliente que nao gosta de toda hora ficar colocando login e senha, entao deixo o cookie ativo, engraçado que geralmente quem usa plaquinha que dá esse tipo de problema, aki to usando nano 2 e agora nanoloco 5.8 e esses dificilmente dão esse problema. No meu caso tenho que entrar no hotspot active e desligar o cliente, ae ele faz login, senão nao consegue, isso é o calcanhar de aquiles do hotspot !!!



  3. #3

    Padrão

    Citação Postado originalmente por Claudio Ver Post
    Amigo, vendo seu tópico ae tbm me identifiquei com esse problema, tem alguns clientes que dão esse problema, realmente é estranho, ja aumentei o keepalivetimeout para 1h e 30 m mesmo assim de vez em quando da problema, uso login por cokie, talvez seja isso, mas tem cliente que nao gosta de toda hora ficar colocando login e senha, entao deixo o cookie ativo, engraçado que geralmente quem usa plaquinha que dá esse tipo de problema, aki to usando nano 2 e agora nanoloco 5.8 e esses dificilmente dão esse problema. No meu caso tenho que entrar no hotspot active e desligar o cliente, ae ele faz login, senão nao consegue, isso é o calcanhar de aquiles do hotspot !!!
    Eu não tenho ninguém com placa pci. Alguns poucos com notebook mas o restante é todo rádios e a maioria também é ubiquiti. Eu vou procurar fazer uma filtragem para ver se há alguma ligação nisso.

  4. #4

    Padrão

    E ae amigo, alguma solução por que aki ta foda, nao sei se o cookie tem algo a ver com isso, essa semana tive problemas de novo com already logged em nano 2, nano 5, pci, rádio... ta foda.. to usando hotspot com dhcp server, to pensando em tirar o dhcp e deixar ip fixo...



  5. #5

    Padrão

    Amigo do forum, acho que achei o fio da meada, to fazendo uns testes aki, to usando o dhcp server com ip poll na faixa 100-200 ae blz, estou conectado no hotspot navegando de boa, ae entrei e troquei meu ip, coloquei manualmente em 192.168.xxx.20 ae na hora de abrir o navegador puumm tela de login, fui lá e a mensagem fatidica, user already logged in, limpei o cookie e nada, fui nas conexoes de rede e coloquei automatico de novo, como o meu dhcp server ta setado em 2 horas fiquei com o mesmo ip que estava usando antes, abri o navegador e navegou de boa. acho q nossos problemas estao no dhcp server.. to buscando na net sobre o assunto e nada.. mas acho que o fio da meada já encontrei, espero uma resposta sua ae..

  6. #6

    Padrão

    Citação Postado originalmente por Claudio Ver Post
    Amigo do forum, acho que achei o fio da meada, to fazendo uns testes aki, to usando o dhcp server com ip poll na faixa 100-200 ae blz, estou conectado no hotspot navegando de boa, ae entrei e troquei meu ip, coloquei manualmente em 192.168.xxx.20 ae na hora de abrir o navegador puumm tela de login, fui lá e a mensagem fatidica, user already logged in, limpei o cookie e nada, fui nas conexoes de rede e coloquei automatico de novo, como o meu dhcp server ta setado em 2 horas fiquei com o mesmo ip que estava usando antes, abri o navegador e navegou de boa. acho q nossos problemas estao no dhcp server.. to buscando na net sobre o assunto e nada.. mas acho que o fio da meada já encontrei, espero uma resposta sua ae..
    Eu creio que tem algo a ver com cookie, pois quando elimino o cookie e derrubo o usuário dai vai normall
    No profile uso como http pap habilitado e cookie habilitado.



  7. #7

    Padrão Re: Log Hotstpot " already logged in"

    Vou tranquilozar uns e prorrogar a dor-de-cabeça de outros...

    1 - Não é problema por ser DHCP;
    2 - Não é problema por usar Cookies.

    Digo isso com certeza, porque meus clientes usam IP Fixo e Não utilizo Cookies porque envio mensagens para os clientes no login.

    Resumindo: mesmo assim, estou passando pelo mesmo problema.

    Mas para detalhar melhor, qual versão de mikrotik que vocês estão usando?
    Alguém utiliza página de acesso modificada (personalizada)?

    Vou desabilitar a autenticação HTTP CHAP, deixar só habilitado HTTP PAP e HTTPS que são as que uso atualmente, depois vou fazer o inverso e qualquer novidade posto o resultado aqui!

    Vamos colocar o tópico pra frente para ver se aparece a solução!
    Última edição por emsfalcao; 08-07-2010 às 13:18.

  8. #8

    Padrão Re: Log Hotstpot " already logged in"

    Atualizei o Mikrotik para a versão 4.10, mas o problema persiste.


    Última edição por emsfalcao; 09-07-2010 às 19:54.



  9. #9

    Padrão Re: Log Hotstpot " already logged in"

    Continuamos aqui com o hotspot com esta bendita mensagem de que usuario já está logado.
    Ele insiste , insiste até que aceita o login.
    Seria falha de navegador? Pois não acontece em todos e mesmo naqueles que acontece não é sempre.
    Qaundo percebo no log o que está acontecendo, eu derrubo o cookie. Daí vai.
    Última edição por 1929; 17-07-2010 às 15:42.

  10. #10

    Padrão Re: Log Hotstpot " already logged in"

    Citação Postado originalmente por 1929 Ver Post
    Continuamos aqui com o hotspot com esta bendita mensagem de que usuario já está logado.
    Ele insiste , insiste até que aceita o login.
    Seria falha de navegador? Pois não acontece em todos e mesmo naqueles que acontece não é sempre.
    Qaundo percebo no log o que está acontecendo, eu derrubo o cookie. Daí vai.
    Também estou com esse problema!

    Alguns computadores eu resolvi formatando, outro só limpando o Cache dos navegadores.



  11. #11

    Padrão Re: Log Hotstpot " already logged in"

    fiz alguns testes com hotspot...
    e estou migrando aos poucos os clientes... em breve terei toda a rede em hotspot...
    lenquanto isso, acompanhando o topico.

  12. #12

    Padrão Re: Log Hotstpot " already logged in"

    Citação Postado originalmente por 1929 Ver Post
    Eu creio que tem algo a ver com cookie, pois quando elimino o cookie e derrubo o usuário dai vai normall
    No profile uso como http pap habilitado e cookie habilitado.
    somente uma teoria...
    creio que tenha algo a ver com algum banco de dados que o hotspot guarde.
    vejamos:
    quando o usuario faz login, o hotspot deve guardar alguma informacao sobre ele... como IP, mac, etc...
    qdo o usuario tenta fazer login novamente... o hotspot fala que ele ja esta conectado.
    ao derrubar o cookie... vc renova a conexao... faz com que o hotspot guarde novas informacoes...
    em resumo, me parece que o hotspot nao esta renovando a conexao do usuario.
    bug?

    so para levantar algumas informacoes:
    ao configurar o hotspot, vc criam o usuario... nesse usuario vc´s adiciona qual seria o IP do usuario? ou seja, prendem o ip ao mac?



  13. #13

    Padrão Re: Log Hotstpot " already logged in"

    Citação Postado originalmente por mascaraapj Ver Post
    somente uma teoria...
    creio que tenha algo a ver com algum banco de dados que o hotspot guarde.
    vejamos:
    quando o usuario faz login, o hotspot deve guardar alguma informacao sobre ele... como IP, mac, etc...
    qdo o usuario tenta fazer login novamente... o hotspot fala que ele ja esta conectado.
    ao derrubar o cookie... vc renova a conexao... faz com que o hotspot guarde novas informacoes...
    em resumo, me parece que o hotspot nao esta renovando a conexao do usuario.
    bug?

    so para levantar algumas informacoes:
    ao configurar o hotspot, vc criam o usuario... nesse usuario vc´s adiciona qual seria o IP do usuario? ou seja, prendem o ip ao mac?
    Creio que possa ser por aí mesmo Andrio. Aqui usamos dhcp. Depois da primeira conexão, eu copio o mac que chega, que é o do rádio cliente, ja que não clonamos mac.
    Assim, no cadastro fica o mac. O ip não fica cadastrado, mas em dhcp server em leases fixamos o ip atribuido para o cliente.
    Estou pensando em fixar também o IP atribuido pelo dhcp e amarrar com o mac. Depois acessar os rádios clientes remotamente e desativar o dhcp da wan e fixar o mesmo ip.

    Tem uma coisa que eu não entendo bem no modo de fazer login no hotspot. Em server profiles tem lá opção de chap, pap, mac, cookie entre as mais usadas.
    Eu uso http chap. Mas não sei em que situações cada uma das opções seria a indicada. Os tutoriais não entram em detalhes sobre isso.

    Por ex. se estiver marcado só login por mac, vai abrir a tela de login e senha? ou faz o login de forma automática?
    E se selecionar http pap seria para que situação?
    Vamos ver se o pessoal entendido em hotspot pode esclarecer isso para nós.
    Última edição por 1929; 18-07-2010 às 02:24.

  14. #14

    Padrão Re: Log Hotstpot " already logged in"

    Galera, é importante lembrar o que eu citei anteriormente, eu não uso a opção Cookie marcada e utilizo IP Fixo nos clientes, então vale ressaltar que questão do Cookie e DHCP diante disso são praticamente descartadas.



  15. #15

    Padrão Re: Log Hotstpot " already logged in"

    Nos profiles do hotspot está como none seu address pool?Aqui utilizo DHCP server em static para alguns casos e com lease time em 1 minuto, só noto esta mensagem quando o cliente abre o navegador e este está configurado com mais de uma página inicial, portanto abre duas páginas de login, ele loga na primeira e na segunda página, e no segundo login aparece esta mensagem no log do MK, que nada mais diz que ele já está logado e navega normalmente, portanto chego a uma conclusão que é problema de configuração, talvez , o DHCP esteja habilitado , dando ip para quem tem setado o IP na máquina ou radio cliente e isso gere uma confusão, pois imagine o DHCP dando um IP para determinado cliente , mas este cliente tenha o IP setado manualmente. Aqui uso CHAP, HTTPS e cookie , IP fixo nos radios clientes,PCIs e USBs com cadastros em users do Hotspot, ARP e IP binddings de IPXMAC

  16. #16

    Padrão Re: Log Hotstpot " already logged in"

    Citação Postado originalmente por marciorct Ver Post
    Nos profiles do hotspot está como none seu address pool?Aqui utilizo DHCP server em static para alguns casos e com lease time em 1 minuto, só noto esta mensagem quando o cliente abre o navegador e este está configurado com mais de uma página inicial, portanto abre duas páginas de login, ele loga na primeira e na segunda página, e no segundo login aparece esta mensagem no log do MK, que nada mais diz que ele já está logado e navega normalmente, portanto chego a uma conclusão que é problema de configuração, talvez , o DHCP esteja habilitado , dando ip para quem tem setado o IP na máquina ou radio cliente e isso gere uma confusão, pois imagine o DHCP dando um IP para determinado cliente , mas este cliente tenha o IP setado manualmente. Aqui uso CHAP, HTTPS e cookie , IP fixo nos radios clientes,PCIs e USBs com cadastros em users do Hotspot, ARP e IP binddings de IPXMAC
    O Falcão lembrou bem. A situação dele é totalmente diversa da minha que uso dhcp e ele ainda assim tem o mesmo problema. Ele só usa mac x ip.
    O que nós precisariamos entender bem ´são os vários modos que o hotspot aceita. E em que situação usa um ou outro. Pois o que pode estar acontecendo é algum conflito na hora da autenticação.
    O coockie é interessante, pois se der um tempo de vida de 24 hs vai evitar que o cliente tenha que abrir novamenta a pág de login. Ele estando com o cookie validado só vai aparecer a pagina dizendo que ele está logado ao solicitar o primeiro site.
    A dúvida é para mim: quando usar http chap , http pap ou então mac. Seleciona só um destes ou seleciona os três tipos? O cookie acho que seleciona sempre pelo que expus acima.
    Agora se o cadastro for ip fixo no rádio, não vai precisar do dhcp pois vai chegar o ip que está no rádio e o mac do rádio. Acho que neste caso seria de marcar só mac e cookie.
    Mas sou sincero, estou no "achismo".
    Eu tenho dhcp ativado mas depois fixo em leases. Assim ele vai voltar sempre com o mesmo ip. A droga é que quando aparece esta mensagem no log, as vezes o sujeito loga e vai tranquilo, outras fica tentando e acaba desistindo.



  17. #17

    Padrão Re: Log Hotstpot " already logged in"

    Citação Postado originalmente por 1929 Ver Post
    O Falcão lembrou bem. A situação dele é totalmente diversa da minha que uso dhcp e ele ainda assim tem o mesmo problema. Ele só usa mac x ip.
    O que nós precisariamos entender bem ´são os vários modos que o hotspot aceita. E em que situação usa um ou outro. Pois o que pode estar acontecendo é algum conflito na hora da autenticação.
    O coockie é interessante, pois se der um tempo de vida de 24 hs vai evitar que o cliente tenha que abrir novamenta a pág de login. Ele estando com o cookie validado só vai aparecer a pagina dizendo que ele está logado ao solicitar o primeiro site.
    A dúvida é para mim: quando usar http chap , http pap ou então mac. Seleciona só um destes ou seleciona os três tipos? O cookie acho que seleciona sempre pelo que expus acima.
    Agora se o cadastro for ip fixo no rádio, não vai precisar do dhcp pois vai chegar o ip que está no rádio e o mac do rádio. Acho que neste caso seria de marcar só mac e cookie.
    Mas sou sincero, estou no "achismo".
    Eu tenho dhcp ativado mas depois fixo em leases. Assim ele vai voltar sempre com o mesmo ip. A droga é que quando aparece esta mensagem no log, as vezes o sujeito loga e vai tranquilo, outras fica tentando e acaba desistindo.
    ao criar o hotspot, definimos nele uma faixa de ip... criamos um pool.
    mesmo que nao tenhamos o dhcp ativado, o proprio hotspot envia ip para o cliente (o hotspot usa o pool criado).
    porem, nesse caso, vc tem o dhcp ativado... e no hotspot desativou o address pool???

  18. #18

    Padrão Re: Log Hotstpot " already logged in"

    Citação Postado originalmente por mascaraapj Ver Post
    ao criar o hotspot, definimos nele uma faixa de ip... criamos um pool.
    mesmo que nao tenhamos o dhcp ativado, o proprio hotspot envia ip para o cliente (o hotspot usa o pool criado).
    porem, nesse caso, vc tem o dhcp ativado... e no hotspot desativou o address pool???
    Foi isso que eu quis dizer, pode estar havendo uma duplicidade no fornecimento de IPs.



  19. #19

    Padrão Re: Log Hotstpot " already logged in"

    Citação Postado originalmente por marciorct Ver Post
    Nos profiles do hotspot está como none seu address pool?
    Exatamente, está setado "none". Acontece o mesmo problema, o cliente está logado e o navegador do nada solicita login novamente, o cliente recebe a mensagem que está logado, mas quando vai navegar continua a ser solicitado o login por várias vezes e por insistência para e eles conseguem navegar e nos log do mikrotik, aparece essa mensagem para nosso desespero. Em tempo, relembro que a opção de cookie é desativada no meu hotspot.

  20. #20

    Padrão Re: Log Hotstpot " already logged in"

    emsfalcao,
    vc disse que nao tem o pool setado no hotspot.
    tbm disse que nao usa cookie... mas continua com o mesmo problema.

    Tenho algumas perguntas:
    no hotspo, vc prende o usuario ao IPxMAC? ou apenas cria o usuario?
    vc usa a tabela arp? prendendo o usuario ao IPxMAC?
    vc disse que usa ip fixo no cliente... o seu dhcp server esta desativado?