Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. Devido á grande dificuldade que tive , para encontrar scripts a funcionar, imagino que muitos dever estar na mesma situação, então posto aqui:



    ChangeIp (Alterar 4 primeiras linhas)

    Código PHP:
    :global ddnsuser "METES NOME"
    :global ddnspass "METES PASSWORD"
    :global ddnshost "EXEMPLO.ddns.info"
    :global ddnsinterface "pppoe-out2"
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    # END OF USER DEFINED CONFIGURATION
    # ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    :global ddnssystem ("mt-" . [/system package get [/system package find name=systemversion] )
    :global 
    ddnsip [ /ip address get [/ip address find interface=$ddnsinterfaceaddress ]
    :global 
    ddnslastip
    :if ([:len [/interface find name=$ddnsinterface]] = ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
    :if ([ :
    typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/}
    :if ([ :
    typeof $ddnsip ] = "nothing" ) do={
    :
    log info ("DDNS: No ip address present on " $ddnsinterface ", please check.")
    } else={
      :if (
    $ddnsip != $ddnslastip) do={
        :
    log info "DDNS: Enviado UPDATE!"
        
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
        :global 
    ddnslastip $ddnsip
      
    } else={ 
        :
    log info "DDNS: Nao Necessita Ser Alterado."
      
    }
    }
    # END OF SCRIPT 



    Dyndns ( Alterar 4 primeiras linhas)

    Código PHP:
    :local ddnsuser "METES NOME"
    :local ddnspass "METES PASSWORD"
    :local theinterface "pppoe-out2"
    :local ddnshost "EXEMPLO.mine.nu"
    :local ipddns [:resolve $ddnshost];
    :
    local ipfresh [ /ip address get [/ip address find interface=$theinterface address ]
    :if ([ :
    typeof $ipfresh ] = nil ) do={
       :
    log info ("DynDNS: No ip address on $theinterface .")
    } else={
       :for 
    i from=( [:len $ipfresh] - 1to=do={ 
          :if ( [:
    pick $ipfresh $i] = "/") do={ 
        :
    set ipfresh [:pick $ipfresh 0 $i];
          } 
    }
     
    :if (
    $ipddns != $ipfresh) do={
        :
    log info ("DynDNS: IP-DynDNS = $ipddns")
        :
    log info ("DynDNS: IP-Fresh = $ipfresh")
       :
    log info "DynDNS: Update IP needed, Sending UPDATE...!"
        
    :local str "/nic/update?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
        
    /tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
        :
    delay 1
        
    :local str [/file find name="DynDNS.$ddnshost"];
        /
    file remove $str
        
    :global ipddns $ipfresh
      
    :log info "DynDNS: IP alterado para $ipfresh!"
        
    } else={
         :
    log info "DynDNS: Nao Necessita Ser Alterado";
        }


  2. Blz, boa contribuição.



  3. Mais uma contribuição...

    Uso na versão 3.xx, bem simples e funcional!

    Código PHP:

    /tool dns-update name=exemplo.changeip.org address=127.0.0.255 key-name=seu_user key=sua_senha 
    Espero ajudar!

    Abraços
    Última edição por cduarte; 23-03-2010 às 08:52.

  4. Fiquei meu confuso.

    O código está em PHP. Ele vai ser reconhecio diretamente pelo mikrotik?
    É só adaptar para minha necessidade e colar no new terminal?



  5. 1929,

    Coloquei em php para ficar mais fácil de copiar.

    Segue o script e o scheduler.

    /system script
    add name=DDNS policy=ftp,reboot,read,write,policy,test,winbox source="/tool dns-update name=exemplo.changeip.org address=127.0.0.255 key-name=seu_user key=sua_senha"

    /system scheduler
    add comment="ATUALIZAR IP DDNS" disabled=no interval=5m name=DDNS on-event="/system script run DDNS" start-date=jan/01/1970 start-time=00:00:00

    Abraços.






Tópicos Similares

  1. Respostas: 9
    Último Post: 08-12-2008, 15:47
  2. Configuração do dns para rede interna
    Por Wal no fórum Servidores de Rede
    Respostas: 9
    Último Post: 12-01-2005, 21:43
  3. Servidor DNS para rede Windows 2000
    Por lopespio no fórum Servidores de Rede
    Respostas: 0
    Último Post: 28-02-2004, 09:58
  4. Direcionando servidor DNS para Provedor
    Por Elvis no fórum Servidores de Rede
    Respostas: 4
    Último Post: 04-07-2003, 11:02
  5. Direcionando servidor DNS para Provedor
    Por Elvis no fórum Servidores de Rede
    Respostas: 5
    Último Post: 14-05-2003, 12:29

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L