Página 1 de 6 12345 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Demorei um pouco para fazer isso, e como algumas pessoas aqui do under me ajudaram estou postando para a comunidade inteira, acho bem util para quem usa Bateria + Carregador

    --------
    Só Funcionam em RBs que possuem medidor de voltagem, geralmente são:
    RB433AH, RB800, RB450G, RB333, mas se quiser ver se sua rb tem suporte ou não a voltagem, vá em System Healt, se aparecer a voltagem ai, é sinal que a sua rb tem suporte SIM.

    Todos os Mikrotiks deve ter o SNMP Ativado.
    para ativar abra o terminal e cole isso:
    /snmp set enabled=yes

    ------
    No The Dude (programa instalado no windows que pode ser baixado pelo site da mikrotik), já com todas as devices adicionadas, e talz é necessário fazer algumas implementações.


    No menu as esquerdas tem o ícone "Functions", dar dois cliques em cima para abri-lo, após Abrir clique no botão + e preencha os campos dessa forma:
    nome: mipsbe_voltage
    Codigo: oid("iso.org.dod.internet.private.enterprises.mikrotik.mikrotikExperimentalModule.mtXRouterOs.mtxrHealth.8.0") /10


    Adicione mais uma Função com as Seguintes caracteristicas:
    nome: mipsbe_voltage_size
    Codigo: round(mipsbe_voltage())

    E por final, é necessario alterar a função cpu_men_disk, caso contrario não irá aparecer a voltagem na devices, dentro dos Mapas.
    Localize então a função cpu_mem_disk, de dois cliques em cima, apague o que tem no código e coloque isso:

    concatenate(
    if(cpu_usage_available(), concatenate("cpu: ", cpu_usage(), "% "), ""),
    if(mem_usage() > 0, concatenate("mem: ", round(mem_usage()), "% "), ""),
    if(virtual_mem_usage() > 0, concatenate("virt: ", round(virtual_mem_usage()), "% "), ""),
    if(mipsbe_voltage() > 0, concatenate("volt: ", (mipsbe_voltage()), "V "), ""),
    if(hdd_usage() > 0, concatenate("disk: ", round(hdd_usage()), "% "), "")
    )

    Por Ultimo, quase no final do menu a Esquerda do Dude tem um ícone com o nome de "Probes", de dois cliques em cima para abri-lo,
    Após Clique no + para Adiciona e preencha os campos com as informações a seguir

    type: Function

    agente: Default

    Desponivel ou avalaiable: mipsbe_voltage_size() > 0

    Erro ou error: if(mipsbe_voltage_size() <= 11, if(mipsbe_voltage_size() >0, "down", ""), "")

    Valor ou value: mipsbe_voltage_size() > 0

    Unidade ou Unit: V

    Taxa ou Rate: nenhum ou none
    Clieque no Botão Salvar

    Pronto!

    ------------------------
    Para o Dude notificar quando a voltagem baixa pode-se fazer o seguinte:
    No menu a Esquerda dentro do Networks Maps, de dois clique no seu Mapa Atual,
    Abra a Device que deseja monitorar (com 2 cliques),
    Vai até a Aba "Services"
    Clique no +, e adicione o "voltagem"
    Clique no botão OK
    -----


    Obs1: veja acima que coloquei "<= 11" irá avisar quando estiver menor ou igual a 11, adapte confome preferir, as rbs funcionam se rastejando em 9v, menor de 9 elas começam a rebootar

    Obs2: Se ainda alguém não conseguiu me fale que eu vou fazer um mini-video

    Obs3: Download do The Dude em: http://www.mikrotik.com/thedude.php
    Última edição por gzanatta00; 25-07-2011 às 19:17.



  2. Gustavo muito útil essa idéia, funciona em qualquer RB? Estou tentando aqui com minha RB-433 e me senti um perdido ao tentar localizar essas funções e proceder seguindo seus passos, enfim, não consegui.

  3. Me perdoe pela ignorancia, mais por onde é colocada essas regras na rb ?

    system script ??

    telnet ??

    ohhh


    Abraços a todos

  4. Kleber!

    Essas regras só funcionam com RB's que possui a função de monitorar a voltagem! Que eu conheça são as RB's 333, 433AH's e 450G!

    Edson

    Pra colocar no The Dude! Título do tópico!

  5. edcomrocha, regras vao no DUDE, basta ativar o SNMP das RB.
    pelo q sei so funciona nessas q o amigo citou...

  6. Citação Postado originalmente por ricardoandre Ver Post
    edcomrocha, regras vao no DUDE, basta ativar o SNMP das RB.
    pelo q sei so funciona nessas q o amigo citou...

    Opa valew, agora entendi heheh


    Abraços

  7. Fiz as configurações e liguei uma fonte de 10V, mas nao apareceu erro para mim. Esqueci algo? fiz como vc falou no seu post

  8. Citação Postado originalmente por ricardoandre Ver Post
    Fiz as configurações e liguei uma fonte de 10V, mas nao apareceu erro para mim. Esqueci algo? fiz como vc falou no seu post
    se a sua rb for mipsle (433ah, 333 450g , 800) ira funcionar, claro se tudas as regras certinhas

    outra coisa ativou o snmp no mikrotik??? ta aparecendo nos dispositivos o disk: voltagem: cpu: ???

  9. Ol´a pessoal configurei tudo certinho, mais não da nenhum resultado. somente aparece no grafico um grafico de voltagem mais fica zerado. alguem pode me ajudar.

  10. Bom dia, parabens pela iniciativa, consegui colocar as regras, mas porem não esta registrando a voltagem, coloquei na aba serviço e lá fica up, mas não aparece em meu mapa, e o grafico fica zerado, minhas routerboard são RB433AH, disk e cpu aparecem no mapa.

    Abraço






Tópicos Similares

  1. Respostas: 10
    Último Post: 03-11-2016, 14:53
  2. Respostas: 53
    Último Post: 13-11-2013, 14:24
  3. Respostas: 0
    Último Post: 04-02-2013, 13:44
  4. Mostrar Voltagem da RouterBoard via Dude
    Por gzanatta00 no fórum Redes
    Respostas: 13
    Último Post: 25-10-2012, 21:52
  5. THE DUDE - Não Carrega o Mapa da Rede
    Por GMICHEL no fórum Redes
    Respostas: 2
    Último Post: 21-02-2011, 10:32

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L