+ Responder ao Tópico



  1. #1

    Padrão Problemas com velocidade do proxy com cache-full MK versão 3.30

    Ola pessoal do Under estou aqui pedindo a ajuda de vocês para ver onde é que errei em fazer este proxy com
    o cache
    estar acontecendo o seguinte o proxy estar funcionando normalmente armazena paginas fotos etc e entrega
    normalmente o problema é quando baixo um programa por exemplo winrar a uma velocidade de 128k demora um
    pouco quando estar no cache o cliente baixa do cache mas na velocidade contratada e não a 2 megas como
    deveria outra observação o cache para dowloads so funciona se for baixado por meio do proprio brause se
    for feito via gerenciador de downloads o mesmo é apagado do cache o que pode estar acontecendo utilizo a
    versão 3.30 com hotspot desde ja agradeço a ajuda de todos e que Deus os abençõe.

    segue a baixo a minhas regras


    /ip proxy>

    enabled: yes
    src-address: 0.0.0.0
    port: 3128
    parent-proxy: 0.0.0.0
    parent-proxy-port: 0
    cache-administrator: "webmaster"
    max-cache-size: 7840000000KiB
    cache-on-disk: yes
    max-client-connections: 600
    max-server-connections: 600
    max-fresh-time: 3d
    serialize-connections: no
    always-from-cache: no
    cache-hit-dscp: 4
    cache-drive: primary-master

    /ip proxy access>
    Flags: X - disabled
    # DST-PORT DST-HOST PATH METHOD ACTION HITS
    0 ;;; WEB PROXY block telnet & spam e-mail relaying
    23-25 deny 0
    1 allow 503
    2 deny 0

    /queue tree>
    Flags: X - disabled, I - invalid
    0 name="CACHE-FULL-Download" parent=global-in packet-mark=pacotes_squid-down
    limit-at=0 queue=default priority=1 max-limit=2M burst-limit=0
    burst-threshold=0 burst-time=0s
    1 name="CACHE-FULL-Upload" parent=global-out packet-mark=pacotes_squid-up
    limit-at=0 queue=default priority=1 max-limit=2M burst-limit=0
    burst-threshold=0 burst-time=0s


    /ip firewall filter> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; WEB PROXY - BLOQUEIO DO PROXY EXTERNO
    chain=input action=drop protocol=tcp in-interface=link dst-port=3128
    1 ;;; CHACHE FULL - ACEITAR CONEXOES PROXY
    chain=input action=accept protocol=tcp dst-port=3128

    /ip firewall nat> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; WEB PROXY redirecionamento porta 80 para webproxy 3128
    chain=dstnat action=redirect to-ports=3128 protocol=tcp
    src-address=192.168.1.0/24 dst-port=80

    /ip firewall mangle> print
    Flags: X - disabled, I - invalid, D - dynamic
    0 ;;; CACHE FULL
    chain=output action=mark-connection new-connection-mark=conn_squid-up
    passthrough=yes protocol=tcp src-port=3128 content=X-Cache: HIT
    1 ;;; CACHE FULL
    chain=output action=mark-packet new-packet-mark=pacotes_squid-up
    passthrough=yes connection-mark=conn_squid-up
    2 ;;; CACHE FULL
    chain=prerouting action=mark-connection
    new-connection-mark=conn_squid-down passthrough=yes protocol=tcp
    dst-port=3128
    3 ;;; CACHE FULL
    chain=prerouting action=mark-packet new-packet-mark=pacotes_squid-down
    passthrough=yes connection-mark=conn_squid-down

  2. #2

    Padrão

    sua marcação em mangle está errada, a marcação é feita de outra maneira através do TOS. Dê uma pesquisada no forum que tem a marcação correta



  3. #3

    Padrão

    Citação Postado originalmente por marciorct Ver Post
    sua marcação em mangle está errada, a marcação é feita de outra maneira através do TOS. Dê uma pesquisada no forum que tem a marcação correta
    ola amigo sem querer incomodar mas ja te incomodando dei uma pesquisada aqui no forum mas não encontrei as marcações corretas, se possivem me passe algum post aqui que fale sobre isto ou caso tenha estas regras seria possivel me passar ou enviar por e-mal [email protected] seria interessante que fosse postado aqui para que todos pudessem ver desde ja te agradeço e que Deus te abençõe.

  4. #4



  5. #5

    Padrão

    Oi amigo , esse tópico que o amigo citou acima te ajuda em parte , pois, essas regras liberam o download de forma geral abaixo segue as regras que uso e não tenho problemas:
    Mangle
    add action=mark-connection chain=output comment="PROXY FULL" disabled=no \
    dscp=4 new-connection-mark=proxyfull passthrough=yes protocol=tcp \
    src-port=1023 time=0s-1d,sun,mon,tue,wed,thu,fri,sat
    add action=mark-packet chain=output comment="" connection-mark=proxyfull \
    disabled=no new-packet-mark=proxyfull passthrough=yes time=\
    0s-1d,sun,mon,tue,wed,thu,fri,sat
    add action=return chain=output comment="" connection-mark=proxyfull disabled=\
    no time=0s-1d,sun,mon,tue,wed,thu,fri,sat
    Nat
    add action=redirect chain=dstnat comment="<<<Redirecionamento Proxy >>>" \
    disabled=no dst-port=80 in-interface=IcatelNet protocol=tcp src-address=\
    192.168.2.0/24 time=0s-1d,sun,mon,tue,wed,thu,fri,sat to-ports=1023
    Queue Tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M \
    max-limit=1M name="Cache - Squid" packet-mark=proxyfull parent=global-out \
    priority=8 queue=default
    Obs: Uso a porta 1023, basta usar a sua e pronto tá rodando!

    Um forte Abraço.

  6. #6

    Padrão

    Geronimo,

    Tá faltando você marcar os pacotes quem dão "hints" no proxy. Somente esses serão utilizados para o cache full. Nas regras do seu mangle adiciona o DSCP que você usou na criação do webproxy. Seria bom também você marcar individualmente alguns serviços. Mas o que tá faltando mesmo ai é só adicionar a regra do DSCP. Fazendo isso vai funcionar, ok?

    Abs.



  7. #7

    Padrão

    Citação Postado originalmente por guilhermeramires Ver Post
    Geronimo,

    Tá faltando você marcar os pacotes quem dão "hints" no proxy. Somente esses serão utilizados para o cache full. Nas regras do seu mangle adiciona o DSCP que você usou na criação do webproxy. Seria bom também você marcar individualmente alguns serviços. Mas o que tá faltando mesmo ai é só adicionar a regra do DSCP. Fazendo isso vai funcionar, ok?

    Abs.
    Ola Guilherme antes de mais nada obrigado pela ajuda, eu andei fuçando bastante o forum e acabei chegando ao wiki do mk e adicionei as regras abaixo, o cache estar perfeito o unico problema é a velocidade que não consigo entregar por fora do limite de banda dos clientes ja tentei de tudo atualmente estou utilizando uma versão 2.9.51 e faço o cache perfeito inclusive a entrega do que estar no cache que passa por fora do controle de banda ja na versão 3.30 que e justamente a que estar em questão aqui não estou conseguindo entregar o conteudo do cache por fora do limite de banda estou postando as novas regras se tiver um tempinho e puder me ajudar ficaria muito grato segue as regras.

    /ip proxy
    set always-from-cache=yes cache-administrator=webmaster cache-hit-dscp=4 \
    cache-on-disk=yes enabled=yes max-cache-size=unlimited \
    max-client-connections=600 max-fresh-time=3d max-server-connections=600 \
    parent-proxy=0.0.0.0 parent-proxy-port=0 port=3128 serialize-connections=\
    yes src-address=0.0.0.0

    /ip firewall nat
    add action=redirect chain=dstnat comment="Redirecionamento do Proxy" disabled=no dst-port=80 \
    in-interface=clientes protocol=tcp src-address=192.168.1.0/24 to-ports=\
    3128

    /ip firewall mangle
    add action=accept chain=output comment="qcept proxy" disabled=no dscp=4
    add action=mark-packet chain=output comment=";;; HIT TRAFFIC FROM PROXY " \
    disabled=no dscp=4 new-packet-mark=proxy-hit out-interface=clientes \
    passthrough=no
    add action=mark-packet chain=prerouting comment=";;; UP TRAFFIC" disabled=no \
    in-interface=clientes new-packet-mark=proxy-up passthrough=no \
    src-address=192.168.1.0/24
    add action=mark-connection chain=forward comment=";;; CONN-MARK" disabled=no \
    new-connection-mark=proxy-conn passthrough=yes src-address=192.168.1.0/24
    add action=mark-packet chain=forward comment=";;; DOWN-DIRECT CONNECTION" \
    connection-mark=proxy-conn disabled=no in-interface=link new-packet-mark=\
    proxy-down passthrough=no
    add action=mark-packet chain=output comment=";;; DOWN-VIA PROXY" disabled=no \
    new-packet-mark=proxy-down out-interface=clientes passthrough=no \
    src-address=192.168.1.0/24
    /queue tree
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M \
    max-limit=2M name=downstream packet-mark=proxy-down parent=global-in \
    priority=8 queue=default
    add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=1M \
    max-limit=2M name=upstream packet-mark=proxy-up parent=global-in \
    priority=8 queue=default

    conto com a ajuda de todos e que Deus os abençõe.

  8. #8

    Padrão

    Aparentemente suas regras agora estão corretas com a marcação usando o DSCP. Confere agora se os contadores estão sendo incrementados pra gente saber se as regras estão atuando. Confere também se o DSCP do seu proxy é realmente "4", ok?

    Abs.



  9. #9
    Avatar de wmglan
    Ingresso
    Jul 2010
    Localização
    RIO DE JANEIRO
    Posts
    9

    Padrão Re: Problemas com velocidade do proxy com cache-full MK versão 3.30

    BOA NOITE PARA TODOS BOM SOU INICIANTE E GOSTARIA DE ALGUMAS REGRAS PARA COLOCAR AQUI JA QUE EU NAO COLOQUEI NADA AINDA SO AQUELAS QUE QUANDO CONFIGURA O MK ELE MESMO FAZ TIPO MEU MK 3.30 REGRAS BASICAS JA ME ADIANTA MUITO JA SABENDO O QUE A MAIORIA VAI FALA QUAL AS REGRAS QUE EU QUERO EMBORA NAO SAIBA ACEITO INDICAÇAO GOSTARIA DE RAGRAS BASICAS JA ME AJUDA MUITO

  10. #10

    Padrão Re: Problemas com velocidade do proxy com cache-full MK versão 3.30

    Acompanhando pra ver se funcionou com o amigo geronimofsa.