Página 1 de 4 1234 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Post Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Escrevi esse artigo pois já vi muitos casos em que equipamentos sofreram defeitos e tiveram logs / backups perdidos por estarem guardados no próprio equipamento. O título não sugere que este guia sirva apenas para versão 4.6 do RouterOS, apenas que as regras foram testadas em bancada e estão funcionado bem nessa versão.


    Sugestões para melhorar ou mesmo consertar serão muito bem vindas.


    configurando o envio de emails:


    no WINBOX:

    menu

    /tool>email>

    Server: smtp.gmail.com
    Port: 587
    From: [email protected]
    User: [email protected]
    Password: ********** (sua senha no gmail=)

    Clique no botao "Apply" e imediatamente a URL smtp.gmail.com é resolvida trocada para o IP certo.

    Escrevendo um script para gerar o arquivo log-mikrotik.txt
    no WINBOX

    menu

    /system>scripts

    adicione um script chamado "salvar-log"

    Name: salvar-log

    Source: (código fonte)

    /log print file=log-mikrotik.txt


    _______________________________________

    Escrevendo um script para gerar o arquivo backup-mikrotik.backup

    do mesmo jeito com o seguinte código fonte:

    Name: salvar-backup

    Source:

    /system backup save name=backup-mikrotik.backup


    _______________________________________


    Agora é preciso criar mais 2 scripts, um para enviar o log e outro para enviar o backup por email



    Name: enviar-log

    Source:

    :log info message="enviando log por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="[email protected]" subject="log-mikrotik $data $hora" file=log-mikrotik.txt tls=yes


    _______________________________________

    Name: enviar-backup

    Source:

    :log info message="enviando backup por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="[email protected]" subject="backup-mikrotik $data $hora" file=backup-mikrotik.backup tls=yes



    _______________________________________


    Configurando o envio automático dos logs/backups

    no WINBOX

    /system>scheduler

    agora é só agendar os 4 scripts de acordo com a necessidade, geralmente uso backup a cada 24 horas e logs a cada 6 horas como nas regras abaixo:

    /system scheduler add comment="" disabled=no interval=1d name=enviar-backup-automatico \
    on-event=enviar-backup policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=23:10:00
    /system scheduler add comment="" disabled=no interval=1d name=salvar-backup-automatico \
    on-event=salvar-backup policy=\
    reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    jan/01/1970 start-time=23:00:00
    /system scheduler add comment="" disabled=no interval=6h name=salvar-log-automatico on-event=\
    salvar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/01/1970 start-time=00:00:00
    /system scheduler add comment="" disabled=no interval=6h name=enviar-log-automatico on-event=\
    enviar-log policy=reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=jan/01/1970 start-time=00:10:00




    Escolhi o Gmail porque tem muito espaço de caixa de entrada e um recurso próprio que facilida a visualização dos logs sem a necessidade de baixar anexos. Isso faz muita diferença pois infelizmente o arquivo ".txt" que o RouterOS gera é no padrão Unix, é muito complicado de visualizar no bloco de notas do Windows.

  2. #2

    Padrão

    Cara, muito bom. Parabéns, era justamente o que eu proucurava.
    Mas uso 5 Routerboards, com a versão 3.31 do Mikrotik, já veio com o 3.31.
    Alguma chance de fazer algo parecido no 3.31?
    ---------------------------EDITADO--------------------------------------
    Consegui fazer esse esquema funcionar na minha versão 3.31 e 3.25 adequando algumas regras =D
    Depois postarei como ficou as regras.
    Mas muito obrigado mesmo, ajudou muito
    ---------------------------EDITADO 2--------------------------------------
    Minhas modificações para 3.XX

    Editado 3: Não deu muito certo esse esquema com o Gmail para o 3.X, a principio parecia funcionar perfeitamente, mas o detalhe era que eu estava com o PC ligado logado no GMAIL.
    Logo após eu desligar meu computador logado no gmail não foi feito o backup como eu esperava. Olhando os logs vi que o problema era justamente na autenticação (antes fazia o backup porque provavelmente o GMAIL ignorava a autenticação já que eu estava logado nele, pelo meu IP, ip no qual é o mesmo que o MK usa para mandar o email com o backup para os servidores GMAIL)

    Mas mesmo assim arrumei outra forma, com o email do bol. Ele tem 4GB de espaço e ao meu ver parece funcionar bem. Fiz os testes, desliguei o meu pc, rebotei o link, e o backup foi feito perfetamente.


    Então pra quem usa as versões 3.XX...
    Tente as modificações:

    Backup automatico por email do BOL nas versões 3.X:

    Clique na imagem para uma versão maior

Nome:	         BACKUP-MK-BOOL.jpg
Visualizações:	1534
Tamanho: 	92,9 KB
ID:      	10499 Clique na imagem para uma versão maior

Nome:	         BACKUP-MK-BOOL2.jpg
Visualizações:	704
Tamanho: 	55,7 KB
ID:      	10500
    Para quem não conhece o email do bol, é um email gratuito e funcional do UOL.
    Para fazer uma conta você deve acessar: www.bol.uol.com.br
    Depois de ter uma conta, configure o servidor NTP pata ter a hora sempre exata.

    Em System > NTP Cliente:


    Mode: unicast
    Primary NTP Server: 159.148.60.2
    Secondary NTP Server: 159.148.60.2
    Marque o: enable

    Depois em System > Clock:


    Time Zone Name: Coloque America/são paulo para fazer o devido ajuste sobre a hora obtida no NTP, que no caso é mundial.


    Configure o email em: tool > email:

    Server: smtp.bol.com.br
    Port: 25
    From: meu_email@bol.com.br
    User: meu_email@bol.com.br
    Password: minha senha do email


    Adicione os Scripts em System > Scripts:

    1º nome: "fazer-e-enviar-backup"

    /system backup save name=backup-mikrotik.backup
    :delay 2s
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="EMAIL PARA QUAL SERA ENVIADO O BACKUP" subject="Backup do Mikrotik NOME_DA_ESTAÇÃO dia: $data as $hora" file="backup-mikrotik.backup" body="Backup automatico do servidor Mikrotik-NOME_DA_ESTAÇÃO realizado as $hora de $data."



    2º nome: "fazer-e-enviar-log"


    /log print file=log-mikrotik.txt
    :delay 2s
    :global data [/system clock get date]
    :global hora [/system clock get time]
    /tool e-mail send to="EMAIL PARA QUAL SERA ENVIADO O LOG" subject="Log do MK-NOME_DA_ESTAÇÃO dia: $data as $hora" file="log-mikrotik.txt" body="Backup automatico do log do servidor Mikrotik-NOME_DA_ESTAÇÃO realizado as $hora de $data."



    Agende a execução dos dois scritps em: system > scheduler:


    1º Agendamento:

    Name:
    Agendamento-backup-mk
    Start date: Apr/11/2010
    Interval: 03:00:00
    On Event: fazer-e-enviar-backup
    Em policy marque todas as opções.

    2º Agendamento: Nome: Agendamento-backup-log
    Start date: Apr/11/2010
    Interval: 03:00:00
    On Event: fazer-e-enviar-log
    Em policy marque todas as opções.


    Pronto.
    ---------------------------------------------------------------------------
    Testado nas versões 3.31 e 3.25, acredito que deva funcionar em todas 3.XX.

    Sobre os scripts, tive que modificar algumas partes, retirar outras que o 3.3 não suportava, além do que acrecentei algumas coisinhas como a mensagem. Também fiz a junção de alguns scripts para facilitar tudo e diminuir as regras.

    Espero que meu ajuste possa ajudar quem também tenha 3.X
    Última edição por thedarkmetal; 12-04-2010 às 16:21.



  3. #3

    Padrão

    Muito bom!
    Obrigado pela ajuda =D
    agora está mais completo ainda!
    abs

  4. #4

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Boa noite!
    amigo coforme seu topico fiz o script para enviar backup pelo MK, funcionou blz ate eu atualizar para versão 4.9 aparti dai não recebi mais os backups no email, resolvi olhar no og do mk, eu qual seria o momento do envio da o seguinte erro "Error sending e-mail:invalid FROM address" e nos MK que estao com a versão 4.6 esta funcionando blz.

    Sds

    Hermes



  5. #5

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    alguem ja testou na 3.13?
    aki em tool/email so tem lugar para colocar
    Server: e From:

  6. #6

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    olá Amigos estou Penando aqui na Configuração para enviar o e-mail do Backup
    o script Gera o Backup Beleza, só não Envia para o meu outro e-mail
    não sei onde esta o erro no script
    eu rodo o Script manualmente o contador de Script roda mas o e-mail não e enviado
    Estou utilizando a versão 3.30
    Segue abaixo o script para a verificação dos amigos

    /system script
    add name=salvar-backup policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=\
    "/system backup save name=backup-mikrotik.backup"
    add name=enviar-backup policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=":log info message=\"enviando backup por email\"\r\
    \n:global data [/system clock get date]\r\
    \n:global hora [/system clock get time]\r\
    \n/tool e-mail send to=\"[email protected]\" subject=\"backup-mikrotik \$data \$hora\" file=backup-mikrotik.backup tls=yes"

    /tool e-mail
    set [email protected] password=palavrapass server=200.221.62.5:25 [email protected]

    se alguém poder me Ajudar agradeço desde já
    Última edição por tonflatland; 18-07-2010 às 07:07. Razão: Correção Texto



  7. #7

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Citação Postado originalmente por tonflatland Ver Post
    olá Amigos estou Penando aqui na Configuração para enviar o e-mail do Backup
    o script Gera o Backup Beleza, só não Envia para o meu outro e-mail
    não sei onde esta o erro no script
    eu rodo o Script manualmente o contador de Script roda mas o e-mail não e enviado
    Estou utilizando a versão 3.30
    Segue abaixo o script para a verificação dos amigos




    se alguém poder me Ajudar agradeço desde já
    Galera Alterei a Porta 25 para 587 do email Bol e Ta funcionando

    Desde já agradeço
    Flw...

  8. #8

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Muito bom!
    Obrigado pela ajuda =D



  9. #9

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Meus parabéns a todos que contribuirão nesse post, utilizei esse metodo de bkp para umas 20 RB sendo 411, 750 , 433, 800 ok tudo certinho , todas elas estão com a versão 4... mas oque esta me deixando um pouco entrigado é na questão do log queria fazer apenas do servidor principal que tambem é MK na questão de geral e enviar esta tudo oque mas quando abro no e-mail esta assim :
    # apr/14/2011 15:51:46 by RouterOS 4.11
    # software id = Y0H8-####
    #
    Se alguem tiver alguma idéia do que eu to fazendo errado, por favor me diga, desde ja muito obrigado estou aprendendo muito no forum, muitas duvidas são esclarecidas apenas com a soluções dos outros colegas, valeo :P

  10. #10

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Muito bom, testado na versão 5.2, 4.13 e 4.11, funcionou 1000000%.
    obrigado pela contribuição



  11. #11
    sergiovinhasc7
    Visitante

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Senhores, utilizei o script e funcionou, porém tentei anexar mais de um arquivo na mensagem e não consegui, alguem já fez a experiencia?

  12. #12

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    muito bom o script, testei na versão 5.7 e rodou beleza ..



  13. #13

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Altere as variáveis emailBKP e senhaBKP

    Código :
    :global emailBKP "[email protected]";
    :global senhaBKP "senha";
    /tool e-mail
    set from=$emailBKP password=$senhaBKP server=74.125.157.109:587 username=$emailBKP
    /system script
    add name=fazer-e-enviar-log policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="/log print file=log-mikrotik.txt\r\
        \n:log info message=\"enviando log por email\"\r\
        \n:global data [/system clock get date]\r\
        \n:global hora [/system clock get time]\r\
        \n/tool e-mail send to=\"$emailBKP\" subject=\"log-mikrotik-$nomRB \$data \$hora\" file=log-mikrotik.txt tls=yes" 
    add name=fazer-e-enviar-backup policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source="/system backup save name=backup-mikrotik.back\
        up\r\
        \n:log info message=\"enviando backup por email\"\r\
        \n:global data [/system clock get date]\r\
        \n:global hora [/system clock get time]\r\
        \n/tool e-mail send to=\"$emailBKP\" subject=\"backup-mikrotik-$nomRB \$data \$hora\" file=backup-mikrotik.backup tls=yes"
     
    /system scheduler
    add comment="" disabled=no interval=24h name=Agendamento-fazer-enviar-log on-event=fazer-e-enviar-log policy=\
        reboot,read,write,policy,test,password,sniff,sensitive start-date=feb/14/2011 start-time=00:00:00
    add comment="" disabled=no interval=24h name=Agendamento-fazer-e-enviar-backup on-event=fazer-e-enviar-backup policy=\
        reboot,read,write,policy,test,password,sniff,sensitive start-date=feb/14/2011 start-time=00:00:00

    Basta copiar, e colar no New Terminal
    Última edição por farias; 16-11-2011 às 21:37. Razão: Retirando link na variável emailBKP

  14. #14

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    o IP que esta funcionando agora e o 74.125.47.109



  15. #15

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Pessoal, incrementei o script para gerar nome de arquivo e subject automático.

    São eles:
    Salvar Backup.
    :global router [/system identity get name]
    /system backup save name="Backup-$router.backup"

    Enviar Backup.
    :log info message="enviando backup por email"
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global router [/system identity get name]
    /tool e-mail send to="seu [email protected]" subject="Backup - $router $data $hora" file="Backup-$router.backup" tls=yes

    Assim não preciso ficar escrevendo o nome do arquivo, basta importar o script e é gerado o nome do backup com a identidade do router.

  16. #16

    Padrão re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Aqui tambem to com o mesmo problema com o ROS 5.11, alguem tem ideia de como coloca esse IP na regra? To tentando e até agora nao consegui.

    Segue modelo que estou usando no script.

    /tool e-mail send server= 98.138.84.55:25 [email protected] body=POP-XXXXX subject=BACKUP-POP-XXXXX password=xxxxxx [email protected] [email protected] file=POP-XXXXX.backup

    Obrigado.



  17. #17

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Ninguém conseguiu resolver este problema do envio de arquivo de backup por e-mail na nova versão?

  18. #18

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Gera blz , mas na hora de enviar da Error seding email <TESTE>:invalid From adress --- minha configração ---
    /tool e-mail set address=74.125.47.109 [email protected] password=\ ********* port=587 [email protected]
    lembrando q no gmail fiz as config necessarias.. tem algum outros serviço q devo ativar.



  19. #19

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Boa noite galera!!

    Na versão 3.9 só tem a opção: Server e Fron em Tools > Email.
    Como procedo para funcionar o script?

  20. #20

    Padrão Re: Configurando Log e Backup Automático por e-Mail Usando o Gmail

    Citação Postado originalmente por Bender Ver Post
    Aqui tambem to com o mesmo problema com o ROS 5.11, alguem tem ideia de como coloca esse IP na regra? To tentando e até agora nao consegui.

    Segue modelo que estou usando no script.

    /tool e-mail send server= 98.138.84.55:25 [email protected] body=POP-XXXXX subject=BACKUP-POP-XXXXX password=xxxxxx [email protected] [email protected] file=POP-XXXXX.backup

    Obrigado.
    Tenta colocar tls=yes

    ficaria assim:

    /tool e-mail send tls=yes server= 98.138.84.55:25 [email protected] body=POP-XXXXX subject=BACKUP-POP-XXXXX password=xxxxxx [email protected] [email protected] file=POP-XXXXX.backup